建立或刪除巨集

標籤    加入巨集 (英文); 自動化 (英文); 停用巨集 (英文); 啟用巨集 (英文); 巨集 (英文); 巨集按鈕 (英文); 巨集安全性 (英文); 指令碼 (英文); 取消隱藏 (英文); vba (英文)

什麼是標籤?(英文)

Microsoft Office Excel 可讓您快速錄製巨集,以便將重複的工作自動化。您也可以透過下列方式建立巨集:使用 Microsoft Visual Basic 的 Visual Basic 編輯器撰寫自己的巨集指令碼,或是將巨集的全部或一部分複製到新的巨集。在建立巨集後,可以將它指定給物件 (如工具列按鈕、圖形或控制項),這樣就可以按一下該物件來執行它。如果不再使用巨集,便可以將它刪除。

您想要做什麼?

錄製巨集

使用 Microsoft Visual Basic 建立巨集

複製巨集的一部分來建立另一個巨集

指定巨集給物件、圖形或控制項

刪除巨集

錄製巨集

當錄製巨集時,巨集錄製會錄製所有需要巨集完成之動作所需的步驟。在錄製的步驟中並不包含功能區導覽。

附註  功能區是 Microsoft Office Fluent 使用者介面 的一個元件。

  1. 如果 [開發人員] 索引標籤無法使用,請執行下列動作顯示索引標籤:

    1. 按一下 [Office 按鈕] Office 按鈕圖像 ,然後按一下 [Excel 選項]

    2. [常用] 類別中,選取 [使用 Excel 時最常用的選項] 底下的 [在功能區顯示 [開發人員] 索引標籤] 核取方塊,然後按一下 [確定]

  2. 若要暫時設定安全性層級來啟用所有巨集,請執行下列動作:

    1. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [巨集安全性]。

      [開發人員] 索引標籤上的 [程式碼] 群組

    2. 按一下 [巨集設定] 底下的 [啟用所有巨集 (不建議使用,會執行有潛在危險的程式碼)],然後按一下 [確定]

      附註  若要防止執行可能具有危險性的程式碼,建議您在結束使用巨集之後,恢復您當初停用所有巨集的任何設定。如需有關變更設定的詳細資訊,請參閱巨集安全性概觀

  3. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [錄製巨集]。

  4. 在 [巨集名稱] 方塊中,輸入巨集的名稱。

    附註  巨集名稱的第一個字元必須是字母。隨後的字元則可以是字母、數字或底線字元。巨集名稱中不能使用空格,但底線字元很適合做為文字分隔字元。如果您使用的巨集名稱也是儲存格參照,可能會產生錯誤訊息,指出該巨集的名稱無效。

  5. 若要指定 CTRL 組合快速鍵來執行巨集,請在 [快速鍵] 方塊中輸入要使用的任何大小寫字母。

    附註  當含有巨集的活頁簿已經開啟時,該快速鍵會優先於任何相同預設的 Excel 快速鍵。如需 Excel 中已指定的 CTRL 組合快速鍵的清單,請參閱 Excel 快速鍵及功能鍵

  6. [將巨集儲存在] 清單中,按一下要儲存巨集的活頁簿。

    提示  如果想要在使用 Excel 時能夠使用巨集,請選取 [個人巨集活頁簿]。當選取 [個人巨集活頁簿] 時,如果隱藏的個人巨集活頁簿 (Personal.xlsb) 不存在的話,Excel 會將它建立,並將巨集儲存於這個活頁簿中。在 Windows Vista 中,這個活頁簿是儲存於 C:\Users\user name\AppData\Local\Microsoft\Excel\XLStart 資料夾。在 Microsoft Windows XP 中,這個活頁簿是儲存於 C:\Documents and Settings\user name\Application Data\Microsoft\Excel\XLStart 資料夾。Excel 啟動時,會自動將 XLStart 資料夾內的活頁簿載入。如果您想要讓個人巨集活頁簿中的巨集在另一個活頁簿中自動執行,也必須將那一個活頁簿儲存到 XLStart 資料夾,這樣才會在 Excel 啟動時同時開啟這兩個活頁簿。

  7. 請在 [描述] 方塊中輸入巨集的描述文字。

  8. 按一下 [確定] 開始進行錄製。

  9. 執行要錄製的動作。

  10. [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [停止錄製] 按鈕圖像

    提示  您也可以按一下狀態列左邊的 [停止錄製] 按鈕圖像

頁首

使用 Microsoft Visual Basic 建立巨集

  1. 如果 [開發人員] 索引標籤無法使用,請執行下列動作顯示索引標籤:

    1. 按一下 [Office 按鈕] Office 按鈕圖像 ,然後按一下 [Excel 選項]

    2. [常用] 類別中,選取 [使用 Excel 時最常用的選項] 底下的 [在功能區顯示 [開發人員] 索引標籤] 核取方塊,然後按一下 [確定]

  2. 若要暫時設定安全性層級來啟用所有巨集,請執行下列動作:

    1. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [巨集安全性]。

      [開發人員] 索引標籤上的 [程式碼] 群組

    2. 按一下 [巨集設定] 底下的 [啟用所有巨集 (不建議使用,會執行有潛在危險的程式碼)],然後按一下 [確定]

      附註  若要防止執行可能具有危險性的程式碼,建議您在結束使用巨集之後,恢復您當初停用所有巨集的任何一項設定。

  3. [開發人員] 索引標籤的 [程式碼] 群組中,按一下 [Visual Basic]

  4. 如果需要,請在 [Visual Basic 編輯器] 中按一下 [插入] 功能表上的 [模組]

    附註  會自動為活頁簿中的所有工作表建立模組。

  5. 在模組的程式碼視窗中,輸入或複製要使用的巨集程式碼。

  6. 若要從模組視窗中執行巨集,請按 F5 鍵。

  7. 巨集撰寫完成後,請在 [Visual Basic 編輯器] 中按一下 [檔案] 功能表上的 [關閉並回到 Microsoft Excel]

頁首

複製巨集的一部分來建立另一個巨集

  1. 如果 [開發人員] 索引標籤無法使用,請執行下列動作顯示索引標籤:

    1. 按一下 [Office 按鈕] Office 按鈕圖像 ,然後按一下 [Excel 選項]

    2. [常用] 類別中,選取 [使用 Excel 時最常用的選項] 底下的 [在功能區顯示 [開發人員] 索引標籤] 核取方塊,然後按一下 [確定]

  2. 若要暫時設定安全性層級來啟用所有巨集,請執行下列動作:

    1. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [巨集安全性]。

      [開發人員] 索引標籤上的 [程式碼] 群組

    2. 按一下 [巨集設定] 底下的 [啟用所有巨集 (不建議使用,會執行有潛在危險的程式碼)],然後按一下 [確定]

      附註  若要防止執行可能具有危險性的程式碼,建議您在結束使用巨集之後,恢復您當初停用所有巨集的任何一項設定。

  3. 開啟含有要複製之巨集的活頁簿。

  4. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [巨集]。

  5. 在 [巨集名稱] 方塊中,按一下要複製的巨集名稱。

  6. 按一下 [編輯]。

  7. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示  若要複製整個巨集,請將 [Sub][End Sub] 這兩行包括在選取範圍中。

  8. 按一下 [編輯] 功能表上的 [複製]。

    提示  您也可以使用滑鼠右鍵按一下,然後按一下 [貼上],或是按下 CTRL+V 鍵。

  9. 在程式碼視窗的 [程序] 方塊中,按一下要放置程式碼的模組。

  10. 按一下 [編輯] 功能表上的 [貼上]。

    提示  您也可以使用滑鼠右鍵按一下,然後按一下 [複製],或是按下 CTRL+C 鍵。

提示  由於個人巨集活頁簿檔案 (Personal.xlsb) 是一個隱藏的活頁簿,而且一直處於開啟狀態,所以無法對它進行編輯。您必須先使用 [取消隱藏] 指令,將這個活頁簿取消隱藏。藉由按 ALT+F11 鍵,也可以在 [Visual Basic 編輯器] 中將它開啟。

頁首

指定巨集給物件、圖形或控制項

  1. 在工作表上,以滑鼠右鍵按一下要指定現有巨集的物件、圖形或控制項,然後按一下 [指定巨集]

  2. 在 [巨集名稱] 方塊中,按一下要指定的巨集。

頁首

刪除巨集

  1. 請執行下列其中一項操作:

    • 開啟含有要刪除之巨集的活頁簿。

    • 如果要刪除的巨集儲存在個人巨集活頁簿 (Personal.xlsb) 中,而且此活頁簿處於隱藏狀態,請執行下列步驟取消隱藏活頁簿:

      1. [檢視] 索引標籤的 [視窗] 群組中,按一下 [取消隱藏]

      2. [取消隱藏活頁簿] 下方,按一下 [個人],然後按一下 [確定]

  2. 如果 [開發人員] 索引標籤無法使用,請執行下列動作顯示索引標籤:

    1. 按一下 [Office 按鈕] Office 按鈕圖像 ,然後按一下 [Excel 選項]

    2. [常用] 類別中,選取 [使用 Excel 時最常用的選項] 底下的 [在功能區顯示 [開發人員] 索引標籤] 核取方塊,然後按一下 [確定]

  3. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組

  4. [巨集存放在] 清單中,選取內含要刪除巨集的活頁簿。例如,按一下 [現用活頁簿]

  5. 在 [巨集名稱] 方塊中,按一下要刪除的巨集名稱。

  6. 按一下 [刪除]。

頁首

適用: Excel 2007



這項資訊有幫助嗎?

我們應該如何改進?

255 剩餘字元數

若要保護您的隱私,請不要在意見反應中包含連絡資訊。 檢閱我們的 隱私權原則

感謝您的意見反應!

支援資源

變更語言