連接兩個資料檢視

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

在 Microsoft Office SharePoint Designer 2007 中,您可能習慣建立廣泛使用資料來源與 [資料檢視] 的應用程式。透過連接已插入做為檢視或表單的 [資料檢視],就可以建立它們之間的連線,如此一來,當您在一個 [資料檢視] 中執行動作時,它就會變更另一個 [資料檢視] 的內容。連接 [資料檢視] 是將互動功能新增至網站或應用程式的快速且強大的方式。

附註: [資料檢視] 是一種網頁組件類型,因此本文中的概念與程序也適用於任何可連接的兩個網頁組件。

本文說明如何建立兩個 [資料檢視] 以及如何使用「網頁組件連線精靈」來連接它們。

若要深入瞭解資料檢視,請參閱建立資料檢視

本文內容

為什麼連線網頁組件?

使用 3o-建立第一個資料檢視

建立 XML 檔案做為範例資料來源

使用 Suppliers.xml 建立資料檢視

連接網頁組件

測試網頁組件連線

移除網頁組件連線

為什麼要連接網頁組件?

透過連接兩個網頁組件,您就可以在它們之間傳送資料並同步處理它們的行為。例如,您可以將顯示員工清單的 [清單檢視網頁組件] 連接到 [圖像網頁組件]。在連結兩個網頁組件後,每次您按一下 [清單檢視網頁組件] 中的員工名稱時,就會在 [圖像網頁組件] 中顯示所選取員工的圖片。

您可以在瀏覽器中建立簡單的網頁組件連線。例如,您可以將一個網頁組件連接到位於相同「網頁組件頁面」的另一個網頁組件。不過,您可以使用 Office SharePoint Designer 2007 來擴充連線的功能。例如,您可以使用 [表單網頁組件] 來篩選另一個網頁組件中的資料,或是在相同頂層網站的兩個不同「網頁組件頁面」中,建立網頁組件之間的連線。這兩個動作都需要 Office SharePoint Designer 2007,而且無法在瀏覽器中執行。

頁面頂端

使用 Products.xml 建立第一個資料檢視

北風貿易是一家美食產品配銷公司,在名稱為 Products.xml 的 .xml 檔案中追蹤其庫存,並在 [資料檢視] 中顯示該檔案的資料。此 [資料檢視] 已插入做為表單,因此小組可以透過瀏覽器將變更儲存到 Products.xml 中,以更新庫存。當庫存量變低時,小組成員會致電該產品的供應商以訂購產品,然後使用 [資料檢視] 來更新庫存。但是每次小組成員訂購產品時,他們也必須查詢供應商的連絡人資訊。

您建議插入第二個 [資料檢視] 以顯示供應商的連絡人資訊,然後在兩個網頁組件之間建立連線。如此一來,當小組成員準備訂購產品時,只要按一下單一超連結,就可以同時檢視每個產品的庫存資料與供應商的連絡人資訊。

下列程序需要使用兩個.xml 檔案做為資料來源,並建立資料檢視的每一種這些資料來源。若要追蹤的範例,請依照下列插入為表單資料檢視的文件中的程序需要建立 3o-從第一個資料檢視。若要建立第二個資料檢視 Suppliers.xml 從這份文件,然後返回。

頁面頂端

建立做為範例資料來源的 XML 檔案

北風貿易將他們供應商的連絡人資訊儲存在名稱為 Suppliers.xml 的 .xml 檔案中。

建立 Suppliers.xml

  1. 按一下 [檔案] 功能表上的 [開啟網站]。

  2. 在 [開啟網站] 對話方塊中,瀏覽至您的網站並加以選取,然後按一下 [開啟]。

  3. 當出現提示時,在 [連線至] 對話方塊中,輸入使用者名稱和密碼,然後按一下 [確定]。

  4. 按一下 [檔案] 功能表上的 [開新檔案]。

  5. 在 [新增] 對話方塊中,按兩下 [文字檔]。

    網站中隨即開啟一個新的文字檔。

  6. 選取下列數行程式碼並按下 CTRL+C,進行複製。

    <?xml version="1.0" encoding="utf-8"?>
    <SuppliersRoot>
    <Suppliers>
    <SupplierID>1</SupplierID>
    <CompanyName>Exotic Liquids</CompanyName>
    <ContactName>Charlotte Cooper</ContactName>
    <ContactTitle>Purchasing Manager</ContactTitle>
    <Address>49 Gilbert St.</Address>
    <City>London</City>
    <PostalCode>EC1 4SD</PostalCode>
    <Country>UK</Country>
    <Phone>(171) 555-2222</Phone>
    </Suppliers>
    <Suppliers>
    <SupplierID>2</SupplierID>
    <CompanyName>New Orleans Cajun Delights</CompanyName>
    <ContactName>Shelley Burke</ContactName>
    <ContactTitle>Order Administrator</ContactTitle>
    <Address>P.O. Box 78934</Address>
    <City>New Orleans</City>
    <Region>LA</Region>
    <PostalCode>70117</PostalCode>
    <Country>USA</Country>
    <Phone>(100) 555-4822</Phone>
    <HomePage>#CAJUN.HTM#</HomePage>
    </Suppliers>
    </SuppliersRoot>
  7. 在 Office SharePoint Designer 2007 中,將插入點置於頁面頂端,然後按 CTRL+V,貼上您剛才複製到頁面中的程式碼。

  8. 按一下 [檔案] 功能表上的 [另存新檔]。

  9. 在 [另存新檔] 對話方塊,在 [檔案名稱] 方塊中輸入suppliers.xml

  10. 按一下 [檔案類型] 清單中的 [XML],然後按一下 [儲存]。

頁面頂端

使用Suppliers.xml 建立資料檢視

  1. 開啟包含您在 [插入資料檢視做為表單的文件中建立第一個資料檢視的頁面。

    雖然並不需要將兩個 [資料檢視] 放在相同網頁上,不過在此例中,您希望小組只要按一下產品即可快速檢視供應商的連絡人資訊。

    以表單顯示選取的資料

  2. 選取第一個 [資料檢視],然後按兩次向右鍵,將游標放置在 [資料檢視] 的下方。

  3. 按一下 [資料檢視] 功能表上的 [插入資料檢視]。

    第一個 [資料檢視] 的下方就會顯示空白的 [資料檢視],而且會開啟 [資料來源程式庫] 工作窗格。

    空白的資料檢視

  4. 在 [資料來源程式庫] 工作窗格中,尋找資料來源,然後按一下它,再按一下 [顯示資料]。

    就此範例而言,按一下 [XML 檔案] 之下的 Suppliers.xml,然後按一下 [顯示資料]。如果 [XML 檔案] 標題已摺疊,請按一下加號 (+) 將它展開。

  5. 在 [詳細資料來源] 工作窗格中,按一下您要插入 [資料檢視] 中的欄位。

    提示: 若要選取多個欄位,請按住 CTRL 鍵,同時按一下想要的欄位。

    就此範例而言,在 [SuppliersRoot] 資料夾的 [Suppliers] 之下,按一下 [CompanyName]。按住 CTRL 鍵,同時按一下 [ContactName]、[Country] 和 [Phone]。

  6. 按一下 [插入選取欄位為],然後按一下 [單一項目檢視],將選取的資料插入 [資料檢視]。

    您選擇在 [資料檢視] 中只顯示一個項目,因為您想要一次只顯示一個供應商的連絡人資訊。

    在 [詳細資料來源] 工作窗格中選取的欄位現在會出現在第一個 [資料檢視] 下方的第二個 [資料檢視]。

    [供應商資料檢視] 出現在 [產品資料檢視] 下方
    資料檢視的 Suppliers.xml (紅色大綱) 出現的資料檢視的 3o-下方。

頁面頂端

連接網頁組件

Suppliers.xml 與 Products.xml 透過稱為 SupplierID 的共同欄位相關聯。透過使用「網頁組件連線精靈」,您可以將 Products.xml 中的 SupplierID 欄位連結至 Suppliers.xml 中的 SupplierID 欄位。

現在您已經建立兩個 [資料檢視],接著將在 Products.xml 之 [資料檢視] 中的每個產品旁邊新增文字,而這些文字將以超連結方式連結到 Suppliers.xml 的 [資料檢視]。當您按一下第一個 [資料檢視] 中某個產品的超連結時,該產品的供應商連絡人資訊將會出現在第二個 [資料檢視] 中。

Products.xml 的 [資料檢視] 是來源網頁組件,而 Suppliers.xml 的 [資料檢視] 則是目標網頁組件。因為您將 [資料檢視] 插入做為表單,所以需要在表單欄位外面建立文字超連結。輸入文字後,選取文字,然後使用「網頁組件連線精靈」來建立 Products.xml 中的超連結,以連結到 Suppliers.xml 的 [資料檢視]。

  1. 在資料檢視中建立的 3o-,將游標移到右邊的 [包含產品名稱] 文字方塊中,按下空格鍵,,然後輸入順序。資料檢視使用 XSLT 格式設定,因為 「 訂單 」 文字會新增至清單中的每個產品] 欄位中。

    Order 出現在清單中每個產品的 ProductName 欄

  2. 在 [資料檢視] 中,選取 "order" 文字,以滑鼠右鍵按一下它,然後按一下快顯功能表上的 [網頁組件連線]。

    「網頁組件連線精靈」隨即開啟。

  3. 在 [選擇來源網頁組件上的動作以使用於此連線] 清單中,按一下[傳送資料列至],然後按 [下一步]。

    網頁組件連線精靈中的頁面

  4. 在 [選擇包含此連線之網頁組件的網頁] 區段中,按一下 [連線至此網頁上的網頁組件],然後按 [下一步]。

    網頁組件連線精靈中的頁面

  5. 在 [目標網頁組件] 清單中,按一下 suppliers.xml

  6. 因為您要篩選 Suppliers.xml 中的資料以符合第一個 [資料檢視] 中特定產品的 SupplierID,所以請按一下 [目標動作] 清單中的 [取得篩選值來源],然後按 [下一步]。

    網頁組件連線精靈中的頁面

  7. 在 [輸入至 Suppliers.xml] 欄中,向下捲動清單,直到您看到 SupplierID 為止。在清單的 SupplierID 左邊的 [Products.xml 中的欄] 一欄中,按一下儲存格,再按一下箭號,然後按一下清單中的 [SupplierID]。按 [下一步]。

    網頁組件連線精靈中的頁面

  8. 在 [建立超連結於] 清單中,按一下 [[ 目前的選取範圍 ]],然後按 [下一步]。

    網頁組件連線精靈中的頁面

  9. 按一下 [完成]。

  10. 按一下 [檔案] 功能表上的 [儲存檔案]。或者也可以按 CTRL+S。

文字 “order” 現在已經是超連結,並且已設定網頁組件連線。

頁面頂端

測試網頁組件連線

現在已經設定了網頁組件連線,就可以在瀏覽器中預覽網頁以測試連線。

  • 若要在瀏覽器中預覽檔案,請按一下 [通用] 工具列上的 [預覽],或按 F12。

這兩個網頁組件都會出現在瀏覽器的網頁上。若要顯示供應商的特定產品,請在第一個 [資料檢視] 中,按一下 ProductName 欄中所需產品旁邊的 order 超連結。該供應商的連絡人資訊就會出現在下方的第二個 [資料檢視]。

網頁上兩個連接的資料檢視

附註: Exotic Liquids 是 Chai、Chang 以及 Aniseed Syrup 的供應商。 New Orleans Cajun Delights 是 Chef Anton’s Cajun Seasoning 與 Chef Anton’s Gumbo Mix 的供應商。

頁面頂端

移除網頁組件連線

您也可以移除網頁組件連線,使得這兩個網頁組件不再連結。當您連接網頁組件時,每個網頁組件會列出該連線,如此一來,您只要使用來源或目標網頁組件,就可以移除連線。從來源網頁組件移除連線也會同時移除目標網頁組件的連線。

  1. 在 [資料檢視] 上按一下滑鼠右鍵,然後按一下快顯功能表上的 [網頁組件連線]。

  2. 在 [網頁組件連線] 對話方塊中,按一下您要移除的連線,然後按一下 [移除]。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×