設計表單範本為基礎的 Microsoft Access 資料庫

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

您可以設計搭配 Microsoft Office Access 資料庫查詢資料,或是來查詢及資料送出的 Microsoft Office InfoPath 表單範本。您可以設計表單範本根據Microsoft Office Access 2007 (.accdb 格式) 資料庫或 Access 資料庫儲存為舊版 (.mdb 格式)。

本文內容

概觀

相容性注意事項

開始之前

設計表單範本

設定 [送出] 選項

概觀

表單可以有一個主要的資料連線,稱為主資料連線,而該連線可以選擇性地有一或多個次要資料連線。您可以使用的主資料連線來查詢或送出表單資料至 Access 資料庫。您也可以使用查詢及資料送出到外部資料來源,有一些例外狀況的次要資料連線。例如,您可以使用次要資料連線到 Access 資料庫,使其只查詢資料庫。您無法新增次要資料連線至表單送出表單資料目錄到 Access 資料庫。

當您設計表單範本為基礎的 Access 資料庫時,InfoPath 就會建立主資料來源包含查詢欄位和資料欄位的群組,並也會建立查詢的資料連線,做為表單範本的主資料連線。這些欄位與群組會對應到資料會儲存在資料庫中的資料表中的方式。

查詢欄位的查詢結果限制為符合 [查詢] 欄位中的資料,且使用者輸入表單的資料。當此表單範本為基礎的表單使用的主資料連線時,InfoPath 就會建立查詢,使用 [查詢] 欄位中的資料。InfoPath 傳送到資料連線的查詢。資料庫會傳回查詢結果的資料連線到表單。查詢的結果是放到表單上的控制項繫結至這些資料欄位都可以編輯的資料欄位。

Because the data structure of the query and the data fields must match the way that data is stored in the database, you cannot modify these fields or groups in the main data source. You can only add fields or groups to the root group in the main data source. Find links to more information about data sources in the See Also section.

表單可以送出表單的主資料連線到資料庫的資料,如果表單範本為基礎的表單和資料庫符合下列需求:

  • 表單範本已無法在瀏覽器相容表單範本   如果您要設計瀏覽器相容表單範本 InfoPath 不會在主要的資料連線建立送出資料連線。若要允許使用者在瀏覽器相容表單範本為基礎的表單資料送出,使用 Web 服務的運作方式與資料庫。

  • 左的資料表關聯資料表的主資料來源中的每一對包含主索引鍵   至少一個的每一組相關資料表的關聯性必須包含從左側資料表的主索引鍵。

  • 無表單市集大型的二進位資料類型的主資料來源中的資料欄位   如果查詢包含可以儲存大型的二進位資料類型,例如圖片、 圖像、 OLE 物件、 檔案附件,Office Access 備忘資料類型或 SQL 文字資料類型的欄位,則 InfoPath 會停用送出資料連線。

InfoPath 可以讓送出資料連線,使用者可以送出到資料庫的主要資料來源中的資料欄位中所儲存的資料。您可以自訂此表單範本為基礎的表單的送出選項。

頁面頂端

相容性注意事項

您無法設計根據 Access 資料庫的瀏覽器相容表單範本。

頁面頂端

開始之前

您可以順利設計表單範本為基礎的 Access 資料庫之前,您會需要 Access 資料庫的下列資訊:

  • 名稱和資料庫的位置。

    附註: 請確定您的資料庫是在您的使用者可以存取的網路位置。

  • 如果表單範本可讓使用者送出表單至資料庫,將會收到的資料表名稱送出資料。當您設定的送出資料連線,您會使用此表格的主要資料表。

  • 提供傳送至資料庫,查詢的結果,如果您的表單範本只會查詢資料庫資料表的名稱。當您設定的查詢資料連線,您會使用此表格的主要資料表。

  • 主要資料表可能需要資料的任何其他資料表的名稱。在大部分情況下,在資料庫中已經建立資料表關聯。若要手動建立主要資料表與另一個資料表間的關聯,您需要兩個資料表的相關的欄位名稱。

頁面頂端

設計表單範本

若要設計表單範本與查詢資料連線,您需要建立的表單範本。當您建立的表單範本為基礎的資料庫時,則 InfoPath 會建立查詢的資料連線為表單範本與資料庫之間的主要資料連線。此程序會自動建立表單範本的主資料來源。

您建立的表單範本後,您必須新增控制項至表單範本,並將該控制項繫結至主資料來源中的欄位。這個選項可讓使用者能看到的表單中的查詢結果。

步驟 1: 建立的表單範本

  1. 在 [檔案] 功能表上按一下 [設計表單範本]。

  2. 設計表單範本] 對話方塊中,按一下 [在設計新的 [表單範本]。

  3. 根據] 清單中,按一下 [資料庫],然後按一下[確定]

    [資料連線精靈] 啟動

  4. 在 [資料連線精靈的第一個頁面上,按一下 [選取資料庫]。

  5. 在 [選取資料來源] 對話方塊中,瀏覽至您的資料庫的位置。

    附註: 如果您的資料庫儲存在網路位置中,瀏覽至該位置的通用命名慣例 (UNC) 路徑。未瀏覽至對應的網路磁碟機上透過網路位置。如果您使用的對應的網路磁碟機,建立此表單範本為基礎的表單的使用者會搜尋對應的網路磁碟機的資料庫。如果使用者未與任何對應的網路磁碟機,表單就不會找到資料庫。

  6. 按一下您的資料庫名稱,然後按一下 [開啟

  7. 在 [選取表格] 對話方塊中,按一下主索引的資料表或您想要使用的查詢,然後按一下[確定]

  8. 在精靈的下一個頁面上,選取 [顯示資料表的資料行] 核取方塊。

  9. 根據預設,所有的資料表中的欄位會新增至主資料來源的表單範本。清除您不想要包含在主要的資料來源中欄位的核取方塊。

    新增任何其他資料表或您想要使用中的查詢資料連線的查詢。

    如何進行?

    1. 按一下 [新增資料表]。

    2. 在 [新增資料表或查詢] 對話方塊中,按一下子資料表的名稱,然後按 [下一步。InfoPath 嘗試設定關聯比對兩個資料表中的欄位名稱。如果您不想使用建議的關聯性,請選取的關聯性,,然後按一下 [移除關聯。若要新增關聯,請按一下 [新增關聯。在 [新增關聯] 對話方塊中,按一下 [在個別的欄中,每個相關欄位的名稱,然後按一下[確定]

    3. 按一下 [完成]。

    4. 若要新增額外的子表格,請重複這些步驟。

  10. 按一下 [下一步]。

  11. 在精靈的最後一個頁面上,輸入主資料連線的名稱。這個名稱會出現在 [資料來源] 工作窗格中的 [資料來源] 清單中。

  12. 如果表單範本符合需求 [概觀] 區段中的,[精靈的 [在此頁面上的 [摘要] 區段會指出 InfoPath 啟用送出中的資料連線的主資料連線。

  13. 若要變更的送出資料連線的名稱,請在適當的方塊中輸入新名稱。

  14. 若要啟用您要送出到另一個表單資料送出資料的連線,您會稍後新增至表單範本的使用者,請清除 [啟用送出此連線] 核取方塊。

    附註: 如果表單範本不符合概觀一節中的需求,InfoPath 停用送出資料連線,而 [輸入送出連線的名稱] 方塊及啟用此連線的送出] 核取方塊無法使用。如果 InfoPath 已停用送出資料連線,您的表單範本的主資料連線會包含只查詢資料連線。

步驟 2: 將控制項繫結到的欄位

  1. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  2. 拖曳控制項至表單範本。

  3. 控制項繫結] 對話方塊中,選取您要繫結控制項的欄位。

頁面頂端

設定 [送出] 選項

如果表單範本與您在 [資料連線精靈中選取的資料表符合需求 [概觀] 區段中的,InfoPath 就會設定以使用其主要資料連線的資料送出表單範本。

如果您選擇使用此送出資料連線,InfoPath 設定表單範本,讓使用者可以送出表單資料至資料庫,然後也會送出] 按鈕新增至 [標準] 工具列和 [送出] 命令,檔案表單上的功能表。InfoPath 也設定表單範本,以便使用者送出表單,表單會保持開啟,並會顯示一則訊息,指出是否已成功送出表單。您可以變更的文字會出現在 [送出] 按鈕上,並使用者送出後,也變更表單的行為。

  1. 在 [工具] 功能表上按一下 [送出選項]。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請送出中的 [標題] 方塊中輸入新名稱選項] 對話方塊。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  2. 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項:

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×