移至新的 SharePoint 文件庫的發佈的表單範本

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

本文內容

概觀

開始之前

取得使用表單範本的複本

步驟 1︰ 將表單範本發佈至新的文件庫

步驟 2︰ 複製並連結的現有表單

概觀

在您將表單範本發佈至文件庫供使用者填寫之後,可能想要將表單範本移至另一個文件庫。例如,您可能要將表單範本移至更大容量的伺服器,讓更多使用者同時填寫表單。有些使用者所填寫的表單,可能是以儲存於原始文件庫中的表單範本為基礎。當您將表單範本移至新文件庫時,也要同時移動這些現有表單。您也要確認現有表單是否能在新文件庫中正常使用,然後封存或刪除舊文件庫。

提示: 將發佈的表單範本移至新文件庫之前,先擬定通知使用者表單已經移至新文件庫的計劃。要求使用者使用新文件庫儲存新表單或修改現有表單。計劃中也應該包含封存或刪除原始文件庫的程序。

若要將表單範本及其現有表單移至新文件庫,首先您需要將表單範本的工作複本發佈至新文件庫。工作複本是儲存在您電腦上或版本控制程式 (例如 Microsoft Visual SourceSafe) 中的版本。

提示: 如果您沒有表單範本的工作複本,可以從原始文件庫儲存表單範本複本至電腦,做為工作複本。

在您將工作複本發佈至新文件庫之後,需要將舊文件庫中的任何表單複製到新文件庫,然後將新文件庫中的表單重新連結至新發佈的表單範本。

如果因為移動表單範本而需要進行變更,請在發佈表單範本之前先進行變更。例如,移動表單範本之後,以此表單範本為基礎之表單所使用的外部資料來源位置可能也會變更。在這種情況下,您需要將表單範本中的資料連線變更成外部資料來源的新位置,然後發佈表單範本。如需關於變更資料連線的詳細資訊,請瀏覽「請參閱」一節中的的連結。

附註: 發佈表單範本無法儲存表單範本的相同。當您發佈表單範本時,發佈精靈會將發佈位置和處理指示的表單範本,讓使用者可以開啟此表單範本為基礎的表單。當您儲存表單範本時,就如同您將檔案儲存到您的電腦將表單範本的複本。當您要開放填寫您的使用者表單範本時,您應該一律使用發佈精靈。

頁面頂端

在您開始之前

將表單範本及任何以表單範本為基礎的現有表單移至新文件庫之前,您需要下列項目:

  • 表單範本的工作複本    這是您將修改然後重新發佈至新文件庫的表單範本複本。工作複本可以儲存在您電腦或版本控制程式 (例如 Visual SourceSafe) 中。

  • 所有新外部資料來源的位置    如果以表單範本為基礎的表單使用已變更的外部資料來源,您便需要外部資料來源的新位置。請向管理員確認您自己及使用者是否有適當權限來使用外部資料來源。如果表單範本是使用資料連線檔案中的設定以連接到外部資料來源,請確認資料連線檔案是否已更新外部資料來源的新位置。

  • 在執行 Windows SharePoint Services 3.0 之伺服器上的適當權限    您需要伺服器上的適當權限,以便將表單範本發佈至新文件庫,以及將舊文件庫中的所有現有的表單複製到新文件庫。請向伺服器管理員確認您是否有這些權限。

頁面頂端

取得表單範本的工作複本

如果想要修改已發佈至文件庫或共用網路的表單範本,但卻沒有表單範本的工作複本,您可以從發佈位置中將表單範本的工作複本儲存到電腦上。

提示: 請考慮使用版本控制程式 (如 Microsoft Visual SourceSafe),以管理表單範本的工作複本。

從文件庫中將表單範本的複本儲存到電腦上

  1. 在網頁瀏覽器中,開啟文件庫的發佈表單範本的位置。

  2. 在 [設定] 功能表中,按一下 [設定],然後按一下表單庫設定

  3. 按一下 [一般設定] 底下的 [進階設定]

  4. 按一下 [文件範本] 區段中的 [編輯範本]

    表單範本會開啟 Microsoft Office InfoPath 中。

  5. 按一下 [Microsoft Office InfoPath] 對話方塊中的 [是]

  6. 在 [檔案] 功能表上按一下 [另存新檔]。

  7. 在 [ Microsoft Office InfoPath ] 對話方塊中,按一下[確定]

  8. 在 [另存新檔] 對話方塊中,瀏覽到您要儲存表單範本複本的位置,然後按一下 [儲存]。

從共用網路資料夾中將表單範本的複本儲存到電腦上

  1. 在 [檔案] 功能表上按一下 [設計表單範本]。

  2. 按一下 [開啟表單範本] 底下的 [在我的電腦上]。

  3. 瀏覽至發佈的表單範本的共用的網路資料夾,按一下 [表單範本,再按一下 [開啟

  4. 在 [檔案] 功能表上按一下 [另存新檔]。

  5. 在 [ Microsoft Office InfoPath ] 對話方塊中,按一下[確定]

  6. 在 [另存新檔] 對話方塊中,請選取的位置,不是原始發佈您要儲存的表單範本中,使用複本的位置,然後按一下 [儲存

頁面頂端

步驟 1:將表單範本發佈至新文件庫

  1. 以設計模式開啟表單範本的工作複本。

  2. 按一下 [檔案] 功能表上的 [發佈]。

  3. 在 [發佈精靈] 中,按一下 [至 SharePoint 伺服器 (使用或不使用 InfoPath Forms Services 皆可)],然後按一下 [下一步]。

  4. 在 [輸入 SharePoint 或 InfoPath Forms Services 網站的位置] 方塊中,輸入要放置表單範本之新文件庫所在的 SharePoint 網站位置,然後按一下 [下一步]。

  5. 在精靈的下一頁,按一下 [文件庫],然後按一下 [下一步]。

  6. 按一下 [建立新文件庫],然後按一下 [下一步]。

  7. 在精靈的下一頁,輸入新文件庫的名稱及描述,然後按一下 [下一步]。

  8. 在表單範本中,選擇要在文件庫預設檢視中顯示為欄的欄位。

    做法

    1. 按一下 [新增]

    2. 選取您想要在文件庫中,以欄的方式新增的欄位,然後執行下列其中一項︰

      • 在 [欄名稱] 方塊中輸入資料行的名稱。

      • 網站欄群組清單中選取網站欄,選取 [欄名稱] 清單中的名稱,然後按一下[確定]

        附註: 如果您選取資料顯示在文件庫中的重複欄位時,您可以定義要如何顯示文件庫中的欄位,按一下 [函數] 清單中的值。您可以選擇是否要顯示的欄位,最後一個值] 欄位中或計數的所有欄位的項目中的第一個值或是否要合併的所有值。

    3. 按一下 [確定]

    您可以在「請參閱」一節中找到更多有關在文件庫中顯示欄中資料的資訊連結。

  9. 按一下 [下一步]。

  10. 在精靈的下一頁,確認顯示的資訊是否正確,然後按一下 [發佈]。

  11. 若要開啟文件庫,並測試填寫以此表單範本為基礎之表單的程序,請選取 [開啟此文件庫] 核取方塊,然後按一下 [關閉]。

    文件庫隨即在瀏覽器中開啟。當您按一下清單工具列上的 [新增] 時,以此表單範本為基礎的表單會在 Microsoft Office InfoPath 中開啟。

將表單範本發佈至新的文件庫之後,您可以從新文件庫將以舊版表單範本的現有表單複製到新文件庫。在複製現有表單之後,可以將現有表單重新連結至新版的表單範本。如果您沒有連結現有表單,使用者可能無法開啟這些現有表單。

頁面頂端

步驟 2:複製及重新連結現有表單

這個程序假設新舊文件庫都是位於執行 Windows SharePoint Services 3.0 的伺服器上。

  1. 在網頁瀏覽器中開啟舊文件庫。

  2. 按一下 [檢視] 功能表上的 [檔案總管檢視]。

  3. 按住 CTR 並選取要移動的每個表單,然後以滑鼠右鍵按一下其中一個表單。

  4. 在 [Internet Explorer] 對話方塊中,按一下 [是],然後按一下快顯功能表上的 [複製]。

  5. 開啟新文件庫。

  6. 在 [選取檢視] 底下按一下 [檔案總管檢視]。

  7. 以滑鼠右鍵按一下資料夾視窗中的空白區域。

  8. 在 [Internet Explorer] 對話方塊中,按一下 [是],然後按一下快顯功能表上的 [貼上]。

  9. 按一下 [檢視] 功能表上的 [重新連結文件]。

  10. 在 [重新連結] 欄中,對每個要連結至新表單範本的表單選取核取方塊。

  11. 在清單工具列上,按一下 [重新連結選取的文件]。

將現有表單重新連結至新表單範本之後,使用者便可以變更已複製到新文件庫中的現有表單,或填寫以新發佈表單範本為基礎的新表單。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×