新增資料至圖形

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

Microsoft Office Visio 繪圖不僅僅是圖片,它也可以是整理資料以及擷取報表資料的有效方法。

本文件將會討論手動新增資料至所選取圖形的最佳方式、如何建立一組可重複使用的資料讓您套用到繪圖中的多個圖形,以及新增資料至主圖形的方法。

附註: 下列程序會同時套用到 Microsoft Office Visio 專業版 2007 及 Microsoft Office Visio 標準版 2007。如果您有 Visio Professional,就可以自動匯入資料、新增資料至圖形,並使用資料圖片顯示圖形上的資料。如果要查明您的 Visio 版本,請按一下 [說明] 功能表上的 [關於 Microsoft Office Visio]。

您想要做什麼?

新增資料至選取圖形

建立一組可重複使用的資料欄位

新增資料欄位至主圖形

新增資料至選取圖形

若要將資料新增至繪圖中已經存在的圖形,您必須先將資料欄位新增至圖形,然後再新增欄位的值。

提示: 下列程序是新增資料至圖形最簡單的方式。不過,如果您想要將相同的資料新增至多個圖形,請考慮使用本文件其他段落中所描述的替代方案。

資料欄位與值兩者間的差異為何?

  • 資料欄位是一個具有名稱標籤的儲存格,可以擁有值。

  • 值就是位於資料庫資料表、工作表或圖形之儲存格中的文字或數字。

以下範例顯示 [圖形資料] 視窗,其中包含來自 [基本流程圖] 樣版中 [決策] 圖形的欄位及值。在這個例子中,欄位有 [時薪]、[需要存取網路] 及 [工期],而值分別是 [$49.00]、[是] 以及 [3 星期]。

顯示欄位與值的 [圖形資料] 視窗。

新增資料欄位至選取圖形

  1. 選取您要新增資料的圖形。

  2. 以滑鼠右鍵按一下選取項目,指向快顯功能表上的 [資料],然後按一下 [圖形資料]。

  3. 當您看到詢問是否要立即定義資料的訊息,請按一下 [是]。

    附註: 如果圖形中已經包含資料欄位,則不會顯示這個訊息。

  4. [定義圖形資料] 對話方塊中,輸入欄位的標籤。

  5. 若要建立其他欄位,請按一下 [新增] 並重複步驟 4。

  6. 定義所有資料欄位後,請按一下 [確定]。

    [圖形資料] 對話方塊隨即出現,並且會顯示您的欄位。

將值新增至資料欄位

  1. 按一下 [檢視] 功能表上的 [圖形資料視窗]。

  2. 一次選取一個圖形,並在 [圖形資料] 視窗中,輸入資料欄位的值。

    附註: [圖形資料視窗] 其內容只會顯示選取圖形的資料。

頁面頂端​​

建立一組可重複使用的資料欄位

您可以建立一組資料欄位,可以套用到您稍後置於繪圖中的圖形,當然也可以套用到繪圖中原有的圖形。

  1. 按一下 [檢視] 功能表上的 [圖形資料視窗]。

  2. 以滑鼠右鍵按一下 [圖形資料] 視窗中的任一位置,然後按一下 [圖形資料集]。

  3. 在 [圖形資料集] 視窗中,按一下 [新增]。

  4. 在 [新增圖形資料集] 對話方塊中,輸入資料集的名稱。

  5. 選取 [建立新集合],然後按一下 [確定]。

    該資料集隨即出現在 [圖形資料集] 視窗的 [名稱] 資料行中。

    附註: 如果想要變更現有的資料集,您也可以按一下其他的選項。

  6. 按一下 [名稱] 下的新資料集,然後按一下 [定義]。

  7. [定義圖形資料] 對話方塊中,輸入欄位的標籤。

  8. 若要建立其他欄位,請按一下 [新增],然後重複步驟 7。

  9. 定義所有資料欄位後,請按一下 [確定]。

  10. 若要將資料集套用到繪圖中的選取圖形,請選取 [圖形資料集] 視窗中的集合,然後按一下 [套用]。

    提示: 若要查看套用到某一圖形的新欄位,請選取該圖形,然後查詢 [圖形資料] 視窗。

頁面頂端​​

新增資料欄位至主圖形

如果想在每次使用特定圖形時新增相同的圖形資料集合,將資料欄位新增到該圖形主要複本的方式可以節省您的時間。例如,您可以將名稱及員工編號這類資料欄位新增到個人圖形的主圖形。

  1. 以滑鼠右鍵按一下要新增圖形資料的主圖形,指向 [新增到我的圖形],然後按一下 [新增到新樣板]。

    附註: 如果已經有自訂的樣版,除了建立新的樣版外,您也可以將主圖形新增到自訂樣版。

  2. 在 [另存新檔] 對話方塊中,輸入新樣版的名稱,然後按一下 [儲存]。

  3. 指向 [檔案] 功能表上的 [圖形],指向 [我的圖形],然後按一下包含主圖形複本的樣版。

  4. 以滑鼠右鍵按一下新樣版的標題列,然後按一下快顯功能表上的 [編輯樣板]。

  5. 以滑鼠右鍵按一下剛剛新增到樣版的圖形,指向 [編輯主圖形],然後按一下 [編輯主圖形]。

  6. 在圖形的編輯視窗中,以滑鼠右鍵按一下該圖形,指向 [資料],然後按一下 [圖形資料]。

  7. 當您看到詢問是否要立即定義資料的訊息,請按一下 [是]。

    附註: 如果圖形中已經包含資料欄位,則不會顯示這個訊息,不過您仍要繼續完成後續的步驟。

  8. 在 [定義圖形資料] 對話方塊中,輸入該欄位的名稱,並填入您要的任何其他資訊。例如,這次您可能想要變更資料類型或新增圖形提示。

  9. 若要建立其他欄位,請按一下 [新增] 並重複步驟 8。

  10. 定義資料欄位完成後,按一下 [確定]。

    [圖形資料] 對話方塊隨即出現,並且會顯示您的欄位。

    附註: 如果您想要變更欄位,請按一下 [定義] 然後重複步驟 8。

  11. 若要關閉圖形的編輯視窗,請按一下 [檔案] 功能表上的 [關閉]。

  12. 當您看到詢問是否要更新圖形的訊息,請按一下 [是]。

  13. 當您看到另一個詢問是否儲存樣版變更的訊息,請按一下 [是]。

頁面頂端​​

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×