建立或執行巨集

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

在 Word 中,您可以建立和執行巨集來自動化經常使用的工作。巨集是一系列的命令和您群組在一起以單一命令,以自動完成工作的指示進行。

若要節省您花在經常執行之工作上的時間,可將步驟組合成巨集。請先錄製巨集。然後,您可以按一下 [快速存取工具列] 上的按鈕,或按下按鍵組合來執行該巨集。視您設定的方式而定。

  1. 按一下 [檢視] > [巨集] > [錄製巨集]

    [錄製巨集] 命令

  2. 輸入巨集的名稱。

    巨集名稱方塊

  3. 若要在您建立的任何新文件中使用巨集,請確定 [將巨集儲存在] 方塊指定 [所有文件 (Normal.dotm)]

    選擇巨集存放位置的方塊

  4. 若要在您按一下按鈕時執行巨集,請按一下 [按鈕]

    按一下即可將巨集指定到按鈕。

  5. 按一下新巨集 (名稱類似 Normal.NewMacros.<您的巨集名稱>),然後按一下 [新增]

    巨集及 [新增] 按鈕

  6. 按一下 [修改]

    [自訂快速存取工具列] 方塊中的 [修改] 按鈕

  7. 選擇按鈕圖像,輸入您想要的名稱,再按兩次 [確定]

    [修改按鈕] 方塊中的按鈕選項

  8. 現在開始錄製步驟。針對工作中的每個步驟按一下命令或按下按鍵。Word 會記錄您的滑鼠點擊和按鍵動作。

    附註: 錄製巨集時,請使用鍵盤來選取文字。巨集不會錄製使用滑鼠進行的選擇。

  9. 若要停止錄製,按一下 [檢視] > [巨集] > [停止錄製]

    [停止錄製] 命令

您的巨集按鈕即會出現在 [快速存取工具列] 上。

[快速存取工具列] 上的 [巨集] 按鈕

若要執行巨集,請按一下該按鈕。

  1. 按一下 [檢視] > [巨集] > [錄製巨集]

    [錄製巨集] 命令

  2. 輸入巨集的名稱。

    巨集名稱方塊

  3. 若要在您建立的任何新文件中使用巨集,請確定 [將巨集儲存在] 方塊指定 [所有文件 (Normal.dotm)]

    選擇巨集存放位置的方塊

  4. 若要在按下鍵盤快速鍵時執行巨集,請按一下 [鍵盤]

    按一下即可將巨集指定到鍵盤快速鍵

  5. [按新設定的快速鍵] 方塊中輸入按鍵組合。

  6. 檢查該組合是否已經指定給其他動作。如果是,請嘗試不同的組合。

  7. 若要在您建立的任何新文件中使用鍵盤快速鍵,請確定 [將自訂儲存於] 方塊顯示為 [Normal.dotm]

  8. 按一下 [指定]

  9. 現在開始錄製步驟。針對工作中的每個步驟按一下命令或按下按鍵。Word 會記錄您的滑鼠點擊和按鍵動作。

    附註: 錄製巨集時,請使用鍵盤來選取文字。巨集不會錄製使用滑鼠進行的選擇。

  10. 若要停止錄製,按一下 [檢視] > [巨集] > [停止錄製]

    [停止錄製] 命令

若要執行巨集,請按下鍵盤快速鍵。

要執行巨集,請按一下 [快速存取工具列] 上的按鈕,按鍵盤快速鍵,或者,您也可以從 [巨集] 清單中執行巨集。

  1. 按一下 [檢視] > [巨集] > [檢視巨集]

    [檢視巨集] 命令

  2. [巨集名稱] 底下的清單中,按一下要執行的巨集。

  3. 按一下 [執行]

若要使某文件的巨集在所有新文件中皆可用,請將它新增到 Normal.dotm 範本。

  1. 開啟含有巨集的文件。

  2. 按一下 [檢視] > [巨集] > [檢視巨集]

    [檢視巨集] 命令

  3. 按一下 [組合管理]

    [檢視巨集] 方塊中的 [組合管理] 按鈕

  4. 按一下要新增至 Normal.dotm 範本的巨集,然後按一下 [複製]

  1. 按一下 [檔案] > [選項] > [自訂功能區]

  2. [由此選擇命令] 下,按一下 [巨集]

  3. 按一下所要的巨集。

  4. [自訂功能區] 底下,按一下要新增巨集的索引標籤和自訂群組。

如果沒有自訂群組,請按一下 [新增群組]。然後按一下 [重新命名] 並為自訂群組輸入名稱。

  1. 按一下 [新增]

  2. 按一下 [重新命名] 可為巨集選擇圖像並輸入所要的名稱。

  3. 按兩次 [確定]

  1. 按一下 [開發人員] 索引標籤上 [程式碼] 群組中的 [巨集]。

  2. 在 [巨集名稱] 方塊中,輸入巨集的名稱。

    附註: 如果您為新巨集相同名稱的內建的巨集在 Word 中,新的巨集指令將會取代內建的巨集。若要檢視的內建的巨集的清單,請按一下 [巨集存放在清單中的 [ Word 命令]。

  3. 在 [巨集作用於] 清單中,按一下範本或您要儲存巨集的文件。

    若要使用您的巨集的所有文件,請務必按一下Normal.dotm

  4. 按一下 [建立],開啟 Visual Basic 編輯器]。

開啟 Visual Basic 編輯器] 之後,您可能會想深入瞭解使用 Visual Basic for Applications。如需詳細資訊,請按一下 [說明] 功能表上的 [ Microsoft Visual Basic 說明,或按下 F1。

您可以錄製的動作,順序,或您也可以輸入應用程式中Visual Basic 編輯器的程式碼的 Visual Basic 中從頭開始撰寫巨集。

附註: 若要使用Office Word 2007中的巨集,必須先顯示 [開發人員] 索引標籤。

  1. 按一下 Microsoft Office 按鈕 Office 按鈕影像 ,然後按一下 [Word 選項]。

  2. 按一下 [常用]。

  3. 使用 Word 的最常用的選項] 底下選取 [在功能區顯示 [開發人員] 索引標籤] 核取方塊。

    附註: 功能區是 Microsoft Office Fluent 使用者介面的元件。

  1. 在 [開發人員] 索引標籤上,按一下 [程式碼] 群組中的 [錄製巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組
  2. 在 [巨集名稱] 方塊中,輸入巨集的名稱。

    附註: 如果您為新巨集的內建的巨集相同的名稱中Office Word 2007,新的巨集指令將會取代內建的巨集。若要檢視的內建的巨集,清單在開發人員] 索引標籤的 [程式碼] 群組中,按一下 [巨集。在 [巨集作用於] 清單中,按一下 [ Word 命令]。

  3. 在 [儲存巨集儲存在] 方塊中,按一下範本或您要儲存巨集的文件。

    重要: 若要使用您的巨集的所有文件,請務必按一下Normal.dotm

  4. 請在 [描述] 方塊中輸入巨集的描述文字。

  5. 請執行下列其中一項操作:

    • 開始錄製   若要開始錄製巨集,而不將它指派至 [快速存取工具列上的按鈕或快速鍵,請按一下[確定]

    • 建立] 按鈕   若要指定巨集的按鈕,快速存取工具列] 上,執行下列動作︰

      1. 按一下] 按鈕

      2. 在 [自訂快速存取工具列] 底下,選取 [文件 (或所有文件) 您想要將巨集新增至快速存取工具列。

        重要: 若要使用您的巨集的所有文件,請務必按一下Normal.dotm

      3. 在 [由此選擇命令] 對話方塊中,按一下您錄製的巨集,然後按一下 [新增]

      4. 若要自訂] 按鈕,按一下 [修改]。

      5. 在 [符號] 底下,按一下您想要使用的按鈕的符號。

      6. 在 [顯示名稱] 方塊中,輸入您想要顯示的巨集名稱。

      7. 按兩次,即可開始錄製巨集的[確定]。

        您選擇的符號會顯示在 [快速存取工具列。當您指向符號時,會顯示您所輸入的名稱。

    • 指派的鍵盤快速鍵   若要指定巨集的鍵盤快速鍵,執行下列動作︰

      1. 按一下 [鍵盤]。

      2. 在 [命令] 方塊中,按一下您要錄製的巨集。

      3. 在 [按新設定的快速鍵] 方塊中,輸入您要的按鍵組合,然後按一下指派

      4. 按一下 [關閉,開始錄製巨集]。

  6. 執行您想要包含在巨集的動作。

    附註: 當您錄製巨集時,您可以使用滑鼠按一下命令和選項,但無法以選取文字。您必須使用鍵盤選取文字。如需有關使用鍵盤選取文字的詳細資訊,請參閱選取文字

  7. 若要停止錄製您的動作,請按一下 [程式碼] 群組中的 [停止錄製]。

變更巨集的鍵盤快速鍵

  1. 按一下 Microsoft Office 按鈕 Office 按鈕影像 ,然後按一下 [Word 選項]。

  2. 按一下 [自訂]。

  3. 鍵盤快速鍵旁, 按一下 [自訂]。

  4. 在 [類別] 清單中,按一下 [巨集

  5. 在 [巨集] 清單中,按一下您想要變更的巨集。

  6. 在 [按新設定的快速鍵] 方塊中,輸入您要選擇的按鍵組合。

  7. 核取 [現用代表鍵] 方塊,請確定您不指定您已使用來執行其他工作的按鍵組合。

  8. 在 [儲存變更] 清單中,按一下符合您想要用來執行巨集的選項。

    重要: 若要使用您的巨集的所有文件,請務必按一下Normal.dotm

  9. 按一下 [關閉]

  1. 按一下 [開發人員] 索引標籤上 [程式碼] 群組中的 [巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組

  2. 在 [巨集名稱] 清單中,按一下您想要執行的巨集。

  3. 按一下 [執行]。

  1. 按一下 [開發人員] 索引標籤上 [程式碼] 群組中的 [巨集]。

    [開發人員] 索引標籤上的 [程式碼] 群組

  2. 在 [巨集名稱] 方塊中,輸入巨集的名稱。

    附註: 如果您為新巨集的內建的巨集相同的名稱中Office Word 2007,新的巨集指令將會取代內建的巨集。若要檢視的內建的巨集的清單,請按一下 [巨集存放在清單中的 [ Word 命令]。

  3. 在 [巨集作用於] 清單中,按一下範本或您要儲存巨集的文件。

    若要使用您的巨集的所有文件,請務必按一下Normal.dotm

  4. 按一下 [建立],開啟 Visual Basic 編輯器]。

開啟 Visual Basic 編輯器] 之後,您可能會想深入瞭解使用 Visual Basic for Applications。如需詳細資訊,請按一下 [說明] 功能表上的 [ Microsoft Visual Basic 說明,或按下 F1。

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×