建立型錄合併列印

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

Publisher 功能來建立簡短的目錄,您可以使用的範本。只選擇目錄範本,然後取代的版面配置區以自己的圖片,然後輸入您要的文字。

如果您想要建立更長的時間的目錄,您可以使用型錄合併列印。您也可以使用型錄合併列印來建立目錄、 相簿或其他任何類型的出版物的每一頁上顯示一或多個項目。[Microsoft Office 型錄合併列印] 工作窗格會引導您逐步型錄合併列印程序。

本文內容

型錄合併列印的運作方式

規劃您的目錄

建立範本

連線至您的資料來源

插入合併欄位

完成、 列印及儲存出版物的目錄

型錄合併列印如何運作

型錄合併列印非常類似合併。當您使用型錄合併列印時,建立型錄合併範本,然後再以產生合併的頁面資料來源中的資訊合併範本。

與合併範本結合的資料來源,用以產生出版物的頁面

1.具有資料來源記錄的資訊,例如項目名稱和描述。

2.型錄合併範本型錄合併區域,以及合併欄位的版面配置區的記錄資訊。

3.結果合併顯示每一頁的多筆記錄的頁面。

您可以將型錄合併列印儲存為新的出版物,或是加到現存出版物的結尾處。您也可以儲存型錄合併列印範本,方便您在更新資料來源的資訊或建立額外合併頁面集時,重複使用它。

開始之前

下列秘訣可以協助您建立成功的型錄合併列印:

  • 在新出版物中開始型錄合併列印。

  • 限制型錄合併範本為一頁的長度。

  • 依照您要用於最終合併頁面的頁面維度,設定型錄合併列印範本。

  • 如果您計劃將建好的合併頁面加到現存出版物的結尾處,請確認合併範本在以下方面符合現存出版物:

    • 頁面大小 (高度及寬度)

    • 整頁模式 (單頁模式或兩頁模式)

    • 出版物類型 (網路或印刷)

    • 頁面順序 (從左至右或從右至左)

頁面頂端

規劃型錄

開始型錄合併列印之前,請先考慮要列在最終合併頁面上的資訊類型。

  • 是否要列出項目名稱和價格?

  • 是否要加入各項目的描述?

  • 是否要加入各項目的圖片?

規劃資料來源

決定好要加入型錄的資訊類型後,您可以建立要用於型錄合併列印的資料來源。如果已經有資料來源,請確認其中包含您要加入合併型錄的所有資訊。

型錄合併列印] 工作窗格,可以使用各種不同的資料來源的格式。如果您還沒有要用於合併列印的資料來源,您可以產生一個在 Publisher 中。您也可以在 Microsoft Office Excel 工作表中或 Microsoft Office Word 表格中建立資料來源。

您的資料來源中包含的資料欄位會對應到您要插入型錄合併範本合併欄位。

設定資料來源時,請建立各種資訊類型 (例如項目名稱、庫存號碼和價格) 的欄。每一個列或每一筆記錄都會對應到某一個項目的資訊。

重要: 請確認您的資料來源包含資料欄位或資料行的每一種將合併列印的資訊。根據您的資料來源類型,您可以對資料進行一些變更之後您連線到其在 Publisher 中,但最好是您開始之前,先完成資訊。

如果您打算將相片合併到型錄頁面,您要包含的每個您要使用的圖片檔案路徑的資料行。請併入您的資料來源的實際的圖片或圖像。

如果您打算在 Publisher 中建立資料來源,您可以建立範本後,執行。

頁面頂端

建立範本

現在您可以建立型錄合併範本,您用來設計最後的合併頁面的版面配置。當您完成合併列印時,您可以使用型錄合併範本以產生合併的頁面,您可以儲存為新的出版物,或新增到現有的出版物的結尾。

型錄合併範本應具備相同的版面配置 (頁面大小與方向) 您想要用於最後的合併頁面。此外,它應該包含任何文字或圖形,您希望顯示在最終出版物的每個頁面上,例如、 背景圖像或您的公司名稱。

如果您計劃將合併頁面加到現存出版物的結尾處,請確認合併範本在以下方面符合現存出版物:

  • 頁面大小 (高度及寬度)

  • 整頁模式 (單頁模式或兩頁模式)

  • 出版物類型 (網路或印刷)

  • 頁面順序 (從左至右或從右至左)

建立型錄合併列印範本

  1. 按一下 [檔案] 功能表上的 [開新檔案]。

  2. 新的出版物] 工作窗格中,按一下空白頁面大小,,然後選擇您要的大小。

    如果您打算要張貼您的網站的目錄,按一下 [網站] 底下的空白頁面大小,然後按一下 [符合目標螢幕解析度的大小。

  3. 按一下 [建立]

  4. 在 [檔案] 功能表上按一下 [頁面設定]。

  5. 在 [版面設定] 對話方塊中,對您要的邊界進行任何變更,然後按一下[確定]

  6. [工具] 功能表中,指向 [郵件與型錄],然後按一下 [型錄合併列印]

頁面頂端

連接到資料來源

格式化您型錄合併範本頁面之後,請使用型錄合併列印] 工作窗格,以建立或找出並連線到您的資料來源。選擇 [下一步的選項取決於您是否已有資料來源,或是否要在 Publisher 中建立新的清單。

  1. 型錄合併列印工作窗格] 下選取的產品清單中,執行下列其中一項︰

  2. 按一下 [下一步︰ 建立或連線到產品清單

使用現有清單

  1. 在 [選取資料來源] 對話方塊中,找出並按一下您想要的資料來源。

    根據預設,Publisher 會儲存在 [我的資料來源] 資料夾中的資料來源。若要瀏覽至 [我的資料來源] 資料夾以尋找您的資料來源。

  2. 按一下 [開啟舊檔]

    根據您所選取的資料來源類型,其他對話方塊可能會出現要求特定的資訊。例如,如果您的資料來源具有多個索引標籤的相關資訊的 Excel 工作表,您必須選取包含您要資訊,然後按一下[確定]索引標籤。

從 Outlook 連絡人選取

  1. 請執行下列其中一項:

    • 在 [選取的連絡人] 對話方塊中,按一下您想要使用的連絡人清單。

    • 在 [選擇設定檔] 對話方塊中,選取您想要使用的連絡人正確的設定檔。

  2. 按一下 [確定]

輸入新清單

  1. 在 [新的產品清單] 對話方塊中,輸入第一個項目或您想要包含在您的目錄中的記錄的資訊。

    如果您想要新增或移除資料行,例如,如果您不包括圖片,按一下 [自訂資料行,然後再進行您所要的變更。

  2. 輸入第一筆記錄的所有資訊之後,請按一下 [新增項目],然後輸入下一筆記錄的資訊。繼續此動作,直到您要加入之所有記錄的資訊都輸入完畢為止。

  3. 完成新的清單後,請按一下 [確定]

  4. [儲存通訊清單] 對話方塊中,輸入新清單的名稱,然後按一下 [儲存]

加入更多清單

如果要在型錄合併列印中使用一個以上的清單,您可以加入清單。

  1. 型錄合併列印的產品清單中,新增至產品清單] 下按一下 [選取現有的清單,或選取 [從 Outlook 連絡人,請根據您所做的出版物。

新增更多項目

如果您想要新增只需要幾個項目,您可以建立新項目的清單,並將其結合您所選取的清單。

  1. 型錄合併列印的產品清單中,新增至產品清單] 下的 [鍵入新清單]

  2. 在 [新的產品清單] 對話方塊中,輸入您想要包含在您的目錄中的第一個項目的資訊。

    如果您想要新增或移除資料行,以符合您使用的清單,按一下 [自訂資料行,然後再的進行變更您要。

  3. 輸入第一筆記錄的所有資訊之後,請按一下 [新增項目],然後輸入下一筆記錄的資訊。繼續此動作,直到您要加入之所有記錄的資訊都輸入完畢為止。

  4. 完成新的清單後,請按一下 [確定]

  5. [儲存通訊清單] 對話方塊中,輸入新清單的名稱,然後按一下 [儲存]

  6. 您的新清單會自動出現在型錄合併列印的產品清單] 對話方塊中的資料來源

選取您要加入的記錄

  1. 型錄合併列印的產品清單] 對話方塊中,執行下列其中一項︰

    • 選取您要加入的記錄旁的核取方塊,然後取消選取您不要加入的記錄旁的核取方塊。

      如果您想要包含在清單中的幾個記錄,請按一下 [全部清除],然後選取 [您想要的記錄。

    • 用特定準則篩選清單,方法是按一下做為篩選依據之項目欄標題旁的箭號,然後按一下要用來篩選的值。

      • (空格)]會顯示對應的欄位為空白的所有記錄。

      • (非空白) 會顯示其中對應欄位包含資訊的所有記錄。

        附註: 如果您的資料來源包含共用相同的資訊,記錄的資料行中有 10 個或更少的唯一值,您可以篩選特定資訊。例如,如果您的資料來源是銷售內容的清單,有多個屬性記錄 Buffalo 作為縣/市/位置的清單,您可以篩選Buffalo

        型錄合併列印的產品清單] 對話方塊會顯示指定的記錄。若要再次顯示所有記錄,請按一下 [ (全部)]。

    • 按一下您要作為排序依據的項目] 欄標題來排序清單中的項目。例如,如果您想要依字母順序顯示依縣/市/位置的清單中,按一下 [縣/市/位置欄標題。

  2. 按一下[確定]返回型錄合併列印] 工作窗格。Publisher 會使用您所指定的記錄的合併列印。

  3. 按一下 [下一步︰ 準備出版物

頁面頂端

插入合併欄位

現在該來排列要顯示在出版物中的資訊了。要對頁面進行版面配置,請將合併欄位加入型錄合併列印區域中。每一個合併欄位都代表資料來源中的一個欄,而且型錄合併列印區域會顯示一筆記錄中的資訊如何顯示。

根據您的需求排列型錄合併列印區域,然後指定每一頁的合併區域重複數目。例如,您可能想要在每一頁顯示四個項目,而且每一個項目都依照您排列的型錄合併列印區域以相同方式顯示。您可以調整每一個項目的大小,也可以變更型錄合併列印區域的大小。

如果您插入型錄合併列印區域外的合併列印功能變數時,它們不會重複當您完成合併列印。

型錄合併區域中插入合併欄位

  • 型錄合併列印] 工作窗格中,在準備您的出版物中,按一下您想要插入的第一個合併欄位。

  • 在型錄合併列印區域中,選取合併欄位,然後執行下列操作以移動並調整合併欄位的大小:

    • 若要將合併列印功能變數,直到指標變更為移動指標 移動指標 ,將滑鼠指標放置合併列印功能變數,然後拖曳合併列印功能變數至新位置。

    • 若要調整大小的合併列印功能變數,將滑鼠指標移到其中一個文字或圖片框上的控點,直到指標變更為調整大小指標 移動尺規 ,然後拖曳滑鼠,直到文字或圖片框是您所要的大小。

  • 在合併欄位外面按一下,以便取消選取合併欄位。

  • 重複步驟 1-3,直到您從資料來源插入了所有需要的欄位。

    如果先前插入的合併欄位],當您插入新的合併列印功能變數時,Publisher 會插入新的合併列印欄位與先前插入的合併功能變數。

設定合併欄位的格式

您可以格式化合併的目錄資料型錄合併範本中的合併欄位的格式設定。

  1. 在型錄合併列印範本中,選取您要設定其資訊格式的欄位,包括周圍的合併欄位字元 («« »»)。

  2. 按一下 [格式] 功能表上的 [字型],然後選取所要的選項。

移動或調整型錄合併列印區域的大小

如果您設好格式的合併欄位不再適合型錄合併列印區域,您可以調整其大小。

如果您增加大小,您可能需要調整較少的項目或記錄,每個頁面上。

  1. 按一下以選取該型錄合併列印的區域

  2. 將滑鼠指標移至其中一個型錄合併列印區域,控點,然後拖曳滑鼠。

  3. 指定多少項目應出現在每個頁面上輸入您想要的項目在頁面上 [型錄合併列印版面配置] 工具列上的頁面的數字。

完成並預覽範本

  1. 輸入任何週期性的文字或您想要顯示資料來源中的資訊] 旁的資訊。例如,新增合併欄位的 [價格] 旁的貨幣符號。

  2. 在 [預覽] 頁面上按一下 [箭號,以檢視合併的資料的每一頁]。

    如果您決定不包含項目,按一下 [該項目的型錄合併列印區域,然後按一下 [型錄合併列印] 工作窗格中的 [排除此項目

  3. 當您準備好要繼續,請按一下下一步︰ 建立合併的出版物

頁面頂端

完成、列印和儲存型錄出版物

要完成合併,有三個選項:

  • 您可以直接列印合併出版物。

  • 您可以建立並列印包含合併內容的新出版物,也可以對此出版物的內容進行變更,就如同在 Publisher 中變更其他任何出版物一樣。

  • 您可以將合併內容加入現存出版物中。

如果您要為出版物加入封面和封底,或是要加入其他任何頁面,您需要建立新的出版物或將內容加入現存出版物中。

列印合併的出版物

  • 型錄合併列印] 工作窗格中,按一下 [列印]。

    Publisher 列印合併的頁面。

合併至新的出版物

如果您要編輯合併的頁面、 加以儲存以供日後使用,或於稍後列印時,您收集並儲存所有頁面合併為單一新增合併包含實際資料的出版物,,例如,[產品名稱] 和 [價格,而不是合併欄位。

  • 型錄合併列印] 工作窗格中,按一下 [合併到新的出版物

    Publisher 建立一個新的出版物,您可以儲存及編輯。您甚至可以加入最上層,並返回封面頁。

    如果您計劃列印為手冊類別目錄,請確定總頁數是四的倍數。

  • 在 [型錄合併列印] 工作窗格中,按一下 [儲存此出版物

  • 檔案名稱] 方塊中,輸入新出版物的名稱,然後按一下 [儲存

  • 如有必要,儲存您對型錄合併範本所做的任何變更。您可以建立其他合併的頁面,在您的資料來源中更新資訊時,一次使用此型錄合併範本。

加入至現存出版物

如果您已在個別出版物中設好封面,或是要將型錄放在較長出版物的結尾處,您可以直接加入合併內容。

將合併頁面加到現存出版物的結尾處之前,請確認合併範本在以下方面符合現存出版物:

  • 頁面大小 (高度及寬度)

  • 整頁模式 (單頁模式或兩頁模式)

  • 出版物類型 (網路或印刷)

  • 頁面順序 (從左至右或從右至左)

附註: 若要開啟的出版物,publisher 無法新增合併的頁面。如果您正在處理您要合併的出版物,請確定您儲存並關閉後再完成合併列印。

  1. 在 [型錄合併列印] 工作窗格中,按一下 [新增至現存的出版物。在開啟出版物] 對話方塊中,找出並選取您要新增合併的頁面,請在的出版物,然後再按一下 [開啟

    Publisher 隨即將合併頁面加到現存出版物的結尾處。

    若要重新排列更新的出版物中的頁面,請按一下您想要移動的頁面分類器,在任何頁面,然後將其拖曳到您想要的位置。

  2. 在現有的出版物中,按一下 [儲存更新的 [檔案] 功能表上的 [儲存]。

  3. 如有必要,儲存您對型錄合併範本所做的任何變更。您可以建立其他合併的頁面,在您的資料來源中更新資訊時,一次使用此型錄合併範本。

列印並儲存出版物的目錄

如果您建立新的合併的出版物,或如果您新增您型錄合併列印至現存的出版物時,您可以按一下 [檔案] 功能表上的 [列印來列印的出版物。

列印成手冊目錄出版物

  1. 在 [檔案] 功能表上按一下 [頁面設定]。

  2. 在 [邊界輔助線,底下,按一下 [進階]。

  3. 在 [版面配置類型] 底下,按一下 [小冊子]。

  4. 在 [頁面上調整的寬度高度的設定,,以符合原始大小的出版物。

    如果您沒有調整的頁面寬度與高度,Publisher 能位置兩個小冊子頁面上的原始的頁面大小,並不符合您的目錄。

儲存您的範本,以便您可以再次使用

最好儲存型錄合併範本。您可以使用其一次建立合併頁面的其他設定,當您更新您的資料來源中的資訊。若要儲存型錄合併列印出版物,執行下列動作︰

  1. 請確定您是在型錄合併列印出版物。

  2. 按一下 [檔案] 功能表上的 [儲存]。

  3. 輸入型錄合併列印出版物的名稱,然後再按一下 [儲存

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×