建立、執行、編輯或刪除巨集

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

若要節省您經常執行的工作時間,您可以為巨集錄製這些工作的步驟。接著,當您想要執行一個這些記錄的工作,您可以啟動要執行的步驟,為您的巨集。

Word

在 Mac 版 Word 2016,您可以建立鍵盤快速鍵的巨集、 執行巨集,和刪除您不再需要的巨集。

  1. 按一下 [檢視] > [巨集] > [錄製巨集]

    在 [檢視] 索引標籤上,按一下 [巨集],然後再按一下 [錄製巨集] 以開始建立巨集。
  2. 輸入巨集的名稱或接受預設的Word提供。

    在 [巨集] 名稱中輸入您的巨集名稱,或接受 Word 提供的一般名稱。
  3. 若要在您建立的任何新文件中使用巨集,請確認 [巨集儲存在] 清單中已選取的所有文件 (一般)]

  4. 按一下 [鍵盤按鍵組合給您的巨集]。

    Word會顯示 [自訂鍵盤] 對話方塊。

  5. 在 [按新的鍵盤快速鍵] 方塊中輸入按鍵組合。

    在您按下按鍵組合之後,Word 會顯示指派給該組合的命令或巨集 (如果有的話)。

    當您按下按鍵組合時, Word會顯示的命令或目前指派給該按鍵組合,如果有任何動作。

  6. 如果您選擇的按鍵組合已指派,從 [按新的鍵盤快速鍵] 方塊中,將其刪除,然後選擇 [新的按鍵組合。

    進入下一個步驟之後您找到未指定的按鍵組合。

    Word 會指出您按下的按鍵組合尚未指派命令或巨集。
  7. 若要在任何新文件中使用此鍵盤快速鍵,確定Normal.dotm,通用範本,儲存變更] 清單中選取。

    選取 Normal.dotm 讓巨集可以在您建立的新文件中使用。
  8. 按一下 [指定]。

  9. 當您準備好錄製巨集時,按一下[確定]

  10. 按一下的命令或按下按鍵每一個步驟中工作。

    Word記錄,您只要按下滑鼠和鍵盤輸入,但不會記錄您使用滑鼠選取的文字。若要選取文字時錄製巨集,請使用鍵盤。

  11. 若要停止錄製,按一下 [檢視] > [巨集] > [停止錄製]

    按一下 [巨集] 功能表上的 [停止錄製] 以停止錄製巨集。

若要執行巨集,請按鍵盤快速鍵,或從 [巨集] 清單中執行巨集。

  1. 按一下 [檢視] > [巨集] > [檢視巨集]

    按一下 [檢視巨集] 以檢視和編輯與目前文件關聯的巨集。
  2. 在 [巨集名稱] 清單中,選取您想要執行的巨集。

  3. 按一下 [執行]。

    在 [巨集] 名稱下選取某個巨集之後,按一下 [執行] 來執行該巨集。

  1. 按一下 [檢視] > [巨集] > [檢視巨集]

    按一下 [檢視巨集] 以檢視和編輯與目前文件關聯的巨集。
  2. 請確認指定的巨集的位置,包含您想要刪除的巨集的位置。

    選取您要從巨集清單中檢視巨集的位置。

    清單中會包含在目前的視窗中,以及全域的範本] 及 [ Word命令已開啟的文件。

  3. 在 [巨集名稱] 底下,選取您想要刪除的巨集,然後按一下減號清單下方。

    選取您要刪除的巨集,然後按一下清單下的減號。
  4. 當Word詢問時以確認您要刪除的巨集時,請按一下 []。

Excel

在 Mac 版 Excel 2016 中,您可以建立鍵盤快速鍵的巨集、 執行巨集,和刪除您不再需要的巨集。

當您錄製巨集時,巨集錄製器記錄的所有步驟都才能完成您要執行巨集的動作。這些步驟可以包含輸入文字或數字,按一下 [儲存格] 或 [命令功能表、 格式設定、 選取儲存格、 列或欄,並拖曳滑鼠或功能區上選取您的試算表上的儲存格。

附註: 錄製、 建立,或刪除巨集,以及其他進階的功能的命令也可在功能區上的 [開發人員] 索引標籤上。如需有關如何使用 [開發人員] 索引標籤的詳細資訊,請參閱建立或刪除巨集在 Mac 版 Excel 2016 中的 [開發人員] 索引標籤

  1. 選取 [工具] >巨集>新的記錄

    選取 [工具],然後巨集,然後錄製新巨集

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    輸入巨集名稱、 位置及捷徑金鑰

  3. 若要建立巨集的鍵盤快速鍵,請在 [ Option + Cmd ] 方塊中鍵入字母。

  4. 從下拉式清單中選取巨集的位置。

    若要儲存巨集

    按一下

    在您正在建立巨集的文件

    [本活頁簿]

    在所有開啟的文件中

    [新增活頁簿]

    每當您使用 Excel 時即可使用

    個人巨集活頁簿

  5. (選用)新增您的巨集的描述。

  6. 當您準備好錄製時,按一下[確定]

  7. 按一下的命令或按下按鍵每一個步驟中工作。

  8. 若要停止錄製,請選取 [工具>巨集>停止錄製。(此步驟將不會記錄在您的巨集。)

    選取 [停止錄製

若要執行巨集,請按鍵盤快速鍵,或從 [巨集] 對話方塊中執行巨集。

  1. [檢視] 索引標籤上,按一下 [檢視巨集]

  2. 在快顯功能表中的 [巨集,然後選取 [此活頁簿

  3. 從清單中選取您的巨集,然後按一下 [執行]

    Mac 版 Excel [巨集] 對話方塊

  1. 選取 [工具] >巨集>巨集

    選取巨集,然後選取 [巨集

  2. 選取要刪除的巨集,然後按 [減號。

    選取巨集名稱,然後選取 [減號

  3. 會顯示確認訊息。按一下 [ ]確認刪除。

    確認刪除

您也可以從 [開發人員] 索引標籤刪除巨集。

  1. [開發人員] 索引標籤上,按一下 [巨集]

  2. 在清單中,按一下要刪除的巨集,然後按一下刪除按鈕。

    選取巨集,然後按一下減號即可將其刪除

Word

若要自動化重複的工作,您可以在 Word 中快速建立巨集。 您也可以在 Microsoft Visual Basic for Applications 中使用 Visual Basic 編輯器來撰寫自己的巨集指令碼,或將巨集的全部或部分複製到新巨集。

當您錄製巨集時,記錄才能完成動作所要執行巨集的所有步驟。不過,回到 [停止錄製] 索引標籤的功能不會包含在記錄的步驟。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [錄製]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

  3. [將巨集儲存在] 快顯功能表上,執行下列其中一項操作:

    儲存巨集

    按一下

    在您正在建立巨集的文件中

    [[文件名稱] (文件)]

    在所有開啟的文件中

    [所有文件 (一般)]

  4. 按一下 [確定],然後執行要錄製的動作。

  5. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [停止]

您可以使用內建的 Visual Basic 編輯器建立巨集。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [編輯器]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 如果需要插入模組,請在 [Visual Basic 編輯器] 的 [插入] 功能表上,按一下 [模組]

  3. 在模組的程式碼視窗中,輸入或貼上要使用的巨集程式碼。

  4. 當您完成時,請在 [Word] 功能表上,按一下 [關閉並返回 Microsoft Word]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下您要執行的巨集,然後按一下 [執行]

若要編輯巨集,可使用 Visual Basic 編輯器。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要編輯的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 進行所需的變更。

  4. 當您完成時,請在 [Word] 功能表上,按一下 [關閉並返回 Microsoft Word]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要複製的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示: 若要複製整個巨集,請將 [Sub] 及 [End Sub] 這兩行包括在選取範圍中。

  4. 按一下 [編輯] 功能表上的 [複製]

  5. 在程式碼視窗的 [專案] 方塊中,按一下要放置程式碼的模組。

  6. 按一下 [編輯] 功能表上的 [貼上]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Word [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要刪除的巨集,然後按一下 [刪除]

PowerPoint

這樣便可自動化重複性的工作,您可以在 PowerPoint 中建立巨集使用 Visual Basic for Applications。

您可以使用內建的 Visual Basic 編輯器建立巨集。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [編輯器]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 如果需要插入模組,請在 [Visual Basic 編輯器] 的 [插入] 功能表上,按一下 [模組]

  3. 在模組的程式碼視窗中,輸入或貼上要使用的巨集程式碼。

  4. 當您完成時,請在 [PowerPoint] 功能表上,按一下 [關閉並返回 Microsoft PowerPoint]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下您要執行的巨集,然後按一下 [執行]

若要編輯巨集,可使用 Visual Basic 編輯器。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要編輯的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 進行所需的變更。

  4. 當您完成時,請在 [PowerPoint] 功能表上,按一下 [關閉並返回 Microsoft PowerPoint]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要複製的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示: 若要複製整個巨集,請將 [Sub] 及 [End Sub] 這兩行包括在選取範圍中。

  4. 按一下 [編輯] 功能表上的 [複製]

  5. 在程式碼視窗的 [專案] 方塊中,按一下要放置程式碼的模組。

  6. 按一下 [編輯] 功能表上的 [貼上]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    PowerPoint [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要刪除的巨集,然後按一下 [刪除]

Excel

若要自動化重複的工作,您可以在 Excel 中快速建立巨集。 您也可以在 Microsoft Visual Basic for Applications 中使用 Visual Basic 編輯器來撰寫您自己的巨集指令碼,或將巨集的全部或部分複製到新巨集。

完成您希望巨集執行的動作所需的所有步驟都會錄製下來。 不過,回到索引標籤以停止錄製的動作並不會包含在錄製的步驟中。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [錄製]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. [巨集名稱] 方塊中,輸入巨集的名稱。

    提示: 若要建立巨集的鍵盤快速鍵,請在 [Option+Cmd+] 方塊中鍵入字母。

  3. [將巨集儲存在] 快顯功能表上,執行下列其中一項操作:

    儲存巨集

    按一下

    在您正在建立巨集的文件中

    [本活頁簿]

    在所有開啟的文件中

    [新增活頁簿]

    每當您使用 Excel 時即可使用

    [個人巨集活頁簿]

    個人巨集活頁簿位於使用者 /使用者名稱/程式庫/應用程式支援 / Microsoft/Office/Excel。

  4. 按一下 [確定],然後執行要錄製的動作。

  5. [開發人員] 索引標籤的 [Visual Basic] 下方,再按一下 [錄製]

您可以使用內建的 Visual Basic 編輯器建立巨集。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [編輯器]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 如果需要插入模組,請在 [Visual Basic 編輯器] 的 [插入] 功能表上,按一下 [模組]

  3. 在模組的程式碼視窗中,輸入或貼上要使用的巨集程式碼。

  4. 當您完成時,請在 [Excel] 功能表上,按一下 [關閉並返回 Microsoft Excel]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下您要執行的巨集,然後按一下 [執行]

    提示: 若要使用鍵盤快速鍵執行巨集,請按 OPTION + COMMAND + 建立鍵盤快速鍵時所鍵入的字母。

若要編輯巨集,可使用 Visual Basic 編輯器。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要編輯的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 進行所需的變更。

  4. 當您完成時,請在 [Excel] 功能表上,按一下 [關閉並返回 Microsoft Excel]

完成此程序後,每當您開啟包含該巨集的活頁簿時,巨集就會執行。

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [錄製]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. [巨集名稱] 方塊中,輸入 Auto_Open

  3. [將巨集儲存在] 快顯功能表上,執行下列其中一項操作:

    儲存巨集

    按一下

    在您正在建立巨集的文件中

    [本活頁簿]

    在所有開啟的文件中

    [新增活頁簿]

    每當您使用 Excel 時即可使用

    [個人巨集活頁簿]

  4. 按一下 [確定],然後執行要錄製的動作。

  5. [開發人員] 索引標籤的 [Visual Basic] 下方,再按一下 [錄製]

  6. 按一下 [檔案] 功能表上的 [另存新檔]

  7. [格式] 快顯功能表上,按一下[Excel 啟用巨集的活頁簿 (.xlsm)],然後按一下 [儲存]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要複製的巨集,然後按一下 [編輯]

    Visual Basic 編輯器便會開啟。

  3. 在 [Visual Basic 編輯器] 的程式碼視窗中,選取要複製的巨集行。

    提示: 若要複製整個巨集,請將 [Sub] 及 [End Sub] 這兩行包括在選取範圍中。

  4. 按一下 [編輯] 功能表上的 [複製]

  5. 在程式碼視窗的 [專案] 方塊中,按一下要放置程式碼的模組。

  6. 按一下 [編輯] 功能表上的 [貼上]

  1. [開發人員] 索引標籤的 [Visual Basic] 下方,按一下 [巨集]

    Excel [開發人員] 索引標籤、[Visual Basic] 群組

    如果無法使用 [開發人員] 索引標籤

    1. 在功能區的右邊,先按一下 [動作] 快顯功能表 ,然後再按一下 [功能區喜好設定]

    2. [自訂] 下方,選取 [開發人員] 核取方塊。

  2. 在清單中,按一下要刪除的巨集,然後按一下 [刪除]

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×