將 Word 文件轉換為 InfoPath 表單範本

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

雖然您可以使用 Microsoft Office Word 建立的文件的外觀和類似表單,Word 最適合作為文字處理程式,而不是表單設計程式。相反地,Microsoft Office InfoPath 建立特別的設計,並填寫電子表單。如果您想要將現有的 Word 文件轉換成 InfoPath 表單範本,您可以在 InfoPath 中使用匯入精靈,執行此作業。然後可以利用專用的 InfoPath 功能設計、 發佈,並填寫的表單。例如,在銷售報表表單範本中,您可以使用條件式格式設定數字低於銷售估算時,會自動套用紅色的背景色彩。在相同的表單範本中,您可以使用規則啟用當有人按一下送出] 按鈕時傳送電子郵件附件的表單範本為基礎的表單。此外,您可以對表單範本提供更多的對象藉由建立瀏覽器使用的表單範本。

當您將 Word 文件轉換成 InfoPath 表單範本時,產生的表單範本密切相符 Word 文件版面的配置。此外,在 Word 文件中符合特定條件的項目都會自動轉換適當控制項讓使用者可以輸入資料。例如,如果在 Word 文件包含方括號括多個空格,InfoPath 假設您作為文字項目欄位中的括號的區域,並將其轉換成產生的表單範本中的文字] 方塊控制項。任何 Word 表單欄位會轉換為 InfoPath 中的相對應的控制項。

您可以使用 [匯入選項] 對話方塊中的設定,變更 Word 文件轉換成 InfoPath 表單範本的選項。

本文說明的基本概念及程序將 Word 文件轉換成 InfoPath 表單範本,包括的功能及轉換程序中不支援的設定。

本文內容

有關將 Word 文件轉換為 InfoPath 表單範本

Word 功能和轉換期間未完全支援的設定

將 Word 文件轉換成 InfoPath 表單範本

將版面配置表格變更重複表格

變更核取方塊,以一組選項按鈕

檢閱轉換問題,在 [設計檢查工作窗格

有關將 Word 文件轉換為 InfoPath 表單範本

當您將 Word 文件轉換成 InfoPath 表單範本時,文件會使用像是藍圖,來建立新的表單範本。盡可能表單範本中重新建立文件的基本結構。在 Word 文件中,「 表單欄位 」 是特定類型的資料,例如名稱或地址所在的位置。如果您選擇當您轉換文件、 文字方塊、 核取方塊,並將下拉式清單方塊控制項新增至 InfoPath 表單範本位置的 Word 文件中的欄位對應的位置,包括 Word 表單欄位。此外,InfoPath 會自動偵測可能運作以及重複表格和 rtf 文字] 方塊中,並將其轉換成適當的控制項的 Word 文件部分。例如,如果費用報表文件包含空白的加上底線區域,讓使用者可以輸入特定的費用的相關附註,InfoPath 會將該區域轉換 rtf 文字方塊。使用者可以接著 [rtf 文字] 方塊中輸入多行文字,然後設定適當的文字格式。

若要進一步瞭解使用 InfoPath 匯入精靈,並產生的 InfoPath 表單範本轉換的 Word 文件之間的關聯性,假設過去數年貴組織已使用的稱為 ExpenseReport.doc Word 文件若要從員工收集費用報表資料。您的 IT 部門想要將文件轉換成 InfoPath 表單範本,以便將表單資料可以為可延伸標記語言 (XML) 提交帳款系統。

如果您使用匯入精靈,將 ExpenseReport.doc 轉換至表單範本時,則 InfoPath 會建立稱為 ExpenseReport.xsn 表單範本。在下列範例中,將結果的 InfoPath 表單範本中的重複表格已轉換 Word 文件中的費用詳細資料] 資料表。重複表格可讓使用者插入或移除所需的支出的快顯功能表上的命令,即可。

Word 表格已轉換為 InfoPath 重複表格

Word 文件轉換成 InfoPath 表單範本時,會保留版面配置及其他元素。根據預設,InfoPath 重複表格中的空白資料列的數字符合 Word 表格中的空白資料列數目。不過,您也可以顯示只要一或兩個資料列根據預設,以節省空間表單範本上。

此新的表單範本包含類似於 Word 文件,例如用來收集費用資訊表格中的項目。不過,根據您選擇匯入精靈中的設定,有些功能可能會有所不同產生的表單範本中:

  • 如果您使用匯入精靈,匯入的 Word 文件,藉由保留只在版面配置   產生的表單範本包含費用報表中輸入項目重複表格。不過,就會從所產生的表單範本捨棄原始文件,例如名稱] 文字方塊中、 部門] 下拉式清單中和除法核取方塊,從任何表單欄位。

  • 如果您使用匯入精靈,匯入的 Word 文件保留版面配置及轉換 Word 表單欄位的控制項 (預設)   產生的表單範本包含費用報表中輸入項目重複表格。從原始文件,例如名稱] 文字方塊中、 部門] 下拉式清單中和除法核取方塊,任何表單欄位會轉換成對應的 InfoPath 控制項。

  • 如果您使用匯入精靈,匯入的 Word 文件保留版面配置及轉換 (自訂) 控制項的表單欄位   您可以選擇當您匯入費用報表完全轉換的欄位。例如,您可以停用將文件中的空白表格儲存格轉換成文字] 方塊中所產生的表單範本的選項。

頁面頂端

Word 功能和轉換期間未完全支援的設定

在 InfoPath 表單範本中不支援某些設定,以及 Word 文件中的格式設定。當您轉換 Word 文件包含這些設定時,這些功能或設定不會包含結果的表單範本。例如,Word 文件有修訂標記,修訂標記將會捨棄產生的表單範本中,因為 InfoPath 不支援此功能。

您可以使用 [設計檢查] 工作窗格中設計模式 ,探索轉換任何問題。您可以採取以修正這些問題的動作。

以下是功能和設定不會保留,當您將 Word 文件轉換成 InfoPath 表單範本的清單。在某些情況下,設定格式化的捨棄,但會保留而基礎文字。例如,如果您有新聞稿樣式欄,InfoPath 可捨棄資料行,,但匯入包含這些資料行中的文字。

  • 書籤

  • 動畫效果的文字

  • 佈景主題

  • 浮水印

  • 行號

  • 頁面框線

  • 註腳和章節附註

  • 新聞稿樣式欄版面配置

  • 檔案附件

  • 連結或內嵌物件,例如 Microsoft Office Excel 工作表和 Microsoft Office Visio 繪圖

  • 繪圖物件 (包括快取圖案、 曲線、 線條及文字藝術師)

  • 字元間距 (包括縮放、 展開或縮合間距引發或降低位置的文字,及字型的字元間距調整)

  • ActiveX 控制項

  • 註解和追蹤的修訂 (包括插入,刪除及格式設定變更)

  • 特定Microsoft Office Word 2007 (包括建置組塊及內容控制項) 的一些功能

  • 部分列印設定 (包括頁首、 頁尾、 奇偶頁不同和偶數頁首和頁尾、 不同的頁首和頁尾第一頁、 裝訂邊設定、 上方和下方邊界,不同的頁面方向、 負數值中的格式設定的混合的字元與個別章節設定)

附註: 密碼才能修改部分的 Word 文件。如果這是與您的文件的情況,您可能無法成功將 InfoPath 匯入。若要修正此問題,請嘗試從文件移除密碼保護,您匯入之前。此外,某些文件限制特定類型的編輯動作,例如表單欄位中輸入資料的使用者。如果這是與您的文件的情況,您可能無法成功將 InfoPath 匯入。若要修正此問題,請嘗試移除您的文件的編輯限制,您匯入之前。

下列清單說明的功能和受到部分支援,當您將 Word 文件轉換成 InfoPath 表單範本的設定:

垂直的文字   InfoPath 會保留在 Word 文件設定格式如果表格儲存格內找不到垂直文字的垂直文字。InfoPath 捨棄垂直的文字格式設定轉換為 Word 文件,如果垂直文字的 Word 文件的另一個組件中找到外部表格儲存格時。

文字方塊   在 Word 文件,文字方塊會是可以調整大小及放置在頁面上的文字容器。如果 Word 文件包含文字方塊,該文字方塊會轉換成產生的表單範本中的表格儲存格。[文字] 方塊中的任何文字會出現在表格中的儲存格所產生的表單範本。

加底線的文字   InfoPath 表單範本支援底線。不過,在 Word 文件中的任何裝飾或雙底線會轉換成單底線產生的表單範本中。

超連結的參照不受支援的通訊協定    轉換所有超連結,但在使用者按一下產生的表單範本中的連結時,如果超連結使用 HTTP、 HTTPS、 檔案、 FTP,或 MAILTO 通訊協定,將無法運作的超連結。

字元樣式和文字效果   上標、 下標和單一的刪除線格式設定樣式會保留在轉換程序。其他格式設定樣式和效果,包括大綱的文字、 隱藏的文字和陰影格式會轉換過程捨棄。浮凸或雕刻文字會轉換成灰色產生的表單範本中的文字。

分節設定   在 Word 中,區段可用來在某一頁面或頁面之間的文件的版面配置視情況而定。InfoPath 不支援下列類型的轉換程序期間會捨棄的節。套用至 Word 文件的第一節中的任何設定會套用至所產生的 InfoPath 表單範本。

頁首及頁尾格式   Word 文件中的頁首及頁尾的文字會轉換成產生的 InfoPath 表單範本中的頁首及頁尾的文字。某些字元格式設定可能會遭到捨棄轉換過程。例如,如果您使用的 Word 文件頁首中的粗體和斜體格式設定,InfoPath 會使用遭遇產生的表單範本中的第一個格式設定樣式,並放棄剩餘的格式設定。同樣地,就會套用至 Word 文件中第一個頁首或頁尾區段的任何設定會套用至所產生的頁首或頁尾文字,在 InfoPath 表單範本。

字型轉換   雖然 InfoPath 匯入的字型從 Word 文件時建立新的表單範本,如果文件中的字型無法使用您用來執行匯入的電腦上的表單範本會自動選取替代字型。

負數的頁面邊界   負數的上方和下方邊界將匯入為 0。

負數的邊界、 邊框和縮排設定   負數的邊界、 邊框和縮排設定將匯入為 0。

頁面頂端

將 Word 文件轉換為 InfoPath 表單範本

  1. 如果您要匯入的 Word 文件已開啟,請將其關閉。

  2. 在設計模式中,按一下 [檔案] 功能表中按一下 [匯入表單]。

  3. 在匯入精靈] 中,按一下InfoPath 匯入工具的 Word 文件,,然後按 [下一步

  4. 按一下 [瀏覽]

  5. 找出並按一下您想要轉換的 Word 文件,然後再按一下 [開啟

    附註: 如果您要匯入的 Word 文件,具有限制權限,您必須具備 「 完全控制存取文件。如果您僅有已讀取] 或 [變更存取文件,您會看到一則錯誤訊息,當您嘗試匯入。

  6. 若要變更預設匯入行為,按一下 [選項],然後按一下您要的選項。

  7. 按一下 [完成]。

頁面頂端

將版面配置表格變更重複表格

如果您的 Word 文件包含資料表,InfoPath 可能會將其轉換成表格版面配置或產生的表單範本中的重複表格。選擇資料表的類型而定的 Word 文件中您所做的設計決策。若要快速變更重複表格已轉換的版面配置表格,您可以使用下列程序。

若要提供使用者額外的大的彈性,填寫表單時,您可以使用重複表格。當您使用的重複表格時,您的表單範本沒有使用者第一次開啟時,顯示大量的空白列。不過,使用者通常會看到只有一個資料列,然後只,可視需要新增更多。這會儲存在表單中的空間,並提供使用者額外的程度的個人化。

  1. 在表單範本中,您想要轉換的版面配置表格內的任何位置按一下滑鼠右鍵。

  2. 在快顯功能表中,指向 [變更為,然後按一下 [重複表格

  3. 在 [變更重複表格大小] 對話方塊中,執行下列一或多項動作:

    • 若要指定重複表格的標題列,請保留為表格標題的列數] 方塊中輸入值。通常,您會使用標題列的欄標題。

    • 若要指定重複表格的頁尾列,請為表格頁尾保留的列數] 方塊中輸入值。多個資料表不包含頁尾列。

    • 若要指定要使用的資料列數目,值方塊中輸入包含時填寫表單的資料列數目重複。資料列是可以 「 重複 」 需要的表單中的一列

  4. [插入] 功能表中,按一下 [其他控制項] 或按 ALT + I、 c。

  5. 插入您要在表格儲存格的控制項。

頁面頂端

將核取方塊變更為一組選項按鈕

如果您在 Word 文件中使用多個核取方塊,則 InfoPath 匯入其為結果的 InfoPath 表單範本中的核取方塊。如果您想要使用的選項按鈕群組,請遵循下列步驟以轉換表單範本中的 [選項] 按鈕的核取方塊。

當您想要使用者可以從有限的選項的只要選取項目,您可以使用 Microsoft Office InfoPath 表單範本上的選項按鈕群組。

  1. 在表單範本中,按一下您想要轉換,然後按住 CTRL 並按一下每個您想要轉換的其他核取方塊的核取方塊。

  2. 在 [編輯] 功能表中,按一下 [變更為,然後按一下 [選項] 按鈕

    選項按鈕群組現在會出現取代表單範本中的核取方塊。每個選項按鈕繫結到資料來源中的相同欄位。當使用者按下的選項按鈕時,與該選項按鈕相關聯的值會儲存在欄位中。

頁面頂端

檢閱轉換問題,在 [設計檢查工作窗格

有時候,原始的 Word 文件中的項目不會顯示預期的結果的 InfoPath 表單範本,或是轉換程序時將會移除。例如,InfoPath 不支援 Word 文字藝術師功能和取代文字藝術師物件中產生的表單範本的預留位置圖像。

如果在轉換程序 InfoPath 偵測到的問題,在您關閉匯入精靈之後,會自動開啟 [設計檢查] 工作窗格。在工作窗格中,您可以檢閱問題清單,並採取必要的步驟來修正這些問題。

  1. 如果看不到 [設計檢查] 工作窗格,請按一下 [工具] 功能表上的 [設計檢查]。

    如果有任何問題的表單範本,您會看到工作窗格中的訊息。

  2. 在 [設計檢查] 工作窗格中,按一下您想要檢閱訊息的文字。

    對話方塊會顯示其他問題的相關資訊。

    附註: 如果 Word 文件包含不支援 InfoPath,例如 Word 繪圖物件,物件然後 InfoPath 新增預留位置圖像產生的表單範本,指出原本在 Word 文件位於物件。若要瞭解更多有關物件,以滑鼠右鍵按一下表單範本上的版面配置區圖像,然後按一下快顯功能表上的 [更多詳細資料

  3. 如有必要,請在表單範本,修正問題。例如,您可能要刪除任何不打算使用完成的表單範本中的版面配置區圖像。

附註: 您可能會發現 [設計檢查] 工作窗格,包含重新整理] 按鈕。按一下 [重新整理] 按鈕,就不會更新當做 Word 文件匯入 InfoPath 出現的訊息。如果您想要從 [設計檢查] 工作窗格中移除匯入郵件,您必須開啟 [資源檔案] 對話方塊 ([工具] 功能表),並移除名為 ImportErrors.xml 的檔案。您匯入 InfoPath 的 Word 文件時,會自動建立此檔案。移除 ImportErrors.xml 檔案之後,請按一下 [若要永久刪除 [匯入郵件的 [設計檢查] 工作窗格中的 [重新整理]。ImportErrors.xml 檔案不必要的表單範本,正常運作。事實上,基於安全性理由,最好先發佈表單範本中移除這個檔案。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×