將表單資料送出到 Web 服務

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

如果您要讓使用者將表單資料送出到 Web 服務,可以為表單範本加入一個送出資料連線,做為次要資料連線。視 Web 服務接受的資料類型而定,您可以設定送出資料連線,以送出指定欄位中的資料、群組中所有欄位的資料,或表單中的所有資料。

在新增了送出資料連線之後,您可以設定表單範本允許使用者將表單資料送出到 Web 服務。如此一來,Microsoft Office InfoPath 會在表單上將 [送出] 按鈕加入 [一般] 工具列,並將 [送出] 命令加入 [檔案] 功能表。您也可以利用下列方式自訂表單範本的送出選項:

  • 變更出現在 [一般] 工具列上 [送出] 按鈕以及 [檔案] 功能表上 [送出] 命令的文字。

  • 變更 [一般] 工具列上 [送出] 按鈕以及 [檔案] 功能表上 [送出] 命令的快速鍵。

  • 建立自訂訊息,在使用者送出表單時顯示。

  • 指定表單要在送出後保持開啟、關閉或開啟另一個空白表單。

新增送出資料連線

  1. 在 [工具] 功能表上按一下 [送出選項]。

  2. 在 [送出選項] 對話方塊中,選取 [允許使用者傳送此表單核取方塊。

  3. 按一下 [傳送表單資料至單一目的地],然後按一下清單中的 [Web 服務]。

  4. 按一下 [新增]。

  5. 在資料連線精靈中,輸入使用者將送出資料的 Web 服務位置,然後按 [下一步]。

    提示: 如果要搜尋 Web 服務的「通用描述、探索與整合」(UDDI) 伺服器,請按一下 [搜尋 UDDI],然後輸入要搜尋的 UDDI 伺服器,並指定要依提供者或提供的服務搜尋,接著輸入搜尋關鍵字,再按一下 [搜尋]。符合搜尋關鍵字的 Web 服務會顯示在 [搜尋結果] 清單中。

  6. 在精靈的下一頁,按一下 [選取作業] 清單中要用來接收表單資料的 Web 服務作業,然後按 [下一步]。

  7. 在精靈的下一頁,若要選取表單中的哪些資料要送出到 Web 服務中的每個參數,請執行下列其中一項:

    送出欄位或群組中的資料

    1. 在 [參數] 清單中,按一下將從表單接收資料的 Web 服務參數。

    2. 按一下 [參數選項] 中的 [欄位或群組]。

    3. 按一下 [修改 按鈕圖像 ]。

    4. 在 [選取欄位或群組] 對話方塊中,按一下要送出資料的欄位或群組,然後按一下 [確定]。

    5. 按一下 [包括] 方塊中的 [僅能使用文字和子元素],只送出這個欄位中的資料以及欄位或群組的子元素,或按一下 [XML 樹狀子目錄,包括選取的元素],送出欄位名稱、欄位中的資料以及選取群組或欄位中的子元素。

    送出表單的所有資料

    1. 在 [參數] 清單中,按一下將從表單接收資料的 Web 服務參數。

    2. 參數選項] 底下按一下 [整個表單 (XML 文件,包括處理指示)]。

    以字串方式送出資料

    1. 在 [參數] 清單中,按一下將從表單接收資料的 Web 服務參數。

    2. 參數選項] 底下按一下 [整個表單 (XML 文件,包括處理指示)]。

    3. 選取 [以字串方式送出資料] 核取方塊。

      附註: 通常,只有在需要送出數位簽章的資料時才選取這個核取方塊。大多數情況下,請清除這個核取方塊。

    關於 Microsoft ADO.NET 資料集物件的技術詳細資料

    如果 Web 服務需要 ADO.NET 資料集物件,請在設定這個資料連線時選取資料集節點。如果需要 ADO 資料集的 Web 服務資料連線使用任何其他類型的節點,送出動作將失敗。

  8. 按 [下一步]。

  9. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請在 [送出選項] 對話方塊中的 [標題] 方塊中輸入新名稱。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  10. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

  11. 若要讓使用者在填寫表單時使用 [送出] 命令或 [一般] 工具列上的 [送出] 按鈕,請選取 [顯示 [送出] 功能表項目及 [送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項 ︰

      1. 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      2. 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      3. 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×