將表單資料送出到 Web 服務

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

如果您想要送出表單資料至 Web 服務使用者,您可以新增至表單範本的送出資料連線的次要資料連線。根據接受 Web 服務的資料類型,您可以設定來指定欄位中,資料、 全部] 群組中的欄位] 或全部的表單中的資料中的資料送出的送出資料連線。

您新增的送出資料的連線之後,您就會設定為允許使用者將表單送出到 Web 服務的表單範本。如此一來,Microsoft Office InfoPath 會新增 [標準] 工具列並送出表單上的 [檔案] 功能表命令送出] 按鈕。您也可以自訂表單範本的送出選項以下列方式:

  • 變更顯示在 [標準] 工具列上的 [送出] 按鈕和 [送出] 命令,在 [檔案] 功能表上的文字。

  • 變更在 [標準] 工具列上的 [送出] 按鈕,然後在 [檔案] 功能表上的 [送出] 命令的鍵盤快速鍵。

  • 建立自訂送出表單時,顯示給使用者的郵件。

  • 指定是否要保持表單開啟、 關閉表單,或在送出表單後,開啟另一個空白的表單。

新增送出資料連線

  1. 在 [工具] 功能表上按一下 [送出選項]。

  2. 在 [送出選項] 對話方塊中,選取 [允許使用者傳送此表單核取方塊。

  3. 按一下 [傳送至單一的目的地表單資料],然後按一下清單中的 [ Web 服務

  4. 按一下 [新增]。

  5. 在 [資料連線精靈中,輸入位置您的使用者會送出其資料,然後按一下 [下一步的 Web 服務的位置。

    提示: 如果您要搜尋的 Web 服務的通用描述、 探索與整合 (UDDI) 伺服器,請按一下 [搜尋 UDDI,輸入您想要搜尋,指定您是否要搜尋提供者或所提供的服務 UDDI 伺服器輸入搜尋關鍵字,然後再按一下 [搜尋]。符合搜尋關鍵字的 web 服務會出現在 [搜尋結果] 清單中。

  6. 在精靈] 中選取 [作業] 清單中的下一個頁面上按一下您想要接收表單資料中,使用 Web 服務作業,然後按 [下一步

  7. 在精靈的下一個頁面上若要在表單中提交的每個參數的 Web 服務中選取資料,請執行下列其中一項:

    送出欄位或群組中的資料

    1. 在 [參數] 清單中,按一下 Web 服務參數的會收到表單的資料。

    2. 參數選項中,按一下 [欄位或群組]。

    3. 按一下 [修改 按鈕圖像 ]。

    4. 在 [選取欄位或群組] 對話方塊中,按一下欄位或群組中您想要送出,其資料,然後按一下[確定]

    5. 在 [包含] 方塊中,按一下 [送出的資料在此欄位和子項目的欄位或群組,或按一下 [送出欄位名稱,在欄位中的資料的XML 子目錄,包含選取的項目文字和子元素和在選取的群組或欄位子項目。

    送出所有的表單中的資料

    1. 在 [參數] 清單中,按一下 Web 服務參數的會收到表單的資料。

    2. 參數選項] 底下按一下 [整個表單 (XML 文件,包括處理指示)]。

    將資料送出成字串

    1. 在 [參數] 清單中,按一下 Web 服務參數的會收到表單的資料。

    2. 參數選項] 底下按一下 [整個表單 (XML 文件,包括處理指示)]。

    3. 選取 [送出資料為字串] 核取方塊。

      附註: 一般而言,您可以選取此核取方塊,以數位簽章的資料送出。在大多數情況下,清除此核取方塊。

    Microsoft ADO.NET 資料集物件的相關技術詳細資料

    如果 Web 服務需要 ADO.NET 資料集物件,請選取資料集節點,當您設定此資料連線。如果您使用其他任何類型的節點需要將 ADO 資料集的 Web 服務資料連線時,就無法送出動作。

  8. 按一下 [下一步]。

  9. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請送出中的 [標題] 方塊中輸入新名稱選項] 對話方塊。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  10. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

  11. 若要允許使用者使用送出] 指令或送出] 按鈕在 [標準] 工具列上填寫表單時,請選取顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項:

      1. 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      2. 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      3. 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×