將表單資料送出到 Microsoft SQL Server 資料庫

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

本文內容

概觀

步驟 1︰ 啟用送出資料連線

步驟 2︰ 設定送出選項

概觀

當您設計以 Microsoft SQL Server 資料庫為根據的表單範本時,[資料連線精靈] 會在滿足以下條件時啟用與此資料庫之間的送出資料連線:

  • 必須使用 Microsoft Office InfoPath 來填寫以此表單範本為根據的表單;如果將使用網頁瀏覽器來填寫此表單,此表單將無法直接送出資料到資料庫。若要設定瀏覽器相容的表單範本來送出資料至資料庫,請使用會將資料送出至 Web 服務的資料連線 (此 Web 服務可搭配此資料庫使用)。

  • 用於主要資料連線的主要資料庫表格包含主索引鍵、唯一限制或唯一索引。

  • 搭配這個主要資料連線使用的其他任何資料庫表格都與主要資料庫表格之間維持一個簡單的關係。

如果此資料庫符合這些需求,InfoPath 會啟用此送出資料連線,並將 [送出] 按鈕加入到 [一般] 工具列,以及將 [送出] 命令加入到表單上的 [檔案] 功能表。

當您設計以資料庫為根據的表單範本時,可以選擇在此精靈中停用此送出資料連線。如果您在此精靈中停用此送出資料連線,而之後決定想要使用此送出資料連線,您可以修改主要資料連線來啟用此送出資料連線。本文將討論如何啟用該送出資料連線。

附註: 只有在資料庫的主要資料連線中才可以有送出資料連線,您不能將送出資料連線加入到資料庫之次要資料連線的表單範本中。如果您想要將資料庫的送出資料連線當做次要資料連線使用,請使用可搭配此資料庫使用的 Web 服務,然後將送出資料連線加入到該 Web 服務中。

當您啟用此送出資料連線之後,您也可以透過以下方式來自訂表單範本的送出選項:

  • 變更 [一般] 工具列的 [送出] 按鈕及 [檔案] 功能表的 [送出] 命令上出現的文字。

  • 變更 [一般] 工具列上 [送出] 按鈕以及 [檔案] 功能表上 [送出] 命令的快速鍵。

  • 建立自訂訊息,在使用者送出表單時顯示。

  • 指定表單要在送出後保持開啟、關閉或開啟另一個空白表單。

頁面頂端

步驟 1:啟用送出資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 按一下 [資料連線] 對話方塊中的主要資料連線,然後按一下 [修改]。

  3. 在 [資料連線精靈] 中,按 [下一步]。

  4. 在此精靈的下一頁上,選取 [替這個連線啟用送出] 核取方塊,然後按一下 [完成]。

頁面頂端

步驟 2:設定送出選項

在您啟用此送出資料連線之後,InfoPath 會將 [送出] 按鈕加入到 [一般] 工具列以及 [送出] 命令加入至 [檔案] 功能表。InfoPath 也會設定以此表單範本為根據的表單,以便在使用者送出填寫完的表單之後,為他們顯示一則訊息,此訊息會陳述該表單是否已成功送出。根據預設,當使用者送出表單之後,InfoPath 也會讓這些表單維持在開啟狀態。若要變更出現在 [送出] 按鈕上的文字,以及當使用者送出表單之後所發生的行為,請執行以下動作:

  1. 在 [工具] 功能表上按一下 [送出選項]。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請在 [送出選項] 對話方塊中的 [標題] 方塊中輸入新名稱。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  2. 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項︰

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×