將表單資料送出到文件庫

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以將所有使用者的表單儲存在執行 Microsoft Windows SharePoint Services 的伺服器上的文件庫,並加以分類。在文件庫中,使用者可以填寫使用表單範本所製作的表單、將填好表單的資料匯出到 Microsoft Office Excel 2003 或 Microsoft Office Excel 2007,或將多份表單的資料合併到同一表單中。

若要讓使用者將使用表單範本所製作的表單送出到文件庫,您可以將送出資料的次要資料連線新增到表單範本。在新增了送出資料連線之後,您可以設定表單範本允許使用者將表單資料送出到文件庫。如此一來,Microsoft Office InfoPath 會在表單上將 [送出] 按鈕加入 [一般] 工具列,並將 [送出] 命令加入 [檔案] 功能表。您也可以利用下列方式自訂表單範本的送出選項:

  • 變更出現在 [一般] 工具列上 [送出] 按鈕以及 [檔案] 功能表上 [送出] 命令的文字。

  • 變更 [一般] 工具列上 [送出] 按鈕以及 [檔案] 功能表上 [送出] 命令的快速鍵。

  • 建立自訂訊息,在使用者送出表單時顯示。

  • 指定表單要在送出後保持開啟、關閉或開啟另一個空白表單。

加入送出資料連線

  1. 在 [工具] 功能表上按一下 [送出選項]。

  2. 在 [送出選項] 對話方塊中,選取 [允許使用者傳送此表單核取方塊。

  3. 按一下 [傳送表單資料至單一目的地],然後按一下清單中的 [SharePoint 文件庫]。

  4. 按一下 [新增]。

  5. 在資料連線精靈中,將 SharePoint 文件庫的位置輸入 [文件庫] 方塊。

  6. 在 [檔案名稱] 方塊中輸入要用來在文件庫中辨識表單的名稱。

    提示: 您也可以使用公式,確保每個表單名稱都是唯一的。

    作法

    1. 按一下 [插入公式] 按鈕圖像

    2. 在 [插入公式] 對話方塊中,執行下列其中一個動作:

      • 若要在公式中使用欄位,請按一下 [插入欄位或群組],然後在 [選取欄位或群組] 對話方塊中按一下要使用的欄位,再按一下 [確定]。

      • 若要在公式中使用函數,請按一下 [插入函數],然後在 [插入函數] 對話方塊中選取要使用的函數,再按一下 [確定]。

        提示: 如果函數需要參數,請在 [插入函數] 對話方塊中選取函數,按一下 [確定],然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下加入的函數,再按一下欄位或群組。如需關於函數的詳細資訊,請瀏覽「請參閱」一節中的主題連結。

      • 若要將值或數學運算子插入公式,請將值或數學運算符號輸入 [公式] 方塊中。

    運算

    符號

    +

    -

    *

    /

    • 附註: 如果公式使用除法 (/) 運算子,請確定除法運算子前後各有一個空格。如果除法運算子前後沒有空格,InfoPath 可能會將 "/" 視為是 XPath 位置步驟的分隔符號,而非除法運算子。

    • 若要檢查公式的語法是否正確,請按一下 [插入公式] 對話方塊中的 [檢查公式]。

      如需關於公式的詳細資訊,請瀏覽「請參閱」一節中的主題連結。

  7. 若要覆寫文件庫中同名的任何現有表單,請選取 [允許覆寫現有的檔案] 核取方塊。

  8. 按 [下一步]。

  9. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

  10. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請在 [送出選項] 對話方塊中的 [標題] 方塊中輸入新名稱。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  11. 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項 ︰

      1. 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      2. 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      3. 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×