如何疑難排解 Office 365、 Azure 或 Intune 無法登入非瀏覽器應用程式

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問題

當使用者嘗試特定用戶端電腦從 Microsoft 雲端服務,例如 Office 365、 Microsoft Azure 或 Microsoft Intune 驗證非瀏覽器應用程式時,一或多個下列問題發生:

  • 系統管理員無法驗證雲端服務,使用下列的管理工具:

    Microsoft Azure Active Directory 同步處理工具 (目錄同步處理在伺服器上)

    Microsoft Azure Active Directory 的 Windows PowerShell 模組 (在電腦上安裝該)
     

  • 使用者無法驗證雲端服務,使用下列豐富型用戶端應用程式:

    Microsoft Outlook

    Microsoft Lync 2010

    Microsoft Office 專業增強版

    Microsoft Office 應用程式

當使用者嘗試存取雲端服務入口網站中使用的網頁瀏覽器,從同一部電腦時,使用者可能會遭遇下列問題:

  • Internet Explorer 無法顯示網頁。

  • 系統會提示使用者認證網頁載入之前。

從其他電腦存取雲端服務使用相同的使用者帳戶資訊時,使用者沒有遇到這些問題。 成功,使用者可以從其他電腦存取雲端服務。

原因

通常,這個問題會發生在特定的用戶端電腦上或用戶端電腦的群組。 只有當公司沒有電腦設定為雲端服務,可能會發生此問題,所有用戶端電腦。 非瀏覽器應用程式驗證可能不是雲端服務的用戶端設定不正確實作的完整功能。

下列的用戶端電腦案例可能會造成此問題:

  • 雲端服務的網路連線受到限制。

  • 防火牆、 proxy 伺服器,或兩者都需要本機驗證。

  • 不符合必要條件非瀏覽器應用程式。

  • 已安裝較舊版本的 Microsoft Online Services 登入小幫手。

  • 非瀏覽器應用程式並未設定為雲端服務。

若要解決此問題在繼續之前,確保下列所有條件都均為 true:

解決方法

若要解決此問題,請使用一或多個下列方法,根據這個問題可能的原因。

解決方法 1: 網路連線受到限制

使用瀏覽器,並嘗試存取http://www.msn.com。 如果您無法存取此網站,疑難排解網路連線問題。

  1. 在命令提示字元,請使用ipconfig偵測 (ping)工具進行疑難排解 IP 連線。 如需如何進行此動作的詳細資訊,請參閱下列 Microsoft 知識庫文章:

        如何疑難排解基本的 tcp/IP

  2. 在命令提示字元,執行nslookup www.msn.com來判斷 DNS 是否已解決網際網路伺服器名稱。

  3. 如果區域網路使用 proxy 伺服器,請確定 [網際網路選項] 中的 proxy 伺服器設定反映適當的 proxy 伺服器]。

  4. 如果 Forefront 威脅管理閘道器 (TMG) 防火牆已安裝的網路邊界,且防火牆要求用戶端驗證,您可能需要安裝與設定 Forefront TMG 用戶端程式用戶端裝置有網際網路存取。 連絡您的雲端服務系統管理員以取得協助。

解決方法 2: 防火牆或 proxy 伺服器需要額外的驗證

若要解決此問題,請針對 Office 365 Url 與應用程式驗證 proxy 設定例外狀況。 例如,如果您執行的 Microsoft 網際網路安全性和加速伺服器 (ISA) 2006年,建立 「 允許 」 規則符合以下準則:

  • 允許傳出連線至下列目的地: *。 microsoftonline.com

  • 允許傳出連線至下列目的地: *.microsoftonline 運作

  • 允許傳出連線至下列目的地: *。 sharepoint.com

  • 允許傳出連線至下列目的地: *。 outlook.com

  • 允許傳出連線至下列目的地: *。 lync.com

  • 允許傳出連線至下列目的地: osub.microsoft.com

  • 連接埠 80/443

  • TCP 及 HTTPS 通訊協定

  • 規則必須套用至所有使用者。

  • HTTPS/SSL 逾時值設為 8 小時

解決方法 3: 不符合必要條件非瀏覽器應用程式,或 Microsoft Online Services 登入小幫手已過期

如果特定作業系統或非瀏覽器應用程式未更新的適當的先決條件,它們可能無法存取預定的服務。 請確定應用程式與電腦符合雲端服務的系統需求。 如需 Office 365 系統需求的詳細資訊,請按一下這裡:

    Office 365 系統需求

若要確保您的電腦會適當地更新 Office 365 最簡單的方法是執行 Office 365 桌面設定工具。 請遵循這些步驟進行安裝:

  1. 使用網頁瀏覽器中,瀏覽https://portal.office.com、 登入],然後再按一下右窗格中的 [下載

  2. 捲動至頁面最底部。 在設定並設定 Office 桌面應用程式,按一下 [設定],然後再確認當系統提示您執行 Office 365 桌面設定工具。

或者,您可以從下載並手動安裝必要的更新和套件下列 Microsoft 網站:

手動安裝 Office 365 桌面更新

解決方法 4: 非瀏覽器應用程式沒有設定雲端服務

如果您尚未已建立設定檔的某些非瀏覽器應用程式,這些應用程式將無法正確存取預定的服務。

若要確保您的電腦會適當地更新 Office 365 最簡單的方法是執行 Office 365 桌面設定工具。 請遵循這些步驟進行安裝:

  1. 使用網頁瀏覽器中,瀏覽https://portal.office.com、 登入],然後再按一下右窗格中的 [下載

  2. 捲動至頁面最底部。 在設定並設定 Office 桌面應用程式,按一下 [設定],然後再確認當系統提示您執行 Office 365 桌面設定工具。

或者,您可以從下載並手動安裝必要的更新和套件下列 Microsoft 網站:

手動安裝 Office 365 桌面更新

或者,您可以手動設定應用程式設定檔。

解決方法 5: 無法登入,以使用新式驗證在 Surface Pro 3 上使用 Office 2016 或 Office 2013

在 Windows 10 版本 1511年中已經修正此問題。 若要解決此問題,請安裝所有積存性更新適用於 Windows 10 的 Windows 更新。 或者,最少,安裝 Windows 10 版的累計更新:

    的 Windows 10 版本 1511年累積更新: 2015 年 11 月 10 日


如果您無法安裝更新,請遵循下列步驟。

重要事項:請謹慎依照本節中的步驟。 如果您修改登錄機碼不正確,可能會發生嚴重的問題。 修改它之前,請遵循下列步驟以備份還原用的登錄在發生問題時。

  1. 在 Windows 10 中,在工作列上的 [搜尋] 方塊中輸入 regedit,然後按一下 Enter 以開啟 [登錄編輯程式。

  2. 請執行下列一個動作,根據您所執行的 Office 版本而定:

  • 如果您有 Office 2016,請刪除下列登錄機碼:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity\Identities

  • 如果您有 Office 2013 時,刪除下列登錄機碼:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Common\Identity\Identities

其他資訊

如需特定的非瀏覽器應用程式的問題的詳細資訊,請參閱下列 Microsoft 知識庫文章:

仍需要協助嗎? 移至Microsoft 社群Azure Active Directory 論壇網站。

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