在 Visio 中新增圖形之間的連接器

在 Visio 中新增圖形之間的連接器

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

Visio 讓您可以在繪圖中輕鬆連接圖形。 您可以在新增圖形時使用自動連接功能來連接圖形,並且可以利用連接器工具來連接現有的圖形。

連接類型

連接器可針對圖形使用兩種連接方式:點對點連接或動態連接。 點對點連接會使連接器黏附至圖形上的特定一個點 (即使移動或旋轉該圖形)。 動態連接可讓連接器在圖形上變更其位置,因此移動或旋轉圖形時,連接器會移至圖形上最接近連接器原點的連接點。

在下列圖表中,圖形 A 和圖形 C 之間採用點對點連接,無論 C 移至何處,A 上的連接器都會與 C 上的同一點保持連接。 相反地,圖形 B 和 C 之間採用動態連接,因此 B 上的連接器會移至 C 上最接近的連接點。

A 與 C 之間是點對點連接,但 B 與 C 之間是動態連接。

您可以讓任一種上取消黏附連接器的兩端的連線。如果您使用自動連接來連接圖形時,兩端會有動態連接。如果您手動選取連接器連接到圖案的位置,您可以指定連線的類型。

新增圖形時自動連接

連接圖形的其中一個方法是,當您新增圖形至繪圖時,讓 Visio 自動連接圖形。 當您在建立流程圖時,此功能特別方便。

使用下列程序將圖形新增至您的繪圖中,而 Visio 會自動將其連接至現有圖形。

附註: 若要使用下列程序,請確認自動連接功能已啟用。 在 [檢視] 索引標籤的 [視覺輔助工具] 群組中,確認已選取 [自動連接]。

若要新增圖形,並自動將其連線至現有的圖案

  1. 從 [圖形] 視窗將圖形拖曳到頁面上 (如果頁面上沒有任何圖形)。

  2. 將滑鼠指標停留在起始圖形上方,直到圖形周圍顯示自動連接箭號。

    [自動連接] 為使用中狀態時,將游標移到圖形上以顯示連接箭號。

    如果您沒有看到自動連接箭號,請檢查 [檢視] 索引標籤,確認是否已選取 [自動連接]。

  3. 將滑鼠指標移至您要新增圖形之方位處的箭號上方。

    將游標移到自動連接箭號上,即會顯示待新增圖形的工具列。

    迷你工具列隨即出現,內含目前位於 [快速圖形] 樣板的前四個快速圖形。 當您指向工具列上的圖形,Visio 即會在頁面上顯示該圖形的預覽。

  4. 按一下您要新增的圖形。

  5. 如果您要繼續,指向最近新增之圖形上的自動連接箭號,即可新增亦會自動連接的另一個圖形。

    將游標移到新增的圖形上,即會顯示用於新增另一個圖形的自動連接箭號。

附註: 若要從所呈現的迷你工具列上的不同圖案,請拖曳到頁面上的位置想要從 [圖形] 視窗的圖案。若要連線的圖案,請使用下一節所述的方法。

連接已在頁面上的圖形

當然,您可以使用自動連接或連接器工具來連接已位於繪圖中的圖形。

當您連接的圖形時,您可以執行兩種類型的連線:指向連線動態連接。如需有關這些連線類型的詳細資訊,請參閱連線的類型,上方。

若要建立點對點連接,使連接器黏附至圖形上的特定一個點,請將第一個圖形的連接點拖曳到第二個圖形的連接點。連接器端點會在圖形相互連接時變為綠色。

將連接器黏附到圖形上的特定點,即可修正連至該點的連接器。
將連接器黏附到圖形上的特定點,即可修正連至該點的連接器。

若要建立動態連接,讓連接器能夠自動移至圖形上最接近的點,請將連接器工具放置在第一個圖形的中心,直到圖形周圍出現綠色方塊。按住滑鼠按鍵並拖曳至第二個圖形的中心。當第二個圖形周圍出現綠色方塊時,放開滑鼠按鍵。

將連接器黏附到圖形上,允許將連接器動態移動至圖形上的點。
將連接器黏附到圖形上,允許將連接器動態移動至圖形上的點。

使用自動連接來連接現有的圖形

  1. 將滑鼠指標停留在某圖形上方,直到圖形周圍顯示自動連接箭號。

    [自動連接] 為使用中狀態時,將游標移到圖形上以顯示連接箭號。
  2. 按一下自動連接箭號再將其拖曳至另一個圖形上,然後將連接器的端點放到該圖形中央以建立動態連接,或放到圖形上的某個特定連接點以建立點對點連接。

    當您將滑鼠指標停留在自動連接箭號上方時,會出現圖形預覽,但您可以忽略該圖形;當您將連接器拖曳至其目的地時,預覽便會消失。

使用連接器工具連接圖形

  1. [常用] 索引標籤上,按一下 [工具] 群組中的 [連接器]

    連接器工具利用將每個端點加以連接的方式來連接圖形。
  2. 按一下某圖形並將連接器拖曳到另一個圖形上。

  3. 完成時,在 [常用] 索引標籤的 [工具] 群組中,按一下 [指標工具]。

快速工作

工作

動作

將連接器類型變更為直角、直線或曲線。

以滑鼠右鍵按一下連接器,再從捷徑功能表中按一下連接器類型:直角、直線或曲線。

對齊圖形並調整間距以使連接器保持整齊。

選取您想要對齊的所有圖形,然後在 [常用] 索引標籤的 [排列] 群組中,按一下 [對齊] > [自動對齊] 或 [位置] > [自動加空白]。 您可以按 Ctrl 鍵並同時點選多個圖形,或在 [常用] 索引標籤的 [編輯] 群組中使用其中一個 [選取] 選項,藉此選取多個圖形。

將連接類型從動態 (或點對點) 變更為點對點 (或動態)。

選取連接器,然後將連接器端點拖曳離開圖形。接著將連接器放到特定點進行點對點連接,或放到圖形中央進行動態連接。

開啟或關閉自動連接

您可以啟用和停用所有 Visio 繪圖的自動連接功能,或只啟用和停用使用中繪圖的自動連接功能。

作用中的圖表中開啟或關閉自動連接

  • 在 [檢視] 索引標籤的 [視覺輔助工具] 群組中,選取或清除 [自動連接]

    選取或清除 [檢視] 索引標籤上的 [自動連接],即可啟動或停用自動連接功能。

附註: 如果 [自動連接] 核取方塊無法使用,請執行下列程序來檢查是否已關閉所有圖表的自動連接功能。

開啟或關閉自動連接所有圖表

  1. 按一下 [檔案] 索引標籤,然後按一下 [選項]

  2. 在 [Visio 選項] 中,按一下 [進階]。

  3. 在 [編輯選項] 底下,選取 [啟用自動連接] 核取方塊以啟動自動連接。清除 [自動連接] 核取方塊則可停用自動連接。

    選取或清除 [啟用自動連接],即可啟用或停用所有圖表與繪圖的自動連接功能。
  4. 按一下 [確定]

請參閱

新增箭頭、 端點或其他線條結尾至連接器

使用連接點工具來新增、 移動或刪除連接點

新增圖形時自動連接

連接圖形的其中一個方法是,當您新增圖形至繪圖時,讓 Visio 自動連接圖形。 當您在建立流程圖時,此功能特別方便。

使用下列程序將圖形新增至您的繪圖中,而 Visio 會自動將其連接至現有圖形。

  1. [圖形] 視窗將起始圖形拖曳到頁面上 (如果頁面上沒有任何圖形)。

  2. 滑鼠指標停留在起始圖形直到圖形周圍顯示藍色的自動連接箭號。

  3. 將滑鼠指標移至您要新增圖形之方位處的箭號上方。

    迷你工具列隨即出現,內含目前位於 [快速圖形] 樣板的前四個快速圖形。於樣板中所選取之圖形的即時預覽會顯示在頁面上。

  4. 將滑鼠指標移至迷你工具列中的四個圖形上方,以從頁面查看每個圖形的即時預覽。

  5. 按一下您要新增的圖形。

如果您要改用其他圖形,請將滑鼠指標從自動連接箭號處移開,預覽便會消失。然後,您可以從 [圖形] 視窗拖曳想要的圖形。

快速工作

工作

動作

變更樣板的快速圖形。

開啟樣板,然後將快速圖形拖曳至想要的順序。您可以將圖形拖進或拖出 [快速圖形] 區域。

變更迷你工具列上顯示的圖形。

[快速圖形] 樣板中,於快速圖形群組中選取您要顯示在迷你工具列上的某個圖形。含所選圖形的群組與會出現在工具列上。

或者,您也可以拖曳含有想要最先顯示之圖形的樣板,然後放到 [快速圖形] 標題列正下方。往上或往下拖曳其他樣板,即可在 [圖形] 視窗中變更各樣板的順序;並會以相同順序出現在 [快速圖形] 樣板中。

連接已在頁面上的圖形

您可以連接已在繪圖,請使用自動連接或連接器工具的圖形。

使用自動連接來連接圖形

  1. 滑鼠指標移到圖形上,直到圖形周圍顯示藍色的自動連接箭號。

  2. 按一下自動連接箭號再將其拖曳至另一個圖形上,然後將連接器的端點放到該圖形中央以建立動態連接,或放到某個特定連接點以建立點對點連接。

    當滑鼠指標移至藍色箭號上方時,會出現圖形的即時預覽,不過您可以忽略此圖形;因為預覽將在移開滑鼠指標後消失。

使用連接器工具連接圖形

  1. [常用] 索引標籤上,按一下 [工具] 群組中的 [連接器]

  2. 按一下某圖形並將連接器拖曳到另一個圖形上。

若要使連接器與圖形上的特定點保持黏附狀態,請將第一個圖形的連接點拖曳到第二個圖形的連接點。連接器端點會在圖形連接時變為紅色。這稱為點對點連接。

若要使連接器能跟在圖形周圍隨圖形一起移動,請將連接器工具放置在第一個圖形的中心,直到圖形周圍出現紅色方塊。按住滑鼠按鍵並拖曳至第二個圖形的中心。當第二個圖形周圍出現紅色方塊時,放開滑鼠按鍵。這稱為動態連接。

快速工作

工作

動作

將連接器類型變更為直角、直線或曲線。

以滑鼠右鍵按一下連接器,再從快顯功能表按一下任何連接器類型。

對齊圖形並調整間距以使連接器保持整齊。

選取您想要對齊,然後在 [常用] 索引標籤上按一下 [自動對齊及加空白的所有圖形。按住 CTRL 鍵,同時按一下這些全部],或使用其中一個選取的選項,您可以選取多個圖形。

將連接類型從動態 (或點對點) 變更為點對點 (或動態)。

選取連接器,然後將連接器端點拖曳離開圖形。接著將連接器放到特定點進行點對點連接,或放到圖形中央進行動態連接。

開啟或關閉自動連接

您可以開啟或關閉所有 Visio 繪圖的自動連接功能,或只開啟或關閉使用中繪圖的自動連接功能。

開啟或關閉使用中圖表的自動連接

  • [檢視] 索引標籤的 [視覺輔助工具] 群組中,選取或清除 [自動連接] 核取方塊。

如果 [自動連接] 核取方塊無法使用,請執行下列步驟以檢查是否關閉了所有圖表的自動連接。

開啟或關閉所有圖表的自動連接

  1. 按一下 [檔案] > [選項]

  2. 按一下 [進階]類別。

  3. 選取 [編輯選項] 底下的 [啟用自動連接] 核取方塊以開啟自動連接; 清除該核取方塊則可關閉自動連接。

另請參閱

新增箭頭、 端點或其他線條結尾至連接器

新增、 移動或刪除連接點

使用自動連接來連接圖形

連接圖形的其中一個方法是,當您新增圖形至繪圖時,讓 Visio 自動連接圖形。 當您在建立流程圖時,此功能特別方便。

使用下列程序將圖形新增至您的繪圖中,而 Visio 會自動將其連接至現有圖形。

將圖形拖曳到頁面時,請使用自動連接

  1. 將圖形從樣板拖曳到繪圖頁面,並將其放在靠近另一圖形。

    放在靠近另一圖形之位置的圖形

  2. 同時按住滑鼠按鈕,將滑鼠指標移至藍色三角形上方。三角形會變成深藍色。

    指標放在藍色三角形上方

  3. 放開滑鼠按鈕。將圖案放在繪圖頁面上,並新增連接器並黏附至這兩個圖形。

    按一下藍色三角形之後,就會新增連接器並黏附至這兩個圖形。

提示: 如果您不喜歡拖曳圖形,您可以達成相同的結果第一個選取中的圖形] 樣板中,只要將滑鼠指標移到圖形上,在您的繪圖,然後按一下 [藍色三角形上方所顯示的圖形附近的其中一個。

使用自動連接的頁面上的圖形

  1. 將指標移至您想要連線的圖案。

    指標放在要從該處連接的圖形上方

  2. 將指標移到最接近您要連線圖形的藍色三角形。

    滑鼠指標放在最靠近您要連接之圖形的藍色三角形上方。

    三角形開啟深藍色,並連線到您想要的圖形周圍出現紅色方塊。

    附註: 如果沒有連線到您想要的圖形周圍出現紅色方塊,圖形可能太遠。將移往圖案並再試一次,或使用 [連接器] 工具

  3. 按一下藍色三角形。新增連接器並黏附至這兩個圖形。

    按一下藍色三角形之後,就會新增連接器並黏附至這兩個圖形。

啟用或停用自動連接

您可以啟用或停用所有 Visio 繪圖,或僅限目前繪圖中的自動連接功能。為所有的繪圖物件:

  1. 在 [工具] 功能表中,按一下 [選項]。

  2. 按一下 [一般] 索引標籤。

  3. 在 [繪圖視窗選項] 底下,選取 [啟用自動連接]核取方塊。

目前繪圖只:

  • 在 [標準] 工具列上按一下 [自動連接] 工具。

    附註: 如果按一下 [自動連接] 工具不會啟用自動連接,請確定已在 [選項] 對話方塊中選取 [啟用自動連接]核取方塊。

使用連接器工具連接圖形

新增和黏附連接器的最有彈性的方式是以繪製它在 [標準] 工具列上使用連接器工具 按鈕影像

  1. 按一下 [標準] 工具列上的 [接點] 工具 按鈕影像

  2. 請執行下列其中一項操作:

    • 若要將連接器黏附到圖形上的特定點,將連接點 連接點影像 - 藍色 X 第一個圖形上第二個圖案上的連接點。當圖形連接時,連接線結束點變成紅色。這稱為點對點連接。利用點對點連接,繼續黏附至相同的連接點當您將其中一個圖形。

    • 若要允許連接器,以移至最接近的可用的連接點,連接器工具放置的第一個圖形的中心,直到圖形周圍出現紅色方塊。按住滑鼠按鈕,然後拖曳至 [第二個圖案的中心。當第二個圖案周圍出現紅色方塊,請在放開滑鼠按鈕。這稱為圖形對圖形連接。圖形對圖形連線後,繼續黏附至每個圖形移至 [最近的連接點,當您將其中一個圖形。如果沒有連接點,請連接器會移至最接近的旁邊。

      附註: 您也可以建立連線,圖形之間的連接器的一端連接的連接點的連接器另一端連接至圖形 (反之亦然)。

  3. 按一下 [標準] 工具列上的 [指標] 工具 [指標] 按鈕 ,以返回標準編輯。

    附註: 

    • 若要從某個圖案的連接器新增到多個圖案中,您需要新增多個連接器;沒有 」 分支 」 的連接器圖形。

    • 如果您嘗試建立點對點連接和黏附連接器,您所要的位置,以難以時間,請嘗試不同的貼齊和黏附設定:

    • 在 [工具] 功能表中,按一下 [貼齊和黏附],然後在 [一般] 索引標籤上選取您要的選項。

      如果您黏附到圖形幾何、 圖形控點或圖形頂點,如果沒有的話,會自動會新增連接點。

另請參閱

新增箭頭、 端點或其他線條結尾至連接器

新增、移動或刪除連接點

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×