在電子郵件訊息中送出表單資料

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

您可以新增次要送出資料連線,您可讓使用者在電子郵件傳送表單資料的表單範本。您可以使用靜態值,根據表單,或公式以指定的形式傳送至電子郵件地址、 電子郵件的主旨行及表單名稱中的資料值。您也可以指定是否要顯示的電子郵件訊息,或以附件的郵件本文中的表單。

如果您設定表單範本包含表單以電子郵件訊息的附件,也可以將表單範本附加到電子郵件中。以電子郵件訊息的附件形式包含表單與表單範本,您可以協助確保即使他們沒有在自己的電腦上快取的表單範本的電子郵件收件者可以在 [Microsoft Office InfoPath 中開啟表單。開啟附件收件者的順序,則必須在自己的電腦上安裝 InfoPath。

當使用者送出表單資料以電子郵件訊息時,InfoPath 就會建立電子郵件表單資料,並傳送訊息給您指定在您建立的資料連線的電子郵件收件者。如果收到已完成的表單的人員使用Microsoft Office Outlook 2007,他們可以在他們的收件匣,以包含所有接收和設定要顯示在 Outlook 中的資料行中的表單中的資料的該資料夾的 InfoPath 表單中新增資料夾。

您新增的送出資料的連線之後,您就會設定為允許使用者在他們表單資料送出表單範本。如此一來,當使用者開啟表單時,InfoPath 會自動新增送出] 按鈕以 [標準] 工具列和 [送出] 命令,[檔案] 功能表。您也可以自訂表單範本的送出選項以下列方式:

  • 變更顯示在 [標準] 工具列上的 [送出] 按鈕和 [送出] 命令,在 [檔案] 功能表上的文字。

  • 變更在 [標準] 工具列上的 [送出] 按鈕,然後在 [檔案] 功能表上的 [送出] 命令的鍵盤快速鍵。

  • 建立自訂送出表單時,顯示給使用者的郵件。

  • 指定是否要保持表單開啟、 關閉表單,或使用者送出表單之後,開啟另一個空白的表單。

頁面頂端

加入送出的資料連線

  1. 在 [工具] 功能表上按一下 [送出選項]。

  2. 在 [送出選項] 對話方塊中,選取 [允許使用者傳送此表單核取方塊。

  3. 按一下 [傳送至單一的目的地表單資料],然後在清單中,按一下 [電子郵件

  4. 按一下 [新增]。

  5. 在資料連線精靈] 的適當的方塊中,輸入收件者、 主旨要出現在電子郵件訊息中和您要的任何簡介文字的電子郵件地址,然後按 [下一步

    提示: 您也可以指定一個欄位,或使用公式以建立除了簡介] 方塊中的每個方塊的值。

    如何進行?

    1. 按一下 [插入公式 按鈕圖像 ]。

    2. 在 [插入公式] 對話方塊中,執行下列其中一項:

      • 若要使用公式中的欄位,按一下插入的欄位或群組,按一下您想要使用 [選取欄位或群組] 對話方塊中的欄位,然後按一下[確定]

      • 若要在公式中使用函數,按一下 [插入函數、 選取您想要使用 [插入函數] 對話方塊中的函數,然後按一下[確定]

        提示: 如果函數需要的參數,選取 [插入函數] 對話方塊中的函數,按一下[確定],然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下您新增的函數並按一下欄位或群組。請參閱 一節中找到有關函數的詳細資訊的連結。

      • 若要插入公式或數學運算子,請輸入的值,或是進行數學運算符號在 [公式] 方塊中。

    運算

    符號

    新增

    +

    相減

    -

    將相乘

    *

    除數

    /

    • 附註: 如果公式使用除法 (/) 運算子,請確定有空間之前和之後的除法運算子。如果除法運算子沒有之前的空格,而且之後,可能會解讀 InfoPath 「 / 」 作為分隔符號的 XPath 位置步驟而非除法運算子。

    • 若要檢查的公式為正確的語法,在 [插入公式] 對話方塊中,按一下確認公式

      請參閱 一節中找到關於公式的詳細資訊的連結。

  6. 在精靈的下一個頁面上,請執行下列其中一項:

    1. 若要顯示的電子郵件訊息本文中的表單,按一下 [傳送使用中檢視的表單,並且不附件]。

    2. 若要傳送電子郵件附件的表單資料,請按一下 [傳送附件的形式將表單資料附加以確保使用者可以開啟表單的表單範本] 核取方塊,,然後選取然後輸入附件名稱中的 [表單名稱] 方塊。您也可以指定一個欄位,或使用公式以確保每個表單名稱是唯一的。

      如何進行?

      1. 按一下 [插入公式 按鈕圖像 ]。

      2. 在 [插入公式] 對話方塊中,執行下列其中一項:

        • 若要使用公式中的欄位,按一下插入的欄位或群組,按一下您想要使用 [選取欄位或群組] 對話方塊中的欄位,然後按一下[確定]

        • 若要在公式中使用函數,按一下 [插入函數、 選取您想要使用 [插入函數] 對話方塊中的函數,然後按一下[確定]

          提示: 如果函數需要的參數,選取 [插入函數] 對話方塊中的函數,按一下[確定],然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下您新增的函數並按一下欄位或群組。請參閱 一節中找到有關函數的詳細資訊的連結。

        • 若要插入公式或數學運算子,請輸入的值,或是進行數學運算符號在 [公式] 方塊中。

      運算

      符號

      新增

      +

      相減

      -

      將相乘

      *

      除數

      /

      • 附註: 如果公式使用除法 (/) 運算子,請確定有空間之前和之後的除法運算子。如果除法運算子沒有之前的空格,而且之後,可能會解讀 InfoPath 「 / 」 作為分隔符號的 XPath 位置步驟而非除法運算子。

      • 若要檢查的公式為正確的語法,在 [插入公式] 對話方塊中,按一下確認公式

        請參閱 一節中找到關於公式的詳細資訊的連結。

      附註: 收到以電子郵件附件的表單資料的人員必須在自己的電腦上安裝的開啟附件的 InfoPath。

  7. 按一下 [下一步]。

  8. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

  9. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請送出中的 [標題] 方塊中輸入新名稱選項] 對話方塊。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  10. 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項:

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×