在圖形之間新增連接器

在圖形之間新增連接器

Visio 讓連接繪圖中的圖形更輕鬆。您可以在新增圖形時使用「自動連接」功能連接它們,也可以使用連接器工具連接現有圖形。您也可以變更迷你工具列中出現的圖形,並開啟或關閉「自動連接」功能。

自動連接圖形

連接頁面上現有的圖形

連接到另一個頁面上的圖形

使用佈景主題變更連接器的外觀

使用替代的連接器圖形

變更「自動連接」迷你工具列中的圖形

開啟或關閉「自動連接」功能

自動連接圖形

連接圖形的其中一個方法是,當您新增圖形至頁面時,讓 Visio 自動連接圖形。此功能在建立流程圖時特別方便。

  1. 請確認自動連接功能已啟用,方法如下:在 [檢視] 索引標籤的 [視覺輔助工具] 群組中,確認已選取 [自動連接]。

  2. 將圖形從 [圖形] 窗格拖曳到頁面中。

  3. 將滑鼠指標停留在圖形上方,直到圖形周圍顯示「自動連接」箭號。

    當「自動連接」功能為啟用狀態時,將游標移到圖形上以顯示連接箭號。
  4. 將滑鼠指標移至您要新增圖形之方位處的箭號上方。

    將游標移到「自動連接」箭號上,即會顯示待新增圖形的工具列。

    迷你工具列隨即出現,內含目前位於 [快速圖形] 樣板的前四個快速圖形。當您指向工具列上的圖形,Visio 即會在頁面上顯示該圖形的預覽。

  5. 按一下您要新增的圖形。

  6. 如果您要繼續,指向最近新增之圖形上的自動連接箭號,即可新增亦會自動連接的另一個圖形。

    將游標移到新增的圖形上,即會顯示用於新增另一個圖形的「自動連接」箭號。

頁面頂端

連接頁面上現有的圖形

提示: 在[常用] 索引標籤上,[工具] 群組中的命令會將 Visio 設為不同的狀態或模式,有時這難免會令人混淆。您可以使用鍵盤輕鬆地在 [指標工具] 選取物件 (按 Ctrl+1) 和 [連接器] 按鈕影像 (按 Ctrl+3) 工具之間切換。無論您使用何種工具,例如 [文字區塊] 或 [連接點],只要按幾下 Esc 即可返回 [指標工具]。

  1. 在 [常用] 索引標籤上,按一下 [工具] 群組中的 [連接器] 按鈕影像 或 Ctrl+3。

  2. 按一下某圖形,並將連接器拖曳到另一個圖形上。

  3. 完成時,在 [常用] 索引標籤的 [工具] 群組中按一下 [指標工具] 選取物件 ,或是按 Ctrl+1。

連接器工具利用連接每個端點的方式來連接圖形。

或者,[連接圖形] 命令可以新增至您的功能區,並用來以多個圖形選取的順序來連接。

提示: 尚未出現在您功能區中的實用命令,可以藉由按一下 [檔案] > [選項] > [自訂功能區] 來新增。

頁面頂端

連接到另一個頁面上的圖形

您只能針對同一頁面上不同的圖形使用連接器。若要連接至另一個頁面上的圖形,請使用 [換頁參考] 圖形建立跨頁超連結,或者在任何圖形中新增 [超連結] 與 [按兩下] 動作,讓它可以瀏覽至相同文件中的不同頁面。

使用 [換頁參考]

  1. 開啟 [基本流程圖圖形] 樣板,然後將 [換頁參考] 圖形拖曳到目前頁面上。

    換頁參考圖形
  2. 在 [換頁參考] 對話方塊中,選取 [確定] 即可新增圖形至目前的頁面和新建立的頁面。

  3. 在新頁面上,繼續建立您的圖表。

  4. 若要變更 [換頁參考] 圖形的外觀,請以滑鼠右鍵按一下圖形,然後選取 [外寄]、[內寄]、[圓形] 或 [箭號]。

若要在不同頁面移動,請在任一頁面中點兩下 [換頁參考] 圖形。如需詳細資訊,請參閱 [換頁參考] 對話方塊

使用 [超連結] 與 [按兩下]

  1. 以滑鼠右鍵按一下任何圖案或按 CTRL+K,然後選取 [超連結]。

  2. 按一下 [子位址] 欄位旁的 [瀏覽],然後按一下 [頁面] 旁的下拉式清單來選取您想要的頁面。

    [超連結] 對話方塊

    附註: 目的地頁面上圖形的名稱也可以針對超連結指定。請按一下 [開發人員] 索引標籤,然後選取 [圖形名稱]。您可以使用 [名稱] 欄位中的預設名稱,或加以編輯然後按一下 [確定]。

  3. 若要設定圖形的 [按兩下] 動作,請按一下 [開發人員],然後選取 [行為]。

  4. 按一下 [按兩下] 索引標籤,選取 [移至指定頁] 選像,然後按下拉式清單來選取您想要的頁面。

    Visio 連按兩下動作

    附註: 請務必在您已經編輯頁面名稱之後才執行此動作,因為它們不會在此自動更新。

頁面頂端

使用佈景主題變更連接器的外觀

雖然連接器的預設外觀可能是簡單的線條,它們可能是設計來搭配會加入裝飾線 (例如箭頭) 的佈景主題使用。內建的佈景主題可以從 [設計] 索引標籤中的 [佈景主題] 樣式庫套用。

附註: 

  • 若要查看更多裝飾線,請按一下 [設計] 索引標籤。按一下 [變化] 群組中的下拉式箭號,然後選取 [連接器]。

使用替代的連接器圖形

任何連接器圖形 (例如 [其他圖形] > [Visio 其他功能] > [連接器] 樣板上提供使用的連接器圖形) 都可以用來將圖形連接在一起,而非使用預設的 [動態連接器] 圖形。這些圖形可以拖曳並放入頁面,選取來搭配 [連接器] 和 [連接圖形] 工具使用,或是可僅用來取代現有的連接器。

  1. 開啟包含替代連接器圖形的樣板

  2. 選取頁面上要取代的現有的連接器

  3. 在 [常用] 索引標籤的 [編輯] 群組中,按一下 [變更圖形],然後選取您想要的連接器圖形。

附註: [變更圖形] 功能已在 Visio 2013 中推出,但 [連接器] 和 [連接圖形] 已在 Visio 2007 之前推出

頁面頂端

變更「自動連接」迷你工具列中的圖形

迷你工具列上的圖形是來自圖表的 [快速圖形] 樣板。迷你工具列最多會顯示四個圖形。您可以自訂迷你工具列上顯示的圖形。下列程序以 [基本圖表] 為例。

  1. 根據預設,迷你工具列中的圖形是樣板中緊接在 [快速圖形] 樣板後方的前四個圖形。例如,這是 [基本] 樣板中的前 4 個圖形。

    使用預設基本圖形的迷你工具列
  2. 若要針對特定樣板顯示迷你工具列中的不同圖形,您可以將它們拖曳至樣板頂端,重新排列圖形。比方說,您可以將 [4 星形]、[ 5 星形]、[6 星形] 和 [7 星形] 圖形拖曳至 [基本] 樣板的頂端。

    含有新基本圖形的迷你工具列
  3. 您也可以在「圖形」窗格中將樣板往上或往下拖曳,藉此變更樣板順序。這些圖形的子集合會顯示在「快速圖形」樣板中,並以它們在「圖形」窗格中的相同順序排列。例如,如果您在 [圖形] 窗格中將 [裝飾圖形] 拖曳到 [快速圖形] 樣板的正後方時,[快速圖形] 樣板中的順序也會變更。

    透過重新排序使用不同樣板的迷你工具列

    附註: 如果您先關閉圖表再重新啟動,「圖形」窗格中樣板的預設順序會自動還原,並在「快速圖形」中反映。

  4. 若要使用其他樣板做為迷你工具列的基礎樣板,請在 [快速圖形] 樣板中,針對這些圖形的子集合選取樣板圖形。例如,您可以選取 [圖表和數學圖形] 樣板中的 [文氏圖表]。

    透過選取使用新樣板的迷你工具列

提示: 若要將樣板中的圖形順序還原成預設值,請在 [圖形] 窗格中以滑鼠右鍵按一下樣板名稱,然後選取 [重設樣板]。

附註: 並非所有的樣板都有可用於迷你工具列中的圖形。例如,[箭頭圖形] 樣板中的圖形並不會顯示在迷你工具列上。

頁面頂端

開啟或關閉「自動連接」功能

您可以只針對目前的繪圖使用「自動連接」功能,也可以為所有 Visio 繪圖預設啟用或停用此功能。

開啟或關閉使用中圖表的「自動連接」功能

  • 在 [檢視] 索引標籤的 [視覺輔助工具] 群組中,選取或清除 [自動連接]。

    選取或清除 [檢視] 索引標籤上的 [自動連接],即可啟動或停用「自動連接」功能。

如果 [自動連接] 核取方塊無法使用,請執行下列程序來檢查是否已關閉所有圖表的自動連接功能。

開啟或關閉所有圖表的「自動連接」功能

  1. 按一下 [檔案] 索引標籤,然後按一下 [選項]。

  2. 在 [Visio 選項] 中,按一下 [進階]。

  3. 在 [編輯選項] 底下,選取 [啟用自動連接] 核取方塊以啟動自動連接。清除 [自動連接] 核取方塊則可停用自動連接。

    選取或清除 [啟用自動連接],即可啟用或停用所有圖表與繪圖的「自動連接」功能。
  4. 按一下 [確定]。

頁面頂端

使用「自動連接」功能來連接圖形

連接圖形的其中一個方法是,當您新增圖形至繪圖時,讓 Visio 自動連接圖形。當您在建立流程圖時,此功能特別方便。

使用下列程序將圖形新增至您的繪圖中,而 Visio 會自動將其連接至現有圖形。

將圖形拖曳至頁面的同時,使用「自動連接」功能

  1. 將樣板圖形拖曳至繪圖頁面,然後放在另一個圖形附近。

    放在靠近另一圖形之位置的圖形

  2. 一邊按住滑鼠按鈕,一邊將滑鼠指標移到藍色三角形上。三角形隨即會變成深藍色。

    將指標放在藍色三角形上方,三角形會變成深藍色。

  3. 放開滑鼠按鈕。圖形會置於繪圖頁面上方,且連接器會新增並黏附至這兩個圖形。

    圖形會置於繪圖頁面上,且連接器會新增並黏附至這兩個圖形。

提示: 如果您不喜歡拖曳圖形,還有另一種方法可以達到相同的結果,方法是先選取樣板中的圖形、將滑鼠指標重新置於繪圖中的圖形上,然後按一下圖形附近顯示的其中一個藍色三角形。

針對頁面上現有的圖形使用「自動連接」功能

  1. 將滑鼠指標置於您要連接的圖形「起點」。

    將滑鼠指標置於您要連接的圖形「起點」。

  2. 然後針對所要連接的圖形「目的地」,將滑鼠指標置於最近的藍色三角形上方。

    針對所要連接的圖形,將滑鼠指標置於最近的藍色三角形上方。

    三角形會變成深藍色,然後在您要連接的圖形周圍會顯示紅色的方塊。

    附註: 如果您要連接的圖形周圍沒有出現紅色方塊,這可能表示圖形離得太遠了。請將圖形移近一點,然後再試一次,或是使用連接器工具 (機器翻譯)。

  3. 按一下藍色的三角形,連接器就會新增並黏附至這兩個圖形。

    圖形會置於繪圖頁面上,且連接器會新增並黏附至這兩個圖形。

啟用或停用「自動連接」功能

您可以啟用或停用所有 Visio 繪圖中的「自動連接」功能,或只在目前的繪圖中使用此功能。為全部繪圖進行設定:

  1. 在 [工具] 功能表中,按一下 [選項]。

  2. 按一下 [一般] 索引標籤。

  3. 在 [繪圖視窗] 選項底下,選取 [啟用自動連接] 核取方塊。

為目前的繪圖進行設定:

  • 在 [標準] 工具列上,按一下 [自動連接] 工具。

    附註: 若按一下 [自動連接] 工具無法啟用 [自動連接],請確認您已選取 [選項] 對話方塊中的 [啟用自動連接] 核取方塊。

使用連接器工具連接圖形

若要新增並黏附連接器,其中一個最有彈性的做法便是使用 [標準] 工具列上的 [連接器] 工具 按鈕影像 來繪製。

  1. 按一下 [標準] 工具列上的 [連接器] 工具 按鈕影像

  2. 執行下列其中一個動作:

    • 若要將連接器持續黏附在圖形上的特定點,請將第一個圖形的連接點 連接點影像 - 藍色 X 拖曳至第二個圖形的連接點上。圖形連接時,連接器端點會變成紅色。這稱為點對點連接。點對點連接後,連接器會持續黏附在相同的連接點,即使您移動其中一個圖形也不會移動。

    • 若要允許連接器移到最近的可用連接點,請將 [連接器] 工具放到第一個圖形的中央,直到圖形周圍出現紅色方塊。按住滑鼠按鈕,然後拖曳到第二個圖形的中央。當第二個圖形周圍出現紅色方塊時,放開滑鼠按鈕。此操作稱為圖形對圖形連接。使用圖形對圖形連接時,當您移動其中一個圖形,連接器會移到最近可用的連接點,以持續保持黏附在每個圖形上。如果沒有任何連接點,連接器會移到最近的一側。

      附註: 您也可以在圖形之間建立連接,這會將連接器的一端連至連接點,而連接器的另一端則會連接至圖形 (反之亦然)。

  3. 按一下 [標準] 工具列上的 [指標] 工具 [指標] 按鈕 ,以返回標準編輯。

    附註: 

    • 若要將某一圖形的連接器新增至多個圖形,您需新增多個連接器;產品中並沒有所謂的「分支」連接器圖形。

    • 若您嘗試建立點對點連接,卻發現要將連接器確實黏附至所需位置很困難,這時不妨嘗試貼齊和黏附設定:

    • 在 [工具] 功能表上按一下 [貼齊和黏附],然後在 [一般] 索引標籤上選取您想要的選項。

      如果您黏附至圖形幾何、圖形控點或圖形端點,且沒有任何連接點時,系統會自動建立一個。

在圖形和點連接之間切換

您可以將連接器從圖形某一點黏附至不同圖形上的另一個點,或是從整個圖形黏附至另一個完整圖形。您也可以建立連接,將連接器的其中一端黏附至圖形上的點,並將連接器的另一端黏附至整個圖形。

  1. 將連接器端點從圖形上移除。

  2. 執行下列其中一個動作:

    • 若要將連接器端點黏附至圖形上的連接點,請將端點拖曳至圖形其中一個連接點,直到連接點周圍出現紅色方塊。

    • 若要將連接器的端點黏附至整個圖形,請將端點拖曳至圖形中央,直到整個圖形周圍出現紅色方塊。

請參閱

新增及編輯連接器文字

建立自訂連接器

黏附或取下連接器

Visio 訓練

掌握所有 Visio 桌面連接器的必要知識 (Visio 小組部落格)

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×