匯出圖形資料至資料庫

附註: 我們想要以您的語言,用最快的速度為您提供最新的說明內容。本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。此為英文文章出處,以供參考。

如果圖形含有資料,您可以執行資料庫匯出精靈]建立包含該資料的資料庫資料表。

資料庫匯出精靈]與 [] 對話方塊中,而是使用 [匯出到資料庫] 命令之間的差異,是執行精靈可供選擇匯出圖層上的所有圖形。如果您不需要匯出的圖層,您可能會發現更有效率使用 [匯出到資料庫] 命令。

使用資料庫匯出精靈

  1. 在 [檢視] 索引標籤上 >附加元件> Visio Extras] >資料庫匯出精靈]

  2. 依照精靈頁面上的指示。

    提示: 

    • 出現在清單中的圖形資料的儲存格名稱的前面的屬性,例如Prop.Cost

    • 當您執行的資料庫匯出精靈] ,匯出圖形資料時,精靈會儲存繪圖頁面的 [匯出的相關資訊。如果您對圖形進行變更,並想再次匯出資料,以滑鼠右鍵按一下繪圖頁面,然後選擇 [匯出資料表

使用 [匯出至資料庫] 命令

  1. 在 [檢視] 索引標籤上 >附加元件> Visio Extras] >匯出到資料庫

  2. 選取您想要使用的資料庫資料表。

    • 如果資料來源儲存在非預設位置,請按一下 [瀏覽] 尋找檔案。

    • 若要建立新的資料來源,請按一下 [建立]。請依照 [建立新的資料來源精靈]。按一下 [完成]後,便會出現 [ ODBC 設定] 對話方塊。從該處您可以選取現有的資料庫,或建立新的範本。您將稍後資料庫中建立表格。

      附註: 

      • 如果您使用 Excel 作為資料來源,您可以選取現有的活頁簿,但您無法建立從精靈。

      • 如果您選擇 Excel 活頁簿,請務必清除 [選取活頁簿] 對話方塊中的 [唯讀] 核取方塊。

  3. 如果您的資料庫支援的擁有者,在 [擁有者] 清單中,按一下 [擁有者名稱,以篩選表格擁有者清單]。使用您用來登入資料庫的名稱建立資料庫資料表。

  4. 如果您的資料庫可讓您存取多重資料庫,請在 [辨識符號] 清單中按一下所要使用的資料庫。

    提示: 如果您使用 Access 或 Excel,將資料匯出到資料庫的位置與名稱會列於此處。

  5. [資料表] 清單中,按一下所要使用的資料庫資料表。若要建立新資料表,請輸入其名稱。

  6. 若要變更從 ShapeSheet 儲存格匯出資料的方式,請執行下列其中一個動作:

    將 ShapeSheet 儲存格新增至匯出清單

    1. 按一下 [新增]

    2. 選取所要匯出的 ShapeSheet 儲存格。

    3. [評估為] 方塊中,選擇儲存在資料庫欄位中之值的資料類型。

    4. 選取要將圖形資料複製進去的資料庫欄位。

    5. 指定資料庫欄位的資料庫資料類型、欄位長度和小數點精確度。

    修改匯出 ShapeSheet 儲存格資料的方式

    1. 選取儲存格名稱,然後按一下 [修改]。

    2. 變更資料匯出的方式。

    從匯出清單刪除 ShapeSheet 儲存格

    選取儲存格名稱,然後按一下 [刪除]。

使用資料庫匯出精靈

  1. 在 [工具] 功能表上指向 [附加元件Visio Extras],指向,再按一下資料庫匯出精靈]

  2. 依照精靈頁面上的指示。

    提示: 

    • 出現在清單中的圖形資料的儲存格名稱的前面的屬性,例如Prop.Cost

    • 當您執行的資料庫匯出精靈] ,匯出圖形資料時,精靈會儲存繪圖頁面的 [匯出的相關資訊。如果您對圖形進行變更,並想再次匯出資料,以滑鼠右鍵按一下繪圖頁面,然後選擇 [匯出資料表

使用 [匯出至資料庫] 命令

  1. 在 [工具] 功能表上指向附加元件,然後指向 [ Visio Extras],,然後按一下 [匯出到資料庫

  2. 選取您想要使用的資料庫資料表。

    • 如果資料來源儲存在非預設位置,請按一下 [瀏覽] 尋找檔案。

    • 若要建立新的資料來源,請按一下 [建立]。請依照 [建立新的資料來源精靈]。按一下 [完成]後,便會出現 [ ODBC 設定] 對話方塊。從該處您可以選取現有的資料庫,或建立新的範本。您將稍後資料庫中建立表格。

      附註: 

      • 如果您使用 Microsoft Office Excel 作為資料來源,您可以選取現有的活頁簿,但您無法建立從精靈。

      • 如果您選擇 Excel 活頁簿,請務必清除 [選取活頁簿] 對話方塊中的 [唯讀] 核取方塊。

  3. 如果您的資料庫支援的擁有者,在 [擁有者] 清單中,按一下 [擁有者名稱,以篩選表格擁有者清單]。使用您用來登入資料庫的名稱建立資料庫資料表。

  4. 如果您的資料庫可讓您存取多重資料庫,請在 [辨識符號] 清單中按一下所要使用的資料庫。

    提示: 如果您使用 Microsoft Office Access 或 Excel,將資料匯出到資料庫的位置與名稱會列於此處。

  5. [資料表] 清單中,按一下所要使用的資料庫資料表。若要建立新資料表,請輸入其名稱。

  6. 若要變更從 ShapeSheet 儲存格匯出資料的方式,請執行下列其中一個動作:

    將 ShapeSheet 儲存格新增至匯出清單

    1. 按一下 [新增]

    2. 選取所要匯出的 ShapeSheet 儲存格。

    3. [評估為] 方塊中,選擇儲存在資料庫欄位中之值的資料類型。

    4. 選取要將圖形資料複製進去的資料庫欄位。

    5. 指定資料庫欄位的資料庫資料類型、欄位長度和小數點精確度。

    修改匯出 ShapeSheet 儲存格資料的方式

    1. 選取儲存格名稱,然後按一下 [修改]。

    2. 變更資料匯出的方式。

    從匯出清單刪除 ShapeSheet 儲存格

    選取儲存格名稱,然後按一下 [刪除]。

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×