加上數位簽章以表示信任

附註: 我們想要以您的語言,用最快的速度為您提供最新的說明內容。本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。此為英文文章出處,以供參考。

您可以顯示您認為資料庫安全,而其內容,可信任的資料庫中新增數位簽章 。使用資料庫這可協助使用者決定是否要信任及其內容。

您使用數位簽章資料庫的程序取決於資料庫是否使用較新的檔案格式,例如.accdb 檔案或舊版格式,如.mdb 檔案。不過,這兩個程序需要您使用的安全性憑證。

您可以使用商業安全性憑證,或建立您自己。本主題說明如何建立您自己的安全性憑證。

本文內容

開始之前

封裝、 簽署及散發 Access 資料庫

數位簽署舊版資料庫

開始之前

若要新增數位簽章,您必須先取得或建立安全性憑證。套用畫筆,您使用數位簽章的項目,或蠟密封,只有您可以將安全性憑證。

如果您沒有安裝安全性憑證,您可以建立一個使用 SelfCert 工具 (隨附於 Microsoft Office)。

建立自我簽署憑證

  1. 在 Microsoft Windows 中,按一下 [開始] 按鈕指向 [所有程式],都指向 [ Microsoft Office,都指向 [ Microsoft Office 工具],再按一下VBA project 數位憑證

    -或-

    瀏覽至包含您的 Microsoft Office 程式檔案的資料夾。

    您必須找出可執行檔SelfCert.exe,和位置會因各種情況這類如果您使用的 32 位元或 64 位元 Windows 作業系統,或如果您使用的 Office 365 的訂閱版本。

    如果您使用 Office 2019 或 Office 2016,請嘗試其中一個位置:

    • C:\Program Files\Microsoft Office\Office16

    • C:\Program 檔案 (x86) \Microsoft Office\Office16

    如果您使用的 Office 365,請嘗試其中一個位置:

    • C:\Program Files\Microsoft Office\root\Office16

    • C:\Program 檔案 (x86) \Microsoft Office\root\Office16

    如果您使用 Office 2013,尋找 office 15] 資料夾,從上述選項。如果您使用的 Office 2010,尋找 [Office14] 資料夾。如果您使用 Office 2007,尋找 [Office12] 資料夾。

    尋找正確的資料夾,然後按兩下SelfCert.exe

    隨後會出現 [建立數位憑證] 對話方塊。

  2. [您的憑證名稱] 方塊中輸入新測試憑證的名稱。

  3. 按兩次 [確定]

附註: 如果沒有看到 [VBA Project 數位憑證] 命令,或者找不到 SelfCert.exe,就可能需要 [安裝 SelfCert]

安裝 SelfCert.exe

  1. 啟動 Microsoft Office 安裝光碟或其他安裝媒體。

  2. 在 [安裝程式] 中,按一下 [新增或移除功能],然後按 [繼續]

    附註: 如果您工作環境中的 Microsoft Office 是由 IT 系統管理員安裝在各台電腦上,並非使用光碟,請照下列步驟進行:

    1. 在 Microsoft Windows 中,按一下 [開始] 按鈕,再按一下 [控制台]。

    2. 按兩下新增或移除程式]。

    3. 選取您的 Microsoft Office 版本,然後再按一下 [變更]。

      安裝程式就會啟動。

    4. 按一下 [新增或移除功能],然後按一下 [繼續]

    5. 繼續執行下列步驟。

  3. 按一下 [Microsoft Office][Office 共用的功能] 旁的加號 ([+]),以展開節點。

  4. 按一下 [VBA Project 數位憑證]

  5. 按一下 [從我的電腦執行]

  6. 按一下 [繼續] 安裝元件。

您只應該使用 SelfCert 建立您自己的組織內的使用的簽名。如果您想要數位簽署的資料庫,然後再自由散佈該資料庫,您應該取得商業安全性憑證從商業憑證授權單位 (CA)。

封裝、 簽署及傳送Access資料庫

Access可讓您輕鬆地快速簽署及散發資料庫。當您建立的.accdb 檔案或.accde 檔案時,您可以封裝檔案、 如何封裝、 套用數位簽章,然後發佈給其他使用者已簽署的套件。[封裝並簽署] 工具會資料庫置於存取部署 (.accdc) 檔案、 登入該檔案,然後將已簽署的套件放在您決定的位置。使用者可以接著從套件中解壓縮資料庫,然後直接在資料庫 (不在套件檔案)。

在進行動作時,請記得以下幾點:

  • 封裝資料庫和簽署套件就是一種表達信任的方式。 封裝並簽署資料庫時,您的數位簽章確認該資料庫並未在套件建立後遭人竄改。

  • 在套件中解壓縮資料庫後,簽署的套件與解壓縮後的資料庫間就會中斷連結。

  • 您可以使用 [封裝並簽署工具只能與資料庫儲存為較新的檔案格式 (.accdb、.accde,...)。Access也會提供登入,並將分散有舊版的檔案格式的資料庫的工具。您必須使用數位簽章工具適用於您所使用的資料庫檔案格式。

  • 一個套件內只能加入一個資料庫。

  • 此程序會簽署內含整個資料庫的套件,而不只是巨集或模組。

  • 此程序也會壓縮套件檔案來縮短下載時間。

  • 您可以從位於執行Windows SharePoint Services 3.0伺服器上或更新版本的套件檔案解壓縮資料庫。

下列章節會逐步說明如何建立簽署的套件檔案,以及如何從已簽署的套件檔案解壓縮並使用資料庫。

建立已簽署的套件

  1. 開啟您要封裝並簽署的資料庫。

  2. 按一下 [檔案] >儲存為>封裝並簽署。請注意,如果您使用 Access 2007 中,按一下Microsoft Office 按鈕] >發佈>封裝並簽署

    隨後會出現 [選取憑證] 對話方塊。

  3. 請選取憑證,然後按一下 [確定]

    [建立 Microsoft Access 簽署的套件] 對話方塊隨即出現。

  4. [儲存位置] 清單中,選取已簽署資料庫套件的位置。

  5. [檔案名稱] 方塊中輸入已簽署套件的名稱,然後按一下 [建立]

    Access 便會建立 .accdc 檔案並將其放到您所選的位置。

解壓縮並使用已簽署的套件

  1. 按一下 [檔案] >開啟>瀏覽]。[開啟] 對話方塊隨即出現。請注意,如果您使用 Access 2007 中,按一下Microsoft Office 按鈕] >開啟

  2. 選取 [ Microsoft Access 簽署的套件 (*.accdc) ] 作為檔案類型。

  3. 找出內含.accdc 檔案的資料夾,選取檔案,再按一下 [開啟

  4. 請執行下列其中一項動作:

    • 如果您選擇信任用來簽署部署套件的安全性憑證,就會出現 [解壓縮資料庫至] 對話方塊。 繼續執行下一步。

    • 倘若您尚未決定信任安全性憑證,就會出現下列訊息。

      提示訊息

      如果您信任資料庫時,請按一下 [開啟]。如果您信任的提供者所提供的任何憑證,請按一下 [信任所有來自發行者]。[解壓縮資料庫]對話方塊隨即出現。

      附註: 如果您使用自我簽署憑證來簽署資料庫套件,然後按一下 [信任來自發行者的所有內容],當您開啟該套件時,使用自我簽署憑證簽署的套件就會一律受到信任。

  5. 您也可以選擇在 [儲存位置] 清單中選取一個位置存放解壓縮後的資料庫,然後在 [檔案名稱] 方塊中,為解壓縮的資料庫中輸入不同的名稱。

    提示: 如果把資料庫解壓縮到信任的位置,您每次開啟時就會自動啟用內容。 如果您選擇了不受信任的位置,則部分資料庫就會預設為停用。

  6. 按一下 [確定]

如果您不確定是否要信任憑證,請參閱如何判斷數位簽章是否值得信任文章中的一般資訊,瞭解如何檢查憑證日期和其他項目來輔助確保其有效性。

頁面頂端

數位簽署舊版資料庫

重要: 本節中的步驟不適用於使用其中一種新檔案格式的資料庫。

使用.mdb 或.mde 的檔案格式的資料庫,您可以套用數位簽章資料庫中的元件。數位簽章可確認簽章者與任何巨集與程式碼模組資料庫中的其他可執行元件起始,而的任何人已變更他們已簽署資料庫後。

要把簽章套用至資料庫,首先必須要有數位憑證。 如果建立的資料庫要做為商業發佈之用,就必須從商業憑證授權單位 (CA) 取得憑證。 憑證授權單位會進行背景調查,藉此確認建立內容 (如資料庫) 的人士可以信賴。

如果您想要使用的個人版或有限的工作群組案例的資料庫, Access會提供的工具來建立自我簽署的憑證。下列各節中的步驟說明如何安裝和使用稱為 SelfCert.exe 工具來建立自我簽署的憑證。

程式碼簽署資料庫

附註: 請記住,這些步驟適用於只有當您使用的使用其中一個舊版資料庫檔案格式,如.mdb 檔案的資料庫。若要登較新的資料庫,請參閱封裝、 簽署及傳送 Access 資料庫

  1. 開啟要簽署的資料庫。

  2. [資料庫工具] 索引標籤中,按一下 [巨集] 群組內的 [Visual Basic],啟動 [Visual Basic 編輯器]。

    鍵盤快速鍵: 按下 ALT + F11。

  3. 在 [專案總管] 視窗中選取要簽署的資料庫或 Visual Basic for Applications (VBA) 專案。

  4. [工具] 功能表上,按一下 [數位簽章]

    [數位簽章] 對話方塊隨即出現。

  5. 按一下 [選擇] 選取您的測試憑證。

    隨後會出現 [選取憑證] 對話方塊。

  6. 選擇要套用的憑證。

    如果照前一節中的步驟進行,請選擇使用 SelfCert 建立的憑證。

  7. 按一下[確定] 關閉 [選取憑證] 對話方塊中,然後按一下[確定] 以關閉 [數位簽章] 對話方塊。

簽署舊版資料庫的秘訣

  • 如果想要防範解決方案使用者不小心修改您的 VBA 專案並讓簽章失效,請先鎖定 VBA 專案再簽署。

    附註: 鎖定您的 VBA 專案無法防止其他使用者以另一個簽章取代此數位簽章。 公司的系統管理員可以重新簽署範本及增益集,藉此精準控制使用者可以在自己電腦中執行哪些操作。

  • 當您數位簽署 VBA 專案] 時,請考慮使用時間戳記,讓其他人可以驗證您的簽名,即使已過期用於簽章的憑證。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×