開啟並尋找封存 Outlook 資料檔 (.pst) 中的項目

感謝客戶的意見反應,本文已於 2016 年 2 月 23 日更新。

有時候您可能會需要搜尋 Outlook 資料檔中的項目。本文涵蓋如何尋找項目以及針對搜尋問題進行疑難排解。

檢閱您的封存項目

根據預設,Outlook 中的自動封存會定期移除資料夾中的舊項目和過期項目。此做法可協助您管理您使用的信箱或郵件伺服器中的空間。

您可以設定自動封存,以將舊項目移動或複製到指定的封存資料夾,或自動刪除項目。如果您沒有刪除封存項目,您仍可在封存資料夾中使用這些項目。

擷取封存項目

若要查看您的 [自動封存] 設定和位置,以及 [關閉自動封存] 的指示,請參閱使用自動封存自動移動或刪除較舊的項目

  1. 在您電腦上的 Outlook 中 (Outlook 2016、Outlook 2013、Outlook 2010),選擇 [常用] > [新項目] > [其他項目] > [Outlook 資料檔]。

    選擇 [新項目] > [其他項目] > [Outlook 資料檔]。

  2. 選擇名為 [封存] 的檔案 (或您指定的封存檔案名稱)。

    選擇名稱為 "archive" 的檔案。

  3. 在 Outlook 瀏覽窗格中展開封存檔案以查看其中的子資料夾。按一下每個子資料夾以查看內容。

    在瀏覽窗格中展開封存檔案以查看其下的子資料夾。

  4. 若要搜尋特定電子郵件,請使用 Outlook 或 Windows Search 中的立即搜尋

  5. 若要將封存項目匯入回收件匣,請按照匯入 .pst 檔案的指示進行。您即將匯入的檔案名稱為「封存」,而且會將它匯入到您目前的電子郵件帳戶。

如果您看不到封存電子郵件

附註: 封存 Outlook 資料檔 (.pst) 會顯示與封存檔案相同的資料夾結構。如果封存中的資料夾是空的,表示該資料夾沒有封存項目。

如果您已按照上述指示擷取封存電子郵件,但仍看不到,請檢查您電子郵件的自動封存設定。

  1. 在您電腦上的 Outlook 中 (Outlook 2016、Outlook 2013、Outlook 2010),選擇 [檔案]。

    在 Outlook 2010 中,選擇 [檔案] 索引標籤。

  2. 選擇 [選項]。

  3. 選擇 [進階] > [自動封存設定]。

    選擇 [進階],然後選擇 [自動封存] 設定。

    附註: 如果您沒有看到 [自動封存設定],表示貴組織未啟用自動封存。

  4. 請注意電子郵件的封存頻率,以及是否會在一段時間過後清除封存檔案。根據這些設定,您的封存資料夾中是否應有電子郵件?

    這是您選擇自動封存選項的位置。

  5. 電子郵件會封存到 [將舊項目移到] 中列出的位置。

我的電子郵件會封存在哪個位置?

Outlook 2016、Outlook 2013、Outlook 2010:新封存檔案會儲存在下列位置:

  • Windows Vista、Windows 7、8 和 10:   磁碟機:\使用者\user\我的文件\Outlook 檔案\archive.pst

  • Windows XP   :磁碟機:\Documents and Settings\使用者\Local Settings\Application Data\Microsoft\Outlook\archive.pst

舊版 Outlook:封存檔案會儲存在下列位置:

  • Windows 7 與 Windows Vista   :磁碟機:\使用者\user\AppData\Local\Microsoft\Outlook\archive.pst

  • Windows XP   :磁碟機:\Documents and Settings\使用者\Local Settings\Application Data\Microsoft\Outlook\archive.pst

所有郵件、連絡資訊、行事曆以及您在 Microsoft Outlook 中建立的其他資料都會保存在個人資料夾檔案 (.pst),或者如果您使用的是 Microsoft Exchange Server 帳戶,則會保存在貴組織的 Exchange 伺服器上。針對您不需要但不想刪除的舊內容,Outlook 提供可清除常用資料夾的封存功能。您可以讓自動封存自動執行此功能,或者也可以視需要手動封存。

雖然封存內容不會再顯示於您常用的資料夾中,如果您想要還原該內容,您仍可存取及擷取這些項目。

附註: 

  • 有些公司會對公司電子郵件帳戶施加大小限制,封存功能有助於減緩此限制。同樣地,封存檔案通常必須維持可以存取,以免合規性要求還原封存檔案。

  • Outlook 不能封存目前或使用中的檔案。例如,週期性會議不能封存,除非所有會議項目都已在過去發生。未來的任何排定會議項目會視為目前的項目,因此無法封存。

使用立即搜尋尋找項目

  • 您資料檔的索引編製可能不完整。編製索引可讓立即搜尋功能快速尋找項目。

    附註: 當您第一次開始使用立即搜尋時,Outlook 需要為您的資料檔編製索引,以提供快速且完整的搜尋結果。此程序可能需要幾分鐘的時間。

  • 您正在搜尋的郵件是純文字簽署 (一種加密方法),而且您在個人資料夾檔案 (.pst) 或離線資料夾檔 (.ost) 的檔案中搜尋這些項目。

    附註: 如果您使用 Windows 桌面搜尋 (WDS) 或 Outlook (立即搜尋或進階尋找) 來搜尋郵件,可能會發生這種情形。

    請參閱<解決純文字簽署郵件問題>。

驗證可為 Outlook 資料檔編製索引

Outlook 會為下列資料檔編製索引:

  • 個人資料夾檔案 (.pst)

  • 離線資料夾檔 (.ost)

這包括 Microsoft Windows Live Mail、IMAP 和 POP 電子郵件帳戶。如果您使用 Microsoft Exchange 帳戶 (相較於家用或個人帳戶,這種帳戶在公司電子郵件系統中較為常見),您必須連線到執行 Exchange 的伺服器,然後針對立即搜尋使用 Exchange 快取模式 (離線) 來為您的郵件編製索引。[Exchange 快取模式 (離線)] 使用離線資料夾檔 (.ost) 將資訊儲存在電腦上。若要驗證已為哪些資料檔編製索引,請執行下列操作:

  1. 在 [工具] 功能表上,指向 [立即搜尋],然後按一下 [搜尋選項]。

    或者,按一下 [立即搜尋] 窗格中的箭號,然後按一下功能表上的 [搜尋選項]。

  2. 在 [索引] 底下,確認 [建立這些資料檔的郵件索引] 清單中已選取您要在搜尋中包含的資料檔。

確認已完成編製索引

若要確認編製索引狀態,請執行下列操作:

  1. 在 [工具] 功能表上,指向 [立即搜尋],然後按一下 [索引狀態]。

    或者,按一下 [立即搜尋] 窗格中的箭號,然後按一下功能表上的 [索引狀態]。

  2. 確認對話方塊報告 [剩下 0 個項目]。若非如此,表示索引編製未完成,而且要等到完成後才能搜尋您所有的 Outlook 項目。

[索引狀態] 報告「剩下 0 個項目」,但搜尋結果不正確

如果 [索引狀態] 報告「剩下 0 個項目」,而立即搜尋仍未傳回正確的搜尋結果,請結束 Outlook 並重新啟動電腦。當您再次啟動 Outlook 時,請執行下列操作,確認 Outlook 正確地為您的項目編製索引:

  1. 在 [工具] 功能表上,指向 [立即搜尋],然後按一下 [索引狀態]。

    或者,按一下 [立即搜尋] 窗格中的箭號,然後按一下功能表上的 [索引狀態]。

  2. 確認 [索引狀態] 對話方塊中的項目數量已增加。如果數字未增加,您必須等到索引編製完成為止,以取得結果。

我已重新啟動電腦,而立即搜尋仍未傳回正確的結果

如果重新啟動後未收到結果,下一步則須重建搜尋目錄。搜尋目錄是一種檔案,用於編製所有 Outlook 和 Microsoft Windows 項目的索引。若要重建搜尋目錄,請執行下列操作:

  1. 結束 Outlook。

  2. 在 Microsoft Windows 中,按一下 [開始] 按鈕,再按一下 [控制台]。

  3. 請執行下列其中一項操作:

    • Windows Vista   :按一下 [系統維護],然後按一下 [索引選項]。

      附註: 在 [傳統檢視] 中,按兩下 [索引選項]。

    • Microsoft Windows XP   :在 [另請參閱] 底下,按一下 [其他控制台選項],然後按一下 [索引選項]。

      附註: 在 [傳統檢視] 中,按兩下 [索引選項]。

  4. 按一下 [進階]。

  5. 按一下 [重建]。

  6. 重新啟動 Outlook。

解決純文字簽署郵件問題

如果純文字簽署郵件是儲存在個人資料夾檔案 (.pst) 或離線資料夾檔 (.ost) 中,Outlook 立即搜尋 (和 Windows 桌面搜尋) 將無法找到郵件。使用純文字簽署加密技術簽署時,Outlook 加密或「封裝」郵件內文的方式會將郵件文字轉譯為無法搜尋。

如需有關簽署和加密技術的詳細資訊,請參閱了解公開金鑰加密

不過,您可以使用下列步驟,確認檔案位置是否為導致問題的部分原因。

  1. 判斷您搜尋的是 .pst 還是 .ost。

    如何進行?

    1. 在 [收件匣] 中,按一下 [搜尋所有郵件項目] 方塊旁的單箭號。

    2. 按一下 [搜尋選項]。

    3. 在 [索引] 區段中,確認是否已選取下列核取方塊:

      • [個人資料夾]

      • [信箱 - <您的名稱>]

  2. 如果您認為郵件儲存在 .pst 或 .ost 以外的其他資料檔,請清除核取方塊 (如有需要),然後再次嘗試搜尋。

如果您搜尋 .pst 或 .ost 以外的資料檔,而且立即搜尋仍找不到郵件,請確認您是否已將 Outlook 電子郵件帳戶設為使用 [Exchange 快取模式 (離線)]。若是如此,請關閉 [Exchange 快取模式 (離線)],然後再次嘗試搜尋。

如何進行?

  1. 在 [工具] 功能表上,按一下 [帳戶設定]。

  2. 在 [電子郵件] 索引標籤上按一下 Exchange 帳戶,然後按一下 [變更]。

  3. 在 [Microsoft Exchange 伺服器] 底下,清除 [使用快取 Exchange 模式] 核取方塊。

  4. 結束並重新啟動 Outlook。

一旦 [Exchange 快取模式 (離線)] 關閉後,如果您仍未獲得預期的搜尋結果,請嘗試使用其他 Outlook 設定檔。如果您沒有設定其他設定檔,您可以建立一個。在每種情況下,您都必須按照上述程序關閉 [Exchange 快取模式 (離線)]。

從封存位置複製所有項目

您可以將封存項目複製到其原始資料夾 (例如從封存 [收件匣] 複製到您目前的 [收件匣]),或複製到您指定的新資料夾。

  1. 在 [檔案] 功能表上,按一下 [匯入及匯出] 來開啟 [匯入及匯出精靈]。

  2. 按一下 [從其他程式或檔案匯入],然後按一下 [下一步]。

  3. 按一下 [個人資料夾檔案 (.pst)],然後按一下 [下一步]。

    重要: 如果您找不到 .pst 檔案,表示檔案可能已隱藏,而且您必須顯示檔案位置才能繼續下一個步驟。

  4. 在 [要匯入的檔案] 方塊中,將醒目提示路徑中的預設檔案名稱從 backup.pst 變更為您要匯入的封存檔案名稱。或者,按一下 [瀏覽] 以找到您要匯入的檔案。

  5. 在 [選項] 底下,指定您希望 Outlook 如何處理重複的項目。

  6. 按一下 [下一步]。

  7. 按一下要匯入的資料夾。如果您要匯入的資料夾含有也需要匯入的子資料夾,請選取 [包含子資料夾] 核取方塊。

  8. 選取其中一個目的地選項:

    • [匯入項目到目前的資料夾]:這會將資料匯入目前選取的資料夾。

    • [匯入項目到以下的資料夾]:這會將資料匯入與來源資料夾相同名稱的目的地資料夾,例如 [收件匣] 到 [收件匣]。

  9. 按一下 [完成]。

我找不到 .pst 檔案

封存檔案是一種特殊的資料檔類型:個人資料夾檔案 (.pst)。自動封存第一次執行時,Outlook 會在下列位置自動建立封存檔案:

  • Windows Vista   :C:\使用者\您的使用者名稱\AppData\Local\Microsoft\Outlook\Archive.pst

  • Microsoft Windows XP   :C:\Documents and Settings\您的使用者名稱\Local Settings\Application Data\Microsoft\Outlook\Archive.pst

如果您沒有看到 [Local Settings] 或 [Local] 資料夾,這些資料夾可能已隱藏。若要顯示隱藏的 .pst 檔案,請完成您使用的作業系統的步驟。

Windows 7 和 Windows Vista:

  1. 按一下 [開始] 按鈕,然後按一下 [控制台]。

  2. 按一下 [外觀及個人化]。

    附註: 如果您使用的是控制台傳統檢視,請按兩下 [資料夾選項],然後回到從封存位置複製所有項目底下的步驟 4。

  3. 按一下 [資料夾選項]。

  4. 在 [檢視] 索引標籤上,依序在 [進階設定]、[檔案和資料夾]、[隱藏檔案和資料夾] 底下,選取 [顯示隱藏的檔案及資料夾]。

Windows XP:

  1. 按一下 [開始],然後按一下 [控制台]。

  2. 按一下 [資料夾選項]。

    [資料夾選項] 對話方塊

  3. 在 [檢視] 索引標籤上,按一下 [顯示隱藏的檔案及資料夾] 選項。

從封存位置移動個別項目

  1. 在 [移至] 功能表上,按一下 [資料夾清單]、按一下 [封存資料夾] (或您用於封存位置的名稱)。

  2. 按一下包含您要移動之項目的資料夾。

  3. 選取您要移動的項目,然後在 [資料夾清單] 中將項目拖曳到其原始資料夾,或拖曳到另一個資料夾。

附註: 如果您收到的錯誤訊息指出「.pst 已在使用中」,表示 .pst 檔可能有一些大小或毀損問題。Outlook 收件匣修復工具可修復許多這類問題。執行工具後,請嘗試再次還原檔案。

相關主題

深入了解 Outlook 設定檔
切換到另一個 Outlook 電子郵件設定檔
建立新電子郵件設定檔
使用自動封存備份、還原或刪除項目
手動封存項目
尋找封存項目
在 Mac 版 Outlook 2011 中開啟及尋找封存中的項目

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×