變更表單範本的程式設計語言

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

表單範本只能包含以一種程式設計語言撰寫的指令碼或 Managed 程式碼。您可以透過移除原始指令碼或 Managed 程式碼、指定新的程式設計語言、重新撰寫指令碼或 Managed 程式碼,然後將新指令碼或 Managed 程式碼新增至表單範本等步驟,變更表單範本的程式設計語言。

附註: InfoPath 不能將現有的指令碼或 Managed 程式碼從一種程式設計語言轉換成另一種。

在本文中

概觀

變更表單範本的程式設計語言

概觀

需要使用指令碼或 Managed 程式碼以新增商務邏輯至表單範本時 (例如在根據表單範本建立的表單中,利用使用者輸入表單的數值執行複雜的計算),可以使用多種不同程式設計語言 (包括 C# 或 Microsoft Visual Basic) 的其中一種來新增商務邏輯。新增指令碼或 Managed 程式碼至表單範本之後,如果想對表單範本進行任何變更,或是將任何新指令碼或 Managed 程式碼加入表單範本,都必須以相同的程式設計語言撰寫。

隨著表單範本發展以配合新的商務需求,您可能需要變更表單範本中所使用的程式設計語言。例如,試想下列情況:

  • 您的公司推行新政策,您的部門開發的全部 Microsoft Windows 程式及程式延伸模組都要使用 C# 程式設計語言,而公司中現有的表單範本是使用 Visual Basic 程式設計語言設計的。為了遵守新政策,您必須轉換所有表單範本,以便能夠使用 C# 程式設計語言。

  • 您發佈以 Microsoft Office InfoPath 2003 建立的表單範本,其中具有以 JScript 撰寫的指令碼。由於 Microsoft Office InfoPath 2007 可以讓您的使用者在網頁瀏覽器中,填寫根據表單範本建立的表單,您必須將此表單範本轉換成可供瀏覽器使用的表單範本,然後發佈至執行 InfoPath Forms Services 的伺服器。但是 InfoPath Forms Services 只能顯示含有 Managed 程式碼組件的表單範本;您不能發佈內含指令碼的表單範本至執行 InfoPath Forms Services 的伺服器。您必須將指令碼轉換成 Managed 程式碼組件,才能將表單範本發佈至執行 InfoPath Forms Services 的伺服器。

  • 您要負責維護多種不是您設計的表單範本,這些表單範本包含以 JScript 撰寫的指令碼。雖然您會讀寫 JScript 指令碼,但是使用 Microsoft Visual Basic Scripting Edition (VBScript) 程式設計語言來撰寫指令碼會更加熟練。因為您將維護這些表單範本,如果指令碼是以 VBScript 撰寫將會更有效率,所以您決定要以 VBScript 指令碼取代 JScript 撰寫的現有指令碼。

如果需要變更現有表單範本中使用的程式設計語言,必須先從範本移除現有指令碼或 Managed 程式碼,然後為表單範本指定新的程式設計語言。變更了表單範本中的程式設計語言後,您就能使用 Microsoft Script Editor 或 Microsoft Visual Studio Tools for Applications,以新語言重新撰寫指令碼或 Managed 程式碼,然後將新的指令碼加入表單範本中。

頁面頂端

變更表單範本的程式設計語言

變更表單範本的程式設計語言之前,您可能要以文字編輯器 (例如 Microsoft 記事本) 儲存一份目前的原始程式碼,以防萬一需要參考或使用這些原始程式碼。

儲存目前的原始程式碼

  1. 以設計模式開啟表單範本。

  2. [工具] 功能表上指向 [程式設計],然後執行下列其中一項操作:

    • 如果表單範本包含指令碼,請按一下 [Microsoft Script Editor]

    • 如果表單範本包含 Managed 程式碼,請按一下 [Microsoft Visual Studio Tools for Applications]

  3. 在 Microsoft Script Editor 或 Microsoft Visual Studio Tools for Applications 的 [編輯] 功能表上,按一下 [全選]

  4. 按一下 [編輯] 功能表中的 [複製]

  5. 將複製的程式碼貼到文字編輯器 (如「記事本」) 中。

  6. 儲存文字編輯器檔案。

變更表單範本的程式設計語言

  1. 按一下 [工具] 功能表上的 [表單選項]

  2. [表單選項] 對話方塊的 [類別] 下面,按一下 [程式設計]

  3. 按一下 [程式設計語言] 下面的 [移除程式碼]

  4. 在警告您即將從表單範本移除程式碼的訊息方塊中,按一下 [是]

  5. [表單範本程式碼語言] 清單中,按一下要在表單範本中使用的語言。

    提示: 如果是將程式設計語言變更為 Visual Basic 或 C#,請在 [Visual Basic 及 C# 程式碼的專案位置] 方塊中,輸入儲存專案檔案的位置。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×