變更和修正超連結

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以變更超連結的外觀,也可以變更超連結所連往的對象 (目的地)。如果超連結無法運作,您必須判斷問題所在,然後修正超連結目的地的位址。

附註: 如果要在導覽列上變更超連結的文字或順序,請按一下導覽列,再按一下 [格式] 功能表上的 [導覽列內容]

您想要做什麼?

變更超連結的外觀

變更超連結的目的地

將超連結變為一般文字

將超連結發佈到網站前的測試

修正無法運作的超連結

變更超連結的外觀

變更超連結的顯示文字

  1. 按一下要變更的超連結文字。

  2. 輸入新文字,然後按 DELETE 或 BACKSPACE 鍵個別刪除原始字元。

移除超連結文字的底線

  1. 選取超連結文字。

    如果只要選取底線字元,在最後一個底線字元後面按一下,然後將滑鼠游標拖曳到第一個字元。

  2. [一般] 工具列上,按一下 [底線] 按鈕圖像

變更用於超連結的圖片

  1. 選取連結的圖片。

  2. 以滑鼠右鍵按一下圖片、指向 [變更圖片],然後按一下您要使用的新圖片位置。 例如,如果要使用儲存在您電腦中的圖像,請按一下 [從檔案]

  3. 選取您要使用的新圖片。

頁面頂端

變更超連結的目的地

  1. 用滑鼠右鍵按一下要變更的超連結,然後按一下 [編輯超連結]

    附註: 如果快顯功能表只提供拼字指令,請按一下 [全部忽略],然後用滑鼠右鍵再次按一下超連結。

  2. [編輯超連結] 對話方塊的 [位址] 方塊中,輸入新的超連結目的地。

頁面頂端

將超連結變為一般文字

  • 用滑鼠右鍵按一下超連結,再按一下 [移除超連結]

頁面頂端

將超連結發佈到網站前的測試

將超連結發佈到網站前,可以先測試超連結,確認超連結可以運作。請執行下列其中一項操作:

  • 將超連結發佈到網路前,如果要從網路出版物追蹤超連結,請按住 CTRL 鍵,同時按一下連結的文字或圖片。

  • [檔案] 功能表上,按一下 [網頁預覽],然後在網站預覽中按一下任何一個超連結,即可追蹤其目的地。

    附註: 在網站預覽中,不能測試連往外部檔案的連結。

  • 將網站發佈到本機伺服器,以便測試超連結。

    1. [檔案] 功能表,按一下 [發佈到網站]

    2. 如果看到有關虛擬主機服務的資訊方塊,請按一下 [確定]

    3. [發佈到網站] 對話方塊中,尋找要用來測試網站的本機伺服器,然後按一下 [儲存]

頁面頂端

修正無法運作的超連結

對於無法運作的超連結,以下是一些常用的修正方法。

修正連往 Publisher 網站上其他網頁的超連結

  • 只有一個連結無法運作    遷移一個網頁後,Microsoft Office Publisher 便會自動更新超連結以連往正確網頁。不過,如果有一個超連結無法運作,請確認它不是指向已遭遷移或刪除的書籤。如果要修正超連結,請執行下列操作:

    1. 用滑鼠右鍵按一下超連結,再按一下 [編輯超連結]

    2. [編輯超連結] 對話方塊中,按一下 [這份文件中的位置],然後按一下您要連結的網頁和書籤。

      如果書籤已遭刪除,請按一下 [取消]。前往您要連結的網頁並插入書籤,然後回到需要修正的超連結進行編輯。

  • 有多個連結無法運作    如果有多個超連結無法運作,可能是某些檔案未發佈。根據預設,當您發佈網站時,Publisher 會上載一個稱為 index_files 的子資料夾至指定的檔案位置。這個資料夾包含所有與您網站相關的檔案,除了出版物的第一頁 (亦即網站首頁) 之外,它會指向相關網頁的子資料夾。如果沒有這個資料夾,連往出版物中其他網頁的超連結便無法運作。如果您使用協力廠商程式上載網站,可能無法將這個子資料夾自動上載到網頁伺服器。在此情況下,請手動上載這個子資料夾。

    附註: 您可以變更設定,讓 Publisher 在您下一次發佈網站時不要建立 index_files 資料夾,並且將所有網站檔案都發佈到單一資料夾中。只要在您的網路出版物中,到 [工具] 功能表依序按一下 [選項][網站] 索引標籤,然後取消選取 [將支援的檔案整理到一個資料夾中] 核取方塊即可。

修正連往其他網站的超連結

如果連往其他網站的超連結無法運作,請瀏覽至您要連結的目的地。如果目的地檔案在網際網路上,請用網頁瀏覽器搜尋。如果檔案位於硬碟或網路,請用 Windows 檔案總管搜尋。然後,在您的 Publisher 網路出版物中,檢查下列項目:

  • 目的地可能經過遷移或不存在    用滑鼠右鍵按一下超連結,然後按一下 [編輯超連結]。在 [編輯超連結] 對話方塊中,確認目的地網頁路徑正確。

  • 您以為是超連結的文字其實只是外觀近似    選取文字再按一下 [一般] 工具列中的 [插入超連結] 按鈕圖像 ,確認文字是超連結。

    提示: 按一下 [插入超連結] 之前,請務必先選取一個超連結。當您選取多個超連結,或是在導覽列上選取一個超連結,[插入超連結] 可能無法使用。

  • 您可能沒有目的地的存取權    如果目的地在網際網路中,確認您可以連線到網際網路。如果目的地在網路中,請連絡您的網路管理員,確認您具有目的地檔案的存取權。

修正開啟外部檔案的超連結

在網頁上建立一個開啟外部檔案 (例如 Microsoft Office Word 文件、Microsoft Office Excel 工作表或 PDF 檔案) 的超連結時,請記住下列事項。

檔案名稱

您要連結的外部檔案,檔案名稱最好不要包含空格,並且使用小寫字母。

連結檔案的檔名如果有空格,而且您無法變更檔名,請檢查並確認 Publisher 已在超連結位址中用 %20 取代空格。例如,如果檔名是 my file.docx,超連結位址應該是 my%20file.docx

測試

您不能在 Web 預覽中測試外部檔案的連結,但可以在您的出版物中測試超連結,方法是按住 CTRL 鍵,同時按一下連結文字或圖片。您也可以將網站發佈到本機伺服器,以便測試外部檔案的超連結。

重要: 如果您在本機伺服器上測試外部檔案的連結,請務必將外部檔案複製到該本機伺服器中。

上載

發佈網站時,您必須手動上載外部檔案。Publisher 不會代替您上載。您將外部檔案放在網頁伺服器上的位置,會決定檔案的路徑。舉例來說:

  • 如果要從首頁連結至網頁伺服器上相同目錄中的檔案,路徑只有檔案名稱即可 (例如 myfile.docx)。

  • 如果檔案位於與首頁不同的資料夾中,則此路徑必須包含資料夾名稱 (例如 index_files/myfile.docx)。

您必須決定這個路徑,然後在發佈到網路前,在 [插入超連結] 對話方塊中輸入路徑。選取文字或圖片,讓網頁訪客按一下即可開啟外部檔案。在 [插入] 功能表上,按一下 [超連結]。在 [插入超連結] 對話方塊的 [位址] 方塊中,輸入外部檔案的路徑。

附註: 如果您在 [位址] 方塊中藉由瀏覽方式插入超連結路徑,請根據以上說明,將路徑修改為只包含檔名或是只包含資料夾和檔案名稱。

修正檔案連結路徑以用於光碟片

您可能需要將網站檔案放到 CD 或 DVD 光碟片中,先用別台電腦檢視網站然後再發佈到網路上。如果您將網路出版物檔案複製到光碟片中,連接會失效。所以,請務必將網站直接發佈到光碟片中。方法如下:

在 Windows Vista 中

  1. [檔案] 功能表,按一下 [發佈到網站]

  2. [網址列] 中,按一下您要發佈網站的光碟機,例如 D:\mywebsite。

    如果您要將網站新增至新資料夾,請按一下工具列上的 [新增資料夾],以建立新的資料夾,輸入新資料夾的名稱,然後按下 ENTER 鍵。

  3. [檔案名稱] 方塊中,選取 [index] 做為首頁的預設名稱,然後按一下 [儲存]

    Index.htm 是預設值。選取 [index] 當做首頁的名稱,不但更方便存取,還可避免使用者檢視組成網站的檔案清單。

在 Windows XP 中

  1. [檔案] 功能表,按一下 [發佈到網站]

  2. [儲存位置] 清單中,按一下您要發佈網站的光碟機,例如 D:\mywebsite。

    如果您要將網站新增至新資料夾,請用滑鼠右鍵按一下要新增新資料夾的位置,選取 [新增],按一下 [資料夾] 以建立新的資料夾,在 [名稱] 方塊中輸入新資料夾的名稱,然後按一下 [開啟]

  3. [檔案名稱] 方塊中,選取 [index] 做為首頁的預設名稱,然後按一下 [儲存]

    Index.htm 是預設值。選取 [index] 當做首頁的名稱,不但更方便存取,還可避免使用者檢視組成網站的檔案清單。

修正無法顯示的超連結

這可能是下列其中一個原因所造成的:

  • 超連結位於旋轉過的文字方塊或快取圖案中    位於旋轉過的文字方塊或快取圖案中的超連結無法正常運作,不過在網路出版物中,只要按住 CTRL 鍵再按一下連結即可運作。而且,這種超連結外觀正常,但在 Web 預覽中無法運作,即使將出版物發佈到網路亦然。您可以在網路出版物中還原這種超連結,只要將包含超連結的旋轉文字方塊或快取圖案設回原本的位置即可。

  • 超連結位於具有框線藝術師的文字方塊或快取圖案中    在網路出版物中,如果超連結位於具有具有框線藝術師的文字方塊或快取圖案中,便無法正常運作。您可以在網路出版物中還原這種超連結,只要將框線藝術師自包含超連結的文字方塊或快取圖案移除即可。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×