設計唯讀檢視

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

在 Microsoft Office InfoPath,您可以建立相同的表單範本的不同檢視。檢視是表單範本中呈現資料的替代方法。填寫表單範本為基礎,使用者可以切換檢視可供選擇的表單中顯示的資料量。例如,狀態報表表單範本,您可能會設計除了詳細檢視 [摘要] 檢視。使用者可以選擇他們想要查看,取決於其所需的資訊類型的檢視。

本文說明如何設計無法編輯的使用者檢視。也會說明如何使用規則來自動切換至表單的唯讀檢視當使用者按一下 [讀寫] 檢視中的按鈕。

您想要做什麼?

設計唯讀檢視

[插入] 按鈕,讀寫和唯讀狀態] 檢視之間切換

插入一個使用者送出表單之後,會切換至 [唯讀] 檢視的按鈕

設計唯讀檢視

當您想要合併彙算表單資料的使用者,且不希望他們不小心變更資料,唯讀檢視非常有用。例如,假設您想要防止使用者變更之後,將它提交到 Web 服務的表單中的資料。當使用者按一下表單上的 [送出] 按鈕時,您可以設定表單範本從資料的讀寫檢視切換至唯讀檢視。這個選項可讓使用者看見的資料提交,但可以協助防止修改。

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. 在 [動作] 底下,按一下 [新增新的檢視

  3. 在 [新增檢視] 對話方塊中,輸入檢視的名稱,然後按一下[確定]

  4. 將版面配置表格和控制項新增至其設計] 檢視。

    提示: 如果您想要現有檢視的新檢視的設計,開啟現有的檢視,按下 CTRL + A 以在檢視中,選取所有文字,然後按下 CTRL + C 將選取範圍複製到剪貼簿。在 [檢視] 工作窗格中,切換至新的檢視,然後再按下 CTRL + V 貼上選取新的檢視中。此時,您可以刪除任何控制項或您不需要的版面配置元素,從新的檢視。

  5. 在 [檢視] 工作窗格中,按一下 [檢視屬性

  6. 按一下 [一般] 索引標籤。

  7. 在 [檢視設定] 底下,選取 [唯讀] 核取方塊,然後再按一下[確定]

  8. 若要測試的檢視是唯讀,按一下 [標準] 工具列上的 [預覽]。

  9. 在 [預覽] 視窗中,確定您無法在表單中輸入資料。

  10. 若要返回設計模式中,按一下 [標準] 工具列上的 [關閉預覽]。

頁面頂端

[插入] 按鈕,讀寫和唯讀狀態] 檢視之間切換

檢視通常被為了使用的按鈕和規則,可讓您自動化事件] 或 [填寫表單者所啟動的動作來回應表單範本中的特定工作。例如,您可以表單範本,在 [插入] 按鈕,然後建立 [切換檢視,按下該按鈕時的規則。在下列範例中,表單設計工具所建立的規則,切換到唯讀摘要檢視 [規則] 對話方塊。此規則執行時的使用者按一下表單中的按鈕。

[規則] 對話方塊的一部分

[插入] 按鈕,檢視之間切換

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. 選取 [檢視] 底下按一下讀寫的檢視您想要新增的按鈕。

  3. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  4. 在表單範本中,將游標放在您要插入] 按鈕的位置。

  5. 在 [插入控制項,底下按一下] 按鈕

  6. 在表單範本中,按兩下您剛插入的按鈕。

  7. 按一下 [一般] 索引標籤。

  8. 在 [動作] 清單中,按一下 [規則及自訂程式碼]。

  9. 在 [標籤] 方塊中,輸入您要顯示 [] 按鈕上的文字。

  10. 按一下 [規則]。

  11. 在 [規則] 對話方塊中,按一下 [新增]。

  12. 在 [名稱] 方塊中,輸入規則的名稱。

  13. 按一下 [新增動作]。

  14. 在 [動作] 清單中,按一下 [切換檢視]。

  15. 在 [檢視] 清單中,按一下您想要切換至的檢視,然後按一下[確定]

  16. 按一下[確定] 以關閉所有開啟的對話方塊。

  17. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

  18. 在 [預覽] 視窗中,按一下按鈕。

    開啟您在步驟 15 所指定的檢視。

  19. 若要返回設計模式中,按一下 [標準] 工具列上的 [關閉預覽]。

  20. 若要新增第二個] 按鈕和 [唯讀] 檢視的規則,讓使用者可以切換回 [讀寫] 檢視中,開啟 [唯讀] 檢視中,然後重複步驟 3 到 19。

頁面頂端

插入一個使用者送出表單之後,會切換至 [唯讀] 檢視的按鈕

下列程序說明如何新增按鈕至您送出的資料以唯讀模式檢視顯示的表單範本。您可能會執行此動作狀態報表表單時,當您想要讓使用者從預設檢視切換至表單資料的唯讀摘要檢視。

附註: This procedure works only if your form template includes an existing 資料連線 for submitting form data. If you haven't yet configured a submit data connection, you must do so before completing this procedure, or the following steps won't work. Find links to more information about data connections in the See Also section.

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. 在 [選取檢視] 中,按一下您想要包含 [送出] 按鈕的檢視。

  3. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  4. 在表單範本中,將游標放在您要插入] 按鈕的位置。

  5. 在 [插入控制項,底下按一下] 按鈕

  6. 在表單範本中,按兩下您剛插入的按鈕。

  7. 按一下 [一般] 索引標籤。

  8. 在 [動作] 清單中,按一下 [送出

  9. 若要以顯示為按鈕標籤的 [送出 」 以外的文字,請輸入您要在 [標籤] 方塊中的文字。

  10. 按一下 [送出選項]。

  11. 在 [送出選項] 對話方塊中,確定已選取 [允許使用者傳送此表單] 核取方塊。

  12. 按一下 [執行自訂動作規則,,然後按一下 [規則]。

  13. 在 [送出表單的規則] 對話方塊中,按一下 [新增]。

  14. 在 [名稱] 方塊中,輸入規則的名稱,然後按一下新增動作

  15. 在 [動作] 清單中,按一下 [切換檢視]。

  16. 在 [檢視] 清單中,按一下您想要切換至的唯讀檢視,然後按一下[確定]

  17. 按一下[確定] 以關閉所有開啟的對話方塊。

  18. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

  19. 在 [預覽] 視窗中,按一下 [送出表單所使用的按鈕。

    開啟 [唯讀] 檢視。

  20. 若要返回設計模式中,按一下 [標準] 工具列上的 [關閉預覽]。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×