設計列印最佳化的檢視

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您建立的 Microsoft Office InfoPath 表單範本,是專為使用 InfoPath 或網頁瀏覽器在線上開啟及填寫所設計的。不過,使用者可以選擇列印已完成表單的複本,以供個人記錄或封存之用。因此,最好確認一下表單範本的列印結果是否令人滿意。例如,您應該要檢查表單範本中的控制項是否有超出列印頁面的邊界,以及列印表單上的文字是否清晰易讀。

此外,您可以使用 [檢視] 工作窗格來建立表單範本的特殊版本 (稱為列印檢視),它是專為列印用途而設計的。

本文會說明如何設計表單範本的列印檢視,並提供其他技巧來建立易於列印的表單範本。

本文內容

列印表單範本與表單之間的差異

列印檢視簡介

根據現有檢視設計列印檢視

設計 Word 專用的列印檢視

列印表單範本與表單之間的差異

您可以列印表單範本來大致了解列印頁面如何呈現控制項和其他物件,也可以確認如頁首及頁尾等的列印設定。從設計模式列印表單範本時,可能會在列印的表單範本上看到某些項目 (例如按鈕),但是當使用者根據此表單範本列印表單時,其實並不會出現那些項目 (例如按鈕)。

當使用者根據表單範本列印表單時,InfoPath 會調整表單或移除在列印內容中沒有意義的特定項目。例如,根據預設出現在重複表格底下的 [插入項目] 指示文字並不會出現在列印表單中。按鈕控制項、清單方塊項目或捲動箭號也不會出現,因為這些項目在列印頁面上並沒有作用。

頁面頂端

列印檢視簡介

雖然表單範本的設計是為了使用電子格式收集表單資料,但是您可以建立專為列印而設計的列印檢視。當您希望使用者以特定版面配置列印表單或只列印表單的特定部分時,列印檢視就非常好用。

如果表單範本包含多個檢視,您可以針對每個檢視分別建立列印檢視。或者,您可以設計單一列印檢視來套用到表單範本中的所有檢視。例如,如果表單範本包含三個獨立的檢視,您可以建立一個列印檢視,將這些檢視中的重要資訊合併到單一的列印頁面。

若要建立列印檢視並將列印檢視與現有檢視產生關聯,可以使用 [檢視] 工作窗格中的 [建立此檢視的列印版本] 連結。按一下這個連結時,InfoPath 會執行下列動作:

  • 建立稱為 [列印版本 name] 的新空白檢視,其中 name 是列印檢視所根據的檢視名稱。

  • 將列印檢視與該列印檢視所根據的檢視產生關聯。這個關聯會記錄在 [檢視內容] 對話方塊中的 [列印格式設定] 索引標籤上。例如,假設您建立的列印檢視是根據表單範本中的 [核准] 檢視。當使用者按一下 [核准] 檢視中的 [列印] 按鈕時,InfoPath 會列印 [列印版本核准] 檢視中出現的所有內容。

建立列印檢視之後,您可以設計細項,以反映出您希望的表單列印效果。作法通常是將表單範本中的其他檢視控制項,複製並貼上到列印檢視中。必要時,您可以使用其他控制項來替代列印檢視中的某些控制項。例如,您可以使用標準清單方塊來取代下拉式清單方塊,因為下拉式清單方塊在預設情況下會隱藏清單方塊項目,而標準清單方塊在預設情況下會顯示這些項目。如此一來,所有項目都會列印在表單上。您也可以在 [檢視內容] 對話方塊中指定列印檢視的自訂列印選項,例如頁首、頁尾和頁面邊界。

頁面頂端

根據現有檢視設計列印檢視

根據預設,當使用者列印的表單沒有關聯的特定列印檢視時,便會列印目前顯示在使用者電腦上的檢視。如果建立列印檢視,InfoPath 就會列印該列印檢視而非目前檢視。您可以將現有檢視指定為列印檢視。下列程序會說明如何使用現有檢視做為列印檢視的基礎。

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. [選取檢視] 清單的 [檢視] 工作窗格中,按一下要建立列印檢視的檢視。

  3. 按一下 [動作] 底下的 [建立此檢視的列印版本]

  4. [建立列印版本] 對話方塊中,輸入列印檢視的名稱,然後按一下 [確定]

  5. 按兩下 [檢視] 工作窗格中的列印檢視。

  6. [檢視內容] 對話方塊的 [列印格式設定][版面設定] 索引標籤上,選取您要的選項,然後按一下 [確定]。例如,您可以指定列印檢視的預設邊界設定,或新增頁首及頁尾。

  7. 若要切換成原始檢視,請在 [檢視] 工作窗格的 [選取檢視] 清單中,按一下檢視的名稱。

  8. 若要選取檢視中的全部內容,請按下 CTRL + A。

  9. 若要將選取範圍複製到剪貼簿,請按下 CTRL + C。

  10. 若要切換成列印檢視,請在 [檢視] 工作窗格的 [選取檢視] 清單中,按一下檢視的名稱。

  11. 若要將原始檢視的選取範圍貼到列印檢視中,請按下 CTRL + V。

  12. 刪除不需要的控制項或版面配置元素,或新增其他控制項。

    提示: 若要快速判斷列印頁面是否可以容納控制項和其他設計元素,您可以按一下 [檢視] 功能表上的 [頁寬輔助線],沿著表單範本的右邊顯示頁寬輔助線。頁寬輔助線會以垂直虛線的方式出現在表單範本上。根據電腦的預設印表機,這條線表示列印頁面的右邊界位置。

  13. 若要新增分頁符號至列印檢視,請按一下新頁面開始的地方,然後按一下 [插入] 功能表中的 [分頁符號]

    附註: 分頁符號會顯示為水平虛線表單範本上。如果您預覽表單範本,您就不會看到以下訊息虛線線條或分頁符號的任何其他指示。若要看到分頁符號會如何影響列印您的表單範本為基礎的表單,請按一下 [標準] 工具列上的[預覽列印] 按鈕圖像

頁面頂端

設計 Word 專用的列印檢視

如果您是進階的表單設計者瞭解 XML 技術,您可以使用 [新增列印檢視 Word 精靈來建立一個 Microsoft Office Word 型列印檢視,直接從 Word 中列印表單的資料。這個選項可讓您利用列印功能,可在 Word 中的範圍。若要這麼做,您必須存取至現有的表單範本中的資料轉換成適用於從 Word 中列印的格式 XSL 轉換 (XSLT) 檔。使用者列印包含文字為基礎的列印檢視表單的表單,,將會直接從 Word 中列印的表單中的資料。使用 Microsoft Office Word 2003 或Microsoft Office Word 2007必須建立 XSLT 檔案。

附註: To learn more about creating the XSLT file, refer to the Microsoft Office InfoPath 2003 Software Development Kit (SDK). The SDK contains a tool, called the InfoPath to Word Wizard, that allows you to use Word 2003 or Word 2007 to print InfoPath form data. To locate the InfoPath 2003 SDK, refer to the See Also section.

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. [檢視] 工作窗格的 [動作] 底下,按一下 [新增 Word 列印檢視]

  3. 遵循 [新增 Word 列印檢視精靈] 的指示來指定要用於 Word 式列印檢視的 XSLT 檔案。

  4. [選取檢視] 清單的 [檢視] 工作窗格中,按一下要指定 Word 式列印檢視的檢視,然後按一下 [檢視內容]

  5. 按一下 [列印格式設定] 索引標籤。

  6. 按一下 [選取列印此檢視所使用的現有檢視] 清單中的 Word 式列印檢視。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×