設計以 Microsoft SQL Server 資料庫為基礎的表單範本

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以設計使用 Microsoft SQL Server 資料庫來查詢資料或查詢和送出資料的表單範本。

本文內容

概觀

相容性注意事項

開始之前

設計表單範本

設定 [送出] 選項

概觀

表單可以具有一個主要資料連線 (稱為主要資料連線),也可以具有一個或多個次要資料連線。根據表單的目的而定,資料連線可能會查詢或送出表單資料給外部資料來源,如 Microsoft SQL Server 資料庫或 Web 服務。

當您設計表單範本為基礎的資料庫時,Microsoft Office InfoPath 就會建立主資料來源包含查詢欄位和資料欄位做為表單範本的主資料連線的查詢資料連線的群組。這些欄位與群組會對應到資料會儲存在資料庫中的資料表中的方式。查詢欄位的查詢結果限制為符合 [查詢] 欄位中的資料,且使用者輸入的資料。當此表單範本為基礎的表單使用的主資料連線時,InfoPath 就會建立查詢,使用 [查詢] 欄位中的資料。InfoPath 傳送的查詢資料連線到查詢。資料庫會傳回查詢結果的查詢資料連線到表單。查詢的結果會放入繫結至這些欄位的控制項間可編輯的資料欄位。

因為查詢和資料欄位的資料結構必須符合資料庫中所儲存之資料的資料結構,所以您無法修改主要資料來源中的這些欄位或群組。您只可以將欄位或群組新增至主要資料來源的根群組。如需資料來源的詳細資訊連結,請瀏覽「請參閱」一節中的連結。

表單可以送出表單的主資料連線到資料庫的資料,如果表單範本為基礎的表單和資料庫符合下列需求︰

  • 表單範本已無法在瀏覽器相容表單範本   如果您要設計瀏覽器相容表單範本 InfoPath 不會在主要的資料連線建立送出資料連線。若要允許使用者在瀏覽器相容表單範本為基礎的表單資料送出,使用 Web 服務的運作方式與資料庫。

  • 左的資料表關聯資料表的主資料來源中的每一對包含主索引鍵   至少一個的每一組相關資料表的關聯性必須包含從左側資料表的主索引鍵。

  • 無表單市集大型的二進位資料類型的主資料來源中的資料欄位   如果查詢包含可以儲存大型的二進位資料類型,例如圖片、 圖像、 OLE 物件、 檔案附件,Office Access 備忘資料類型或 SQL 文字資料類型的欄位,則 InfoPath 會停用送出資料連線。

InfoPath 啟用送出資料連線時,會允許使用者將主要資料來源之資料欄位中的資料送出給資料庫。如果 InfoPath 啟用送出資料連線,您就可以自訂以這個表單範本為基礎之表單的送出選項。

頁面頂端

相容性考量

設計以資料庫為基礎的表單範本時,可以選擇設計瀏覽器相容的表單範本。InfoPath 會建立查詢資料連線做為瀏覽器相容表單範本中的主要資料連線。然而,瀏覽器相容表單範本無法設定成允許使用者將資料送出給資料庫。因此,如果您要設計以 SQL Server 資料庫為基礎的表單範本,而且想要使用者透過主要資料連線將他們的表單資料送出給資料庫,則不可以讓表單範本變成瀏覽器相容。

頁面頂端

在您開始之前

若要設計以 SQL Server 資料庫為基礎的表單範本,需要下列來自資料庫管理員的資訊:

  • 含有表單範本要連線之資料庫的伺服器名稱。

  • 您將搭配此表單範本使用之資料庫的名稱。

  • 資料庫所需的驗證。此資料庫可以使用 Microsoft Windows 驗證或 SQL Server 驗證來判斷使用者如何存取資料庫。

  • 含有想要傳送至表單之資料或接收表單之資料的表格名稱。這是主要表格。如果您會使用資料庫中的多個表格,則需要有其他子表格的名稱,並且還需要子表格中與主要表格之欄位有關聯的欄位名稱。

頁面頂端

設計表單範本

若要設計含有查詢資料連線的表單範本,您必須進行下列動作:

  1. 建立表單範本    建立以資料庫為基礎的表單範本時,InfoPath 會建立查詢資料連線做為表單範本與資料庫間的主要資料連線。這個程序會自動建立表單範本的主要資料來源。

  2. 新增一或多個控制項,以顯示查詢結果   若要允許使用者查看並編輯的主資料來源中的欄位中的資料,開啟表單時,可以將控制項新增至表單範本,並將該控制項繫結至主資料來源中的欄位。

步驟 1:建立表單範本

  1. 按一下 [檔案] 功能表上的 [設計表單範本]

  2. [設計表單範本] 對話方塊的 [設計新的] 底下,按一下 [表單範本]

  3. 按一下 [根據] 清單中的 [資料庫]

  4. 如果您要設計瀏覽器相容表單範本,請選取 [僅啟用瀏覽器相容功能] 核取方塊。

    附註: 「資料連線精靈」不會啟用瀏覽器相容表單範本中的送出資料連線。若要允許使用者將他們的資料從以瀏覽器相容表單範本為基礎的表單送出至資料庫,請新增使用資料庫之 Web 服務的次要資料連線。如需次要資料連線的詳細資訊連結,請瀏覽「請參閱」一節中的連結。

  5. 按一下 [確定]。

  6. 按一下「資料連線精靈」中的 [選取資料庫]

  7. [選取資料來源] 對話方塊中,按一下 [新來源]

  8. 按一下 [您想要連接到何種資料來源] 清單中的 [Microsoft SQL Server],然後按一下 [下一步]

  9. [伺服器名稱] 方塊中,輸入具有 SQL Server 資料庫之伺服器的名稱。

  10. [登入認證] 底下,執行下列其中一項動作:

    • 如果資料庫會根據 Microsoft Windows 網路中所用的認證來判斷具有存取權的使用者,請按一下 [使用 Windows 驗證]

    • 如果資料庫會根據您從資料庫管理員取得的指定使用者名稱和密碼來判斷具有存取權的使用者,請按一下 [使用下列的使用者名稱和密碼],然後在 [使用者名稱][密碼] 方塊中輸入您的使用者名稱和密碼。

  11. 按一下 [下一步]。

  12. [選取包含所需資料的資料庫] 清單中,按一下想要使用的資料庫名稱,並選取 [連接至指定的表格] 核取方塊,然後按一下主要表格的名稱,再按一下 [下一步]

  13. 在精靈的下一頁上,於 [檔案名稱] 方塊中輸入用來儲存資料連線資訊的檔案名稱,然後按一下 [完成] 儲存這些設定。

    如果您打算在查詢資料連線中使用其他表格,可以在精靈的這個頁面中加入其他表格。

    做法

    1. 按一下 [新增表格]

    2. 在 [新增資料表或查詢] 對話方塊中,按一下子資料表的名稱,然後按 [下一步。InfoPath 嘗試設定關聯比對兩個資料表中的欄位名稱。如果您不想使用建議的關聯性,請選取的關聯性,,然後按一下 [移除關聯。若要新增關聯,請按一下 [新增關聯。在 [新增關聯] 對話方塊中,按一下 [在個別的欄中,每個相關欄位的名稱,然後按一下[確定]

    3. 按一下 [完成]。

    4. 若要新增其他子表格,請重複這些步驟。

  14. 按一下 [下一步]。

  15. 在精靈的最後一個頁面上,輸入主資料連線的名稱。這個名稱會出現在 [資料來源] 工作窗格中的 [資料來源] 清單中。

  16. 如果表單範本符合需求 [概觀] 區段中的,此精靈] 頁面會指出 InfoPath 啟用送出中的資料連線的主資料連線。若要變更的送出資料連線的名稱,請在適當的方塊中輸入新名稱。如果您想要送出到另一個表單資料送出資料的連線,您會稍後新增至表單範本使用者,請按一下以清除 [啟用送出此連線] 核取方塊。

    附註: 如果表單範本不符合概觀一節中的需求,InfoPath 停用送出資料連線,且輸入送出連線的名稱] 方塊中,並啟用此連線的送出] 核取方塊無法使用 (停用)。如果 InfoPath 已停用送出資料連線,您的表單範本的主資料連線會有只查詢資料的連線。

步驟 2︰ 新增一或多個控制項,以顯示查詢結果

  1. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  2. 將控制項拖曳至表單範本上。

  3. 控制項繫結] 對話方塊中,選取的群組或您想要繫結控制項的欄位。

頁面頂端

設定送出選項

如果表單範本與您在 [資料連線精靈中選取的資料表符合需求 [概觀] 區段中的,InfoPath 就會設定透過其主要資料連線的資料送出表單範本。如果您選擇使用此送出資料連線,InfoPath 設定表單範本,讓使用者可以送出表單資料至資料庫並新增至 [標準] 工具列和 [送出] 命令,[檔案] 功能表的 [送出] 按鈕,當使用者填寫表單。InfoPath 也會使,當使用者送出表單,表單會保持開啟,並會顯示一則訊息,指出是否已成功送出表單的使用者設定的表單範本。使用者送出表單之後,您可以變更的文字上的 [送出] 按鈕和行為。

  1. 在 [工具] 功能表上按一下 [送出選項]。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請在 [送出選項] 對話方塊中的 [標題] 方塊中輸入新名稱。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  2. 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項︰

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×