設定表單範本的所需的安全性層級

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

When you design a form template, Microsoft Office InfoPath automatically selects the appropriate security level for the functionality required when users fill out forms based on your form template. This setting enables the minimal level of trust that is needed for the form. For example, the Restricted security level limits the ability of a form to access data on other domains, and files and settings on a user's computer. You can override the default setting and manually choose a different security level when you design a form template. Find more information about the security levels of InfoPath form templates in the See Also section.

依預設,所有新的空白表單範本,除了使用 managed 程式碼中使用受限制的安全性層級。當您新增至表單範本的某些功能,網域層級自動引發安全性層級。

附註: 若要新增或編輯受管理的程式碼,您必須Microsoft Visual Studio Tools for Applications (VSTA)您電腦上安裝。安裝 VSTA 之前,必須安裝 Microsoft.NET Framework 2.0 與 Microsoft 核心 XML 服務 6.0。若要安裝 VSTA,[控制台] 中,開啟 [新增或移除程式,找出2007 Microsoft Office system,,然後按一下變更

是很好的做法來協助您避免不必要的安全性風險的使用者表單範本的適當的安全性層級。

若要設定表單範本的安全性層級,請執行下列動作:

  1. 在 [工具] 功能表上按一下 [表單選項]。

  2. 按一下 [類別] 底下的 [安全性與信任]。

  3. 在 [安全性層級,請清除自動判斷安全性層級 (建議使用) ] 核取方塊。

  4. 按一下您想要的安全性層級。

附註: 如果表單範本需要完全信任安全性層級,表單範本必須將為使用者的電腦上安裝或使用受信任的根憑證數位簽署。否則,使用者將無法授與完全信任的表單範本為基礎的表單,並填寫的表單中功能可能無法運作。使用 InfoPath 發佈精靈可安裝的表單範本的檔案。

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×