編輯連接線、箭號或點

編輯連接線、箭號或點

編輯和使用連接器的彈性很高。您可以編輯線條寬度、樣式和彎曲度;控制端點和箭號的樣式;建立曲線、有直角或直線的接點;以及用各種方式管以連接點。

祕訣   :在 [常用] 索引標籤上,[工具] 群組中的命令會將 Visio 設為不同的狀態或模式,有時這難免會令人混淆。您可以使用鍵盤輕鬆地在 [指標工具] 選取物件 (按 Ctrl+1) 和 [連接器] 按鈕影像 (按 Ctrl+3) 工具之間切換。無論您使用何種工具,例如 [文字區塊] 或 [連接點],只要按幾下 Esc 即可返回 [指標工具] (使用 Visio 2010 時除外)。

本文大部分的內容適用於預設的動態連接器圖形,此類圖形可以自動將其本身重新路由,以避開其他圖形。部分的連接器類型 (例如大部分可從 [其他圖形] > [Visio 其他功能] > [連接器] 樣板中取得的連接器) 並無法自動重新路由。

您想要做什麼?   

建立曲線、有直角或直線的接點

將箭頭或其他線條結尾新增至接點

變更連接線寬度、樣式或彎曲度

反轉接點箭頭的方向

變更連接器路徑或讓連接器產生交集

使用連接點的其他方式

另請參閱

建立曲線、有直角或直線的接點

您可以變更連接器,或是變更新連接器的預設值。

變更連接器

  1. 選取連接器。

  2. 在 [設計] 索引標籤上,選取 [版面配置] 群組中的 [連接器],然後選取所需的路由樣式:[直角連接器]、[直線連接器] 或 [曲線連接器]。

  3. 或者,以滑鼠右鍵按一下連接器圖形所顯示的動作功能表,也會有變更連接器路由樣式的選項。

變更新連接器的預設值

  • 若要使預設的連接器為直角、直線或曲線樣式:

    • Visio Online 方案 2、2016、2013   :選取頁面來取消選取所有圖形。選取 [設計] 索引標籤,然後選取 [版面配置] 群組中的 [連接器] 下拉式功能表。然後選取 [直角]、[直線] 或 [曲線]。

    • 或者,選取 [檔案] 索引標籤,選取 [列印],選取 [版面設定],選取 [配置和路徑] 索引標籤,然後在 [外觀] 清單中選取 [直線] 或 [曲線]。

    • 2010   :依序選取 [檔案] 索引標籤 > [列印] > [預覽列印] > [版面設定] > [配置和路徑] 索引標籤,然後在 [外觀] 清單中選取 [直線] 或 [曲線]。

頁面頂端

將箭頭或其他線條結尾新增至接點

您可以將箭頭、端點或其他線條結尾新增至接點。

  1. 選取連接器。

  2. 執行下列其中一個動作:

    • Visio Online 方案 2、2016、2013   :選取滑鼠右鍵動作功能表中的 [格式化圖形] 選項。或者,在 [常用] 索引標籤上,選取 [圖形樣式] 群組中的 [線條],然後選取 [線條選項]。

    • 2010   :在 [常用] 索引標籤上,選取 [圖形] 群組中的 [線條],然後選取 [箭號]。

  3. 執行下列其中一個動作:

    • Visio Online 方案 2、2016、2013   :在 [圖形格式] 窗格中,選取 [線條] 底下的 [實線],然後選取類型、大小或形式類型。

      連接器端點的設定
    • 2010   :選取 [其他箭號],在 [線條] 視窗中選取類型、大小或形式類型,然後按一下 [確定]。

      箭號尾端

頁面頂端

變更連接線寬度、樣式或彎曲度

  1. 選取連接器。

  2. 執行下列其中一個動作:

    • Visio Online 方案 2、2016、2013   :選取滑鼠右鍵動作功能表中的 [格式化圖形] 選項。或者,在 [常用] 索引標籤上,選取 [圖形樣式] 群組中的 [線條],然後選取 [線條選項]。

    • 2010   :在 [常用] 索引標籤上,選取 [圖形] 群組中的 [線條],然後選取 [線條選項]。

  3. 執行下列其中一個動作:

    • Visio Online 方案 2、2016、2013   :在 [圖形格式] 窗格中,在 [線條] 底下選取寬度、樣式或彎曲度。

      連接器樣式的設定
    • 2010   :在 [線條] 視窗中,選取寬度、樣式或彎曲度,然後按一下 [確定]。

      線條寬度和其他設定

頁面頂端

反轉接點箭頭的方向

注意:在部分圖表類型 (例如各種程序流程圖表) 中,連接方向是很重要的。因此應該針對這些連接器使用 [反向翻轉] 命令,而非重新格式化其末端。您可以使用 [檔案] > [選項] > [自訂功能區] 功能,輕鬆地將 [反向翻轉] 命令按鈕新增至功能區。此命令能讓您將所有已選取連接器的流程反轉過來。

或者,若要在不使用 [反向翻轉] 命令的情況下變更連接器的方向,您可以新增箭號至沒有箭號的端點,並從其他端點移除現有箭號。

  1. 選取連接器。

  2. 執行下列其中一個動作:

    • Visio Online 方案 2、2016、2013   :在 [常用] 索引標籤上,選取 [圖形樣式] 群組中的 [線條],然後選取 [線條選項]。

    • 2010   :在 [常用] 索引標籤上,選取 [圖形] 群組中的 [線條],然後選取 [線條選項]。

  3. 執行下列其中一個動作:

    • Visio Online 方案 2、2016、2013   :在 [圖形格式] 窗格中,在 [線條] 底下選取:

      • [開始箭號類型],然後執行步驟 4。

      • [結束箭號類型],然後執行步驟 4。

      用於箭號轉向的設定
    • 2010   :在 [線條] 視窗中選取:

      • [開始箭號類型],然後執行步驟 4。

      • [結束箭號類型],然後執行步驟 4。

      開始和結束的箭號
  4. 若要新增、變更或移除所選連接器開頭結尾的箭號,請在箭號功能表上選取一種箭號或選取 [無]。

    在 [箭頭樣式] 功能表上選取一個箭號樣式或 [無]。

頁面頂端

變更連接器路徑或讓連接器產生交集

在大多數情況下,您可以使用預設的連接器行為。但有時您想要進一步控制圖表中連接器的路徑和交集。

祕訣   :使用 [縮放] 功能可仔細查看小型圖形,並進行更細微的控制:[拉近顯示] (按 ALT+F6)、[拉遠顯示] (ALT+SHIFT+F6),以及 [調整成​​視窗大小​​] (CTRL+SHIFT+W)。

  • 執行下列其中一或多個動作:

    • 若要將連接器連到其他連接器,請新增連接器至圖形,然後將連接器拖曳到其他連接器。

      連接到連接器
    • 若要變更連接器的路徑,請選取連接器,然後將中間點拖曳到新的位置。

      重設連接器路徑
    • 若要按像素調整連接器,請選取連接器,然後按 Shift+所需方向的方向鍵。

      按像素移動連接器

注意   :若要建立樹狀圖表,請參閱建立樹狀圖表

頁面頂端

使用連接點的其他方式

下列各節討論控制連接點的各種方式。

祕訣   :使用 [縮放] 功能可仔細查看小型圖形,並進行更細微的控制:[拉近顯示] (按 ALT+F6)、[拉遠顯示] (ALT+SHIFT+F6),以及 [調整成​​視窗大小​​] (CTRL+SHIFT+W)。

連接點概觀

連接點就是圖形上的特殊點,您可以將連接器與其他圖形黏附到連接點。當您將連接器或圖形黏附到連接點時,即使其中一個圖形已被移除,連接點仍會維持連接的狀態。

當您試圖將一個圖形連接到另一個圖形時,畫面就會顯示連線點。當您使用 [連接器工具],將游標暫留在圖形附近,或將任何連接器或線條的端點,拖曳到有連接點的圖形附近,這時候您就會看到圖形的連接點。

含連接點之圓圈附近的連接器工具

注意   :連接點並不是黏附連接器的唯一位置。您也可以將連接器 (和線條) 黏附至圖形頂角、圖形控點和圖形幾何。如需詳細資訊,請參閱貼齊和黏附對話方塊

使用點或動態連接

將連接器連到圖形有兩種連接方式:點連接 (有時稱為靜態連接) 或動態連接。您可以在連接器的兩端使用任一種連接方式。如果您使用 [自動連接] 或 [連接圖形] 命令​​來連結圖形,兩端會採用動態連接。如果您手動選取連接器連接到圖形的位置,可以指定連接類型。

在下列圖表中,圖形 A 和圖形 C 之間採用點對點連接,無論 C 移至何處,A 上的連接器都會與 C 上的同一點保持連接。相反地,圖形 B 和 C 之間採用動態連接,因此 B 上的連接器會移至 C 上最接近的連接點。

A 與 C 之間是點對點連接,但 B 與 C 之間是動態連接。

建立點連接   

點連接可讓連接器持續黏附至圖形上的特定點,即使圖形被移動或旋轉亦然。

  1. 請將第一個圖形的連接點拖曳至第二個圖形的連接點上。

  2. 圖形連接時,連接器端點會變成綠色。

將連接器黏附到圖形上的特定點,即可修正連至該點的連接器。

建立動態連接   

「動態連接」可讓連接器變更自己在圖形上的位置,如此一來,當圖形移動或旋轉時,連接器會移至圖形上距離原始連接點最近的連接點。

  1. 將 [連接器工具] 移到第一個圖形的中央,直到圖形周圍出現綠色方塊。

  2. 按住滑鼠按鈕,然後拖曳到第二個圖形的中央。

  3. 當第二個圖形周圍出現綠色方塊時,放開滑鼠按鈕。

將連接器黏附到圖形上,允許將連接器動態移動至圖形上的點。

在圖形上新增連接點

如果您要將連接點黏附到圖形,但您要黏附的位置上沒有連接點,您可以直接新增一個連接點。

  1. 選取圖形。

  2. 在 [常用] 索引標籤上,按一下 [工具] 群組中的 [連接點] 工具 按鈕影像

  3. 如果沒有看到連接點,請在 [檢視] 索引標籤上,選取 [視覺輔助工具] 群組中的 [連接點] 核取方塊。

  4. 按住 Ctrl 並在您要新增連接點的位置上按一下滑鼠。系統會自動選取您新增的連接點。

  5. 在 [常用] 索引標籤,按一下 [工具] 群組中的 [指標工具] 選取物件 ,回到正常編輯模式。

在圖形上新增連接點

移動圖形上的連接點

如果您不滿意連接點所在的位置,可以移動該連接點。

  1. 選取圖形。

  2. 在 [常用] 索引標籤上,選取 [工具] 群組中的 [連接點] 工具 按鈕影像

  3. 如果沒有看到連接點,請在 [檢視] 索引標籤上,選取 [視覺輔助工具] 群組中的 [連接點] 核取方塊。

  4. 按住 Ctrl 鍵並將連接點拖曳至您所要的位置。

  5. 在 [常用] 索引標籤,按一下 [工具] 群組中的 [指標工具] 選取物件 ,回到正常編輯模式。

如果您無法順利將連接點移至您所要的位置,請嘗試使用不同的貼齊設定。如需詳細資訊,請參閱調整貼齊強度或關閉貼齊功能

刪除連接點

連接點有時會擋住去路。在此情況下,您可以刪除連接點。

  1. 選取包含您想要刪除之連接點的圖形。

  2. 在 [常用] 索引標籤上,按一下 [工具] 群組中的 [連接點] 工具。

  3. 如果沒有顯示任何連接點,請在 [檢視] 索引標籤上,選取 [視覺輔助工具] 群組中的 [連接點] 核取方塊。

  4. 按一下您要刪除的連接點。連接點隨即會改以洋紅色顯示。

  5. 按 Delete。

  6. 在 [常用] 索引標籤,按一下 [工具] 群組中的 [指標工具] 選取物件 ,回到正常編輯模式。

刪除連接點

隱藏連接點

有時您會想隱藏連接點以便好好檢視圖表。

  • 在 [檢視] 索引標籤的 [視覺輔助工具] 群組中,清除 [連接點] 核取方塊。

在連接點旁新增文字

您無法直接在連接點上新增文字,但是,您可以先將文字新增至圖形,然後再將文字移至連接點旁。

  1. 選取您要新增文字的圖形,然後開始輸入文字。您所輸入的文字會出現在圖形中。

  2. 選取 [常用] \ [工具] \ [文字區塊] 工具 [文字區塊] 工具圖示 (Ctrl + Shift + 4)

  3. 系統將會選取文字區塊

    已選取的文字區塊
  4. 拖曳文字區塊來移動它並視需要調整其大小

    移動並調整文字方塊的大小

若要結束 [文字區塊] 工具,請選取 [指標工具] 選取物件 (Ctrl + 1)

另一個方法是建立多個具唯一標籤及單一連接點的圖形,然後將它們組成群組以形成較大的圖形。那些連接點將會保持可用。

建立多個已命名的連接點

讓連接點向內、向外或兩者

您可以使用向內和向外的連接點,來控制吸引圖形上的連接端點的方式。

  1. 選取圖形。

  2. 在 [常用] 索引標籤上,按一下 [工具] 群組中的 [連接點] 工具 按鈕影像

  3. 如果沒有看到連接點,請在 [檢視] 索引標籤上,選取 [視覺輔助工具] 群組中的 [連接點] 核取方塊。

  4. 如果您想要新增一個向外或向內和向外的連接點,請以滑鼠右鍵按一下連接點,然後按一下:

    • 向內    :大多數時候您會想要使用向內連接點。向內連接點會吸引連接器上的端點,以及二維 (2D) 圖形上的「向外」連接點與「向內和向外」連接點。

    • 向外    :如果您想將一個 2D 圖形黏附到另一個圖形,可以使用向外連接點。向外連接點會受到向內連接點的吸引。

    • 向內和向外    :如果您有一個圖形,但是您不確定要以何種方式黏附至另一個圖形,則可以使用向內和向外連接點

頁面頂端

使用連接點

下列各節討論控制連接點的各種方式。

連接點概觀

含有四個連接點的圖形。

含有四個連接點的圖形。

新增連接點

如果您要將連接點或圖形黏附到圖形,但您要黏附的位置上沒有連接點,您可以直接新增一個連接點,方法很簡單。

  1. 如果沒有看到連接點,請在 [檢視] 功能表上按一下 [連接點]。

  2. 選取圖形。

    附註: 如果您沒有先選取圖形,就無法在圖形上新增連接點。選取的圖形周圍會出現綠色的虛線邊框。

  3. 按一下 [連接點] 工具 按鈕影像

    如果您沒有看到 [連接點] 工具,請按一下 [連接器] 工具 按鈕影像 旁邊的向下箭號,然後按一下 [連接點] 工具 按鈕影像

  4. 按住 CTRL 並在您要新增連接點的位置上按一下滑鼠。

  5. 如果您想要新增一個向外或向內和向外的連接點,請以滑鼠右鍵按一下連接點,然後按一下 [向內]、[向外] 或 [向內和向外]。

    • 通常使用者會使用 [向內] 連接點。向內連接點會「吸引」連接器的端點,以及 2D 圖形上的向外及向內和向外的連接點。

    • 如果您有一個 2D 圖形並想要將其黏附到另一個圖形,您可以使用 [向外] 連接點。向外連接點會受到向內連接點的「吸引」。

    • 如果您有一個圖形,但是您不確定要以何種方式黏附至另一個圖形,則可以使用 [向內和向外] 連接點。

  6. 按一下 [指標] 工具 [指標] 按鈕 以返回正常編輯模式。

在連接點旁新增文字

很抱歉,您無法直接在連接點旁新增文字,但是,您可以先將文字新增至圖形,然後再將文字移至連接點旁。

  1. 選取圖形。

  2. 開始輸入。您所輸入的文字會出現在圖形中。

  3. 按一下 [文字區塊] 工具 按鈕影像

    如果您沒有看到 [文字區塊​​] 工具,請按一下 [文字] 工具 [文字工具] 按鈕 旁的向下箭號,然後按一下 [文字區塊​​] 工具 按鈕影像

  4. 拖曳文字。

提示: 如果圖形具有控制項控點 控制項控點影像 - 黃色菱形 ,您就可以拖曳圖形,快速移動圖形文字。

移動連接點

如果您不滿意連接點所在的位置,可以移動該連接點。

  1. 選取圖形。

    附註: 如果您沒有先選取圖形,就無法移動連接點。選取的圖形周圍會出現綠色的虛線邊框。

  2. 按一下 [連接點] 工具 按鈕影像

    如果您沒有看到 [連接點] 工具,請按一下 [連接器] 工具 按鈕影像 旁邊的向下箭號,然後按一下 [連接點] 工具 按鈕影像

  3. 將連接點拖曳至您所要的位置。

    如果沒有看到連接點,請在 [檢視] 功能表上按一下 [連接點]。

  4. 按一下 [指標] 工具 [指標] 按鈕 以返回正常編輯模式。

如果您無法順利將連接點移至您所要的位置,請嘗試使用不同的貼齊設定:

  • 在 [工具] 功能表上按一下 [貼齊和黏附],然後在 [一般] 索引標籤上的 [貼齊] 底下選取您想要的選項。

刪除或隱藏連接點

有時候連接點反而礙事。這時您有兩種選擇:刪除連接點或隱藏連接點。

如何刪除圖形上的連接點

  1. 選取圖形。

    附註: 如果您沒有先選取圖形,就無法刪除連接點。選取的圖形周圍會出現綠色的虛線邊框。

  2. 按一下 [連接點] 工具 按鈕影像

    如果您沒有看到 [連接點] 工具,請按一下 [連接器] 工具 按鈕影像 旁邊的向下箭號,然後按一下 [連接點] 工具 按鈕影像

  3. 按一下您要刪除的連接點。連接點隨即會改以洋紅色顯示。

    如果沒有看到連接點,請在 [檢視] 功能表上按一下 [連接點]。

  4. 按 DELETE。

  5. 按一下 [指標] 工具 [指標] 按鈕 以返回正常編輯模式。

如何隱藏連接點

  • 在 [檢視] 功能表上按一下 [連接點]。

頁面頂端

將箭頭或其他線條結尾新增至接點

您可以將箭頭、端點或其他線條結尾等元素新增至接點。

  1. 選取連接器。

  2. 在 [格式] 功能表上,按一下 [線條]。

  3. 在 [線條結尾] 底下,選擇您要的線條結尾類型和大小。

  4. 按一下 [確定]。

提示: 您也可以使用 [格式] 工具列上的 [線條結尾] 工具。

建立曲線、有直角或直線的接點

變更圖表上的連接器

  1. 以滑鼠右鍵按一下連接器。

  2. 按一下 [直角連接器]、[直線連接器] 或 [曲線連接器]。

注意   :您無法新增控點至直線或直角連接器,但可以使用 [鉛筆] 工具 按鈕影像 來將控點新增至曲線連接器。

變更新連接器的預設值

  • 若要讓系統預設建立直線或曲線連接器,請在 [檔案] 功能表上,依序按一下 [版面設定] > [配置和路徑] 索引標籤,然後按一下 [外觀] 清單中的 [直線] 或 [曲線]。

反轉接點箭頭的方向

如果想要變更連接器的方向,您可以新增箭號至沒有箭號的端點,並從其他端點移除現有箭號。

  1. 選取您要變更的連接器。

  2. 在 [常用] 索引標籤上,依序按一下 [圖形] 群組 > [線條],然後指向 [箭號] 以開啟 [箭號] 功能表。

    按一下 [圖形樣式] 中的 [線條] 以開啟功能表,然後按一下 [箭號]。
  3. 在 [箭號] 功能表底部,按一下 [其他箭號]。

    按一下 [箭號] 功能表底部的 [其他箭號]。

    Visio 會顯示 [圖形格式] 工作窗格並展開 [線條]。

  4. 若要新增、變更或移除所選連接器開頭的箭號,請在 [起點箭頭類型] 的箭號功能表上選取一種箭號或選取 [無]。

    在選取的連接線上,新增、變更或移除箭號。

    箭號功能表會針對所選連接器顯示目前選取的箭號樣式或顯示 [無]。

    在 [箭頭樣式] 功能表上選取一個箭號樣式或 [無]。
  5. 若要新增、變更或移除所選連接器結尾的箭號,請在 [終點箭頭類型] 在箭號功能表上選取一種箭號或選取 [無]。

另請參閱

新增與編輯連接器文字

在圖形之間新增連接器

黏附或取消黏附連接器

建立自訂連接器

新增或移除連接線跳轉

Visio 訓練課程

關於 Visio 桌面連接器您所需要了解的所有事 (Visio 小組部落格)

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×