新增 Microsoft SQL Server 資料庫的資料連線

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以新增用來查詢 Microsoft SQL Server 資料庫之表單範本的次要資料連線,但是無法新增將表單資料送出給資料庫之表單範本的次要資料連線。如果想要使用次要資料連線將表單資料送出給資料庫,請使用利用該資料庫之 Web 服務的次要資料連線。如需新增 Web 服務之次要資料連線的詳細資訊連結,請瀏覽「請參閱」一節中的連結。

若要新增資料庫的次要資料連線,您必須執行下列動作:

步驟 1:新增表單範本的次要資料連線    這個步驟會根據在資料庫中儲存資料的方式來建立含有適當欄位和群組的次要資料來源。您也可以將表單範本設定為允許表單在第一次開啟表單時使用這個資料連線。

步驟 2:將表單範本設定為使用資料連線    如果想要使用者在開啟表單之後使用這個資料連線,您可以將規則或按鈕新增至表單範本,允許使用者透過這個資料連線取得資料。

本文內容

概觀

開始之前

步驟 1︰ 新增次要資料連線

步驟 2︰ 設定表單範本,使用資料連線

概觀

建立以外部資料來源為基礎的表單範本時,Microsoft Office InfoPath 會建立該外部資料來源的主要資料連線。然後,InfoPath 會根據將資料儲存在外部資料來源中的方式,建立表單範本的主要資料來源。然而,主要資料連線中所用的外部資料來源可能不會有您想要放在表單範本之控制項上的值。這些值可能存在於另一個外部資料來源上 (如另一個 SQL Server 資料庫)。若要取得另一個外部資料來源的值,您可以新增表單範本的次要資料連線。

次要資料連線就是您新增至表單範本的資料連線。這個資料連線可以是查詢資料連線或送出資料連線。您可以只將查詢資料連線新增至表單範本,來做為 SQL Server 資料庫的次要資料連線。只有在需要來自外部資料來源的資料 (而非主要資料連線中的資料) 時,才應該新增這個資料連線。然而,您不可以新增 SQL Server 資料庫的送出資料連線,來做為次要資料連線。

當您新增查詢資料連線至資料庫時,InfoPath 就會建立第二個資料來源與資料欄位或群組的對應資料儲存在資料庫的方法。因為次要資料來源中的資料結構必須符合資料會儲存在資料庫資料表中的方式,您無法修改 [欄位] 或 [次要資料來源中的群組。您可以設定,讓使用者在他們表單未連線到網路時有資料的存取權,將結果儲存的每個查詢的資料連線。根據資料的性質,而定,您可能要使用者連線到網路時,只顯示查詢結果。

安全性附註 : 如果您使用次要資料連線到外部資料來源擷取機密資料,您可能會想要停用此功能,以協助防止未經授權使用保護資料,以防遺失或竊取電腦。如果您停用此功能,資料會只適用於使用者連線至網路。

當您新增表單範本的查詢資料連線時,根據預設,以這個表單範本為基礎的表單會在使用者開啟時使用資料連線。您也可以利用下列其中一種方法,來設定表單範本以使用查詢資料連線:

  • 新增規則   您可以設定規則的條件規則中發生時,使用查詢資料連線。

  • 新增] 按鈕   您可以新增按鈕至表單範本使用者可以按一下以取得使用查詢資料連線的資料。

  • 使用自訂程式碼   如果您無法新增規則] 或 [] 按鈕,您可以使用自訂程式碼,以取得使用查詢資料連線的資料。使用自訂程式碼需要開發人員若要建立自訂的程式碼。

頁面頂端

在您開始之前

將 SQL Server 資料庫的次要資料連線新增至表單範本之前,需要下列來自資料庫管理員的資訊:

  • 伺服器和您將搭配此表單範本使用之資料庫的名稱。

  • 您將搭配此表單範本使用之資料庫的名稱。

  • 資料庫所需的驗證。此資料庫可以使用 Microsoft Windows 驗證或 SQL Server 驗證來判斷使用者如何存取資料庫。

  • 含有想要傳送至表單之資料的表格名稱。這是主要表格。如果想要使用資料庫中的多個表格,則需要有其他那些子表格的名稱,並且還需要子表格中與主要表格之欄位有關聯的欄位名稱。

  • 是否可以安全地將查詢結果儲存在表單中,以供離線使用。

頁面頂端

步驟 1:新增次要資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 按一下 [資料連線精靈] 」中的 [建立新連線至],然後按一下 [接收資料],再按一下 [下一步]

  4. 在精靈的下一頁上,按一下 [資料庫 (僅限於 Microsoft SQL Server 或 Microsoft Office Access)],然後按 [下一步]

  5. 在精靈的下一頁,按一下 [選取資料庫]

  6. [選取資料來源] 對話方塊中,按一下 [新來源]

  7. [您想要連接到何種資料來源] 清單中,按一下 [Microsoft SQL Server],然後按 [下一步]

  8. [伺服器名稱] 方塊中,輸入含有資料庫之伺服器的名稱。

  9. [登入認證] 底下,執行下列其中一項動作:

    • 如果資料庫會根據 Microsoft Windows 網路中所用的認證來判斷具有存取權的使用者,請按一下 [使用 Windows 驗證]

    • 如果資料庫會根據您從資料庫管理員取得的指定使用者名稱和密碼來判斷具有存取權的使用者,請按一下 [使用下列的使用者名稱和密碼],然後在 [使用者名稱][密碼] 方塊中輸入您的使用者名稱和密碼。

  10. 按一下 [下一步]。

  11. 在精靈下一頁的 [選取包含所需資料的資料庫] 清單中,按一下所要使用的資料庫,選取 [連接特定表格] 核取方塊,按一下主資料表的名稱,然後再按 [下一步]

  12. 在精靈下一頁的 [檔案名稱] 方塊中,輸入儲存資料連線資訊的檔案名稱。

  13. 若要儲存這些設定,請按一下 [完成]

  14. 加入您要用在查詢資料連線中的其他任何資料表。

    做法

    1. 按一下 [新增表格]

    2. 在 [新增資料表或查詢] 對話方塊中,按一下子資料表的名稱,然後按 [下一步。InfoPath 嘗試設定關聯比對兩個資料表中的欄位名稱。如果您不想使用建議的關聯性,請選取的關聯性,,然後按一下 [移除關聯。若要新增關聯,請按一下 [新增關聯。在 [新增關聯] 對話方塊中,按一下 [在個別的欄中,每個相關欄位的名稱,然後按一下[確定]

    3. 按一下 [完成]。

    4. 若要新增其他子表格,請重複這些步驟。

  15. 按一下 [下一步]。

  16. 若要在表單未連線至網路時使用查詢資料連線的結果,請選取 [在表單範本中儲存資料複本] 核取方塊。

    安全性附註 : 如果選取這個核取方塊,會在表單使用這個資料連線時,將資料儲存在使用者電腦上。如果表單是透過這個資料連線取得敏感性資料,則應該停用這個功能,如此將有助於在電腦遺失或遭竊時保護資料。

  17. 按一下 [下一步]。

  18. 在精靈的下一頁,輸入這個次要資料連線的描述名稱。如果您要讓表單在開啟的時候自動接收資料,請選取 [開啟表單時自動擷取資料] 核取方塊。

頁面頂端

步驟 2:將表單範本設定為使用資料連線

如果想讓以此表單範本為基礎的表單在使用者開啟表單之後使用這個資料連線,您可以在特定條件下將規則新增至使用這個資料連線的表單範本,或是將按鈕新增至表單範本,如此使用者只要按一下該按鈕,就可以使用這個資料連線。

新增規則

您可以將一項規則加入至表單範本,以便在每次符合此規則的條件時,從查詢資料連線取得資料。下列程序會假設您已為表單範本建立查詢資料連線,而且假設您已在表單範本上設定顯示該資料連線之資料的控制項。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 按兩下要新增規則的控制項。

  3. 按一下 [資料] 索引標籤。

  4. 按一下 [驗證及規則] 底下的 [規則]

  5. 按一下 [規則] 對話方塊中的 [新增]。

  6. [名稱] 方塊中輸入規則的名稱。

  7. 若要執行規則時,請指定條件,按一下設定條件],然後輸入條件。條件發生時,會執行規則。如果您沒有設定條件,當使用者變更的控制項中,值,然後移離該控制項的他或她游標執行規則。

  8. 按一下 [新增動作]

  9. [動作] 清單中,按一下 [使用資料連線查詢]

  10. [資料連線] 清單中,按一下想要使用的查詢資料連線,然後按一下 [確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

新增按鈕

您可以將按鈕控制項新增至表單範本,如此使用者只要按一下該按鈕,就可以透過查詢資料連線取得資料。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  3. 將按鈕控制項拖到您的表單範本上。

  4. 按兩下剛加入表單範本的按鈕控制項。

  5. 按一下 [一般] 索引標籤。

  6. [動作] 清單中,按一下 [重新整理]

  7. [標籤] 方塊中,輸入要在表單範本上顯示的按鈕名稱。

  8. 按一下 [設定]

  9. 按一下 [重新整理] 對話方塊中的 [一個次要資料來源]

  10. [選擇次要資料來源] 清單中,按一下與查詢資料連線關聯的次要資料來源。

  11. 按一下 [確定] 關閉每個開啟的對話方塊。

  12. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×