新增資料連線至 Microsoft Access 資料庫

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

如果您的使用者需要 Microsoft Office Access 2007 (.accdb 格式) 資料庫或以舊版儲存的 Access 資料庫 (.mdb 格式) 中的資料來填寫以您的 Microsoft Office InfoPath 表單範本為基礎的表單,您可以新增查詢 Access 資料庫的次要資料連線至您的表單範本。

您可以新增次要資料連線,但是該資料連線只能查詢 Access 資料庫。您無法新增將表單資料送出至 Access 資料庫的次要資料連線。

如果您想要讓使用者將表單資料送出至 Access 資料庫,您可以設計一個以 Access 資料庫為基礎的表單範本,然後啟用主要資料連線的送出資料連線。或者,您也可以新增次要資料連線至和您的 Access 資料庫搭配使用的 Web 服務。

請使用「請參閱」一節中的連結,取得設計以 Access 資料庫為基礎的表單範本以及新增次要資料連線至 Web 服務的詳細資訊。

在本文中

概觀

相容性注意事項

開始之前

步驟 1︰ 新增次要資料連線

步驟 2︰ 設定表單範本,使用資料連線

概觀

次要資料連線指的是您新增至表單範本的資料連線。次要資料連線和主要資料連線不同,後者是當您設計以資料庫或 Web 服務為基礎的新表單範本時所建立的資料連線。表單範本的主要資料連線可以接收外部資料來源,也可以送出表單資料至外部資料來源。但是,一個表單範本只可以有一個主要資料連線。

您可以視需要新增任意數目的次要資料連線至表單範本。例如,假設您的 Access 資料庫中包含一個資料表,其中儲存員工資料,而另一個資料表則儲存客戶資料;您可以新增一個次要資料連線,從員工資料表中擷取資料,再新增另一個次要資料連線,從同一個 Access 資料庫的客戶資料表中擷取資料。

雖然您可以新增次要資料連線至表單範本,將表單資料送出至外部資料來源,如 Web 服務或 Windows SharePoint Services 文件庫,但您只可以使用次要資料連線從 Access 資料庫中擷取資料。您無法新增將表單資料送出至 Access 資料庫的次要資料連線。

當您新增查詢資料連線至資料庫時,InfoPath 就會建立第二個資料來源包含資料的欄位或群組的對應資料儲存在資料庫的方法。因為次要資料來源中的資料結構必須符合資料會儲存在資料庫資料表中的方式,您無法修改 [欄位] 或 [次要資料來源中的群組。

您可以設定查詢資料連線儲存結果,這樣一來,當使用者的表單沒有連線至網路時,也可以存取資料。視資料的性質而定,您可以只在使用者連線至網路時才顯示查詢結果。

安全性附註 : 如果您使用次要資料連線到外部資料來源擷取機密資料,您可能會想要停用此功能,以協助防止未經授權使用保護資料,以防遺失或竊取電腦。如果您停用此功能,資料會只適用於使用者連線至網路。

當您新增表單範本的查詢資料連線時,根據預設,以這個表單範本為基礎的表單會在使用者開啟時使用資料連線。您也可以利用下列其中一種方法,來設定表單範本以使用查詢資料連線:

  • 新增規則   您可以設定規則的條件規則中發生時,使用查詢資料連線。

  • 新增] 按鈕   您可以新增按鈕至表單範本使用者可以按一下以取得使用查詢資料連線的資料。

  • 使用自訂程式碼   如果您無法新增規則] 或 [] 按鈕,您可以使用自訂程式碼,以取得使用查詢資料連線的資料。使用自訂程式碼需要開發人員若要建立自訂的程式碼。

頁面頂端

相容性考量

您無法在瀏覽器相容的表單範本中新增 Access 資料庫的資料連線。

頁面頂端

在您開始之前

在表單範本中新增 Access 資料庫的次要資料連線之前,您需要知道下列資訊:

  • 資料庫的名稱和位置。

    附註: 如果您的 Access 資料庫儲存在網路位置,請確認使用者可以存取您的資料庫。

  • 為根據此表單範本的表單提供資料的資料表或查詢名稱。當您設定查詢資料連線時,將使用這個資料表或查詢做為主要的資料表或查詢。

  • 任何其他資料表或查詢提供其他資料的主要資料表或查詢的名稱。在大部分情況下,在資料庫中已經建立資料表關聯。如果您有要手動建立 [主要資料表或查詢與另一個資料表或查詢之間的關聯性,您需要兩個資料表或查詢的相關的欄位名稱。

頁面頂端

步驟 1:新增次要資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 按一下 [資料連線精靈] 」中的 [建立新連線至],然後按一下 [接收資料],再按一下 [下一步]

  4. 在精靈的下一頁上,按一下 [資料庫 (僅限於 Microsoft SQL Server 或 Microsoft Office Access)],然後按 [下一步]

  5. 在精靈的下一頁,按一下 [選取資料庫]

  6. [選取資料來源] 對話方塊中,瀏覽至您的資料庫位置。

    附註: 如果您的資料庫儲存在網路位置中,瀏覽至通用命名慣例 (UNC) 路徑的位置。未瀏覽至對應的網路磁碟機上透過網路位置。如果您使用的對應的網路磁碟機,建立此表單範本為基礎的表單的使用者會搜尋對應的網路磁碟機的資料庫。如果使用者未與任何對應的網路磁碟機,表單就不會找到資料庫。

  7. 按一下資料庫名稱,然後按一下 [開啟]

  8. [選取資料表] 對話方塊中,按一下您想要使用的主要資料表或查詢,然後按一下 [確定]

  9. 在精靈的下一頁中,選取 [顯示資料表資料行] 核取方塊。

    根據預設,資料表或查詢中的所有欄位會新增至表單範本的主要資料來源。

  10. 清除次要資料來源中,您不想要包含的欄位的核取方塊。

    新增任何其他資料表或查詢至資料連線。

    做法

    1. 按一下 [新增表格]

    2. 在 [新增資料表或查詢] 對話方塊中,按一下子資料表的名稱,然後按 [下一步。InfoPath 嘗試設定關聯比對兩個資料表中的欄位名稱。如果您不想使用建議的關聯性,請選取的關聯性,,然後按一下 [移除關聯。若要新增關聯,請按一下 [新增關聯。在 [新增關聯] 對話方塊中,按一下 [在個別的欄中,每個相關欄位的名稱,然後按一下[確定]

    3. 按一下 [完成]。

    4. 若要新增其他子表格,請重複這些步驟。

  11. 按一下 [下一步]。

  12. 若要在表單沒有連線至網路時也可使用查詢資料連線的結果,請選取 [在表單範本中儲存資料複本] 核取方塊。

    安全性附註 : 選取此核取方塊會在表單使用此資料連線時,將資料儲存在使用者的電腦上。如果表單擷取的是機密資料,您可以停用這項功能,這樣電腦遺失或遭竊時才能保護資料。

  13. [下一步]

  14. 在精靈的下一頁中,輸入此次要資料連線的描述性名稱,然後確認 [摘要] 區段中的資訊是正確的。

  15. 若要設定表單在開啟時自動擷取資料,請選取 [在表單開啟時自動擷取資料] 核取方塊。

頁面頂端

步驟 2:設定表單範本使用資料連線

如果您想要在使用者開啟以此表單範本為基礎的表單後,表單會使用此資料連線,您可以新增規則至表單範本,使它在特定情況下使用此資料連線。或者,您也可以新增按鈕至表單範本,讓使用者按一下即可使用此資料連線。

新增規則

您可以新增規則至表單範本,在符合規則的情況下,從查詢資料連線擷取資料。例如,您可以新增文字方塊至表單範本,讓使用者可以在其中填寫,以從外部資料來源取得特定的資料。然後再新增一個規則,在使用者於文字方塊中輸入資料時,使用資料連線。

下列程序假設您已經為表單範本建立了查詢資料連線,並在表單範本上設定了一個控制項 (非按鈕),以從該資料連線顯示資料。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 按兩下要新增規則的控制項。

  3. 按一下 [資料] 索引標籤。

  4. 按一下 [驗證及規則] 底下的 [規則]

  5. 按一下 [規則] 對話方塊中的 [新增]。

  6. [名稱] 方塊中輸入規則的名稱。

  7. 若要執行規則時,請指定條件,按一下設定條件],然後輸入條件。條件發生時,會執行規則。如果您沒有設定條件,當使用者變更的控制項中,值,然後移離該控制項的他或她游標執行規則。

  8. 按一下 [新增動作]

  9. [動作] 清單中,按一下 [使用資料連線查詢]

  10. [資料連線] 清單中,按一下想要使用的查詢資料連線,然後按一下 [確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

新增按鈕

您可以將按鈕控制項新增至表單範本,如此使用者只要按一下該按鈕,就可以透過查詢資料連線取得資料。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  3. 將按鈕控制項拖到您的表單範本上。

  4. 按兩下剛加入表單範本的按鈕控制項。

  5. 按一下 [一般] 索引標籤。

  6. [動作] 清單中,按一下 [重新整理]

  7. [標籤] 方塊中,輸入要在表單範本上顯示的按鈕名稱。

  8. 按一下 [設定]

  9. [重新整理] 對話方塊中,執行下列其中一項操作:

    • 若要在具有數個次要資料連線的表單範本上擷取所有外部資料來源的最新資料,請按一下 [所有次要資料來源]

    • 若要在具有一個次要資料連線的表單範本上,設定按鈕以擷取一個外部資料來源的最新資料請按一下 [一個次要資料連線],然後按一下 [選擇次要資料來源] 清單中的一個次要資料來源。

  10. 按一下 [確定] 以關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×