新增資料連線到 Microsoft SQL Server 資料庫

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

您可以新增次要資料連線到表單範本的查詢 Microsoft SQL Server 資料庫。您無法加入您送出表單資料至資料庫的表單範本的次要資料連線。如果您想要使用的次要資料連線來送出表單資料至資料庫,請使用 Web 服務,可以使用該資料庫的次要資料連線。尋找連結新增到 Web 服務,請參閱 一節中的次要資料連線的相關詳細資訊。

若要新增至資料庫的次要資料連線,您必須執行下列動作:

步驟 1: 新增至表單範本的次要資料連線   此步驟中使用適當的欄位和群組根據資料就會儲存在資料庫中的方式建立次要資料來源。您也可以設定允許表單第一次開啟時,請使用此資料連線的表單的表單範本。

步驟 2: 設定表單範本,使用資料連線   若要讓使用者能在表單開啟後,請使用此資料連線,您可以新增至表單範本,讓使用者取得此資料連線的規則或按鈕。

本文內容

概觀

開始之前

步驟 1: 新增次要資料連線

步驟 2: 設定表單範本,使用資料連線

概觀

當您建立外部資料來源為基礎的表單範本時,Microsoft Office InfoPath 建立主資料連線的外部資料來源。InfoPath 然後建立根據的方式,資料會儲存在外部資料來源的表單範本的主資料來源。不過,使用中的主資料連線的外部資料來源可能沒有您想要放置在表單範本上的控制項中的值。其他外部資料來源,例如另一個 SQL Server 資料庫可能存在這些值。若要取得其他外部資料來源的值,您可以新增至表單範本的次要資料連線。

次要資料連線是您新增至表單範本的資料連線。查詢資料連線或送出資料連線,可使用此資料連線。您可以新增至表單範本的查詢資料連線,只為次要資料連線至 SQL Server 資料庫。只有當您需要從外部資料來源中的主資料連線的一個以外的資料,您可以新增此資料連線。您無法新增送出資料連線至 SQL Server 資料庫,做為次要資料連線。

當您新增查詢資料連線至資料庫時,InfoPath 就會建立第二個資料來源與資料欄位或群組的對應資料儲存在資料庫的方法。因為次要資料來源中的資料結構必須符合資料會儲存在資料庫資料表中的方式,您無法修改 [欄位] 或 [次要資料來源中的群組。您可以設定,讓使用者在他們表單未連線到網路時有資料的存取權,將結果儲存的每個查詢的資料連線。根據資料的性質,而定,您可能要使用者連線到網路時,只顯示查詢結果。

安全性附註: 如果您使用次要資料連線到外部資料來源擷取機密資料,您可能會想要停用此功能,以協助防止未經授權使用保護資料,以防遺失或竊取電腦。如果您停用此功能,資料會只適用於使用者連線至網路。

當您新增至表單範本的查詢資料連線時,依預設此表單範本為基礎的表單的資料連線時使用使用者開啟。您也可以設定表單範本,使用查詢資料連線下列方法之一:

  • 新增規則   您可以設定規則的條件規則中發生時,使用查詢資料連線。

  • 新增] 按鈕   您可以新增按鈕至表單範本使用者可以按一下以取得使用查詢資料連線的資料。

  • 使用自訂程式碼   如果您無法新增規則] 或 [] 按鈕,您可以使用自訂程式碼,以取得使用查詢資料連線的資料。使用自訂程式碼需要開發人員若要建立自訂的程式碼。

頁面頂端

開始之前

您新增的次要資料連線至 SQL Server 資料庫表單範本之前,您會需要從您的資料庫系統管理員的下列資訊:

  • 您會使用此表單範本的資料庫伺服器的名稱。

  • 資料庫,您會使用此表單範本的名稱。

  • 驗證所需的資料庫。資料庫可以使用 Microsoft Windows 驗證或 SQL Server 驗證,來判斷使用者如何存取資料庫。

  • 包含您想要傳送至表單的資料的資料表名稱。這是主要資料表。如果您打算在資料庫中使用多個表格,您需要的其他人員的名稱、 子資料表。您也需要主要資料表中的欄位具有關聯的子資料表中欄位的名稱。

  • 是否可以安全地儲存查詢結果中離線使用的表單。

頁面頂端

步驟 1: 新增次要資料連線

  1. 在 [工具] 功能表上按一下 [資料連線]。

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 在 [資料連線精靈中,按一下 [建立新的連線,接收資料],然後按一下然後按 [下一步

  4. 在精靈的下一個頁面上,按一下資料庫 (Microsoft SQL Server 或 Microsoft Office Access 只)],然後按 [下一步

  5. 在精靈的下一個頁面上,按一下 [選取資料庫]。

  6. 在 [選取資料來源] 對話方塊中,按一下 [新來源

  7. 您要連線至何種資料來源] 清單中,按一下 [ Microsoft SQL Server,然後再按 [下一步

  8. 在 [伺服器名稱] 方塊中,輸入與資料庫伺服器的名稱。

  9. 在 [登入認證,請執行下列其中一項:

    • 如果資料庫決定誰有權存取根據用於 Microsoft Windows 網路認證,請按一下 [使用 Windows 驗證]。

    • 如果資料庫決定誰有權存取根據指定的使用者名稱與您取得資料庫系統管理員的密碼,請按一下 [使用下列的使用者名稱和密碼,然後在 [使用者名稱中輸入您的使用者名稱和密碼密碼方塊。

  10. 按一下 [下一步]。

  11. 選取含有您要的資料的資料庫在清單中,在精靈的下一個頁面上按一下您想要使用、 選取連線至特定的表格] 核取方塊,按一下 [主要] 資料表中的名稱,然後按 [下一步的資料庫.

  12. 在 [檔案名稱] 方塊中,在精靈的下一個頁面上輸入檔案名稱儲存資料連線資訊。

  13. 若要儲存這些設定,請按一下 [完成]。

  14. 新增任何其他您想要使用中的查詢資料連線的資料表。

    如何進行?

    1. 按一下 [新增資料表]。

    2. 在 [新增資料表或查詢] 對話方塊中,按一下子資料表的名稱,然後按 [下一步。InfoPath 嘗試設定關聯比對兩個資料表中的欄位名稱。如果您不想使用建議的關聯性,請選取的關聯性,,然後按一下 [移除關聯。若要新增關聯,請按一下 [新增關聯。在 [新增關聯] 對話方塊中,按一下 [在個別的欄中,每個相關欄位的名稱,然後按一下[確定]

    3. 按一下 [完成]。

    4. 若要新增額外的子表格,請重複這些步驟。

  15. 按一下 [下一步]。

  16. 若要使用的表單未連線到網路時的結果的查詢資料連線,請選取儲存一份表單範本中的資料] 核取方塊。

    安全性附註: 選取此核取方塊使用者的電腦上儲存的資料,當表單使用此資料連線。如果表單機密資料從這個資料連線,您可能會想要停用此功能,以協助保護資料,以防遺失或竊取電腦。

  17. 按一下 [下一步]。

  18. 在精靈的下一個頁面上,輸入此次要資料連線的描述性名稱。若要開啟表單時,自動接收資料的表單,請選取 [自動擷取資料表單開啟時,核取方塊。

頁面頂端

步驟 2: 設定表單範本,使用資料連線

如果您想要使用此資料連線之後使用者開啟表單, 此表單範本為基礎的表單,您可以加入使用特定條件下的此資料連線的表單範本中的規則,或您可以新增按鈕至您的使用者可以 cli 的表單範本若要使用此資料連線 ck。

新增規則

您可以新增規則至表單範本,每當規則的條件符合時取得從查詢資料連線的資料。下列程序假設您已為表單範本,建立查詢的資料連線,而且您已設定要顯示的資料連線的資料表單範本上的控制項。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 按兩下您想要加入規則的控制項。

  3. 按一下 [資料] 索引標籤。

  4. 按一下 [按一下驗證和規則] 底下的 [規則]。

  5. 在 [規則] 對話方塊中,按一下 [新增]。

  6. 在 [名稱] 方塊中,輸入規則的名稱。

  7. 若要執行規則時,請指定條件,按一下設定條件],然後輸入條件。條件發生時,會執行規則。如果您沒有設定條件,當使用者變更的控制項中,值,然後移離該控制項的他或她游標執行規則。

  8. 按一下 [新增動作]。

  9. 在 [動作] 清單中,按一下 [查詢使用的資料連線]。

  10. 在 [資料連線] 清單中,按一下您要使用的查詢資料連線,然後按一下[確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

[新增] 按鈕

您可以新增按鈕控制項至表單範本的使用者可以按一下以取得查詢的資料連線。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  3. 您可以拖曳按鈕控制項至表單範本。

  4. 按兩下您剛才新增至表單範本的按鈕控制項。

  5. 按一下 [一般] 索引標籤。

  6. 在 [動作] 清單中,按一下 [重新整理

  7. 在 [標籤] 方塊中,輸入您要顯示在表單範本上] 按鈕上的名稱。

  8. 按一下 [設定]。

  9. 在 [重新整理] 對話方塊中,按一下一個次要資料來源

  10. 選擇次要資料來源清單中,按一下 [次要資料來源的查詢資料連線與相關聯。

  11. 按一下 [確定] 關閉每個開啟的對話方塊。

  12. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×