新增自訂說明文字至表單範本

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

若要協助使用者瞭解的表單,目的,並以協助他們填寫成功,您可以新增說明的說明文字至表單範本。

本文說明如何決定最佳類型說明文字的表單範本的考量因素類型的表單範本建立後,您對象,如何廣泛部署表單範本,例如,以及使用者可填寫表單根據您使用網頁瀏覽器的表單範本。

本文內容

相容性注意事項

類型的說明

建立檢視,以顯示說明

建立自訂工作窗格顯示的說明

用來顯示關聯式說明的 [設定格式化的條件

建立外部的說明檔或網站的超連結

新增使用者來檢視的 InfoPath 說明系統的相關指示

相容性注意事項

當您設計表單範本中Microsoft Office InfoPath 2007時,您可以選擇設計瀏覽器相容的表單範本。當您設計瀏覽器相容表單範本時,有些功能無法使用。例如,自訂工作窗格,通常用來顯示自訂說明文字,不支援的瀏覽器相容表單範本。若要新增至瀏覽器相容表單範本的說明,請考慮新增說明,例如要顯示的關聯式說明使用條件式格式設定另一種方法。

頁面頂端

類型的說明

根據複雜的表單範本與您的使用者的需求,您可以新增不同類型的說明文字使用不同的程序。根據您的表單範本,您可能會在表單範本中使用多種類型的說明文字。以下是最常見的方法說明文字顯示在表單範本中的清單:

  • 協助檢視   建立另一個檢視以顯示您想要提供給使用者的詳細的指示說明文字。您可以建立包含唯一的說明文字,說明檢視,或者您可以複製您在表單範本的預設檢視中新增的控制項,並包含公開金鑰說明文字。您可以藉由新增說明文字的控制項,提供替代的檢視來填寫表單,包含每個區段或控制項的關聯式說明。當您對象包含新使用者,需要額外協助,與經驗豐富的使用者,已經知道如何填寫表單時,這是很有用的方法。

    提示: 由於瀏覽器相容表單範本不支援的自訂工作窗格,請使用說明檢視顯示說明文字是自訂工作窗格的好方法。

  • 自訂工作窗格   自訂工作窗格是使用者填寫表單時,其內容會顯示在 InfoPath 工作窗格中的 HTML 檔案。您可以指定單一的 HTML 檔案,以開啟預設自訂工作窗格中的表單範本,但您可以將其他的 HTML 檔案新增至表單範本中,為資源檔案,然後建立 [它們之間的超連結。只有 HTML 檔案可以自訂工作窗格中顯示。自訂工作窗格可提供表單特定的命令和說明內容。讓使用者可以檢視自訂工作窗格協助填寫的表單,或您可以連結至另一個位置中所儲存的 HTML 檔案的自訂工作窗格時,甚至,您可以直接與表單範本,新增的 HTML 檔案。例如,如果您打算經常,更新的說明內容,但不想要更新的 HTML 說明檔案每次發佈表單範本,則建議您先在另一個位置和連結中儲存的 HTML 檔案以便從自訂工作窗格。請記住,在瀏覽器相容表單範本不支援自訂工作窗格,好讓您應該在 InfoPath 中建立的自訂工作窗格,僅適用於將填寫的表單。

  • 設定格式化的條件    您可以使用設定格式化的條件若要指定不同的格式設定選項控制項根據出現在表單上的條件。如果指定的條件為真,當使用者填寫表單時,會套用設定格式化的條件。當您新增說明文字至區段在表單範本中,並將條件化格式設定] 區段中,您允許使用者以顯示或隱藏關聯式說明節的文字,或控制視需要,而不切換檢視。這是針對特定區段或控制項需要協助使用者提供內嵌說明的有用方式。

  • 外部說明    您可以新增連結至外部檔案,例如在網站上的 HTML 檔案。例如,如果貴組織的技術支援網站包含網頁的技術支援工程師啟動即時交談工作階段,您可以新增超連結至表單範本,讓使用者可以在其網頁瀏覽器中開啟該頁面。此方法時,您組織中的 [設計另一個部門的表單範本與部門最適合限定為使用者提供協助或技術支援人員。

  • InfoPath 的 [說明] 系統的使用者填寫表單    InfoPath 包含專用的 [說明] 系統的使用者填寫表單。透過您的使用者填寫表單時,請按下 F1,讓他們可存取標準的 InfoPath 功能的下列說明主題。使用此方法使用者填寫只使用 InfoPath 的表單。

頁面頂端

建立檢視,以顯示說明

若要建立另一個檢視使用者來檢視說明的相關填寫表單的表單範本中,必須先建立的表單範本,協助檢視,,然後將按鈕新增至您的使用者可以按一下以存取 [說明] 檢視的預設表單檢視。

建立說明檢視

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. 在 [檢視] 工作窗格中的動作] 底下按一下 [新增新的檢視

  3. 在 [檢視名稱] 方塊中,輸入 [說明] 檢視中的名稱,然後按一下[確定]

    例如,輸入說明

  4. 在表單範本中,按一下您剛才新增的檢視],然後輸入或貼上您要的說明文字。

  5. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  6. 在 [控制項] 工作窗格中,按一下按鈕

  7. 以滑鼠右鍵按一下您所加入] 按鈕,然後按一下快顯功能表上的 [屬性] 按鈕

  8. 按一下 [一般] 索引標籤。

  9. 在 [標籤] 方塊中,輸入標籤] 按鈕。例如,輸入回到表單

  10. 按一下 [規則]。

  11. 在 [規則] 對話方塊中,按一下 [新增]。

  12. 按一下 [新增動作]。

  13. 在 [動作] 方塊中,按一下 [切換檢視]。

  14. 在 [檢視] 方塊中,按一下您的預設檢視的名稱。

  15. 按一下[確定]四次返回表單範本。

您建立的表單範本的 [說明] 檢視後,您必須將按鈕新增至您的預設檢視,以便填寫表單時,使用者可以輕鬆地存取說明檢視。

新增至預設檢視畫面] 按鈕

  1. 在 [檢視] 功能表上按一下 [管理檢視]。

  2. 在 [檢視] 工作窗格中,按一下您的預設檢視的名稱。

  3. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  4. 在 [控制項] 工作窗格中,按一下按鈕

  5. 以滑鼠右鍵按一下您所加入] 按鈕,然後按一下快顯功能表上的 [屬性] 按鈕

  6. 按一下 [一般] 索引標籤。

  7. 在 [標籤] 方塊中,輸入標籤] 按鈕。例如,輸入說明

  8. 按一下 [規則]。

  9. 在 [規則] 對話方塊中,按一下 [新增]。

  10. 按一下 [新增動作]。

  11. 在 [動作] 方塊中,按一下 [切換檢視]。

  12. 在 [檢視] 方塊中,按一下您在上述程序所加入的說明檢視的名稱。

  13. 按一下[確定]四次返回表單範本。

提示: 您也可以新增相同的控制項至預設檢視中所包含的 [說明] 檢視。這可讓使用者選擇如果不需要協助,請填寫預設檢視] 中的表單,或使用 [說明] 檢視填寫表單,如果需要查看的說明文字指示進行。

頁面頂端

建立自訂工作窗格顯示的說明

附註: 建立自訂工作窗格的顯示表單範本中的說明之前,請考慮下列各項:

  • 瀏覽器相容表單範本不支援的自訂工作窗格。

  • 啟用自訂工作窗格之前,您必須先建立自訂工作窗格的 HTML 檔案使用 HTML 編輯器,例如Microsoft Office SharePoint Designer 2007。

若要建立並啟用自訂工作窗格,請執行下列動作:

  1. 在 [工具] 功能表上按一下 [表單選項]。

  2. 在 [類別] 底下,按一下 [程式]。

  3. 選取 [啟用自訂工作窗格] 核取方塊。

  4. 在 [工作窗格名稱] 方塊中,輸入您想要自訂工作窗格的頂端顯示的名稱。例如,輸入說明

  5. 若要將檔案新增至表單範本中,按一下 [資源檔案]。

    附註: 若要將檔案連結至表單範本,在 [工作] 窗格的位置] 方塊中輸入絕對路徑 HTML 檔案的位置,然後按一下[確定]

    安全性附註: 建議您連結至位於相同的網域為您的表單範本的 HTML 檔案。否則,請開啟表單的表單範本為基礎的使用者會看到通知。

  6. 在 [資源檔案] 對話方塊中,按一下 [新增]。

  7. 在 [新增檔案] 對話方塊中,瀏覽至並選取您要的 HTML 檔案,然後按一下[確定]

  8. 如果您新增參照其他檔案,例如階層式樣式表的 HTML 檔案新增這些檔案。

    提示: 您可以指定單一的 HTML 檔案,以開啟預設自訂工作窗格中的表單範本,但您可以將其他的 HTML 檔案新增至表單範本中,為資源檔案,然後建立 [它們之間的超連結。

  9. 在 [表單選項] 對話方塊中,按一下您剛才新增的工作窗格的位置] 中的 HTML 檔案的名稱。

  10. 若要測試變更,請按一下 [預覽],請在 [標準] 工具列上,或按 CTRL + SHIFT + B。預覽表單範本時,預設應該會出現您剛剛建立的自訂工作窗格。

頁面頂端

用來顯示關聯式說明的 [設定格式化的條件

下列程序說明如何使用設定格式化的條件以顯示或隱藏關聯式說明。

  1. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  2. 在 [控制項] 工作窗格中,按一下 [核取方塊,,然後按一下一節

  3. 按一下您剛才新增至您的表單範本] 區段中,輸入說明文字。

  4. 刪除預設標籤文字,] 核取方塊,然後輸入 [按一下以顯示或隱藏說明

  5. 按一下 [在您的表單範本上節的索引標籤,然後在 [格式] 功能表上按一下 [設定格式化的條件

  6. 按一下 [新增]。

  7. 在 [如果此條件為真] 的第一個方塊中,按一下 [選取欄位或群組]。

  8. 在 [選取欄位或群組] 對話方塊中,選取對應到您在步驟 2] 中新增核取方塊控制項的欄位,然後按一下[確定]

  9. 在第二個方塊中,在 [設定格式化的條件] 對話方塊中,按一下 [等於]。

  10. 在第三個方塊中,按一下 [ FALSE]。

  11. [套用此格式,請選取 [隱藏此控制項] 核取方塊。

    附註: 條件現在會顯示,是否已核取方塊,將會顯示 [] 區段中的位置。

  12. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

建立外部的說明檔或網站的超連結

下列程序說明如何從表單範本新增超連結,外部說明檔案,例如的 HTML 檔案或已編譯的說明 (.chm) 檔案,或網站,例如技術支援的網站。

附註: 

  • 請確定您建立的連結的外部說明檔案或網站是由您的使用者存取。如果您想要加入只與 InfoPath 相容的表單範本中的 HTML 檔案的連結 (也就是說,使用者必須使用 InfoPath 表單的表單範本為基礎),您也可以將 HTML 檔案表單範本中,新增藉由新增它們為開啟的資源檔案在 [自訂工作窗格。您應該瀏覽器相容表單範本,請發佈 HTML 檔案的網站,可以存取您的使用者,最好是相同的網站表單範本的位置,並指向外部 HTML 表單範本中建立的靜態超連結檔案。

  • 如果您決定要使用另一種格式說明檔案,例如.chm 檔案],請記住,以驗證您的使用者電腦上的作業系統是否支援您選擇的檔案格式。

建立外部檔案的靜態超連結

  1. 在表單範本中,按一下您要插入超連結,或選取的文字或您想要轉換成超連結的圖片。

  2. 在 [標準] 工具列上按一下 [插入超連結  按鈕影像

  3. 按一下 [一般] 索引標籤。

  4. 在 [位址] 方塊中,輸入您想要連結的 URL。

  5. 若要變更超連結文字的顯示表單範本上,輸入您要在 [文字] 方塊中的文字。

    附註: 如果您在步驟 1 中選取圖片,此選項無法使用。

  6. 若要指派的使用者將滑鼠指標移超連結時,會出現工具提示,請按一下 [進階] 索引標籤,然後在 [工具提示] 方塊中,輸入您想要顯示的文字。

  7. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

新增使用者來檢視的 InfoPath 說明系統的相關指示

InfoPath 包含專用的說明系統填寫表單時,使用者可使用。此 [說明] 系統包含一般工作,例如開啟或關閉自動完成和表單中的文字的拼字檢查的相關資訊。表單設計人員,您可以為表單使用者開啟 InfoPath 說明在預覽預覽視窗中的表單時,請按下 F1。

說明表單使用者限於套用到所有的表單中,因此建議您先提供自訂協助您設計表單範本的工作。若要協助使用者檢視的 InfoPath 說明系統填寫表單時,您可以新增指示表單範本,說明如何存取 InfoPath 說明系統。例如,您可能會表單範本中包含下列範例其中一項:

  • 若要開啟 InfoPath 說明,請按下 F1。

  • 若要開啟 InfoPath 說明,按一下 [說明] 功能表上的 [ Microsoft Office InfoPath 說明]。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×