建立 Windows XP 介面元素

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

使用 [Windows XP 使用者介面] 範本,以依據 Microsoft Windows XP 指導方針所設計的圖形來建立使用者介面模型。這些圖形包括通常用於介面的元素,例如用來做為應用程式視窗基本圖形、精靈頁面、工具列及功能表圖形,以及控制項圖形的空白表單。

若要從建立複雜的應用程式視窗或分頁] 對話方塊中的所有項目進行簡單的訊息方塊或單一] 按鈕,您可以使用這些圖形。

您想要做什麼?

建立單一對話方塊

建立索引標籤式對話方塊

建立應用程式視窗

建置功能表及工具列

建立單一對話方塊

  1. 從 [視窗與對話方塊] 將 [空白表單] 圖形拖曳到繪圖頁面上。

  2. 選取圖案,然後輸入對話方塊的標題。

  3. 將 [Windows 按鈕] 圖形拖曳到標題列的右端,然後選取按鈕類型;通常會有從左到右排列的 [說明] 按鈕及 [關閉] 按鈕。

  4. 將 [確定]、[取消] 及 [套用] 等命令按鈕加入 [空白表單] 圖形的右下角。

    how

    1. 從 [通用控制項] 將 [命令按鈕] 圖形拖曳到 [空白表單] 圖形的右下方。

    2. 選取每個按鈕,然後輸入控制項的名稱。

  5. 將適當的控制項拖曳到 [空白表單] 圖案。以滑鼠右鍵按一下圖案,選擇需要的選項。

    如需特定控制項圖形的說明,請以滑鼠右鍵按一下圖形,然後按一下 [說明]。

    如果您使用 [文字] 工具在 [空白表單] 圖案上建立文字,請將文字的格式設為 [新細明體 9 pt]。

  6. 將命令分為幾個邏輯群組。

  7. 將 [群組方塊] 和 [群組線條] 圖案拖曳到 [空白表單] 圖案,以視覺化方式分隔群組。

    使用 [輔助線] 對齊控制項。

    [檔案] 功能表底下的 [列印] 對話方塊就是一個包含很多常用元素的對話方塊的好例子。

頁面頂端​​

建立索引標籤式對話方塊

  1. 從 [視窗與對話方塊] 將 [空白表單] 圖形拖曳到繪圖頁面上。

  2. 選取圖案,然後輸入對話方塊的標題。

  3. 將 [Windows 按鈕] 圖形拖曳到標題列的右端,然後選取按鈕類型;通常會有從左到右排列的 [說明] 按鈕及 [關閉] 按鈕。

  4. 將 [確定]、[取消] 及 [套用] 等命令按鈕加入 [空白表單] 圖形的右下角。

    how

    1. 從 [通用控制項] 將 [命令按鈕] 圖形拖曳到 [空白表單] 圖形的右下方。

    2. 選取每個按鈕,然後輸入控制項的名稱。

  5. 將 [索引標籤控制項 (本文)] 圖形拖曳到 [空白表單] 圖形上,然後調整它的大小讓它落在表單內,同時記得留下索引標籤的空間。

  6. 拖曳 [索引標籤控制項 (索引標籤)] 圖形,將它黏附到 [索引標籤控制項 (本文)] 圖形的上邊緣。

  7. 選取 [索引標籤控制項 (索引標籤)] 圖形,輸入索引標籤的名稱。

  8. 重複步驟 6 到 7 來建立每一個索引標籤,分別將各自的索引標籤黏附到 [索引標籤控制項 (本文)] 圖形。

  9. 以滑鼠右鍵按一下您要放在最前面的索引標籤,然後按一下 [前景索引標籤],並將其他設為 [背景索引標籤]。

  10. 將適當的控制項拖曳到 [空白表單] 圖案。以滑鼠右鍵按一下圖案,選擇需要的選項。

    如需特定控制項圖形的說明,請以滑鼠右鍵按一下圖形,然後按一下 [說明]。

    如果您使用 [文字] 工具在 [空白表單] 圖案上建立文字,請將文字的格式設為 [新細明體 9 pt]。

  11. 將命令分為幾個邏輯群組。

  12. 將 [群組方塊] 和 [群組線條] 圖案拖曳到 [空白表單] 圖案,以視覺化方式分隔群組。

    使用 [輔助線] 對齊控制項。

    [檔案] 功能表底下的 [頁面設定] 對話方塊就是一個包含很多常用元素的對話方塊的好例子。

頁面頂端​​

建立應用程式視窗

  1. 從 [視窗與對話方塊] 將 [空白表單] 圖形拖曳到繪圖頁面上。

  2. 選取圖形,然後輸入應用程式視窗的標題。

  3. 若要新增圖示到標題列中文字的左邊,以滑鼠右鍵按一下 [空白表單] 圖形,然後選取 [圖示的空間] 核取方塊。

  4. 將 [Windows 按鈕] 圖形拖曳到標題列的右端,然後選取按鈕類型;通常會有從左到右排列的 [最小化] 按鈕、[最大化] 或 [還原] 按鈕,以及 [關閉] 等三個按鈕。

  5. 從 [工具列與功能表] 將 [功能表列] 圖形拖曳到 [空白表單] 圖形上,將它黏附到標題列的底部,然後新增功能表項目。

    how

    1. 將 [頂層功能表項目] 圖形拖曳到頁面,並將它黏附到 [功能表列] 的左邊緣。

      您可以在第一個功能表項目的左邊放置某個圖示。

    2. 選取圖案並輸入名稱。如果功能表項目有快速鍵,請在後面加上適當的字母和底線。

    3. 請依需要重複步驟 1 到 2。

      如需圖案的說明,請以滑鼠右鍵按一下圖案,然後按一下 [說明]。

      若要隱藏連接點 連接點圖像 - 藍色 X ,請按一下 [檢視] 功能表上的 [連接點]。

      欄中的項目應與最寬的項目等寬。

    若要顯示功能表列左邊緣的移駐夾點,以滑鼠右鍵按一下圖形,然後清除 [鎖定功能表列] 核取方塊。

  6. 從 [工具列與功能表] 將 [工具列] 圖形拖曳到 [空白表單] 圖形上,將它黏附到功能表列的底部,然後新增工具列按鈕。

    how

    1. 將其中一個 [工具列按鈕] 圖形拖曳到頁面,並將它黏附到 [工具列] 圖形的左邊緣。

    2. 在 [圖形資料] 對話方塊中,選擇您要的按鈕類型。如果稍後想要變更按鈕,請以滑鼠右鍵按一下圖形,然後按一下 [設定按鈕類型] 重新開啟 [圖形資料] 對話方塊。

    3. 依需要拖曳出其他 [工具列按鈕] 及 [按鈕分隔線] 圖形,將它們彼此黏附在一起。

      如需圖案的說明,請以滑鼠右鍵按一下圖案,然後按一下 [說明]。

      若要隱藏連接點 連接點圖像 - 藍色 X ,請按一下 [檢視] 功能表上的 [連接點]。

    若要顯示工具列左邊緣的移駐夾點,以滑鼠右鍵按一下圖形,然後清除 [鎖定工具列] 核取方塊。

  7. 依需要從 [通用控制項] 將水平及垂直捲軸拖曳到 [空白表單] 圖形的右邊緣及下邊緣。

  8. 以滑鼠右鍵按一下捲軸,然後選擇 [設定捲動標籤大小] 以指出視窗的捲動幅度有多少。

    若要表示文件只有一小部分是可見的,請減少捲動標籤大小;若要表示文件大部分是可見的,請增加捲動標籤大小。

  9. 將 [狀態列] 圖形拖曳到應用程式視窗的下邊緣,並適當地加以格式化。

    how

    1. 將 [狀態列分割線] 圖形拖曳到頁面,並將它黏附到 [狀態列] 圖形的控制項控點 控制項控點

      控制項控點提供空間讓您將 [狀態列分割線] 圖形黏附到 [狀態列] 或其他 [狀態列分割線] 圖形。

      將 [狀態列分割線] 圖形黏附到 [狀態列] 圖形之後,如果看不到狀態列分割線,請選取 [狀態列] 圖形,然後指向 [圖形] 功能表上的 [順序],再按一下 [下移一層]。

    2. 將 [視窗調整大小] 圖形拖曳到狀態列的右邊緣,指出視窗目前處於可調整大小狀態。

頁面頂端​​

建置功能表及工具列

您可以使用 Windows XP 圖形建置基本功能表、下拉功能表及工具列。

建置功能表

  1. 從 [工具列與功能表] 將 [功能表列] 圖形拖曳到繪圖頁面上。若要顯示功能表列左邊緣的移駐夾點,以滑鼠右鍵按一下圖形,然後清除 [鎖定功能表列] 核取方塊。

  2. 拖出 [頂層功能表項目] 圖形並將它黏附到 [功能表列] 的左邊緣。

    提示: 您可能需要在第一個功能表項目的左邊放置圖示。

  3. 選取圖案並輸入名稱。如果功能表項目有快速鍵,請在後面加上適當的字母和底線。

  4. 請依需要重複步驟 2 到 3。

    如需圖案的說明,請以滑鼠右鍵按一下圖案,然後按一下 [說明]。

    若要隱藏連接點 連接點圖像 - 藍色 X ,請按一下 [檢視] 功能表上的 [連接點]。

    欄中的項目應與最寬的項目等寬。

建置下拉功能表

  1. 將 [頂層功能表項目] 圖形拖曳到繪圖頁面上。

  2. 選取圖案並輸入名稱。如果功能表項目有快速鍵,請在後面加上適當的字母和底線。

  3. 拖曳 [下拉功能表項目] 圖形,將它黏附到 [頂層功能表項目] 的底部,然後輸入名稱。

  4. 針對欄中的所有下拉功能表項目重複步驟 3。

  5. 調整所有 [下拉功能表項目] 的大小,讓它們與最寬的項目等寬。

  6. 以滑鼠右鍵按一下每個 [下拉功能表項目] 圖形,再按一下 [功能表項目屬性],然後選取適當的選項。

    如需圖案的說明,請以滑鼠右鍵按一下圖案,然後按一下 [說明]。

    若要隱藏連接點 連接點圖像 - 藍色 X ,請按一下 [檢視] 功能表上的 [連接點]。

建置工具列

  1. 從 [工具列與功能表] 將 [工具列] 圖形拖曳到繪圖頁面上。若要顯示工具列左邊緣的移駐夾點,以滑鼠右鍵按一下圖形,然後清除 [鎖定工具列] 核取方塊。

  2. 拖曳 [工具列按鈕] 圖形並將它黏附到 [工具列] 圖形的左邊緣。

  3. 在 [圖形資料] 對話方塊中,選擇您要的按鈕類型。如果稍後想要變更按鈕,請以滑鼠右鍵按一下圖形,然後按一下 [設定按鈕類型] 重新開啟 [圖形資料] 對話方塊。

  4. 依需要拖曳其他 [工具列按鈕] 及 [按鈕分隔線] 圖形,將它們彼此黏附在一起。

    如需圖案的說明,請以滑鼠右鍵按一下圖案,然後按一下 [說明]。

    若要隱藏連接點 連接點圖像 - 藍色 X ,請按一下 [檢視] 功能表上的 [連接點]。

頁面頂端​​

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×