建立電子郵件合併

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

當您要傳送大量的電子郵件訊息,且其內容大多相同,但每個訊息也包含部分特有的資訊時,請使用電子郵件合併。例如,您可以使用電子郵件合併建立個別的自訂電子郵件訊息,其中包含了個人化的附註或鎖定不同目標客群的多樣化內容。您也可以使用電子郵件合併建立傳送給前 100 大客戶的產品介紹,在出版物中除了每個客戶的電子郵件不同外,其餘大部分的文字都是相同的。

附註: 電子郵件合併需要使用 Microsoft Office Outlook 2007 或 Microsoft Outlook Express 5.0 (含) 以後版本。

使用 [電子郵件合併] 工作窗格建立一個電子郵件合併訊息。若要在全新或現有的出版物中開啟 [電子郵件合併] 工作窗格,指向 [工具] 功能表上的 [郵件與型錄],然後按一下 [電子郵件合併]。

本文內容

建立或連線到收件者清單

準備您的出版物

建立合併的出版物

取消合併列印

建立或連接到收件者清單

若要執行電子郵件合併,必須開啟一個全新或現有的出版物,然後連接到資料來源 (也就是含有要加入出版物中唯一資訊的檔案)。資料檔案可能包含名稱及電子郵件地址的清單、產品資料或圖片。資料檔案可以是不同的格式,包括:

  • Microsoft Office Outlook 連絡人清單

  • Microsoft Office Excel 工作表

  • Microsoft Office Word 表格

  • Microsoft Office Access 資料庫資料表

  • 文字檔案,其中使用 Tab、逗號、分號或其他分隔符號來分隔欄,以及使用段落換行字元來分隔列

您可以連接到現有的清單或資料來源,或建立新的收件者清單。在您的合併中,如果只要使用部分的清單項目,可以依據特定的準則來篩選清單,也可以依照字母順序對清單項目進行排序。

附註: 如果您想要將圖片合併到出版物頁面中,您的資料來源必須包含想要合併之圖片檔案的檔案名稱或路徑。 請勿在資料來源中包含實際的圖片或圖像。

使用現有清單

  1. 按一下 [建立收件者清單] 底下的 [使用現有清單],然後按一下 [下一步: 建立或連線至收件者清單]。

    根據預設,Microsoft Office Publisher 會將資料來源儲存在 [我的資料來源] 資料夾。您可能需要瀏覽並尋找資料來源的位置。

  2. 按一下 [選取資料來源] 對話方塊中您要的資料來源。

  3. 按一下 [開啟]。

    根據所選取的資料來源類型,可能會出現其他對話方塊,要求特定的資訊。

    例如,如果資料類型為 Microsoft Office Excel 活頁簿,其中的資訊分別位於多個工作表中,那麼必須選取包含所需資訊的所有工作表,然後按一下 [確定]。

    清單中的所有連絡人都會顯示在 [合併列印收件者] 對話方塊,您可以在該對話方塊中篩選並將要包含在合併中的收件者清單排序。

從 Outlook 連絡人選取收件者

  1. 按一下 [建立收件者清單] 底下的 [從 Outlook 連絡人選取],然後按一下 [下一步: 建立或連線至收件者清單]。

  2. 如果出現提示要您選擇郵件設定檔,請按一下所要的設定檔,然後按一下 [確定]。

  3. 按一下 [選取連絡人] 對話方塊中所要的連絡人清單,然後按一下 [確定]。

    資料夾中所有的連絡人都會顯示在 [合併列印收件者] 對話方塊中,您可以在該對話方塊中篩選並將要包含在合併中的收件者清單排序。

輸入新清單

如果沒有現存清單可以連接,您可以建立新的清單。

  1. 按一下 [建立收件者清單] 底下的 [鍵入新清單],然後按一下 [下一步: 建立或連線至收件者清單]。

  2. 在 [新增通訊清單] 對話方塊中,加入任何需要的新欄位或欄位標題。

    做法

    按一下 [新增通訊清單] 對話方塊中的 [自訂欄位],然後執行下列任何一項:

    • 若要新增欄位,請按一下要新增的欄位名稱,然後按一下 [新增]。

    • 若要移除欄位,請按一下要移除的欄位名稱,然後按一下 [刪除]。

    • 若要重新命名欄位,請按一下要重新命名的欄位名稱,然後在 [更改欄位名稱] 對話方塊的 [至] 文字方塊中輸入新的名稱。

    • 若要上移或下移清單中的欄位,請按一下要移動的欄位名稱,然後按一下 [上移] 或 [下移] 直到它位在您要的位置上。

  3. 在相關欄位中輸入第一個項目的資訊,包括收件者的電子郵件地址。您不需要填寫所有的欄位。

  4. 完成輸入第一個項目的資訊後,按一下 [新增項目]。

  5. 在完成新增項目之前重複步驟 3 和步驟 4,然後按一下 [確定]。

  6. 在 [儲存通訊清單] 對話方塊的 [檔案名稱] 方塊中輸入通訊清單的名稱,然後選取儲存清單的資料夾。

    根據預設,Microsoft Office Publisher 會將通訊清單儲存於 [我的資料來源] 資料夾。這是保存通訊清單的最佳位置,因為此資料夾也是 Publisher 尋找資料來源的預設資料夾。

    新的清單中所有的連絡人都會顯示在 [合併列印收件者] 對話方塊中,您可以在該對話方塊中篩選並將要包含在合併中的收件者清單排序。

選取收件者

在 [合併列印收件者] 對話方塊中,您可以選取要包含在合併中的收件者。選取要包含的收件者旁的核取方塊,並清除要從合併中排除的收件者旁的核取方塊。

選取或清除清單中的所有項目

  • 選取或清除標題列中的核取方塊。

如果只要在合併中使用部分的清單項目,可以依據特定的欄位或準則來篩選清單。在篩選清單後,可以使用核取方塊來包含或排除記錄。

篩選清單中的項目

  1. 為要當做篩選依據的項目,按一下其欄位標題旁的箭號。

  2. 按一下下列任何一項:

    • [(空白)] 會顯示其中對應欄位為空白的所有記錄。

    • [(非空白)] 會顯示其中對應欄位包含資訊的所有記錄。

    • [(進階)] 會開啟 [篩選和排序] 對話方塊,您可以根據多項準則進行篩選。您也可以在 [合併列印收件者] 對話方塊中,按一下 [調整收件者清單] 底下的 [篩選] 來開啟 [篩選和排序] 對話方塊。

      提示: 如果資料來源包含多個記錄 (其中部分的欄位具有相同資訊),而且如果一欄有 10 個以下的唯一值,您可以依據特定的資料來進行篩選。例如,如果有多個地址都將澳大利亞列為其國家/地區,那麼可以依據 [澳大利亞] 進行篩選。

      [合併列印收件者] 對話方塊僅顯示符合準則的記錄。若要再次顯示所有記錄,請按一下 [(全部)]。

如果要依照字母順序查看清單中的項目,可以對這些項目進行排序。

在清單中的排序項目

  • 按一下 [合併列印收件者] 對話方塊中要做為排序依據之項目的欄位標題。

    例如,如果要按姓氏的字母順序來顯示清單,請按一下 [姓氏] 欄位標題。

  • 若要依據多項準則進行排序,請在 [合併列印收件者] 對話方塊中,請按一下 [調整收件者清單] 底下的 [排序]。在 [篩選和排序] 對話方塊中,選取要做為排序依據的準則。

按一下 [確定],回到 [電子郵件合併] 工作窗格。

頁面頂端

準備您的出版物

電子郵件合併會將包含每個複本中相同資訊的訊息,以及代表每個複本中唯一資訊的一個或多個保留位置合併。出版物建立之後,您可以插入要在每個電子郵件合併出版物的版本中顯示的其他文字 (例如祝賀詞) 以及唯一資訊的保留位置 (例如收件者的名稱)。

如果您尚未這麼做,請插入文字方塊,輸入要在電子郵件合併出版物的每個版本中都顯示的文字,並加入唯一資訊的保留位置。

插入文字方塊

  1. 在 [物件] 工具列上,按一下 [文字方塊 按鈕圖像 ]。

  2. 在出版物中指向您想要文字方塊一角出現的位置,然後沿對角線拖曳直至文字方塊成為所需大小為止。

插入要加入到每個版本中的文字

  • 按一下文字方塊的內部,然後輸入您想要在電子郵件合併出版物的每個版本中都顯示的文字。

將資料欄位插入出版物

  1. 在電子郵件合併出版物中,按一下您要插入資料欄位的文字方塊內部。

  2. 插入下列任何一項:

    地址欄位

    在 [電子郵件合併] 工作窗格 ([準備您的出版物]) 中,從 [準備您的出版物] 底下的清單拖曳所要的欄位,將欄位加入到您為此欄位建立的文字方塊中。

    附註: 

    • 您也可以按一下 [其他項目] 底下的 [地址欄位],然後按一下 [插入地址欄位] 對話方塊中每個要加入的位址元素。

    • 如果資料來源中資料欄位的名稱與 Publisher 用於地址欄位的名稱不相符,可能需要按一下 [插入地址欄位] 對話方塊的 [符合欄位]。在 [符合欄位] 對話方塊中,使用下拉式清單選取資料來源中與 Publisher 欄位對應的欄位。

    個人化超連結

    1. 在 [電子郵件合併] 工作窗格 ([準備您的出版物]) 中,按一下 [其他項目] 底下的 [插入個人化的超連結]。

    2. 在 [插入個人化的超連結] 對話方塊中,輸入要顯示的文字以及當收件者按一下超連結時要前往的網址。

    3. 如果要在顯示文字中插入資料欄位,按一下顯示文字方塊中要插入資料欄位的位置,然後在右側的清單中按一下要插入的資料欄位。

      附註: 如果插入資料欄位,就可以為任何對應到插入資料欄位的空白項目指定替代的顯示文字及網址。視需要選取 [使用空白項目的預設文字] 和 [使用空白項目的預設超連結] 核取方塊,並輸入替代的文字及網址。

    [圖片] 欄位

    1. 在 [電子郵件合併] 工作窗格 ([準備您的出版物]) 中,按一下 [其他項目] 底下的 [圖片欄位]。

    2. 按一下 [插入圖片欄位] 對話方塊中對應到您要插入之圖片檔名清單的欄位。

    問候行

    1. 在 [電子郵件合併] 工作窗格 ([準備您的出版物]) 中,按一下 [其他項目] 底下的 [祝賀行]。

    2. 在 [插入祝賀行] 對話方塊中,選取祝賀行格式。每個祝賀行格式包括問候語、名稱格式以及之後的標點符號。

    3. 選取要在 Publisher 無法解譯收件者名稱的情況下顯示的文字,例如,如果資料來源沒有收件者的名字或姓氏,只包含公司名稱的時候。

      附註: 如果資料來源中資料欄位的名稱與 Publisher 用於祝賀行欄位的名稱不相符,您可能需要按一下 [插入祝賀行] 對話方塊的 [符合欄位]。使用 [符合欄位] 對話方塊中的下拉式清單選取資料來源中與 Publisher 欄位對應的欄位。

設定資料欄位格式

您也可以將文字格式套用到資料欄位及新增的其他文字 (例如「您好」的問候或「親愛的」之類的問候語),變更合併資料的外觀。若要設定合併資料的格式,您必須在電子郵件合併出版物中設定合併欄位的格式。

  1. 在電子郵件合併出版物中,選取含有要格式化的資訊之欄位。

  2. 按一下 [格式] 功能表上的 [字型],然後選取所要的選項。

預覽出版物中資料欄位內收件者的資料

現在,您可以檢閱當實際資料出現在合併資料欄位時出版物的外觀。

  1. 若要預覽出版物,請執行下列任何一項動作:

    • 若要順序預覽項目會顯示在合併出版物中,按一下 [導覽] 按鈕底下預覽收件者電子郵件合併工作窗格 [下一頁] 按鈕 [返回] 按鈕

      資料來源第一筆記錄中的資訊會填入資料欄位。您無法在出版物頁面上編輯資料來源項目,但可以設定格式、移動或刪除資料欄位。

    • 若要尋找並預覽資料來源中的特定項目,按一下 [尋找收件者],然後在 [尋找項目] 對話方塊中輸入搜尋準則。

  2. 如果有需要,您可以變更收件者清單。請執行下列任何一項動作:

    • 若要從合併中排除特定收件者,按一下 [排除收件者]。

    • 若要變更收件者清單,按一下 [編輯收件者清單],然後在 [合併列印收件者] 對話方塊中進行變更。

  3. 當完成電子郵件合併出版物並插入所有合併欄位後,按一下 [檔案] 功能表上的 [另存新檔]。在 [檔案名稱] 方塊中輸入出版物的名稱,然後按一下 [儲存]。

  4. 按一下 [下一步: 建立合併的出版物]。

頁面頂端

建立合併出版物

在 [電子郵件合併] 工作窗格中的 [選取電子郵件合併輸出] 下方,您可以:

  • 以電子郵件方式傳送合併出版物。

  • 預覽出版物 (在傳送所有版本前先查看其外觀,並解決潛在問題)。

預覽合併出版物

  1. 按一下 [電子郵件預覽]。

  2. 按一下 [下一封] 及 [前一封] 按鈕,預覽每個電子郵件訊息傳送時顯示的樣子。

    附註: 如果 [設計檢查] 發現會造成電子郵件合併無法成功完成的問題,您會在 [電子郵件合併] 工作窗格中的 [電子郵件預覽] 下方接到通知。若要檢視並解決潛在的問題,按一下 [設計檢查]。

頁面頂端

傳送合併出版物

  1. 按一下 [傳送電子郵件]。

  2. 在 [合併列印至電子郵件] 對話方塊中,從 [收件者] 下拉式清單中選取收件者欄位。在大多數的情況下,[電子郵件地址] 會是電子郵件合併適當的選擇。

  3. 在 [主旨] 底下,輸入主旨行。在 [要插入的項目] 底下,按一下要插入主旨行的任何資料欄位。

  4. 按一下 [選項],指定所要的任何其他選項,如副本或密件副本收件者或郵件附件。

  5. 按一下 [傳送]。

    [傳送合併列印的電子郵件] 對話方塊隨即開啟,所以您可以藉由檢視是否傳送電子郵件的收件者清單來確認郵件。

頁面頂端

取消合併

只要是在傳送合併列印的電子郵件之前,都可以在任何時間取消合併,中斷電子郵件合併出版物與其資料來源之間的連線。

  1. 指向 [工具] 功能表上的 [郵件與型錄],然後按一下 [取消合併]。

  2. 在詢問是否要取消合併時,按一下 [是]。

出版物與其資料來源的連線已經中斷。

附註: 如果取消電子郵件合併,部分的資料欄位會轉換為文字,但地址區塊、地址欄位及祝賀行等資料欄位仍會保持在作用中。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×