建立資料檢視

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

企業會收集及儲存許多資料;為了讓您和您的小組能夠輕鬆存取及使用這些資料,您想要在小組的 Microsoft SharePoint 網站上建立追蹤或報告的應用程式;您要從何處著手呢?

使用 Microsoft Office SharePoint Designer 2007 可讓您快速建立即時資料的自訂檢視,這種檢視稱為 [資料檢視]。您可以使用 [資料檢視] 來檢視各種不同來源的資料,包括資料庫查詢、XML 文件、Web 服務、SharePoint 清單和文件庫以及伺服器端指令碼。

將 [資料檢視] 插入到頁面的方式有兩種;您可以將 [資料夾清單] 或 [資料來源程式庫] 中的資料來源拖曳到網站上的新頁面或現有頁面上,以建立 [資料檢視],或者您可以使用 [插入資料檢視] 命令建立 [資料檢視],然後僅插入您希望在 [資料來源詳細資料] 工作窗格中顯示的欄位,開始立即修改該檢視。

本文將介紹 [資料檢視],也將示範如何建立範例 XML 檔案當做資料來源,然後會示範如何根據該資料建立 [資料檢視] (先使用拖放方法,然後使用 [資料來源詳細資料] 工作窗格)。本文會使用 .xml 檔案當做資料來源,好讓您可以輕鬆地建立資料來源且易於遵循;但是,下列程序適用於任何資料來源,特別是 SharePoint 清單資料 (這種資料可能是建立 [資料檢視] 所最常使用的資料來源)。

重要: 本文討論在執行 Windows SharePoint Services 3.0 之伺服器上的 SharePoint 網站中建立 [資料檢視] 的相關資訊。如果您的網站不在執行 Windows SharePoint Services 3.0 的伺服器上,可能無法使用所有的功能。

本文內容

什麼是資料檢視?

建立.xml 檔案做為範例資料來源

拖曳頁面的資料來源建立資料檢視

使用 [資料來源詳細資料] 工作窗格中建立資料檢視

建議的後續步驟

何謂資料檢視?

資料檢視是可自訂之即時檢視,運用 Microsoft ASP.NET 技術的資料來源。Office SharePoint Designer 2007從表單的可延伸標記語言 (XML) 中的資料來源中擷取資料,並使用可延伸樣式表語言轉換 (Xslt) 顯示該資料。您可以使用Office SharePoint Designer 2007修改資料檢視。資料檢視可以顯示來自各種來源,包括資料庫查詢、 XML 文件、 Web 服務、 SharePoint 清單和文件庫與伺服器端指令碼的資料。您也可以建立顯示多個資料來源的資料檢視。

資料檢視會從資料來源中擷取資料,並使用 XSLT 顯示該資料

[資料檢視] 會呈現您可加以篩選、排序或群組的即時 [資料檢視];您也可以在完全 WYSIWYG (所見即所得) 的環境中變更版面配置、套用樣式或是套用設定格式化的條件。

您的網頁中插入資料檢視之後,您也可以新增或移除資料行、 變更字型格式設定,或將色彩套用至使用中Office SharePoint Designer 2007 WYSIWYG 工具。當您使用Office SharePoint Designer 2007中可用的 WYSIWYG 工具來格式化資料檢視時,可延伸樣式表語言 (XSL) 是直接插入 HTML。雖然可以編輯的 XSL 直接在程式碼] 檢視中,您可以使用格式設定工具來快速套用 XSL Office SharePoint Designer 2007中輕鬆地而不知道任何 XSL。

頁面頂端

建立 .xml 檔案當做範例資料來源

Northwind Traders 是一家美食產品配銷公司,該公司使用 XML 格式保存其產品清單,此產品清單包含庫存資訊。現在,您的小組藉由列印分送給其他小組的報告來追蹤庫存;您建議他們在其內部網路網站上建立 [資料檢視],好讓整個公司的小組可以快速且輕鬆地存取產品庫存資訊,而不需要列印庫存報告。

下列程序必須使用 .xml 檔案當做資料來源;如果您的 SharePoint 網站上沒有 .xml 檔案,必須先建立 Northwind Traders 產品清單;當您建立這份清單之後,可以使用 [資料檢視] 來建立此清單中所含之資料的檢視。

建立 products.xml

  1. 按一下 [檔案] 功能表上的 [開啟網站]。

  2. 在 [開啟網站] 對話方塊中,瀏覽並選取 SharePoint 網站,然後按一下 [開啟]。

  3. 當出現提示時,在 [連線至] 對話方塊中輸入使用者名稱和密碼,然後按一下 [確定]。

  4. 按一下 [檔案] 功能表上的 [開新檔案]。

  5. 在 [開新檔案] 對話方塊中,按兩下 [文字檔]。

    網站中即會開啟一個新的文字檔。

  6. 選取以下行的程式碼,再按 CTRL+C 進行複製。

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. 在 Office SharePoint Designer 2007 中,將插入點置於頁面頂端,然後按 CTRL+V,貼上您剛才複製到頁面中的程式碼。

  8. 按一下 [檔案] 功能表上的 [另存新檔]。

  9. 在 [另存新檔] 對話方塊,在 [檔案名稱] 方塊中輸入3o

  10. 按一下 [檔案類型] 清單中的 [XML],然後按一下 [儲存]。

頁面頂端


拖曳資料來源到頁面上來建立資料檢視

當您拖曳到頁面上的資料來源時,則結果為資料與您出現在 [基本表格中的每個資料列中的資料來源中的前五個欄位的預設檢視。不過,[資料檢視是完全可自訂的。插入資料檢視之後,您可以輕鬆地新增欄至或移除資料檢視],最適合您需求的資料行。如需詳細資訊,請參閱主題修改資料檢視中的欄

[資料檢視] 是以 Microsoft ASP.NET 2.0 技術為根據;若要建立 [資料檢視],您必須先從 ASP.NET 網頁 (.aspx 檔案) 開始。在本範例中,您將會建立一個新的 ASP.NET 網頁,然後拖曳資料來源到該網頁上來建立 [資料檢視]。

  1. 按一下 [檔案] 功能表上的 [開新檔案]。

  2. 按兩下 [開新檔案] 對話方塊中的 [ASPX]。

    含有 FORM 標籤的新頁面隨即開啟。

    ASP.NET form 標籤

  3. 請執行下列其中一項操作:

    • 在 [資料夾清單] 中尋找資料來源 (在本範例中,也就是 products.xml),然後將它拖曳到頁面上。

    • 按一下 [工作窗格] 功能表上的 [資料來源程式庫];在 [資料來源程式庫] 工作窗格中,尋找資料來源 (在本範例中,也就是 products.xml),然後將它拖曳到頁面上。

      頁面上即會顯示 [資料檢視],而且會開啟 [資料來源詳細資料] 工作窗格。

      拖曳資料來源所建立的資料檢視會顯示前五個欄位
      基本表格版面配置中,顯示前五個欄位。

頁面頂端


使用詳細資料來源工作窗格建立資料檢視

當您使用 [資料來源詳細資料] 工作窗格建立 [資料檢視] 時,會先將 [資料檢視] 插入到頁面中,然後在 [資料來源程式庫] (也就是管理 SharePoint 網站之可用資料來源的一個工作窗格) 中選取資料來源。當您選取資料來源之後,[詳細資料來源] 工作窗格隨即開啟;在 [資料來源詳細資料] 工作窗格中,您會選擇想要顯示的欄位,然後將這些欄位插入到 [資料檢視] 中。

[資料檢視] 是以 ASP.NET 2.0 技術為根據;若要建立 [資料檢視],您必須先從 ASP.NET 網頁 (.aspx 檔案) 開始。在本範例中,您將會建立一個新的 ASP.NET 網頁,然後使用 [資料來源詳細資料] 工作窗格來建立 [資料檢視]。

  1. 按一下 [檔案] 功能表上的 [開新檔案]。

  2. 按兩下 [開新檔案] 對話方塊中的 [ASPX]。

    含有 FORM 標籤的新頁面隨即開啟。

    ASP.NET form 標籤

  3. 按一下 [資料檢視] 功能表上的 [插入資料檢視]。

    網頁上現在會顯示空白的資料檢視,而且會開啟 [資料來源程式庫] 工作窗格。

    空白的資料檢視

    現在您已經插入資料檢視,可以準備開始新增資料。

  4. 在 [資料來源程式庫] 工作窗格中尋找資料來源,然後按一下它,再按一下 [顯示資料]。

    在此範例中,按一下 [XML 檔案] 底下的 [products.xml],然後按一下 [顯示資料]。如果 [XML 檔案] 標題已摺疊,請按一下加號 (+) 將它展開。

  5. 在 [資料來源詳細資料] 工作窗格中,按一下您想要插入到 [資料檢視] 中的欄位。

    提示: 若要選取多個欄位,請按住 CTRL 鍵,並按一下所要的欄位。

    在此範例中,按一下 [ProductsRoot] 資料夾中 [Products] 底下的 [ProductName];按住 CTRL 鍵,並按一下 [UnitsInStock]、[UnitsOnOrder] 及 [ReorderLevel]。

    在 [詳細資料來源] 工作窗格中選取的欄位

  6. 按一下 [插入選取欄位為],然後按一下 [多重項目檢視],將選取的資料插入至 [資料檢視] 中。

    附註: [單一項目檢視] 會在 [資料檢視] 中顯示單筆記錄,[多重項目檢視] 則會顯示多筆記錄,包含各欄中的欄位及每一欄的標題。

    您在 [資料來源詳細資料] 工作窗格中選取的欄位現在會出現在表格中。

    在 [資料檢視] 中出現的 Products.xml

    建立 [資料檢視] 之後,您可以使用 WYSIWIG 工具 (例如 [格式] 工具列) 來修改字型、對齊文字或套用色彩。當您將新的格式設定套用到 [資料檢視] 中的資料點時,Office SharePoint Designer 2007 便會透過修改頁面所附加的 XSLT 樣式表,將該格式設定套用到 XML 中相同層級的所有資料。例如,在之前的圖例中,如果您選取 [Chai],然後按一下 [格式] 工具列上的 [粗體],Office SharePoint Designer 2007 就會將相同的格式設定套用到出現在 [ProductName] 欄位中的所有內容。

    套用到 [ProductName] 欄位中所有資料的粗體格式設定

頁面頂端


建議的後續步驟

[資料檢視] 是功能強大,而且完全可以自訂的即時 [資料檢視];現在您已經了解如何建立 [資料檢視],您可能還會想要學習以下事項:

  • 在 [資料檢視中篩選資料   您可以輕鬆地篩選資料檢視中的資料。如需詳細資訊,請參閱篩選資料檢視中的資料

  • 排序及群組資料檢視中的資料    您可以快速排序,或群組資料檢視中的資料。如需詳細資訊,請參閱排序及群組資料檢視中的資料

  • 套用條件化格式設定至資料檢視   您可以套用特定格式設定至資料檢視 [資料檢視中的資料符合特定條件。如需詳細資訊,請參閱套用條件化格式設定至資料檢視

  • 建立資料檢視中的資料欄    您可以建立計算結果的欄中所顯示的其他資料行的計算結果資料檢視,如同試算表。例如,您可以將單價庫存的數字乘以並不同的欄位中顯示的項目總值。如需詳細資訊,請參閱建立公式欄資料檢視中

  • 修改資料檢視中的資料行   您可以快速且輕鬆地新增、 移除或排列資料檢視中的資料行。如需詳細資訊,請參閱修改資料檢視中的欄

  • 顯示單一資料檢視中的多個來源的資料    您可以連結兩個或更多相關的資料來源,並在單一資料檢視中顯示這些資料來源的資料。如需詳細資訊,請參閱從單一資料檢視中的多個來源顯示資料

  • 在資料檢視中顯示範例資料    在 [資料檢視中,您可以輕易顯示範例資料。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×