建立資料庫模型 (亦稱為「實體關聯」圖表)

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以利用「資料庫模型圖」範本建立新模型,或是使用關聯或物件關聯模型概念,將現有的資料庫反向工程為模型。使用「實體關聯」樣板製作以 SQL92 (含) 以前標準為主之資料庫的模型。使用「物件關聯」樣板 (其中包含搭配類型使用的額外圖形) 製作以 SQL99 (含) 以後標準為主之資料庫的模型。

資料庫模型範例

您可以利用「資料庫模型圖」範本建立新模型,或是使用關聯或物件關聯模型概念,將現有的資料庫反向工程為模型。使用「實體關聯」樣板製作以 SQL92 (含) 以前標準為主之資料庫的模型。使用「物件關聯」樣板 (其中包含搭配類型使用的額外圖形) 製作以 SQL99 (含) 以後標準為主之資料庫的模型。

本文中說明如何建立資料庫模型,以及建立完成之模型的功能。

找不到資料庫模型功能?

並非 Microsoft Visio 的每一個版本都含有資料庫模型功能。如果您找不到本文中的程序所述的功能,很有可能您的 Visio 版本沒有包含這些功能。

  • Microsoft Visio Standard 不提供「資料庫模型圖」範本。

  • Microsoft Visio Professional 和 Premium 版本支援「資料庫模型圖」範本的反向工程 (也就是,使用現有的資料庫在 Visio 中建立模型),但是不支援正向工程 (也就是,使用 Visio 資料庫模型產生 SQL 程式碼)。

  1. 若要啟動您的資料庫模型圖,請執行下列其中一項︰

    從頭開始建立新的模型圖

    如果您沒有可以用來開始進行工作的現成資料庫,那麼您可以使用空白的資料庫模型,並新增自己的資料表和關聯。

    1. 按一下 [檔案] 索引標籤。

    2. 按一下 [開新檔案],然後按一下 [軟體與資料庫],再按兩下 [資料庫模型圖]

    3. [資料庫] 索引標籤上,按一下 [管理] 群組中的 [顯示選項]

    4. [資料庫文件選項] 對話方塊中,選取您要使用的符號組,以及其他資料表和關聯選項,然後按一下 [確定]。

    開始使用現有的資料庫

    如果您有要用來製作模型的資料庫,以方便了解或是用來做為製作新模型的基礎,您可以使用「反向工程精靈」展開資料庫的結構描述或結構,並建立新的模型。

    啟動精靈之前︰

    1. 如果您要對 Microsoft Excel 活頁簿進行反向工程,必須在啟動精靈之前先開啟該活頁簿,並且為包含欄位標題的儲存格群組 (或範圍) 命名。如果您要使用多個工作表,則需要為每一個工作表中的資料欄儲存格群組命名。這些範圍會視為精靈中的資料表。如需如何為儲存格範圍命名的詳細資訊,請參閱 Excel 說明中標題為「定義命名的儲存格參考或範圍」的主題。

    2. 為了獲得最佳結果,請先將您的預設驅動程式設定為要進行反向工程的目標資料庫,再執行「反向工程精靈」。這個步驟能確保精靈正確對應到原生資料類型,以及精靈展開的所有程式碼都能正確顯示於 [程式碼] 視窗中。

    3. 按一下 [檔案] 索引標籤。

    4. 按一下 [開新檔案],然後按一下 [軟體與資料庫],再按兩下 [資料庫模型圖]

    5. [資料庫] 索引標籤上,按一下 [模型] 群組中的 [反向工程]

    6. 在 [反向工程精靈] 的第一個畫面中,執行以下動作:

      1. 選取適用您資料庫管理系統 (DBMS) 的資料庫驅動程式。如果您尚未建立 Visio 資料庫驅動程式與特定 ODBC 資料來源之間的關聯,請按一下 [設定]

        附註: 如果您要對 Excel 工作表進行反向工程,請選擇 [ODBC 標準驅動程式]。

      2. 選取要更新的資料庫資料來源。如果您尚未建立現有資料庫的資料來源,請立即按一下 [新增] 建立資料來源。

        建立新的來源時,會在 [資料來源] 清單中加入該來源的名稱。

      3. 設定完成後,按 [下一步]

    7. 按照任何驅動程式專屬對話方塊中的指示進行。

      例如,在 [連接資料來源] 對話方塊中輸入使用者名稱及密碼,然後按一下 [確定]

      附註: 如果您使用「ODBC 標準驅動程式」,則可能會收到錯誤訊息,表示反向工程資訊可能未完成。在大部分情況下,這種情形並不構成問題;只要按一下 [確定] 並且繼續執行精靈即可。

    8. 選取您要展開之資訊類型的核取方塊,然後按 [下一步]

      附註: 某些項目可能無法使用 (顯示為灰色),因為並非所有資料庫管理系統都支援精靈能夠展開的所有項目類型。

    9. 選取您要展開之資料表 (以及檢視 (如果有的話)) 的核取方塊,或是按一下 [全選],展開全部內容,然後按一下 [下一步]

      附註: 如果您要進行 Excel 工作表的反向工程,但是在此清單中並未看見任何內容,則您可能需要為工作表中包含欄位標題的儲存格範圍命名。

    10. 如果您選取了 [預存程序] 核取方塊,請選取您要展開的程序,或是按一下 [全選] 展開所有程序,然後按 [下一步]

    11. 選擇是否要將完成反向工程的項目自動新增至目前的頁面。

      附註: 您可以選擇讓精靈除了在 [資料表及檢視] 視窗中列出完成反向工程的項目之外,同時自動建立繪圖。如果您決定不要自動建立繪圖,可以從 [資料表及檢視] 視窗中將項目拖曳至您的繪圖頁面上,以便手動組合資料庫模型。

    12. 檢視您的選項,以確定展開的是您要的資訊,然後按一下 [完成]

      精靈會壓縮選取的資訊,然後在 [輸出] 視窗中顯示與壓縮程序相關的說明。

    匯入及改善現有的模型

    如果您擁有現成的 VisioModeler 或 PLATINUM ERwin 模型,可以將它匯入並建立 Visio 資料庫模型圖。這項能力僅限於 VisioModeler 2.0 (含) 以後的字典模型 (.imd) 檔,以及 PLATINUM ERwin 2.6、3.0 及 3.52 .erx 檔。

    1. 按一下 [檔案] 索引標籤。

    2. 按一下 [開新檔案],然後按一下 [軟體與資料庫],再按兩下 [資料庫模型圖]

    3. [資料庫] 索引標籤上,按一下 [模型] 群組中的 [匯入],然後按一下模型類型。

    4. 輸入您要匯入之模型的路徑及檔案名稱,或是按一下 [瀏覽] 按鈕尋找模型檔案,然後按一下 [開啟]

    5. 按一下 [匯入] 對話方塊中的 [確定]。

      Visio 會匯入該檔案,並且在 [輸出] 視窗中顯示進度。匯入的資料表會顯示於 [資料表及檢視] 視窗中。

    6. 在 [資料表及檢視] 視窗中,選取要製作模型的資料表,然後將資料表拖曳到繪圖頁面上。

  2. 在您建立資料庫模型圖之後,便要開始進行細分圖表的工作。您可以新增或自訂資料表及檢視、建立關聯,以及自訂資料欄和資料類型。

    表格

    使用 [實體] 圖形在您的圖表中建立資料表。

    1. [實體關聯][物件關聯] 樣板中拖曳 [實體] 圖形至繪圖上。

    2. 按兩下圖形,開啟 [資料庫屬性] 視窗。

    3. 按一下 [類別] 下的 [定義],然後輸入資料表的名稱。

    4. 按一下 [類別] 下的 [資料欄],輸入名稱,然後選擇資料類型。

    5. 針對不能有 null 值的資料欄選取 [必要欄位] 核取方塊。

    6. 針對在資料庫資料表中各資料列具有唯一識別的資料欄,選取 [PK] (主索引鍵) 核取方塊。

    7. 按一下 [類別] 下的 [索引][觸發程序][檢查][擴充],建立這些選用的項目。

    資料行

    使用 [資料庫屬性] 視窗新增或變更資料欄的屬性,包括資料類型和主索引鍵。

    1. 按兩下圖表中的資料表。

    2. [資料庫屬性] 視窗中,按一下 [類別] 底下的 [資料欄]

    3. 按一下第一個空的 [實體名稱] 儲存格,然後輸入名稱。

    4. 若要變更資料欄的資料類型,請按一下資料欄的 [資料類型] 欄位,然後從清單中選取資料類型,或在清單中輸入資料類型。例如,您可以輸入 decimal(8,2)char(30)

    5. 若要避免出現 null 值,請選取 [必要欄位] 核取方塊。

    6. 若要將資料欄指定為主要索引鍵,請選取 [PK] 核取方塊。

    7. 除了您按下 [資料欄] 類別時出現的資料欄屬性之外,若要查看更多資料欄屬性,請選取資料欄,然後按一下 [編輯]

    關聯性

    關聯使用主索引鍵及外部索引鍵讓資料庫對應某個資料表中的資料列,以及相關資料表中的資料列。您可以在圖表中顯示這些關聯。此外,您還可以設定其基數 (例如,一對多) 並且使用 Crow's feet、關聯式或 IDEF1X 表示法顯示基數。不過,您無法在「資料庫模型圖」範本中使用這些表示法顯示多對多關聯。

    1. 建立資料表之間的關聯︰

      1. 確認可以在圖表中看見這兩個資料表。如果您是從現有資料庫進行模型的反向工程,則需要從 [資料表及檢視] 視窗中將其中一個或這兩個資料表拖曳到繪圖頁面上。

      2. 按兩下要用於關聯中主索引鍵端的資料表。

      3. [資料庫屬性] 視窗中,按一下 [類別] 底下的 [資料欄]

      4. 按一下資料格中要用來做為資料表中各資料列之唯一識別的資料欄,然後選取 [PK] 核取方塊將它設定為主索引鍵。

      5. [物件關聯][實體關聯] 樣板中,拖曳 [關聯] 圖形並放置到頁面上的空白處。

      6. 將資料表較高的一端連接到父系資料表。

      7. 將另一端連接到子系資料表。

        如果第二份資料表中的資料欄與主索引鍵的名稱不同,模組器會將該主索引鍵加入第二份資料表,做為外部索引鍵。

        附註: 如果關聯線消失,請在 [資料庫] 索引標籤上,按一下 [管理] 群組中的 [顯示選項]。在 [關聯] 索引標籤上,選取 [顯示] 底下的 [關聯] 核取方塊。

    2. 設定關聯的基數︰

      1. 按兩下關聯。

      2. [資料庫屬性] 視窗中,按一下 [類別] 底下的 [其他]

      3. [基數] 下選擇最適合關聯的基數。最適合一對多關聯的選項為 [零或更多][一或更多]。最適合一對一關聯的選項為 [零或一個][只有一個]

  3. 若要將圖表細分成其他部分 (例如,建立索引、檢查子句及觸發程序),您可以執行下列動作︰

    建立索引

    索引能在您執行查詢時,改善資料庫的效能或加快速度。

    1. 開啟資料庫模型圖。

    2. 按兩下要在其中新增索引的資料表,然後在 [資料庫屬性] 視窗中,按一下 [類別] 清單中的 [索引]

    3. 按一下 [新增]。

    4. [建立索引] 對話方塊中輸入索引的名稱,然後按一下 [確定]

    5. [索引類型] 清單中,選取建立唯一索引的選項或非唯一索引的選項。

    6. [可用資料欄] 清單中,選取要加入此索引之各資料欄的名稱,然後按一下 [新增 >]

    7. [索引資料欄] 清單中選取 [Asc] 核取方塊,建立使用遞增排序順序的索引,或清除該核取方塊,建立使用遞減排序順序的索引。

      資料庫模型圖會更新。

    建立檢視

    您可以想像已儲存查詢的檢視。如果您需要從多個資料表重複存取相同的資料,或是想要對使用者公開資料,但不讓他們變更實際的資料表,則使用檢視會十分方便。

    [實體關聯][物件關聯] 樣板將 [檢視] 圖形拖曳到繪圖頁面上。

    設定資料表和檢視表擴充的屬性

    根據您的資料庫管理系統 (DBMS) 而定,您可能可以設定資料表或檢視的擴充屬性,以決定其儲存位置。

    按兩下要設定其擴充屬性的資料表或檢視,然後在 [資料表屬性] 視窗中,按一下 [類別] 清單中的 [擴充]

    建立檢查子句

    使用檢查子句確認輸入資料欄中的資料是在特定的值範圍之內。例如,您可以建立檢查子句,要求 [年齡] 資料欄中的資料必須超過 65。

    1. 按兩下資料表,開啟 [資料庫屬性] 視窗。

    2. 按一下 [類別] 下的 [資料欄],然後按一下要在其中新增檢查子句的資料欄。

    3. 按一下 [編輯]。

    4. [欄屬性] 對話方塊的 [檢查] 索引標籤上,輸入您要使用的限制式。

      檢查子句會新增到 [本機程式碼] 底下的 [程式碼] 視窗。

    建立預存程序及使用者定義函數

    使用預存程序及使用者定義功能可以建立各種不同的程式碼,讓您用來重複執行相同的動作。兩者之間主要的差異在於,使用者定義功能會傳回值,而預存程序會執行程式碼,但不會傳回值。

    1. [資料庫] 索引標籤上,選取 [顯示/隱藏] 群組中的 [程式碼] 核取方塊,以開啟 [程式碼] 視窗。

    2. 按一下 [全域程式碼],然後按一下 [新增]

    3. [程式碼編輯器][屬性] 索引標籤上,按一下您要編輯的程式碼類型,然後輸入該程式碼的名稱。

    4. [主體] 索引標籤上輸入程式碼,然後按一下 [確定]

    建立引動程序

    當資料庫中發生特定事件時,觸發程序會執行您在觸發程序中指定的 SQL 程式碼。

    1. 按兩下資料表,開啟 [資料庫屬性] 視窗。

    2. 按一下 [類別] 下的 [觸發程序],然後按一下 [新增]

    3. [屬性] 索引標籤上輸入觸發程序的名稱。

    4. [主體] 索引標籤上輸入程式碼,然後按一下 [確定]

      觸發程序會新增到 [本機程式碼] 底下的 [程式碼] 視窗。

本文中說明如何建立資料庫模型,以及建立完成之模型的功能。若要立即開始進行,請指向 [檔案] 功能表上的 [開新檔案],再指向 [軟體和資料庫],然後按一下 [資料庫模型圖]。

找不到資料庫模型功能?

很有可能是您的 Microsoft Office Visio 版本並未包含您所尋找的功能。若要確認您的 Visio 版本,按一下 [說明] 功能表上的 [關於 Microsoft Office Visio],您便會在對話方塊中的第一行文字中看到版本名稱。

  • Microsoft Office Visio Standard 不提供「資料庫模型圖」範本。

  • Microsoft Office Visio Professional 支援「資料庫模型圖」範本的反向工程 (也就是,使用現有的資料庫在 Visio 中建立模型),但是不支援正向工程 (也就是,使用 Visio 資料庫模型產生 SQL 程式碼)。

  • Visio for Enterprise Architects 為您提供一套完整的資料庫模型功能,包括反向/正向工程。Visio for Enterprise Architects 包含在 MSDN Premium Subscription 中;MSDN Premium Subscription 會隨 Visual Studio Professional 及 Visual Studio Team System 的角色架構版本提供。

  1. 若要啟動您的資料庫模型圖,請執行下列其中一項︰

    從頭開始建立新的模型圖

    如果您沒有可以用來開始進行工作的現成資料庫,那麼您可以使用空白的資料庫模型,並新增自己的資料表和關聯。

    1. 在 [檔案] 功能表上,依序指向 [新增] 及 [軟體和資料庫],然後按一下 [資料庫模型圖]。

    2. 指向 [資料庫] 功能表上的 [選項],然後按一下 [文件]。

    3. 在 [資料庫文件選項] 對話方塊中,選取您要使用的符號組,以及其他資料表和關聯選項,然後按一下 [確定]。

    開始使用現有的資料庫

    如果您有要用來製作模型的資料庫,以方便了解或是用來做為製作新模型的基礎,您可以使用「反向工程精靈」展開資料庫的結構描述或結構,並建立新的模型。

    附註: 啟動精靈之前︰

    1. 如果您要對 Microsoft Office Excel 活頁簿進行反向工程,必須在啟動精靈之前先開啟該活頁簿,並且為包含欄位標題的儲存格群組 (或範圍) 命名。如果您要使用多個工作表,則需要為每一個工作表中的資料欄儲存格群組命名。這些範圍會視為精靈中的資料表。如需如何為儲存格範圍命名的詳細資訊,請參閱 Microsoft Office Excel 說明中標題為「定義命名的儲存格參考或範圍」的主題。

    2. 為了獲得最佳結果,請先將您的預設驅動程式設定為要進行反向工程的目標資料庫,再執行「反向工程精靈」。這個步驟能確保精靈正確對應到原生資料類型,以及精靈展開的所有程式碼都能正確顯示於 [程式碼] 視窗中。

    3. 在 [檔案] 功能表上,依序指向 [新增] 及 [軟體和資料庫],然後按一下 [資料庫模型圖]。

    4. 按一下 [資料庫] 功能表中的 [反向工程]。

    5. 在 [反向工程精靈] 的第一個畫面中,執行以下動作:

      1. 選取適用您資料庫管理系統 (DBMS) 的 Microsoft Office Visio 資料庫驅動程式。如果您尚未建立 Visio 資料庫驅動程式與特定 ODBC 資料來源之間的關聯,請按一下 [設定]。

        附註: 如果您要對 Excel 工作表進行反向工程,請選擇 [ODBC 標準驅動程式]。

      2. 選取要更新的資料庫資料來源。如果您尚未建立現有資料庫的資料來源,請立即按一下 [新增] 建立資料來源。

        建立新的來源時,會在 [資料來源] 清單中加入該來源的名稱。

      3. 設定完成後,按 [下一步]

    6. 按照任何驅動程式專屬對話方塊中的指示進行。

      例如,在 [連接資料來源] 對話方塊中輸入使用者名稱及密碼,然後按一下 [確定]。如果您的資料來源並未受到密碼保護,則只需要按一下 [確定]。

      附註: 如果您使用「ODBC 標準驅動程式」,則可能會收到錯誤訊息,表示反向工程資訊可能未完成。在大部分情況下,這種情形並不構成問題;只要按一下 [確定] 並且繼續執行精靈即可。

    7. 選取您要展開之資訊類型的核取方塊,然後按 [下一步]

      附註: 某些項目可能無法使用 (顯示為灰色),因為並非所有資料庫管理系統都支援精靈能夠展開的所有項目類型。

    8. 選取您要展開之資料表 (以及檢視 (如果有的話)) 的核取方塊,或是按一下 [全選],展開全部內容,然後按一下 [下一步]

      附註: 如果您要進行 Excel 工作表的反向工程,但是在此清單中並未看見任何內容,則您可能需要為工作表中包含欄位標題的儲存格範圍命名。

    9. 如果您在步驟 5 中選取了 [預存程序] 核取方塊,請選取您要展開的程序,或是按一下 [全選] 展開所有程序,然後按 [下一步]。

    10. 選擇是否要將完成反向工程的項目自動新增至目前的頁面。

      附註: 您可以選擇讓精靈除了在 [資料表及檢視] 視窗中列出完成反向工程的項目之外,同時自動建立繪圖。如果您決定不要自動建立繪圖,可以從 [資料表及檢視] 視窗中將項目拖曳至您的繪圖頁面上,以便手動組合資料庫模型。

    11. 檢視您的選項,以確定展開的是您要的資訊,然後按一下 [完成]

      精靈會壓縮選取的資訊,然後在 [輸出] 視窗中顯示與壓縮程序相關的說明。

    匯入及改善現有的模型

    如果您擁有現成的 VisioModeler 或 PLATINUM ERwin 模型,可以將它匯入並建立 Visio 資料庫模型圖。這項能力僅限於 VisioModeler 2.0 (含) 以後的字典模型 (.imd) 檔,以及 PLATINUM ERwin 2.6、3.0 及 3.52 .erx 檔。

    1. 在 [檔案] 功能表上,依序指向 [新增] 及 [軟體和資料庫],然後按一下 [資料庫模型圖]。

    2. 指向 [資料庫] 功能表上的 [匯入],然後按一下 [匯入 <模型樣式>]。

    3. 輸入您要匯入之模型的路徑及檔案名稱,或是按一下 [瀏覽] 按鈕尋找模型檔案,然後按一下 [開啟]。

    4. 按一下 [匯入] 對話方塊中的 [確定]。

      Visio 會匯入該檔案,並且在 [輸出] 視窗中顯示進度。匯入的資料表會顯示於 [資料表及檢視] 視窗中。

    5. 在 [資料表及檢視] 視窗中,選取要製作模型的資料表,然後將資料表拖曳到繪圖頁面上。

  2. 在您建立資料庫模型圖之後,便要開始進行細分圖表的工作。您可以新增或自訂資料表及檢視、建立關聯,以及自訂資料欄和資料類型。

    表格

    使用 [實體] 圖形在您的圖表中建立資料表。

    1. 從 [實體關聯] 或 [物件關聯] 樣板中拖曳 [實體] 圖形至繪圖上。

    2. 按兩下圖形,開啟 [資料庫屬性] 視窗。

    3. 按一下 [類別] 下的 [定義],然後輸入資料表的名稱。

    4. 按一下 [類別] 下的 [資料欄],輸入名稱,然後選擇資料類型。

    5. 針對不能有 null 值的資料欄選取 [必要欄位] 核取方塊。

    6. 針對在資料庫資料表中各資料列具有唯一識別的資料欄,選取 [PK] (主索引鍵) 核取方塊。

    7. 按一下 [類別] 下的 [索引][觸發程序][檢查][擴充],建立這些選用的項目。

    資料行

    使用 [資料庫屬性] 視窗新增或變更資料欄的屬性,包括資料類別和主索引鍵。

    1. 按兩下圖表中的資料表。

    2. 按一下 [資料庫屬性] 視窗中 [類別] 下的 [資料欄]。

    3. 按一下第一個空的 [實體名稱] 儲存格,然後輸入名稱。

    4. 若要變更資料欄的資料類型,請按一下資料欄的 [資料類型] 欄位,然後從清單中選取資料類型,或在清單中輸入資料類型。例如,您可以輸入 decimal(8,2)char(30)

    5. 若要避免出現 null 值,請選取 [必要欄位] 核取方塊。

    6. 若要將資料欄指定為主要索引鍵,請選取 [PK] 核取方塊。

    7. 除了您按下 [資料欄] 類別時出現的資料欄屬性之外,若要查看更多資料欄屬性,請選取資料欄,然後按一下 [編輯]

    關聯性

    關聯使用主索引鍵及外部索引鍵讓資料庫對應某個資料表中的資料列,以及相關資料表中的資料列。您可以在圖表中顯示這些關聯。此外,您還可以設定其基數 (例如,一對多) 並且使用 Crow's feet、關聯式或 IDEF1X 表示法顯示基數。不過,您無法在「資料庫模型圖」範本中使用這些表示法顯示多對多關聯。

    1. 建立資料表之間的關聯︰

      1. 確認可以在圖表中看見這兩個資料表。如果您是從現有資料庫進行模型的反向工程,則需要從 [資料表及檢視] 視窗中將其中一個或這兩個資料表拖曳到繪圖頁面上。

      2. 按兩下要用於關聯中主索引鍵端的資料表。

      3. 按一下 [資料庫屬性] 視窗中 [類別] 下的 [資料欄]。

      4. 按一下資料格中要用來做為資料表中各資料列之唯一識別的資料欄,然後選取 [PK] 核取方塊將它設定為主索引鍵。

      5. [物件關聯][實體關聯] 樣板中,拖曳 [關聯] 圖形並放置到頁面上的空白處。

      6. 將資料表較高的一端連接到父系資料表。

      7. 將另一端連接到子系資料表。

        如果第二份資料表中的資料欄與主索引鍵的名稱不同,模組器會將該主索引鍵加入第二份資料表,做為外部索引鍵。

        附註: 如果關聯線消失,請指向 [資料庫] 功能表上的 [選項],然後按一下 [文件]。在 [關聯] 索引標籤的 [顯示] 下,選取 [關聯] 核取方塊。

    2. 設定關聯的基數︰

      1. 按兩下關聯。

      2. 按一下 [資料庫屬性] 視窗中 [類別] 下的 [其他]。

      3. 在 [基數] 下選擇最適合關聯的基數。最適合一對多關聯的選項為 [零或更多] 或 [一或更多]。最適合一對一關聯的選項為 [零或一個] 或 [只有一個]。

  3. 若要將圖表細分成其他部分 (例如,建立索引、檢查子句及觸發程序),您可以執行下列動作︰

    建立索引

    索引能在您執行查詢時,改善資料庫的效能或加快速度。

    1. 開啟資料庫模型圖。

    2. 按兩下要在其中新增索引的資料表,然後按一下 [資料庫屬性] 視窗中 [類別] 清單下的 [索引]。

    3. 按一下 [新增]。

    4. [建立索引] 對話方塊中輸入索引的名稱,然後按一下 [確定]

    5. [索引類型] 清單中,選取建立唯一索引的選項或非唯一索引的選項。

    6. [可用資料欄] 清單中,選取要加入此索引之各資料欄的名稱,然後按一下 [新增 >]

    7. [索引資料欄] 清單中選取 [Asc] 核取方塊,建立使用遞增排序順序的索引,或清除該核取方塊,建立使用遞減排序順序的索引。

      資料庫模型圖會更新。

    建立檢視

    您可以想像已儲存查詢的檢視。如果您需要從多個資料表重複存取相同的資料,或是想要對使用者公開資料,但不讓他們變更實際的資料表,則使用檢視會十分方便。

    [實體關聯][物件關聯] 樣板將 [檢視] 圖形拖曳到繪圖頁面上。

    設定資料表和檢視表擴充的屬性

    根據您的資料庫管理系統 (DBMS) 而定,您可能可以設定資料表或檢視的擴充屬性,以決定其儲存位置。

    按兩下要設定其擴充屬性的資料表或檢視,然後按一下 [資料表屬性] 視窗中 [類別] 清單下的 [擴充]。

    建立檢查子句

    使用檢查子句確認輸入資料欄中的資料是在特定的值範圍之內。例如,您可以建立檢查子句,要求 [年齡] 資料欄中的資料必須超過 65。

    1. 按兩下資料表,開啟 [資料庫屬性] 視窗。

    2. 按一下 [類別] 下的 [資料欄],然後按一下要在其中新增檢查子句的資料欄。

    3. 按一下 [編輯]。

    4. [檢查] 索引標籤的 [欄屬性] 對話方塊中,輸入您想要的限制式。如需選項的詳細資訊,請參閱資料欄和欄位屬性] 對話方塊 ([核取] 索引標籤)

      檢查子句會新增到 [本機程式碼] 底下的 [程式碼] 視窗。

    建立預存程序及使用者定義函數

    使用預存程序及使用者定義功能可以建立各種不同的程式碼,讓您用來重複執行相同的動作。兩者之間主要的差異在於,使用者定義功能會傳回值,而預存程序會執行程式碼,但不會傳回值。

    1. 指向 [資料庫] 功能表上的 [檢視],然後按一下 [程式碼] 開啟 [程式碼] 視窗。

    2. 按一下 [全域程式碼],然後按一下 [新增]。

    3. [程式碼編輯器][屬性] 索引標籤上,按一下您要編輯的程式碼類型,然後輸入該程式碼的名稱。

    4. [主體] 索引標籤上輸入程式碼,然後按一下 [確定]

    建立引動程序

    當資料庫中發生特定事件時,觸發程序會執行您在觸發程序中指定的 SQL 程式碼。

    1. 按兩下資料表,開啟 [資料庫屬性] 視窗。

    2. 按一下 [類別] 下的 [觸發程序],然後按一下 [新增]。

    3. [屬性] 索引標籤上輸入觸發程序的名稱。

    4. [主體] 索引標籤上輸入程式碼,然後按一下 [確定]

      觸發程序會新增到 [本機程式碼] 底下的 [程式碼] 視窗。

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×