將 Word 文件轉換為 InfoPath 表單範本

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

雖然您可以使用 Microsoft Office Word 建立外觀和感覺都像表單的文件,但 Word 主要還是文書處理程式,而不是設計表單的程式。相反地,Microsoft Office InfoPath 是特別針對設計和填寫電子表單而建立的。如果要將現有 Word 文件轉換為 InfoPath 表單範本,可以使用 InfoPath 中的匯入精靈。然後便可利用 InfoPath 的特有功能來設計、發佈和填寫表單。例如,您可以在銷售報表表單範本中使用條件式格式設定,當數字低於銷售計劃時,便會自動套用紅色的背景色彩。您可以在同一份表單範本中使用規則,當使用者按一下送出按鈕時,便會將表單範本的表單以電子郵件附件的方式送出。此外,您也可以建立瀏覽器使用的表單範本,以供更多人使用表單範本。

當您將 Word 文件轉換為 InfoPath 表單範本時,所產生的表單範本在版面配置上與 Word 文件非常相似。此外,Word 文件中的項目如符合特定條件,會自動轉換成適當的控制項,讓使用者可以輸入資料。比方說,如果 Word 文件包含括住多個空格的括號,InfoPath 就會假設您使用括號所括住的區域來當做文字輸入欄位,接著便會在產生的表單範本上將其轉換成文字方塊。任何 Word 表單欄位都可以轉換成 InfoPath 中對應的控制項。

您可以使用 [匯入選項] 對話方塊中的設定變更將 Word 文件轉換為 InfoPath 表單範本的選項。

本文說明將 Word 文件轉換為 InfoPath 表單範本的基本概念和步驟,包括轉換時不支援的功能和設定。

本文內容

關於將 Word 文件轉換為 InfoPath 表單範本

轉換時未能完整支援的 Word 功能和設定

將 Word 文件轉換為 InfoPath 表單範本

將版面配置表格變更為重複表格

將核取方塊變更為一組選項按鈕

在設計檢查工作窗格中查看轉換問題

關於將 Word 文件轉換為 InfoPath 表單範本

當您將 Word 文件轉換為 InfoPath 表單範本時,會將文件當做藍圖來建立新的表單範本。文件的基本結構會盡可能重現在表單範本中。在 Word 文件中,「表單欄位」是指儲存特定類型的資料 (例如名稱或地址) 的位置。如果在轉換文件時選擇一起轉換 Word 表單欄位,InfoPath 表單範本便會在相對應的位置加入文字方塊、核取方塊以及下拉清單方塊控制項。此外,InfoPath 也會自動偵測 Word 文件是否有適合使用重複表格和 RTF 文字方塊的部分,然後將這些部分轉換成適當的控制項。比方說,如果費用報表文件上有一個空白並加上底線的區域,讓使用者輸入某項費用的備註,InfoPath 就會將這個區域轉換為 RTF 文字方塊。接著使用者便可以在 RTF 文字方塊中輸入多行文字,並視需要設定文字格式。

若要進一步瞭解使用 InfoPath 匯入精靈,並產生的 InfoPath 表單範本轉換的 Word 文件之間的關聯性,假設的過去數年貴組織已使用 Word 文件一部分 ExpenseReport.doc 收集員工費用報表資料。您的 IT 部門想要將文件轉換成 InfoPath 表單範本,以便將表單資料可以為可延伸標記語言 (XML) 提交帳款系統。

如果使用匯入精靈將 ExpenseReport.doc 轉換為表單範本,InfoPath 會建立名為 ExpenseReport.xsn 的表單範本。在下列範例中,Word 文件的 Expense Details 表格在產生的 InfoPath 表單範本上已轉換為重複表格。重複表格可讓使用者按一下快顯功能表上的命令,視需要插入或移除費用。

Word 表格已轉換為 InfoPath 重複表格

當 Word 文件轉換為 InfoPath 表單範本時,會保留版面配置和其他元素。根據預設,InfoPath 重複表格的空白列的數目會與 Word 表格中的空白列數目相同。不過,您可以預設只顯示一或兩列,節省表單範本的空間。

這個新表單範本包含的元素與 Word 文件的類似,例如收集費用資訊的表格。不過,根據您在匯入精靈選擇的設定,某些功能在產生的表單範本上可能會不同:

  • 如果使用匯入精靈匯入 Word 文件時只要保留版面配置    產生的表單範本會包含重複表格來輸入費用報表中的細目。不過,產生的表單範本不會保留原始文件的任何表單欄位,例如 Name 文字方塊、Department 下拉清單以及 Division 核取方塊等。

  • 如果使用匯入精靈匯入 Word 文件時,要同時保留版面配置並將 Word 表單欄位轉換為控制項 (預設)    產生的表單範本會包含重複表格來輸入費用報表中的細目。原始文件的任何表單欄位,例如 Name 文字方塊、Department 下拉清單以及 Division 核取方塊,都會轉換為相對應的 InfoPath 控制項。

  • 如果使用匯入精靈匯入 Word 文件時,要同時保留版面配置並將表單欄位轉換為控制項 (自訂)    當您匯入費用報表時,可以決定要轉換哪些欄位。例如,您可以停用將文件中空白表格儲存格轉換為產生表單範本上文字方塊的選項。

頁面頂端

轉換時未能完整支援的 Word 功能和設定

InfoPath 表單範本不支援 Word 文件中的某些設定和格式。如果轉換包含這些設定的 Word 文件,產生的表單範本就不會包含這些功能或設定。比方說,如果 Word 文件有修訂符號,產生的表單範本將會移除這些修訂符號,因為 InfoPath 不支援這項功能。

您可以在設計模式中使用 [設計檢查] 工作窗格查看轉換是否發生任何問題,然後再採取動作來解決問題。

下面列出將 Word 文件轉換為 InfoPath 表單範本時不保留的功能和設定。在某些情況下,格式會移除,但基本的文字還是會保留。比方說,如果有文件中有新聞稿樣式的欄,InfoPath 會移除這些欄,但匯入這些欄中所包含的文字。

  • 書籤

  • 動畫效果的文字

  • 佈景主題

  • 浮水印

  • 行號

  • 頁面框線

  • 註腳和章節附註

  • 新聞稿樣式欄版面配置

  • 檔案附件

  • 連結或內嵌的物件,例如 Microsoft Office Excel 工作表和 Microsoft Office Visio 繪圖

  • 繪圖物件 (包括快取圖案、曲線、直線及文字藝術師)

  • 字元間距 (包括比例、加寬或緊縮間距、上移或下移文字位置,以及字距壓縮微調)

  • ActiveX 控制項

  • 註解與追蹤修訂 (包括插入、刪除及格式變更)

  • 特定Microsoft Office Word 2007 (包括建置組塊及內容控制項) 的一些功能

  • 部分列印設定 (包括頁首與頁尾的混合字元格式設定、奇數和偶數頁首與頁尾不同、第一頁有不同的頁首與頁尾、裝訂邊設定、上下邊界使用負值、不同頁面方向以及個別區段設定)

附註: 密碼才能修改部分的 Word 文件。如果這是與您的文件的情況,您可能無法成功將 InfoPath 匯入。若要修正此問題,請嘗試從文件移除密碼保護,您匯入之前。此外,某些文件限制特定類型的編輯動作,例如表單欄位中輸入資料的使用者。如果這是與您的文件的情況,您可能無法成功將 InfoPath 匯入。若要修正此問題,請嘗試移除您的文件的編輯限制,您匯入之前。

以下清單說明將 Word 文件轉換為 InfoPath 表單範本時部分支援的功能和設定:

直書文字    如果 Word 文件的直書文字是在表格儲存格之內,InfoPath 會保留直書文字格式。但如果直書文字不在表格儲存格之內,而是在 Word 文件的另一部分,那麼轉換 Word 文件時,InfoPath 就會移除直書文字格式。

文字方塊    在 Word 文件中,文字方塊是文字的容器,可在頁面上調整位置和大小。如果 Word 文件包含文字方塊,文字方塊會轉換為產生表單範本上的表格儲存格。文字方塊中的任何文字將出現在表單範本上的表格儲存格中。

底線文字    InfoPath 表單範本支援底線。不過,如果 Word 文件中有任何裝飾性或雙底線,在產生的表單範本上會轉換為單底線。

參照不支援通訊協定的超連結    所有超連結都會轉換,不過如果超連結使用 HTTP、HTTPS、FILE、FTP 或 MAILTO 以外的通訊協定,當使用者按一下產生表單範本上的超連結時,不會有任何作用。

字元樣式與文字效果    上標、下標及刪除線格式樣式在轉換時會保留。其他格式樣式及效果,包括外框文字、隱藏文字及陰影格式,都會在轉換時移除。浮凸或雕刻文字在產生的表單範本上會轉換為灰色文字。

區段設定    在 Word 中,區段可用來改變文件在頁面上或頁面之間的版面配置。InfoPath 不支援這些類型的區段,在轉換時會移除。套用到 Word 文件第一個區段的設定會套用到產生的 InfoPath 表單範本。

頁首與頁尾格式    Word 文件的頁首和頁尾文字會轉換為產生的 InfoPath 表單範本上的頁首與頁尾文字。但部分字元格式可能會在轉換時移除。比方說,如果在 Word 文件的頁首同時使用了粗體和斜體格式,InfoPath 會在產生的表單範本上使用遇到的第一種格式樣式,並移除另一種格式。同樣地,Word 文件的第一個頁首或頁尾區段所套用的任何設定,也會套用到 InfoPath 表單範本中所產生的頁首或頁尾文字。

字型轉換    雖然 InfoPath 在建立新的表單範本時,會從 Word 文件匯入字型,但如果執行匯入的電腦上沒有文件中的字型,表單範本就會自動選擇替代的字型。

負值頁面邊界    負值上下邊界會匯入為 0。

負值邊界、邊框距離及縮排設定    負值邊界、邊框距離及縮排設定會匯入為 0。

頁面頂端

將 Word 文件轉換為 InfoPath 表單範本

  1. 如果要匯入的 Word 文件處於開啟狀態,請先將其關閉。

  2. 在設計模式中,按一下 [檔案] 功能表上的 [匯入表單]。

  3. 在匯入精靈中,按一下 [InfoPath 的 Word 文件匯入工具],然後按 [ 下一步]。

  4. 按一下 [瀏覽]。

  5. 找到並按一下要轉換的 Word 文件,然後按一下 [開啟]。

    附註: 如果匯入的 Word 文件有限制權限,您必須擁有該文件的 [完全控制] 存取權。如果只有文件的 [讀取] 或 [變更] 存取權,當您嘗試匯入時會看到錯誤訊息。

  6. 若要變更預設匯入的行為,請按一下 [選項],然後選取想要的選項。

  7. 按一下 [完成]。

頁面頂端

將版面配置表格變更為重複表格

如果 Word 文件包含表格,InfoPath 可能會在產生的表單範本上將表格轉換為表格版面配置或重複表格。選擇哪種類型的表格,會根據您在 Word 文件中所做的設計決定。您可以使用下列程序,快速將轉換的版面配置表格變更為重複表格。

若要提供使用者額外的大的彈性,填寫表單時,您可以使用重複表格。當您使用的重複表格時,您的表單範本沒有使用者第一次開啟時,顯示大量的空白列。不過,使用者通常會看到只有一個資料列,然後只,可視需要新增更多。這會儲存在表單中的空間,並提供使用者額外的程度的個人化。

  1. 在表單範本中,您想要轉換的版面配置表格內的任何位置按一下滑鼠右鍵。

  2. 在快顯功能表中,指向 [變更為,然後按一下 [重複表格

  3. 在 [變更重複表格大小] 對話方塊中,執行下列一或多項動作 ︰

    • 若要指定重複表格的標題列,請保留為表格標題的列數] 方塊中輸入值。通常,您會使用標題列的欄標題。

    • 若要指定重複表格的頁尾列,請為表格頁尾保留的列數] 方塊中輸入值。多個資料表不包含頁尾列。

    • 若要指定要使用的資料列數目,值方塊中輸入包含時填寫表單的資料列數目重複。資料列是可以 「 重複 」 需要的表單中的一列

  4. [插入] 功能表上,按一下 [其他控制項],或按 ALT+I、C。

  5. 插入您要在表格儲存格的控制項。

頁面頂端

將核取方塊變更為一組選項按鈕

如果您在 Word 文件中使用了多個核取方塊,InfoPath 會將這些核取方塊匯入成為產生 InfoPath 表單範本上的核取方塊。如果想改用一組選項按鈕,請執行下列步驟,將表單範本上的核取方塊轉換為選項按鈕。

當您想要使用者可以從有限的選項的只要選取項目,您可以使用 Microsoft Office InfoPath 表單範本上的選項按鈕群組。

  1. 在表單範本中,按一下您想要轉換,然後按住 CTRL 並按一下每個您想要轉換的其他核取方塊的核取方塊。

  2. 在 [編輯] 功能表中,按一下 [變更為,然後按一下 [選項] 按鈕

    選項按鈕群組現在會出現取代表單範本中的核取方塊。每個選項按鈕繫結到資料來源中的相同欄位。當使用者按下的選項按鈕時,與該選項按鈕相關聯的值會儲存在欄位中。

頁面頂端

在設計檢查工作窗格中查看轉換問題

有時候,原始 Word 文件的元素並未如預期般地出現在產生的 InfoPath 表單範本上,或在轉換過程中移除。例如,InfoPath 不支援 Word 的文字藝術師功能,在產生的表單範本上會以預留位置圖像取代文字藝術師物件。

如果 InfoPath 在轉換時偵測到問題,在您關閉匯入精靈之後,會自動開啟 [設計檢查] 工作窗格。您可以從工作窗格查看問題清單,並採取必要的步驟來更正問題。

  1. 如果看不到 [設計檢查] 工作窗格,請按一下 [工具] 功能表上的 [設計檢查]。

    如果表單範本有任何問題,您會在工作窗格中看到訊息。

  2. 在 [設計檢查] 工作窗格中,按一下要查看的訊息文字。

    這時會出現對話方塊,顯示關於問題的更多資訊。

    附註: 如果 Word 文件包含 InfoPath 不支援的物件,例如 Word 繪圖物件,InfoPath 會在產生的表單範本上加入預留位置圖像,表示物件在 Word 文件上的原始位置。若要進一步了解物件,請以滑鼠右鍵按一下表單範本上的預留位置圖像,然後按一下快顯功能表上的 [其他詳細資料]。

  3. 視需要更正表單範本的問題。例如,您可以刪除任何預留位置圖像,因為完成的表單範本並不會使用這些圖像。

附註: 您可能會發現 [設計檢查] 工作窗格,包含重新整理] 按鈕。按一下 [重新整理] 按鈕,就不會更新當做 Word 文件匯入 InfoPath 出現的訊息。如果您想要從 [設計檢查] 工作窗格中移除匯入郵件,您必須開啟 [資源檔案] 對話方塊 ([工具] 功能表),並移除名為 ImportErrors.xml 的檔案。您匯入 InfoPath 的 Word 文件時,會自動建立此檔案。移除 ImportErrors.xml 檔案之後,請按一下 [若要永久刪除 [匯入郵件的 [設計檢查] 工作窗格中的 [重新整理]。ImportErrors.xml 檔案不必要的表單範本,正常運作。事實上,基於安全性理由,最好先發佈表單範本中移除這個檔案。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×