將資料連線新增至 SharePoint 文件庫或清單

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以新增一或多個次要資料連線到您可以從文件庫或清單中,[查詢資料的表單範本,或執行 Microsoft Windows SharePoint Services 的伺服器上的文件庫的資料送出。

本文內容

概觀

在您開始之前

新增查詢資料連線

新增送出資料連線

概觀

次要資料連線是任何資料連線到您新增至表單範本的外部資料來源。不同的主資料連線時您設計表單範本,根據資料庫、 Web 服務或設定連線的文件庫中建立此資料連線。您無法查詢,或傳送的主資料連線到資料時,才可以新增次要資料連線。

當您新增的次要資料連線到表單範本的查詢資料,Microsoft Office InfoPath 建立資料來源次要資料欄位和群組的對應,資料會儲存在文件庫或清單的方法。 外部資料來源與表單範本中的資料來源之間的關聯。

因為次要資料來源中的資料結構必須符合,資料會儲存在文件庫或清單的方式,您無法修改現有的欄位] 或 [次要資料來源中的群組。

A data connection that queries data from a SharePoint document library or list automatically returns all of the items in that document library or list. If you are using a query data connection to populate a list box, drop-down list box, or combo box control, and the control contains too many items or you want to display only items that meet a specified criteria, you can use a filter in the control to limit the number of items. Find links to more information about filtering the data displayed in a control in the See Also section.

您也可以將每個查詢資料連線設定為儲存它的結果,如此使用者就可以在他們的表單未連線至網路時存取資料。而視資料本質的不同,您可能會只想要在使用者已連線至網路時才顯示查詢結果。

安全性附註 : 如果您使用次要資料連線到外部資料來源擷取機密資料,您可能會想要停用此功能,以協助防止未經授權使用保護資料,以防遺失或竊取電腦。如果您停用此功能,資料會只適用於使用者連線至網路。

當您新增表單範本的查詢資料連線時,根據預設,以這個表單範本為基礎的表單會在使用者開啟時使用資料連線。您也可以利用下列其中一種方法,來設定表單範本以使用查詢資料連線:

  • 新增規則   您可以設定規則的條件規則中發生時,使用查詢資料連線。

  • 新增] 按鈕   您可以新增按鈕至表單範本使用者可以按一下以取得使用查詢資料連線的資料。

  • 使用自訂程式碼   如果您無法新增規則] 或 [] 按鈕,您可以使用自訂程式碼,以取得使用查詢資料連線的資料。使用自訂程式碼需要開發人員若要建立自訂的程式碼。

新增表單範本的送出資料連線時,您可以將表單範本設定為允許使用者送出他們的表單資料,而且可以設定以您的表單範本為基礎之表單的送出選項。

頁面頂端

在您開始之前

新增表單範本的次要資料連線之前,需要下列來自網站管理員的資訊:

  • SharePoint 網站的位置以及存取它的必要權限

  • 確認已設定網站,讓使用者可以取得來自文件庫或清單的資料

  • 確認可以將文件庫或清單的資料儲存在使用者電腦上,供離線使用

頁面頂端

新增查詢資料連線

若要允許使用者查詢網站之文件庫或清單中的資料,而該網站位在執行 Microsoft Windows SharePoint Services 的伺服器,您必須在表單範本中進行下列動作:

  1. 新增次要資料連線。

  2. 設定要使用次要資料連線的表單範本。

步驟 1:新增次要資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 按一下 [資料連線精靈] 」中的 [建立新連線至],然後按一下 [接收資料],再按一下 [下一步]

  4. 在精靈的下一頁,按一下 [SharePoint 文件庫或清單],然後按 [下一步]

    在 [資料連線精靈] 中的頁面,用來指定做為資料來源的 SharePoint 網站。

  5. 在精靈的下一個頁面上,輸入文件庫或清單中的 SharePoint 網站的 URL,然後再按 [下一步。例如,若要使用的 URL http://www.adventureworks.com/EmployeeListSharePoint 網站上的文件清單,您輸入http://www.adventureworks.com/EmployeeList

  6. 在精靈下一頁的 [選取清單或程式庫] 清單中,按一下想要使用的清單或程式庫,然後按一下 [下一步]

  7. 在精靈的下一頁上,選取想要接收之值旁邊的核取方塊。如果要將表單範本發佈至文件庫,而且想要以這個表單範本為基礎的表單取得表單的中繼資料,請選取 [僅包含使用中表單的資料] 核取方塊。

  8. 按一下 [下一步]

  9. 如果想要使用表單範本儲存查詢結果,請選取 [在表單範本中儲存資料複本] 核取方塊。選取這個核取方塊會將查詢結果儲存在表單範本中。由於資料是儲存在表單範本中,因此即使使用者的電腦並未連線到網路,仍然可以存取使用者所填寫之表單中的資料。

    安全性附註 : 選取此核取方塊時,會將查詢結果儲存在表單範本。因為資料儲存在表單範本,並使用表單中的使用者填寫時,即使他們的電腦未連線至網路。如果您的機密資料從取得此資料連線,您可能會想要停用此功能,以協助保護資料,以防遺失或竊取電腦。

  10. [下一步]

  11. 在下一頁的精靈] 中輸入此資料連線名稱] 方塊中,輸入此次要資料連線的描述性名稱。這是出現在 [資料來源] 工作窗格中的 [資料來源] 清單中的名稱。若要由使用者開啟表單時自動執行這個查詢,請選取 [自動擷取資料表單開啟時,核取方塊。

步驟 2:設定要使用次要資料連線的表單範本

如果您希望您的使用者開啟表單後,請使用此資料連線的表單範本為基礎的表單,您可以加入使用特定條件下的此資料連線的表單範本中的規則,或您可以新增按鈕至表單範本的使用者可以按一下 [使用此資料連線。

新增規則

您可以將一項規則加入至表單範本,以便在每次符合此規則的條件時,從查詢資料連線取得資料。下列程序會假設您已為表單範本建立查詢資料連線,而且假設您已在表單範本上設定顯示該資料連線之資料的控制項。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 按兩下想要顯示查詢結果的控制項。

  3. 按一下 [資料] 索引標籤。

  4. 按一下 [驗證及規則] 底下的 [規則]

  5. 按一下 [規則] 對話方塊中的 [新增]。

  6. [名稱] 方塊中輸入規則的名稱。

  7. 若要執行規則時,請指定條件,按一下設定條件],然後輸入條件。條件發生時,會執行規則。如果您沒有設定條件,當使用者變更的控制項中,值,然後移離該控制項的他或她游標執行規則。

  8. 按一下 [新增動作]

  9. [動作] 清單中,按一下 [使用資料連線查詢]

  10. [資料連線] 清單中,按一下想要使用的查詢資料連線,然後按一下 [確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

新增按鈕

您可以將按鈕控制項新增至表單範本,如此使用者只要按一下該按鈕,就可以使用這個查詢資料連線。下列程序假設您已經建立表單範本的查詢資料連線。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  3. 拖曳按鈕控制項至表單範本。

  4. 按兩下您剛才新增至表單範本的按鈕控制項。

  5. 按一下 [一般] 索引標籤。

  6. [動作] 清單中,按一下 [重新整理]

  7. [標籤] 方塊中,輸入要在表單範本上顯示的按鈕名稱。

  8. 按一下 [設定]

  9. 按一下 [重新整理] 對話方塊中的 [一個次要資料來源]

  10. [選擇次要資料來源] 清單中,按一下與查詢資料連線關聯的次要資料來源,然後按一下 [確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

新增送出資料連線

若要允許使用者將以您的表單範本為基礎的表單送出給文件庫,您必須進行下列動作:

  1. 新增將資料送出給您的表單範本的次要資料連線。

  2. 將表單範本設定為允許使用者將他們的表單資料送出給文件庫。

步驟 1:新增次要資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 按一下「資料連線精靈」中的 [建立新連線至],然後按一下 [送出資料],再按一下 [下一步]

  4. [您要如何送出資料] 下按一下 [到 SharePoint 網站上的文件庫],然後按一下 [下一步]

  5. 在「資料連線精靈」的 [文件庫] 方塊中,輸入 SharePoint 文件庫的 URL。

  6. [檔案名稱] 方塊中,輸入要用來識別文件庫中之表單的名稱。

    提示: 您也可以使用公式,確保每個表單名稱都是唯一的。

    作法

    1. 按一下 [插入公式] 按鈕圖像

    2. 在 [插入公式] 對話方塊中,執行下列其中一個動作:

      • 若要在公式中使用欄位,請按一下 [插入欄位或群組],然後在 [選取欄位或群組] 對話方塊中按一下要使用的欄位,再按一下 [確定]。

      • 若要在公式中使用函數,請按一下 [插入函數],然後在 [插入函數] 對話方塊中選取要使用的函數,再按一下 [確定]。

        提示: 如果函數需要的參數,選取 [插入函數] 對話方塊中的函數按一下[確定] ,然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下您新增的函數,按一下欄位或群組。請參閱 >一節中找到有關函數的詳細資訊的連結。

      • 若要將值或數學運算子插入公式,請將值或數學運算符號輸入 [公式] 方塊中。

    運算

    符號

    +

    -

    *

    /

    • 附註: 如果公式使用除法 (/) 運算子,請確定有空間之前和之後的除法運算子。如果除法運算子沒有之前的空格,而且之後,可能會解讀 InfoPath 「 / 」 作為分隔符號的 XPath 位置步驟而非除法運算子。

    • 若要檢查公式的語法是否正確,請按一下 [插入公式] 對話方塊中的 [檢查公式]。

      如需公式的詳細資訊連結,請瀏覽「請參閱」一節的連結。

  7. 若要使用相同的名稱覆寫文件庫中任何現有的表單,請選取 [允許覆寫現有的檔案] 核取方塊。

  8. 按一下 [下一步]。

  9. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

在您加入次要送出資料連線之後,就必須將表單範本設定為允許使用者使用此送出資料連線來送出表單資料。

步驟 2:啟用表單範本上的送出

將表單範本設定為允許使用者送出他們的表單資料時,InfoPath 會在 [標準] 工具列上新增 [送出] 按鈕,而且會在表單的 [檔案] 功能表上新增 [送出] 命令。您也可以用下列方式自訂表單範本的送出選項:

  • 變更出現在 [送出] 按鈕上的文字。

  • 變更此 [送出] 按鈕的快速鍵。

  • 建立自訂訊息,在使用者送出表單時為他們顯示該訊息。

  • 指定表單要在送出後保持開啟、關閉或開啟另一個空白表單。

  • 在 [工具] 功能表上按一下 [送出選項]。

  • 在 [送出選項] 對話方塊中,選取 [允許使用者傳送此表單核取方塊傳送表單資料至單一目的地,然後按一下然後,在清單中,按一下 [ SharePoint 文件庫

  • [選擇送出的資料連線] 清單中,按一下 SharePoint 程式庫之送出資料連線的名稱。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請在 [送出選項] 對話方塊中的 [標題] 方塊中輸入新名稱。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  • 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項 ︰

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×