將表單資料送出到數個位置

附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

您可以設計表單範本,讓使用者可以其表單資料送出到數個位置時,按一下 [送出] 按鈕。

本文內容

概觀

步驟 1: 新增送出資料連線

步驟 2: 設定為允許送出表單範本

概觀

若要允許使用者將表單送出到數個位置,您必須新增次要資料連線到您要讓使用者將表單送出的位置的每個送出資料的表單範本。您新增的所有送出資料的連線之後,您就會設定為允許使用者在他們表單資料送出到多個位置使用規則的表單範本。如此一來,Microsoft Office InfoPath 新增送出] 按鈕至 [標準] 工具列及送出] 命令,[檔案] 功能表,當使用者填寫表單。InfoPath 送出表單資料,以在規則中列出的順序中的次要資料連線。您無法設定規則,同時使用的所有送出資料連線。

當您設定為允許使用者在他們表單資料送出表單範本時,您也可以透過下列方式自訂送出選項:

  • 變更顯示在 [標準] 工具列上的 [送出] 按鈕和 [送出] 命令,在 [檔案] 功能表上的文字。

  • 變更在 [標準] 工具列上的 [送出] 按鈕,然後在 [檔案] 功能表上的 [送出] 命令的鍵盤快速鍵。

  • 建立自訂送出表單時,顯示給使用者的郵件。

  • 指定是否要保持表單開啟、 關閉表單,或在送出表單後,開啟另一個空白的表單。

頁面頂端

步驟 1: 新增送出資料連線

若要設定為允許使用者送出到多個位置的完成的表單的表單範本,您可以新增必要的送出表單範本的資料連線。您可以新增資料連線到下列位置:

  • Web 服務

  • 在執行 Microsoft Windows SharePoint Services 的伺服器上的文件庫

  • 以電子郵件訊息

    附註: 使用者需要安裝在自己的電腦,才能在電子郵件表單資料送出的 Microsoft Office Outlook。

下列程序說明如何新增送出到下列位置的資料連線。

加入送出到 Web 服務資料的資料連線

  1. 在 [工具] 功能表上按一下 [資料連線]。

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 在 [資料連線精靈中,按一下 [建立新的連線,資料送出],然後按一下然後按 [下一步

  4. 在精靈的下一個頁面上,按一下至 Web 服務],然後按 [下一步

  5. 在精靈的下一個頁面上,輸入您的使用者會在位置送出表單,,然後按一下 [下一步的 Web 服務的位置。

    如果您想要搜尋 Web 服務的通用描述、 探索與整合 (UDDI) 伺服器,按一下 [搜尋 UDDI,輸入您要搜尋的 UDDI 伺服器,指定您是否要搜尋提供者或所提供的服務輸入搜尋關鍵字,然後再按一下 [搜尋]。符合搜尋關鍵字的 web 服務會出現在 [搜尋結果] 清單中。

  6. 按一下 [精靈] 中選取 [作業] 清單中的下一個頁面的 [Web 服務作業會收到表單資料,然後按 [下一步]。

  7. 在精靈的下一個頁面上,請執行下列其中一項:

    送出欄位或群組中的資料

    1. 在 [參數] 清單中,按一下 [Web 服務參數會接收資料表單]。

    2. 參數選項中,按一下 [欄位或群組]。

    3. 按一下 [修改 按鈕圖像 ]。

    4. 在 [選取欄位或群組] 對話方塊中,按一下欄位或群組中您想要送出,其資料,然後按一下[確定]

    5. 在 [包含] 方塊中,按一下 [文字和子元素提交內容和任何子項目欄位或群組,或按一下 [送出同時內容與選取的群組或欄位的XML 子目錄,包含選取的項目

    送出所有的表單中的資料

    1. 按一下 [整個表單 (XML 文件,包括處理指示)

    將資料送出成字串

    1. 選取 [送出資料為字串] 核取方塊。

      一般而言,您可以選取此核取方塊,以數位簽章的資料送出。在大多數情況下,清除此核取方塊。

  8. 按一下 [下一步]。

  9. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

  10. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

新增至文件庫的資料送出的資料連線

  1. 在 [工具] 功能表上按一下 [資料連線]。

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 在 [資料連線精靈中,按一下 [建立新的連線,資料送出],然後按一下然後按 [下一步

  4. 在精靈的下一個頁面上,按一下 [ SharePoint 網站上的文件庫],然後再按 [下一步

  5. 文件庫中,在精靈的下一個頁面上輸入 SharePoint 文件庫的位置。

  6. 在 [檔案名稱] 方塊中輸入的名稱會用來識別文件庫中的表單。您也可以使用公式,以確保每個表單名稱是唯一的。

    如何進行?

    1. 按一下 [插入公式 按鈕圖像 ]。

    2. 在 [插入公式] 對話方塊中,執行下列其中一項:

      • 若要使用公式中的欄位,按一下插入的欄位或群組,按一下您想要使用 [選取欄位或群組] 對話方塊中的欄位,然後按一下[確定]

      • 若要在公式中使用函數,按一下 [插入函數、 選取您想要使用 [插入函數] 對話方塊中的函數,然後按一下[確定]

        如果函數需要的參數,選取 [插入函數] 對話方塊中的函數,按一下[確定],然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下您新增的函數並按一下欄位或群組。請參閱 一節中找到有關函數的詳細資訊的連結。

      • 若要插入公式或數學運算子,請輸入的值,或是進行數學運算符號在 [公式] 方塊中。

    運算

    符號

    新增

    +

    相減

    -

    將相乘

    *

    除數

    /

    • 附註: 如果公式使用除法 (/) 運算子,請確定有空間之前和之後的除法運算子。如果除法運算子沒有之前的空格,而且之後,可能會解讀 InfoPath 「 / 」 作為分隔符號的 XPath 位置步驟而非除法運算子。

    • 若要檢查的公式為正確的語法,在 [插入公式] 對話方塊中,按一下確認公式

      請參閱 一節中找到關於公式的詳細資訊的連結。

  7. 若要同名的文件庫中,覆寫任何現有的表單,請選取 [允許覆寫現有檔案] 核取方塊。

  8. 按一下 [下一步]。

  9. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

  10. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

新增電子郵件訊息中的資料送出的資料連線

  1. 在 [工具] 功能表上按一下 [資料連線]。

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 在 [資料連線精靈中,按一下 [建立新的連線,資料送出],然後按一下然後按 [下一步

  4. 在精靈的下一個頁面上,按一下 [以電子郵件],然後再按 [下一步

  5. 在精靈的 [下一步] 頁面中,輸入收件者的郵件、 主旨您想要顯示在郵件中,並在適當的方塊中,您想要的任何簡介文字的電子郵件地址,然後按 [下一步。您也可以使用公式,除了簡介] 方塊中的每個方塊中。

    如何進行?

    1. 按一下 [插入公式 按鈕圖像 ]。

    2. 在 [插入公式] 對話方塊中,執行下列其中一項:

      • 若要使用公式中的欄位,按一下插入的欄位或群組,按一下您想要使用 [選取欄位或群組] 對話方塊中的欄位,然後按一下[確定]

      • 若要在公式中使用函數,按一下 [插入函數、 選取您想要使用 [插入函數] 對話方塊中的函數,然後按一下[確定]

        如果函數需要的參數,選取 [插入函數] 對話方塊中的函數,按一下[確定],然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下您新增的函數並按一下欄位或群組。請參閱 一節中找到有關函數的詳細資訊的連結。

      • 若要插入公式或數學運算子,請輸入的值,或是進行數學運算符號在 [公式] 方塊中。

    運算

    符號

    新增

    +

    相減

    -

    將相乘

    *

    除數

    /

    • 附註: 如果公式使用除法 (/) 運算子,請確定有空間之前和之後的除法運算子。如果除法運算子沒有之前的空格,而且之後,可能會解讀 InfoPath 「 / 」 作為分隔符號的 XPath 位置步驟而非除法運算子。

    • 若要檢查的公式為正確的語法,在 [插入公式] 對話方塊中,按一下確認公式

      請參閱 一節中找到關於公式的詳細資訊的連結。

  6. 在精靈的下一個頁面上,請執行下列其中一項:

    1. 若要顯示的電子郵件訊息本文中的表單,按一下 [傳送使用中檢視的表單,並且不附件]。

    2. 若要傳送電子郵件附件的表單資料,請按一下 [傳送附件的形式將表單資料附加以確保使用者可以開啟表單的表單範本] 核取方塊,,然後選取然後輸入附件名稱中的 [表單名稱] 方塊。您也可以指定一個欄位,或使用公式以確保每個表單名稱是唯一的。如果表單範本設定為自動判斷安全性層級,或設定為受限制或完全信任安全性層級,,只有 [可用這個選項。

      如何進行?

      1. 按一下 [插入公式 按鈕圖像 ]。

      2. 在 [插入公式] 對話方塊中,執行下列其中一項:

        • 若要使用公式中的欄位,按一下插入的欄位或群組,按一下您想要使用 [選取欄位或群組] 對話方塊中的欄位,然後按一下[確定]

        • 若要在公式中使用函數,按一下 [插入函數、 選取您想要使用 [插入函數] 對話方塊中的函數,然後按一下[確定]

          如果函數需要的參數,選取 [插入函數] 對話方塊中的函數,按一下[確定],然後在 [插入公式] 對話方塊中的 [公式] 方塊中,按兩下您新增的函數並按一下欄位或群組。請參閱 一節中找到有關函數的詳細資訊的連結。

        • 若要插入公式或數學運算子,請輸入的值,或是進行數學運算符號在 [公式] 方塊中。

      運算

      符號

      新增

      +

      相減

      -

      將相乘

      *

      除數

      /

      • 附註: 如果公式使用除法 (/) 運算子,請確定有空間之前和之後的除法運算子。如果除法運算子沒有之前的空格,而且之後,可能會解讀 InfoPath 「 / 」 作為分隔符號的 XPath 位置步驟而非除法運算子。

      • 若要檢查的公式為正確的語法,在 [插入公式] 對話方塊中,按一下確認公式

        請參閱 一節中找到關於公式的詳細資訊的連結。

      表單資料以附件方式傳送的電子郵件收件者將需要 InfoPath 安裝在電腦上開啟附件。

  7. 按一下 [下一步]。

  8. 輸入此資料連線名稱] 方塊中,在精靈的下一個頁面上輸入這個的描述性名稱送出資料連線。

  9. 確認 [摘要] 區段中的資訊正確,然後按一下 [完成]

頁面頂端

步驟 2: 設定為允許送出表單範本

您新增至表單範本的必要的次要資料連線之後,您就會設定為允許使用者在他們表單資料送出表單範本。當您執行此動作時,InfoPath 新增送出] 命令至 [檔案] 功能表和 [標準] 工具列送出] 按鈕當使用者填寫表單。然後,您可以設定發生於使用者按一下 [送出] 按鈕的動作。在此情況下,您將加入的規則,提交每個表單資料送出資料連線,當使用者按一下 [檔案] 功能表中的 [送出] 指令或在 [標準] 工具列上的 [送出] 按鈕。

在相同的對話方塊中,您可以設定 [送出] 選項。

  1. 在 [工具] 功能表上按一下 [送出選項]。

  2. 在 [送出選項] 對話方塊中,選取 [允許使用者傳送此表單核取方塊。

    當您選取此核取方塊時,InfoPath 新增送出] 按鈕至 [標準] 工具列及送出] 命令,[檔案] 功能表,當使用者填寫表單。

  3. 按一下 [執行自訂動作規則,,然後按一下 [規則]。

  4. 在 [送出表單的規則] 對話方塊中,按一下 [新增]。

  5. 按一下 [新增動作]。

  6. 在 [動作] 方塊中,按一下 [送出使用資料連線,請按一下您想要使用的資料連線送出 [資料連線] 清單中的動作,然後按一下[確定]

  7. 重複步驟 5 和 6,每個提交您已新增至表單範本的資料連線。

  8. 在表單範本中新增條件,針對您所有的送出資料連線之後,按兩次[確定]

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請送出中的 [標題] 方塊中輸入新名稱選項] 對話方塊。

      如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  9. 若要防止使用者送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項:

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

增進您的 Office 技巧
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×