在 Publisher 中建立合併列印或電子郵件合併

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

當您想要建立幾乎相同但包含一些唯一資訊的大量文件時,可以使用合併列印或電子郵件合併功能。 例如,您可以使用合併列印來建立個別的自訂出版物,其中包含個人化的附註或唯一的地址和問候語。 您也可以先使用合併列印來建立要自訂的產品發表通知,再傳送給特定人員。 出版物中的文字總是相同,但每個收件者的名稱和地址不同。

本文內容

選擇 [合併列印] 或 [電子郵件合併]

建立或連線至收件者清單

準備出版物

建立合併的出版物

取消合併

選擇 [合併列印] 或 [電子郵件合併]

首先請選擇您要為列印作業建立合併列印,或為線上發佈建立電子郵件合併。

  • 按一下 [郵件] 索引標籤,並選擇 [合併列印] 或 [電子郵件合併]。

建立或連線至收件者清單

若要執行合併列印,您必須開啟新的或現有的出版物,然後連線到資料來源 (含有您想要包含之唯一資訊的檔案)。 資料檔案可能包含名稱和地址、產品資料或圖片的清單。 資料檔案可能有各種格式,包括:

  • Outlook 連絡人清單

  • Excel 工作表

  • Word 表格

  • Access 資料庫資料表

  • 以定位點或逗號分隔欄,以及用段落歸位字元分隔列的文字檔案

您可以連線至現有的清單或資料來源,也可以建立新的收件者清單。 如果只想使用清單中的某些項目,您可以依特定準則篩選清單。 您也可以按字母順序排序項目。

附註: 如果您想要將圖片合併到出版物頁面中,您的資料來源必須包含想要合併之圖片檔案的檔案名稱或路徑。 請勿在資料來源中包含實際的圖片或圖像。

從功能區選取收件者

使用現有清單

  1. 按一下 [郵件] > [選取收件者] > [使用現有清單]。

    根據預設,Publisher 會在 [我的資料來源] 資料夾中儲存資料來源。 您可能需要瀏覽以尋找資料來源。

  2. 在 [選取資料來源] 對話方塊中,按一下所要的資料來源,然後按一下 [開啟]。

    視所選的資料來源類型而定,可能會出現要求特定資訊的其他對話方塊。 例如,如果您的資料來源是包含多個工作表資訊的 Excel 活頁簿,您必須選取包含所要資訊的工作表。

從 Outlook 連絡人選取

  1. 按一下 [郵件] > [選取收件者] > [從 Outlook 連絡人選取]。

    如果您收到選擇郵件設定檔的提示,請按一下所要的設定檔,然後按一下 [確定]。

  2. 在 [選取連絡人] 對話方塊中,按一下您要的連絡人清單,然後按一下 [確定]。

    資料夾中的所有連絡人都會出現在 [合併列印收件者] 對話方塊中,您可在其中篩選及排序要包含在合併中的收件者清單。

鍵入新清單

如果您沒有現有清單可連線,可以建立一個新清單。

  1. 按一下 [郵件] > [選取收件者] > [鍵入新清單]。

  2. 在 [新增通訊清單] 對話方塊中,為欄位中的第一個項目輸入郵件的相關資訊。

    附註:  若要變更預設欄位,請按一下 [自訂欄位],然後新增、刪除、重新命名及重新排序清單中的欄位。

  3. 完成第一個項目的資訊輸入後,按一下 [新增項目]。

  4. 重複步驟 2 和步驟 3,直到您完成新增項目,再按一下 [確定]。

  5. 在 [儲存通訊清單] 對話方塊中,於 [檔案名稱] 方塊內輸入通訊清單的名稱並儲存。

    附註: 根據預設,Publisher 會在 [我的資料來源] 資料夾中儲存通訊清單。 最好的方法是將通訊清單保留在這裡,因為此資料夾也是 Publisher 尋找資料來源的預設資料夾。

    新清單中的所有連絡人都會出現在 [合併列印收件者] 對話方塊中,您可在其中篩選及排序要包含在合併中的收件者清單。

選取收件者

在 [合併列印收件者] 對話方塊中,您可以選取要包含在合併中的收件者。 請選取要包含之收件者旁邊的核取方塊,並清除不想包含之收件者旁邊的核取方塊。

如果只想使用清單中的某些項目,您可以依特定欄位或準則篩選清單。 在篩選清單後,您可以使用核取方塊來包含和排除記錄。

篩選清單中的項目:

  1. 在您要篩選之項目的欄位標題旁邊按一下箭號。

  2. 執行下列任何一項操作:

    • [(空白)] 會顯示其中對應欄位為空白的所有記錄。

    • [(非空白)] 會顯示其中對應欄位包含資訊的所有記錄。

    • [(進階)] 會開啟 [篩選與排序] 對話方塊,您可以用來篩選多個準則。 您也可以在 [合併列印收件者] 對話方塊的 [調整收件者清單] 底下,按一下 [篩選] 以開啟 [篩選與排序] 對話方塊。

    • 若要快速選取或清除所有項目,請選取或清除核取方塊欄位標題。

      提示: 如果您的資料來源包含共用相同資訊的記錄,且欄位中有十個或更少的唯一值時,您可以依據特定資訊進行篩選。 例如,如果有多個地址將澳大利亞列為國家/地區,您可以篩選 [澳大利亞]。

      [合併列印收件者] 對話方塊只會顯示指定的記錄。 若要再次顯示所有記錄,請按一下 [(全部)]。

如果您想要依字母順序查看項目,可以排序清單中的項目。

排序清單中的項目:

  • 在 [合併列印收件者] 對話方塊中,按一下您想要排序之項目的欄位標題。 例如,如果您想要依姓氏的字母順序來顯示清單,請按一下 [姓氏] 欄位標題。

  • 若要使用多個準則進行排序,請在 [合併列印收件者] 對話方塊中按一下 [排序]。 在出現的 [篩選與排序] 對話方塊中,選取要做為排序依據的準則。

頁面頂端

準備出版物

一個合併列印程序可使用預留位置資訊以及新增至每一份文件上預留位置資訊的唯一資訊,從單一範本中建立許多文件。 一起取得收件者清單後,即可為主範本做好準備。

插入文字方塊

  1. 按一下 [插入] > [繪製文字方塊] 按鈕影像

  2. 在出版物中,指向您想要文字方塊的某個角落出現的位置,然後拖曳對角線直到出現所需的文字方塊大小。

新增您想在每個版本中顯示的文字

  • 在文字方塊內按一下,然後輸入您要在每個版本的合併列印出版物中顯示的文字。

將資料欄位新增至出版物

插入合併列印功能變數

  1. 在合併列印出版物中,按一下要插入資料欄位的文字方塊內部。

  2. 插入下列任一項:

    • 含有名稱、地址與其他資訊的地址區塊:

      1. 在 [書寫與插入功能變數] 群組中,按一下 [地址區塊]。

      2. 在 [插入地址區塊] 對話方塊中,按一下您要包含的地址元素,然後按一下 [確定]。

        附註: 如果資料來源中的資料欄位名稱不符合 Publisher 使用於地址區塊的欄位名稱,您可能需要在 [插入地址區塊] 對話方塊中按一下 [符合欄位]。 在 [符合欄位] 對話方塊中使用下拉式清單,從對應至 Publisher 欄位的資料來源中選取欄位。

    • 問候行

      1. 在 [書寫與插入功能變數] 群組中,按一下 [問候行]。

      2. 在 [問候行] 對話方塊中,選取問候行格式,其中包括問候語、名稱格式及其後的標點符號。

      3. 選取 Publisher 無法解譯收件者的姓名時 (例如,當資料來源沒有包含收件者的姓氏或名字,而只有包含公司名稱時) 要顯示的文字,再按一下 [確定]。

        附註:  如果資料來源中的資料欄位名稱不符合 Publisher 使用於問候行的欄位名稱,您可能需要在 [問候行] 對話方塊中按一下 [符合欄位]。 在 [符合欄位] 對話方塊中使用下拉式清單,從對應至 Publisher 欄位的資料來源中選取欄位。

    • 圖片

      1. 在 [書寫與插入功能變數] 群組中,按一下 [圖片],然後按一下 [插入圖片欄位]

      2. 在 [插入圖片欄位] 對話方塊中,選取要插入的圖片欄位。

      3. 附註: 如果您想要將圖片合併到出版物頁面中,您的資料來源必須包含想要合併之圖片檔案的檔案名稱或路徑。 請勿在資料來源中包含實際的圖片或圖像。

    • 個別資訊欄位

      • 在 [書寫與插入功能變數] 群組中,選取 [插入合併功能變數],然後按一下想要包含在文字方塊中的欄位。

設定資料欄位的格式

您可以將格式套用至資料欄位及您已新增的任何其他文字 (像是「您好」問候語或類似「親愛的...」這類問候語),以變更合併資料的外觀。 若要設定合併資料的格式,您需要設定合併列印出版物中的資料欄位格式。

在合併列印出版物中,選取您想要為其設定格式之資訊所在的欄位。

  • 如果欄位是 [地址區塊] 或 [問候行],請在 [書寫與插入功能變數] 群組中選取 [格式]。

  • 如果欄位是個別的資料欄位,請在 [文字方塊工具格式] 功能表上按一下 [字型],然後選取所要的選項。

  • 如果 Publisher 將選取的欄位識別為數字、貨幣、日期或時間,請按一下 [格式],並變更這些欄位類型的顯示格式。

預覽出版物資料欄位中的收件者資料

您可以檢閱出版物顯示合併欄位中實際資料的方式。

若要預覽出版物,請按一下 [預覽結果],然後執行下列任何一項操作:

  • 若要依序預覽項目,請按一下導覽按鈕 [下一頁] 按鈕 [返回] 按鈕 來查看合併的出版物中每個項目的外觀。

    資料來源第一筆記錄中的資訊會填入合併欄位。 您無法在出版物頁面上編輯資料來源項目,但可以在那裡格式化、移動或刪除資料欄位。

  • 若要尋找並預覽資料來源中的特定項目,請按一下 [尋找收件者],然後在 [尋找項目] 對話方塊中輸入搜尋準則。

如有需要,您可以變更收件者清單。 執行下列任何一項操作:

  • 若要從合併中排除特定的收件者,請按一下 [排除收件者]。

  • 若要變更收件者清單,請按一下 [編輯收件者清單],然後在 [合併列印收件者] 對話方塊中進行變更。

完成合併列印出版物並插入所有合併欄位後,前往 [檔案] > 按一下 [另存新檔],為出版物命名,最後按一下 [儲存]。

頁面頂端

建立合併的出版物

若要建立合併的出版物,請按一下 [完成與合併] 按鈕,然後依照下列指示來列印、預覽、儲存,將合併頁面新增至另一個出版物,或以電子郵件傳送它。

完成合併列印

列印合併的出版物

  1. 按一下 [合併至印表機]。

  2. 在 [列印] 空間中,選取您想要的選項,然後按一下 [確定]。

    重要: 若要在每紙張上列印不同的合併資料集 (例如,不同的名稱和地址),請在 [列印選項] 區段中按一下 [每張多頁]。 如果您選擇 [每張多份],每張紙會包含相同資料的多個複本。

    每張列印多頁

儲存合併的出版物供稍後使用

如果您想要編輯合併的頁面、儲存它們供以後使用,或稍後列印這些頁面,您可以收集所有合併的頁面,並將它們儲存為單一的全新合併出版物,其中包含實際的資料而非合併欄位。

  1. 按一下 [合併到新的出版物]。

  2. 在新的出版物中,按一下 [合併列印] 工作窗格中的 [儲存此出版物]。 為新的出版物命名,並按一下 [儲存]。

將合併的頁面新增到現有出版物

如果您計劃將合併的頁面加到現有出版物的結尾處,請確定您的合併列印出版物在下列方面符合現有的出版物:

  • 頁面大小 (高度與寬度)

  • 頁面檢視 (單頁模式或兩頁模式)

  • 出版物類型 (網路或列印)

  • 頁面順序 (從左至右或從右至左)

Publisher 會將合併的頁面新增至全新或現有的出版物,但無法將它們新增至已開啟的出版物。 如果要合併的出版物已經開啟,請務必在完成合併之前儲存並關閉它。

  1. 按一下 [新增至現存的出版物]。

  2. 在 [開啟出版物] 對話方塊中,找出要新增合併頁面的出版物,然後按一下 [開啟]。

  3. 在現有的出版物中,按一下 [合併列印] 工作窗格中的 [儲存此出版物] 以儲存更新。

傳送電子郵件訊息

如果您正在建立電子郵件合併,則 [完成與合併] 底下可用的唯一選項將會是 [傳送電子郵件訊息]。

  1. 按一下 [傳送電子郵件訊息]。

  2. 在 [合併列印: 到電子郵件] 對話方塊中,從 [收件者] 下拉式清單中選取收件者欄位。 在大多數情況下,這將會是 [電子郵件地址]。

  3. 在 [主旨] 底下輸入主旨列。 在 [要插入的項目] 底下,按一下您要在主旨列中插入的任何資料欄位。

  4. 按一下 [選項] 來指定您想要的任何其他選項,如副本或密件副本收件者或是郵件附件,然後按一下 [傳送]。

儲存合併列印出版物

若同時儲存包含合併欄位的出版物,您可以返回並編輯欄位,然後建立新的合併出版物。 若要儲存合併的出版物,請執行下列動作:

  1. 按一下 [檔案] > [儲存]

  2. 為出版物命名,然後按一下 [儲存]。

頁面頂端

取消合併

您可以取消合併以中斷合併列印出版物或來自其資料來源的型錄合併列印範本。

  1. 按一下 [郵件] 索引標籤 > [選取收件者],然後按一下 [取消合併]。

    取消合併列印

  2. 當詢問您是否要取消合併時,請按一下 [是]。

    附註: 如果您取消合併列印,則會將 [地址欄位]、[問候行] 和 [地址區塊] 以外的欄位轉換成一般文字。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×