加入資料連接到 Web 服務

重要:  本文係由機器翻譯而成,請參閱免責聲明。本文的英文版本請見這裡,以供參考。

您可以新增表單範本的一個或多個次要資料連線,用以查詢 Web 服務的資料或將資料送出給 Web 服務。

本文內容

概觀

相容性考量

在您開始之前

新增查詢資料連線

新增送出資料連線

概觀

次要資料連線是任何資料連線到您新增至表單範本的外部資料來源。不同的主資料連線時您設計表單範本,根據資料庫、 Web 服務或設定連線的文件庫中建立此資料連線。您無法查詢,或傳送的主資料連線到資料時,才可以新增次要資料連線。

當您新增表單範本的查詢資料,Microsoft Office InfoPath 建立資料來源次要資料欄位和群組對應至 Web 服務的XML 結構描述的次要資料連線。次要資料來源中的資料結構必須符合 XML 結構描述,因此您無法修改現有欄位] 或 [次要資料來源中的群組。當您新增至表單範本的送出資料連線時,您設定表單範本,讓使用者送出表單資料,並設定您的表單範本為基礎的表單的送出選項。

頁面頂端

相容性考量

您無法在瀏覽器相容的表單範本中,將送出資料連線設定為允許使用者將變更資訊與表單資料送出至接受 Microsoft ADO.NET DataSet 的 Web 服務。變更資訊包含使用者對資料庫中存放之資料所做的修改。資料庫會使用 Web 服務,將使用者連線至資料庫。ADO.NET 可以使用變更資訊來判斷如何更新資料庫中的資料。請向您的 Web 服務管理員詢問 Web 服務是否需要變更資訊來更新資料庫。如果需要,您就應該設計一份只能使用 InfoPath 填寫表單的表單範本。

頁面頂端

在您開始之前

新增表單範本的次要資料連線之前,需要下列來自 Web 服務管理員的資訊:

  • Web 服務的位置。

  • 確認 Web 服務是否使用 document/literal 樣式編碼。InfoPath 只能使用 document/literal 樣式的 Web 服務。

  • Web 服務作業的名稱,該作業將傳送或接收以這個表單範本為基礎之表單的資料。

頁面頂端

新增查詢資料連線

若要允許使用者使用表單範本來查詢 Web 服務的資料,您必須在表單範本中進行下列動作:

  1. 新增次要資料連線。

  2. 設定要使用次要資料連線的表單範本。

步驟 1:新增次要資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 按一下 [資料連線精靈] 」中的 [建立新連線至],然後按一下 [接收資料],再按一下 [下一步]

  4. [要接收資料的來源] 下按一下 [Web 服務],然後按一下 [下一步]

  5. 在精靈的下一頁上,輸入 Web 服務的位置,然後按一下 [下一步]

    附註: 如果您想要使用 「 通用描述、 探索及整合 (UDDI) 伺服器搜尋 Web 服務時,按一下 [搜尋 UDDI,輸入您想要搜尋,指定是否要搜尋提供者或所提供的服務,請輸入搜尋關鍵字,然後按一下 [搜尋UDDI 伺服器的 URL。符合搜尋關鍵字的 web 服務會出現在 [搜尋結果] 清單中。選取您要使用的 Web 服務,然後再按一下[確定]。

  6. 在精靈下一頁的 [選取作業] 清單中,按一下將資料傳回表單的 Web 服務作業,然後按 [下一步]

  7. 如果「資料連線精靈」在 Web 服務的結構描述中遇到不明項目,此精靈的下一頁可能會要求您指定每個參數的範例值,以便判斷哪些欄位或群組要加入至主要資料來源。

    作法

    1. 選取 [參數] 資料表中的參數,然後按一下 [設定範例值

    2. 在 [範例值] 方塊中,輸入值可能會使用此欄位中,您的使用者,並按一下 [確定

    3. 在 [參數] 資料表中每個參數的重複這些步驟,然後按一下 [下一步

    技術細節

    當您設定的資料連線,Web 服務資料連線精靈] 中時,Microsoft Office InfoPath 連接至 Web 服務,並要求 Web 服務描述語言 (WSDL) 檔案。WSDL 檔案包含使用 Web 服務的結構描述。Web 服務會傳送檔案給 infopath 來回應邀請。InfoPath 會使用此檔案中的資訊,將適當的欄位和群組新增至表單範本中的次要資料來源。如果 InfoPath WSDL 檔案中發現未知的項目類型,InfoPath 來決定未知的項目類型的定義中使用範例資料,並適當的欄位和群組次要資料來源。

  8. 如果您想要在表單未連線至網路時使用查詢的結果,請選取 [在表單範本中儲存資料複本] 核取方塊。

    安全性附註 : 選取此核取方塊時,會將查詢結果儲存在表單範本。因為資料儲存在表單範本,並使用表單中的使用者填寫時,即使他們的電腦未連線至網路。如果您的機密資料從取得此資料連線,您可能會想要停用此功能,以協助保護資料,以防遺失或竊取電腦。

  9. 按一下 [下一步]

  10. 在精靈的下一頁上,輸入查詢資料連線的描述性名稱。

  11. 若要讓以這個表單範本為基礎的表單在開啟時自動接收資料,請選取 [開啟表單時自動擷取資料] 核取方塊。

  12. 確認 [摘要] 區段中的資訊正確無誤,然後按一下 [完成]

  13. 按一下 [關閉]

步驟 2:設定要使用次要資料連線的表單範本

當您新增表單範本的查詢資料連線時,根據預設,以這個表單範本為基礎的表單會在使用者開啟時使用資料連線。您也可以利用下列其中一種方法,來設定表單範本以使用查詢資料連線:

  • 新增規則   您可以設定規則的條件規則中發生時,使用查詢資料連線。

  • 新增] 按鈕   您可以新增按鈕至表單範本使用者可以按一下以取得使用查詢資料連線的資料。

  • 使用自訂程式碼   如果您無法新增規則] 或 [] 按鈕,您可以使用自訂程式碼,以取得使用查詢資料連線的資料。使用自訂程式碼需要開發人員若要建立自訂的程式碼。

新增規則

您可以將一項規則加入至表單範本,以便在每次符合此規則的條件時,從查詢資料連線取得資料。下列程序會假設您已為表單範本建立查詢資料連線,而且假設您已在表單範本上設定顯示該資料連線之資料的控制項。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 按兩下要新增規則的控制項。

  3. 按一下 [資料] 索引標籤。

  4. 按一下 [驗證及規則] 底下的 [規則]

  5. 按一下 [規則] 對話方塊中的 [新增]。

  6. [名稱] 方塊中輸入規則的名稱。

  7. 若要執行規則時,請指定條件,按一下設定條件],然後輸入條件。條件發生時,會執行規則。如果您沒有設定條件,當使用者變更的控制項中,值,然後移離該控制項的他或她游標執行規則。

  8. 按一下 [新增動作]

  9. [動作] 清單中,按一下 [使用資料連線查詢]

  10. [資料連線] 清單中,按一下想要使用的查詢資料連線,然後按一下 [確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

新增按鈕

您可以將按鈕控制項新增至表單範本,如此使用者只要按一下該按鈕,就可以透過查詢資料連線取得資料。下列程序假設您已經建立表單範本的查詢資料連線。

  1. 如果表單範本中有多個檢視,按一下 [檢視名稱上,前往您要顯示的次要資料來源的資料與控制項檢視的 [檢視] 功能表。

  2. 如果沒有看到 [控制項] 工作窗格,請按一下 [插入] 功能表上的 [其他控制項],或按 ALT+I、C。

  3. 將按鈕控制項拖曳至表單範本上。

  4. 按兩下剛剛新增至表單範本的按鈕。

  5. 按一下 [一般] 索引標籤。

  6. [動作] 清單中,按一下 [重新整理]

  7. [標籤] 方塊中,輸入要在表單範本上顯示的按鈕名稱。

  8. 按一下 [設定]

  9. 按一下 [重新整理] 對話方塊中的 [一個次要資料來源]

  10. [選擇次要資料來源] 清單中,按一下與查詢資料連線關聯的次要資料來源,然後按一下 [確定] 關閉每個開啟的對話方塊。

  11. 若要測試變更,請按一下 [標準] 工具列上的 [預覽],或按 CTRL+SHIFT+B。

頁面頂端

新增送出資料連線

若要允許使用者將以您的表單範本為基礎的表單送出至 Web 服務,請先新增您用來送出資料之表單範本的次要資料連線,然後將表單範本設定為允許使用者送出他們的表單資料。

步驟 1:新增次要資料連線

  1. 按一下 [工具] 功能表的 [資料連線]

  2. 在 [資料連線] 對話方塊中,按一下 [新增]。

  3. 按一下「資料連線精靈」中的 [建立新連線至],然後按一下 [送出資料],再按一下 [下一步]

  4. [您要如何送出資料] 下,按一下 [至 Web 服務],然後按一下 [下一步]

  5. 在精靈的下一頁上,輸入使用者要送出資料的 Web 服務位置,然後按一下 [下一步]

    附註: 如果您想要使用 「 通用描述、 探索及整合 (UDDI) 伺服器搜尋 Web 服務時,按一下 [搜尋 UDDI,輸入您想要搜尋,指定是否要搜尋提供者或所提供的服務,請輸入搜尋關鍵字,然後按一下 [搜尋UDDI 伺服器的 URL。符合搜尋關鍵字的 web 服務會出現在 [搜尋結果] 清單中。選取您要使用的 Web 服務,然後再按一下[確定]。

  6. [選取作業] 清單中,按一下將接收表單資料的 Web 服務作業,然後按一下 [下一步]

  7. 在精靈的下一頁上,若要選取要將表單中的哪些資料送出給 Web 服務中的每個參數,請執行下列其中一個動作:

    送出欄位或群組中的資料

    1. 在 [參數] 清單中,按一下將從表單接收資料的 Web 服務參數。

    2. 按一下 [參數選項] 底下的 [欄位或群組]

    3. 按一下 [修改 按鈕圖像 ]。

    4. 在 [選取欄位或群組] 對話方塊中,按一下要送出資料的欄位或群組,然後按一下 [確定]。

    5. 按一下 [包括] 方塊中的 [僅能使用文字和子元素],只送出這個欄位中的資料以及欄位或群組的子元素,或按一下 [XML 樹狀子目錄,包括選取的元素],送出欄位名稱、欄位中的資料以及選取群組或欄位中的子元素。

    送出表單的所有資料

    1. 在 [參數] 清單中,按一下將從表單接收資料的 Web 服務參數。

    2. 參數選項] 底下按一下 [整個表單 (XML 文件,包括處理指示)]。

    以字串方式送出資料

    1. 在 [參數] 清單中,按一下將從表單接收資料的 Web 服務參數。

    2. 參數選項] 底下按一下 [整個表單 (XML 文件,包括處理指示)]。

    3. 選取 [以字串方式送出資料] 核取方塊。

      附註: 通常,只有在需要送出數位簽章的資料時才選取這個核取方塊。大多數情況下,請清除這個核取方塊。

    有關 ADO.NET DataSet 物件的技術注意事項

    如果 Web 服務需要 ADO.NET DataSet 物件,請在設定這個資料連線時選取資料集節點。如果針對需要 ADO.NET DataSet 物件之 Web 服務的資料連線使用任何其他類型的節點,則送出動作會失敗。

  8. 按一下 [下一步]

  9. 在精靈的下一個頁面上,輸入 [送出資料連線的名稱。

  10. 確認 [摘要] 區段中的資訊正確無誤,然後按一下 [完成]

  11. 按一下 [關閉]

在您加入次要送出資料連線之後,就必須將表單範本設定為允許使用者使用此送出資料連線來送出表單資料。

步驟 2:啟用表單範本上的送出

將表單範本設定為允許使用者送出他們的表單資料時,InfoPath 會將 [送出] 按鈕新增至 [標準] 工具列上,而且會將 [送出] 命令新增至表單的 [檔案] 功能表上。您也可以用下列方式自訂表單範本的送出選項:

  • 變更出現在 [送出] 按鈕和 [送出] 命令上的文字。

  • 變更 [送出] 按鈕和 [送出] 命令的快速鍵。

  • 建立自訂訊息,在使用者送出表單時為他們顯示該訊息。

  • 指定表單要在送出後保持開啟、關閉或開啟另一個空白表單。

  • 在 [工具] 功能表上按一下 [送出選項]。

  • [送出選項] 對話方塊中,選取 [允許使用者送出這個表單] 核取方塊、按一下 [傳送表單資料至單一目的地],然後在清單中,按一下 [Web 服務]

  • [選擇送出的資料連線] 清單中,按一下您在前述步驟中所建立 Web 服務之送出資料連線的名稱。

    1. 若要變更的名稱出現在 [標準] 工具列和 [送出] 命令時,會出現在 [檔案] 功能表上的使用者填寫表單上的 [送出] 按鈕,請在 [送出選項] 對話方塊中的 [標題] 方塊中輸入新名稱。

      提示: 如果要指派鍵盤快速鍵,此按鈕和命令,請輸入 & 符號 (&) 之前您想要使用的鍵盤快速鍵的字元。例如,若要指定為送出] 按鈕和命令的鍵盤快速鍵的 ALT + B,輸入Su 與 bmit

  • 如果您不要人員送出] 指令或送出] 按鈕使用在 [標準] 工具列上,填寫表單時,請清除 [顯示 [提交] 功能表項目及送出] 工具列按鈕] 核取方塊。

    1. 根據預設,使用者送出表單之後, InfoPath 保持表單開啟,並會顯示訊息,表示已成功送出表單。若要變更此預設行為,按一下 [進階],然後執行下列其中一項 ︰

      • 若要關閉表單或建立新的空白表單使用者送出完成的表單之後,請按一下之後送出」 清單中想要的選項。

      • 若要建立自訂的訊息,表示已成功送出表單,選取 [使用自訂的郵件] 核取方塊,,然後輸入您的郵件在成功失敗] 方塊。

        提示: 使用 [失敗] 方塊中的訊息,告訴使用者他們無法送出表單時該怎麼辦。例如,您可以建議使用者儲存表單,並與其他人取得進一步的指示。

      • 如果您不想顯示的訊息,使用者送出表單之後,請清除 [顯示成功和失敗的郵件] 核取方塊。

頁面頂端

附註: 機器翻譯免責聲明︰本文係以電腦系統翻譯而成,未經人為介入。Microsoft 提供此等機器翻譯旨在協助非英語系使用者輕鬆閱讀 Microsoft 產品、服務及技術相關內容。基於本文乃由機器翻譯而成,因此文中可能出現詞辭、語法、文法上之錯誤。

擴展您的技能
探索訓練
優先取得新功能
加入 Office 測試人員

這項資訊有幫助嗎?

感謝您的意見反應!

感謝您的意見反應! 我們將協助您與其中一位 Office 支援專員連絡以深入了解您的意見。

×