Microsoft Office Visio 2007 中的数据连接功能概述。

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

Microsoft Office Visio 2007可以创建比图表和绘图更多的信息-它还可以帮助你可视化、组织、理解和演示数据。

Visio 图表中的每个形状都可以显示不同的数据集。在下图中, 每个形状都显示不同地区的销售数据, 这样就可以轻松地将 "销售结果" 区域与当前和以前年份的地区进行比较。

用标志显示状态

如果要处理的数据已存储在工作簿或数据库表中, 您可以直接将该数据导入 Office Visio 形状中, 而不是手动输入每条信息。

本文内容

将数据连接到图表的建议方式是什么?

我是否仍然可以按照我在早期版本的 Visio 中所做的方式连接到数据?

我是否应该始终使用数据链接功能将数据连接到图表?

将数据连接到图表的建议方式是什么?

Visio 具有多个数据连接功能, 但在大多数情况下, 最好使用 "数据选取器向导" 将数据源连接到图表 (在 "数据" 菜单上, 单击 "将数据导入到形状中")。使用该向导后, 数据将显示在 "外部数据" 窗口中。将已连接的形状添加到绘图后, 您的数据将显示在形状中。Office Visio 2007还包括一组可从中选择或更改的数据图形。

有关数据链接和数据图形功能的详细信息, 请参阅以下文章:

我是否仍然可以按照我在早期版本的 Visio 中所做的方式连接到数据?

没错.Office Visio 2007中的数据链接功能不会替换以前版本的 Visio 中的任何功能。你可以继续使用具有特殊功能的解决方案, 这些解决方案用于连接到数据以及两个数据库连接加载项。

这两个数据库连接加载项是数据库向导和ODBC 数据库命令的链接。若要访问这些功能, 请在 "工具" 菜单上, 指向 "加载项", 指向 "其他Visio 方案", 然后单击 "数据库向导" 或 "链接到 ODBC 数据库"。

一些模板还有特殊的工具, 可用于将特定类型的数据连接到图表或从数据生成图表:

  • "组织结构图" 模板    使用 "组织结构图向导" 连接到 microsoft Exchange Server 数据、microsoft Office Excel 数据、文本文件和其他符合 ODBC 的数据源以生成组织结构图。在组织结构图的图表中, 在 "组织结构图" 菜单上, 单击 "导入组织结构图数据"。在组织结构图生成之后, 您可以使用 "数据选取器向导" 链接到其他外部数据。有关详细信息, 请参阅创建 Visio 组织结构图一文。

  • 日程表模板    使用 "导入日程表向导" 连接到 Microsoft Office Project 数据。在 "数据" 菜单上, 指向 "插入数据解决方案", 然后单击 "日程表"。有关详细信息, 请参阅将数据从 Project 导入到 Visio 日程表中一文。

  • 日历模板    使用 "导入 Outlook 数据" 向导连接到 Microsoft Office Outlook 数据。在 "数据" 菜单上, 指向 "插入数据解决方案", 然后单击 "日历"。

  • 灵感触发图模板    在灵感触发图中, 使用 "灵感触发" 菜单上的 "导入数据" 命令连接到 XML 文件。有关详细信息, 请参阅创建灵感触发图一文。

  • 甘特图模板    使用 "导入项目数据" 向导连接到 Office Project 数据。在甘特图中, 在 "甘特图" 菜单上, 单击 "导入"。有关详细信息, 请参阅将Project 中的数据导入到 Visio 甘特图中一文。

  • 数据库模型图模板    使用 "反向工程向导" 对符合 ODBC 的数据库进行反向工程。在数据库模型图中的 "数据库" 菜单上, 单击 "反向工程"。除了模板中包含的其他向导外, 还可以使用 "数据选取器向导" 将其他数据导入和表示这些图表中的数据。有关详细信息, 请参阅将现有数据库反向工程到数据库模型一文。

我是否应该始终使用数据链接功能将数据连接到图表?

以下方案介绍了你可能希望使用除数据选取器向导以外的其他方法来处理图表中的数据的特定情况:

  • 您使用的是以前使用 "数据库向导" 创建的图表。

  • 若要使用双向数据连接 (例如, 希望 Visio 图表中的数据更改以影响数据源), 请使用 "数据库向导" 进行操作。

  • 当 Visio 为您从数据源创建整个图表时, 您将从数据生成图表, 如日程表、组织结构图和日历。

  • 当 visio 从数据源中创建形状时, 将从数据生成 visio 中的主控形状。

  • 通过使用 "反向工程向导" 反向工程数据库, 可通过 "数据库模型图" 模板访问该向导。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×