Microsoft Access 2010 中的新增功能

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

在 Microsoft Access 2010 中, 您可以生成 web 数据库并将其发布到 SharePoint 网站。sharepoint 访问者可以在 web 浏览器中使用您的数据库应用程序, 使用 SharePoint 权限确定谁可以查看哪些内容。你可以从模板开始, 这样你就可以立即开始协作。

Access 用户界面也已更改。如果你不熟悉Office Access 2007, 功能区和导航窗格可能是你的新增功能。功能区将替换以前版本中的菜单和工具栏。导航窗格将替换并扩展数据库窗口的功能。在Access 2010中, "Backstage" 视图允许你访问应用于整个数据库的所有命令, 如 "压缩和修复" 或 "文件" 菜单中的命令。

本文介绍了Office Access 2007和Access 2010中引入的功能。如果你需要大致的 access 介绍, 请参阅access 2010入门文章。

本文内容

概述

新用户界面

功能更强大的对象创建工具

新的数据类型和控件

改进的数据呈现

增强的安全性

解决问题的更好方法

改进的拼写检查器

概述

如果您有权访问配置了 access Services 的 SharePoint 网站, 则可以使用Access 2010创建 web 数据库。在 SharePoint 网站上拥有帐户的人员可以在 web 浏览器中使用您的数据库, 但必须使用Access 2010进行设计更改。虽然一些桌面数据库功能不会转换为 Web, 但您可以使用新功能 (例如计算字段和数据宏) 执行许多相同的操作。

在 Web 上共享数据库

  • 使用模板   Access 2010提供了五个模板: 联系人、资源、项目、事件和慈善贡献。你还可以在发布之前或之后修改任何模板。

  • 从头开始   创建空白的新数据库时, 可以在常规数据库和 web 数据库之间进行选择。此选项将影响你看到的设计功能和命令, 以便你可以轻松地确保你的应用程序与 Web 兼容。

  • 将现有数据库转换为 web 数据库   你可以将现有的应用程序发布到 Web。并非所有桌面数据库功能在 Web 上都受支持, 因此你可能需要调整应用程序的某些功能。

    你可以运行新的 Web 兼容性检查器, 以帮助你识别并修复任何兼容性问题。

  • Intranet 或 Internet   您可以发布到您自己的 sharepoint 服务器, 也可以使用托管的 sharepoint 解决方案。

    注意:  用户帐户是使用 Web 数据库所必需的。不支持匿名访问。

有关 web 数据库的详细信息, 请参阅生成要在 web 上共享的数据库一文。

新的宏生成器

Access 2010提供了一个新的宏生成器, 它具有 IntelliSense 和简洁明了的界面。

宏生成器

1. 从列表中选择操作 .。。

2 .... 或双击操作目录中的某个操作以将其添加到你的宏。

3. 处理宏时, 将显示 "设计" 选项卡。

添加操作时, 宏生成器中会显示更多选项。例如, 当你添加 "If" 操作时, 你会看到:

包含 If 操作的宏

观看以下视频, 了解新的宏生成器的工作方式。

你的浏览器不支持视频。请安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

除了传统的宏, 还可使用新的宏生成器创建数据宏, 这是一项新功能。

数据宏: 根据事件更改数据

数据宏有助于支持 web 数据库中的聚合, 还提供了一种在任何Access 2010数据库中实现 "触发器" 的方法。

例如, 假设您有一个 "百分比" 域和 "状态" 字段。当您将 "状态" 设置为 "完成" 时, 可以使用数据宏将百分比设置为100 , 将状态设置为 "未启动" 时为0

您可以在以下视频中查看 "操作中的数据宏"。

你的浏览器不支持视频。请安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

增强的表达式生成器

"表达式生成器" 现在具有 IntelliSense 功能, 因此您可以在键入时看到您的选项。它还会在 "表达式生成器" 窗口中显示当前所选表达式值的帮助。例如, 如果您选择 Trim 函数, 则表达式生成器将显示:

Trim (字符串) 返回一个字符串类型变量, 该变量包含不带先导和尾随空格的指定字符串的副本。

有关详细信息, 请参阅使用表达式生成器一文。

计算字段

您可以创建一个显示计算结果的字段。该计算必须引用同一个表中的其他字段。你可以使用表达式生成器来创建计算。

新的数据库模板

Access 2010包括一套专业设计的数据库模板, 用于在其他类型的数据中跟踪联系人、任务、事件、学生和资产。你可以立即使用它们, 或按照所需的方式对信息进行增强和优化以进行跟踪。

Backstage 视图中的可用模板

每个模板都是一个完整的跟踪应用程序, 其中包含预定义的表、窗体、报表、查询、宏和关系。模板设计为可立即使用, 以便你可以快速开始使用并运行。如果模板设计符合你的需求, 你就可以开始。或者, 你可以使用该模板开始创建满足你特定需求的数据库。

资产 Web 数据库

除了Access 2010附带的模板之外, 您还可以连接到Office.com并下载更多模板。

用于向现有数据库添加功能的应用程序部件

通过使用应用程序部件, 可以轻松地将功能添加到现有数据库。Access 2010 中的新增功能是, 应用程序部件是包含数据库的一部分 (例如, 一个预格式化的表) 或具有关联窗体和报表的表的模板。例如, 将 "任务" 应用程序部件添加到数据库, 并获得 "任务" 表、"任务" 窗体和将 tasks 表与数据库中的另一个表相关联的选项。

“创建”选项卡上的应用程序部件

有关详细信息, 请参阅保存和重复使用数据库设计元素一文。

改进的 "数据表" 视图

您可以创建一个表并开始使用它, 而无需提前定义字段, 只需在 "创建" 选项卡上单击 "", 然后开始在出现的新数据表中输入数据。Access 2010将自动确定每个字段的最佳数据类型, 以便你可以在任何时间正常运行和运行。"单击以添加" 列显示要在其中添加新字段的位置, 如果需要更改新的或现有字段的数据类型或显示格式, 则可以在 "字段" 选项卡上的 "功能区" 上使用该命令。你也可以将 Microsoft Excel 表格中的数据粘贴到新数据表中, Access 2010将创建所有字段并自动识别数据类型。

“数据表”视图中的“单击以添加”

“字段列表”窗格

Access 2007 中引入的 "字段列表" 窗格允许您添加其他表中的字段。您可以将表中的字段拖动到记录源、相关表或数据库中的不相关表中。如果需要表之间的关系, 则会自动创建, 或者系统会提示您完成该过程。

“字段列表”窗格

"布局" 视图有助于加速窗体和报表的设计

在窗体或报表中查看数据时使用 "布局" 视图进行设计更改。

"布局" 视图具有多个对 Access 2007 的增强功能, 如果您要为 Web 设计窗体或报表, 则也是必需的。

“布局”视图中显示实时数据的窗体

使用控件布局使内容整齐

Office Access 2007中引入的布局是可作为一个单元移动和调整大小的控件组。在Access 2010中, 布局得到了改进, 允许在窗体和报表上更灵活地放置控件。您可以在水平或垂直方向拆分或合并单元格, 从而使您能够轻松地重新排列字段、列或行。

设计 web 数据库时必须使用 "布局" 视图, 但 "设计" 视图仍可用于桌面数据库设计工作。

全新的用户界面

新的用户界面 (在Office Access 2007中引入, 在Access 2010中增强) 旨在使你能够轻松地查找以前在复杂的菜单和工具栏中通常会隐藏的命令和功能。

功能区

功能区是选项卡的集合, 其中包含按功能和功能进行组织的命令组。功能区将替换在早期版本的 Access 中找到的菜单和工具栏的层。下图显示了选中 "开始" 选项卡的功能区。

Access 2010 中的功能区

功能区的关键功能包括:

  • 命令选项卡-显示常用命令的选项卡, 以便你可以在需要时找到所需的命令。

  • 上下文命令选项卡-根据你的上下文 (即你正在处理的对象或你正在执行的任务) 显示的命令选项卡。上下文命令选项卡包含最有可能应用于你正在执行的操作的命令。

  • 库-显示样式或选项预览的新控件, 以便你可以在提交选项之前查看结果。

Backstage 视图

Backstage 视图中的新增Access 2010包含应用于整个数据库的命令, 如 "压缩和修复" 或 "打开新数据库"。命令在屏幕左侧的选项卡上排列, 每个选项卡都包含一组相关的命令或链接。例如, 如果单击 "新建", 您将看到一组按钮, 可用于从头开始创建新数据库, 或从具有专业设计的数据库模板库中进行选择。

Backstage 视图中的“新建”选项卡

在 Access 的早期版本中的 "文件" 菜单上, 除了最近打开的数据库以及 (如果您已连接到 Internet) 链接到 office.com 文章之外, 还可以在 "Backstage" 视图中找到的许多命令。

若要转到 Backstage 视图, 请单击 "文件" 选项卡。

导航窗格

此功能在 Access 2007 中引入。

导航窗格列出并提供对当前打开的数据库中的所有对象的便捷访问。

导航窗格中的对象

使用导航窗格按对象类型、创建日期、修改日期、相关表 (基于对象从属关系) 或在您创建的自定义组中组织对象。需要更多空间来处理表单设计?你可以轻松地折叠导航窗格, 使其占用较少的空间, 但仍保持可用。

导航窗格取代了早于Access 2007的 Access 版本中所用的数据库窗口。

选项卡对象

此功能在 Access 2007 中引入。

默认情况下, 您的表、查询、窗体、报表和宏在 Access 窗口中显示为选项卡式对象。

你可以更改每个数据库的此设置, 并使用对象窗口而不是选项卡。

Access 2007 中的选项卡式对象 通过单击对象选项卡, 你可以轻松地在各种对象之间切换。

“帮助”窗口

Access 2010在同一 "帮助" 窗口中提供 access 帮助和 access 开发人员参考内容。这两个系统包含不同类型的帮助内容。帮助查看器允许你选择要显示的内容。例如, 您可以将搜索范围更改为 Access 开发人员参考内容。无论你在 "帮助" 窗口中所做的设置如何, access 帮助和 access 开发人员参考内容始终在 Office.com 或 MSDN 上联机使用。

功能更强大的对象创建工具

Access 2010提供了用于创建数据库对象的直观环境。

创建选项卡

使用 "创建" 选项卡快速创建新的窗体、报表、表、查询和其他数据库对象。如果在导航窗格中选择一个表或查询, 则可以通过使用窗体报表命令, 通过单击来创建新的窗体或报表, 方法是单击该对象。

Access 中功能区上的“创建”选项卡

通过此单击过程创建的新窗体和报表将使用更新的设计, 以使其更具吸引力且立即有用。自动生成的窗体和报表可获得具有专业外观的设计, 其中包含带有徽标和标题的标题。此外, 自动生成的报表还包括日期和时间以及信息页脚和汇总。

报表视图和布局视图

这些视图在Office Access 2007中引入, 并在Access 2010中增强, 可让你交互处理表单和报表。通过使用 "报表" 视图, 无需在 "打印预览" 中打印或显示报表, 即可浏览准确的报表呈现。若要重点关注特定记录, 请使用筛选器功能, 或使用 "查找" 操作搜索匹配的文本。你可以使用 "复制" 命令将文本复制到剪贴板, 或者单击报表中显示的活动超链接以关注浏览器中的链接。

"布局" 视图允许您在浏览数据时进行设计更改。在窗体或报表中查看数据时, 可以使用 "布局" 视图进行许多常见的设计更改。例如, 通过从 "新建字段列表" 窗格中拖动一个字段名称来添加字段, 或使用属性表更改属性。

"布局" 视图现提供改进的设计布局: 可调整的控件组, 以便你可以轻松地重新排列字段、列、行或整个布局。您也可以在 "布局" 视图中删除域或轻松添加格式。 “布局”视图中的报表

在报表中简化创建分组和排序

此功能在 Access 2007 中引入。

Access 具有一种新方法, 用于对报表中的数据进行分组和排序, 并添加总计。界面易于导航和理解, 当与新的布局视图结合使用时, 你可以立即看到更改的效果。

“分组、排序和汇总”窗格

假设您想要按地区查看报表中的总销售额。使用 "布局" 视图和 "分组、排序和汇总"窗格添加组级别并请求汇总, 并在报表中查看 "实时更改"。"汇总" 行使报表页眉或页脚的求和、平均值、计数、最大值或最小值增加。简单的汇总不再需要手动创建计算字段。现在, 你只需指向并单击即可。

在报表中创建总计

改进的控件布局可帮助您创建精美的窗体和报表

窗体和报表通常包含表格信息, 如包含客户姓名的列或包含客户的所有字段的行。你可以将这些控件分组为可轻松作为一个单元 (包括标签) 进行操作的布局。

“排列”选项卡上“控件布局”组中的命令

因为您可以从不同的节 (如标签在节页眉或页脚中) 中选择控件, 所以有相当大的灵活性。你可以轻松地执行以下操作:

  • 移动布局或调整其大小。例如, 向左或向右移动一列。

  • 设置版式格式。例如, 设置 "客户姓名" 列以粗体显示, 使其醒目。

  • 向布局添加列 (字段)。

  • 从布局中删除列 (字段)。

  • 合并或拆分单元格

在“布局”视图中移动列

版式与您的设计保存在一起, 以便它们保持可用。以下视频介绍了布局在窗体和报表中的工作方式。

你的浏览器不支持视频。请安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

用于快速浏览数据的分割窗体

此功能在 Access 2007 中引入。

使用分割窗体创建组合数据表视图和窗体视图的窗体。你可以将属性设置为告诉 Access 将数据表放在顶部、底部、左侧或右侧。

分割窗体

注意: 拆分窗体在 web 数据库中不可用。

窗体和报表中的嵌入宏

此功能在 Access 2007 中引入。

使用嵌入的宏来避免编写代码。嵌入的宏存储在属性中, 并且是它所属的对象的一部分。你可以更改嵌入宏的设计, 而无需担心可能使用宏的其他控件, 因为每个嵌入的宏都是独立的。由于嵌入的宏被自动阻止执行潜在的不安全操作, 因此它们是受信任的。

将嵌入的宏分配给双击事件

新的数据类型和控件

Access 2010中的新增, 计算字段允许存储计算的结果。

Office Access 2007引入了以下新的和增强的数据类型和控件:

  • 多值字段

  • 附件数据类型

  • 增强的 "备注" 字段

  • "日期/时间" 字段的内置日历控件

计算字段

您可以创建一个字段, 用于显示从同一个表中的其他数据进行计算的值。你可以使用表达式生成器来创建计算, 以便你可以从 IntelliSense 和轻松访问对表达式值的帮助中获得好处。

不能将其他表中的数据用作计算数据的源。计算字段不支持某些表达式。

多值字段

此功能在 Access 2007 中引入。

多值字段可以为每条记录存储多个值。假设你必须将任务分配给某个员工或合同工, 但想要将其分配给多个用户。在大多数数据库管理系统和早于Office Access 2007的 Access 版本中, 你必须创建多对多关系才能正确执行此操作。

注意: Access 将创建一个隐藏的表, 用于为每个多值字段维护必要的多对多关系。

当您使用包含Windows SharePoint Services中使用的多值字段类型之一的 SharePoint 列表时, 多值字段尤其适用。Access 2010与这些数据类型兼容。

多值字段

文件的附件字段

此功能在 Access 2007 中引入。

"附件" 数据类型使您可以轻松地将所有类型的文档和二进制文件存储在数据库中, 而不会带来数据库大小的不必要的增长。当可能时, Access 会自动压缩附件以最大限度地减少空间使用。是否要将 Word 文档附加到记录或在数据库中保存一系列数字图片?使用附件可以更轻松地执行这些任务。您甚至可以将多个附件添加到一条记录。

“附件”对话框

注意: 您可以在 web 数据库中使用附件字段, 但是每个 web 表最多只能有一个附件字段。

"备注" 字段现在存储格式文本和支持修订历史记录

此功能在 Access 2007 中引入。

"格式文本备忘录" 字段意味着您不再局限于记录中的纯文本。你可以通过选项 (如加粗、倾斜和不同的字体和颜色以及其他常见的格式设置选项) 设置文本格式, 并将文本存储在数据库中。格式文本以基于 HTML 的格式存储在备注字段中, 该格式与Windows SharePoint Services中的格式文本数据类型兼容。将新的TextFormat属性设置为RichText文本, 然后在文本框控件和数据表视图中正确设置信息格式。

"备注" 字段有助于存储大量信息。你可以将 "仅追加" 属性配置为保留对备注字段的所有更改的历史记录。然后, 你可以查看这些更改的历史记录。此功能还支持Windows SharePoint Services中的跟踪功能, 以便你还可以使用 Access 查看 SharePoint 列表内容历史记录。

领料日期日历

此功能在 Access 2007 中引入。

使用 "日期/时间" 数据类型的字段和控件将自动获得对内置交互式日历的支持, 这些日历在Access 2007中引入。"日历" 按钮将自动显示在日期右侧。想要了解接下来的周五的日期?单击该按钮, 日历将自动显示, 允许你查找并选择日期。你可以选择通过使用属性来关闭字段或控件的日历。

改进的数据呈现

新的数据展示功能可帮助您更快地创建数据库对象, 然后更轻松地分析数据。

增强的排序和筛选工具

此功能在 Access 2007 中引入。

假设您必须快速找到匹配值或对一列数据进行排序。Office Access 2007中引入的 "自动筛选" 功能增强了已经强大的筛选能力, 以便您可以快速关注所需的数据。你可以轻松地从列中的唯一值中进行选择, 这对于不能撤回所需名称的情况很有用, 或者你可以使用普通语言的上下文菜单选项对值进行排序, 例如按升序排序到最新或按从小到大顺序进行排序。

自动筛选

最常用的筛选器选项在菜单命令中很容易看到, 或者您可以使用 "快速筛选器" 根据输入的数据来限制信息。快速筛选选项根据数据类型自动更改, 以便您可以看到文本、日期和数字信息的合理选择。

“日期筛选器”菜单

数据表中的汇总和交替背景色

此功能在 Access 2007 中引入。

"数据表" 视图提供 "汇总" 行, 可在其中显示总和、计数、平均值、最大值、最小值、标准偏差或方差。添加 "汇总" 行后, 指向列的单元格中的箭头, 然后选择所需的计算。

数据表中的“总计”行

数据表、报表和连续窗体支持行的交替背景色, 可以独立于默认背景色进行配置。每隔一行加底纹很容易, 并且您可以选择任何颜色。

使用交替行颜色的数据表

条件格式

Access 2010添加了新的条件格式功能, 使你能够实现 Excel 中可用的一些格式样式。例如, 你现在可以添加数据条以使数字列的可读性更强, 如下图所示:

Access 报表中的条件格式

注意: 条件格式在 web 数据库中不可用。

增强的安全性

增强的安全功能和与Windows SharePoint Services的强大集成有助于您更高效地管理和使您的信息跟踪应用程序比以前更安全。通过将跟踪应用程序数据存储在Windows SharePoint Services上的列表中, 你可以审核修订历史记录、恢复已删除的信息和配置数据访问权限。

Office Access 2007推出了一种新的安全模型, 在Access 2010中进行了向前和改进。与 Microsoft Office 信任中心集成的统一信任决定。受信任位置使你可以轻松地信任安全文件夹中的所有数据库。你可以加载具有被禁用的代码或宏的Office Access 2007应用程序, 以提供更安全的沙盒 (即, 不安全命令无法运行) 体验。受信任的宏在沙盒模式下运行。

使用 InfoPath 表单和 Outlook 收集数据

此功能在 Access 2007 中引入。

数据收集功能可帮助你使用 Outlook 和 InfoPath (可选) 收集反馈。你可以自动生成 InfoPath 表单或 HTML 表单, 并将其嵌入到电子邮件正文中。然后, 您可以将该表单发送给从 Outlook 联系人中选择的收件人, 或将其存储在 Access 数据库的某个字段中的收件人的姓名。

使用电子邮件收集数据

选择是收集新信息还是更新现有信息。然后, 收件人完成窗体并返回。Outlook 识别传入的窗体并自动保存 Access 数据库中的数据, 无需重新键入。

导出为 PDF 和 XPS

在Access 2010中, 你可以将数据导出到 pdf (可移植文档格式) 或 xps (XML 纸张规范) 文件格式, 以用于打印、发布和电子邮件分发, 前提是你首先安装 "发布为 PDF" 或 "xps 加载项"。导出窗体、报表或将数据表保存到 .pdf 或 .xps 文件中, 您可以在易于分发的窗体中捕获信息, 该表单保留了所有格式特征, 但不要求其他人在其计算机上安装 Access 以打印或查看您的输出。

  • 可移植文档格式   PDF 是一种固定版式的电子文件格式, 可保留文档格式并有助于文件共享。PDF 格式可确保在联机查看或打印文件时, 它将完全保留所需的格式, 并且文件中的数据不能轻松复制或更改。PDF 格式对于要使用专业印刷方法进行复制的文档也很有用。

  • XML 纸张规范   XPS 是一种电子文件格式, 可保留文档格式并有助于文件共享。XPS 格式可确保在联机查看或打印文件时, 它将完全保留所需的格式, 并且文件中的数据不能轻松复制或更改。

使使用外部数据变得更轻松

现在, 你可以作为外部数据源连接到 Web 服务。你需要由 web 服务管理员提供的 web 服务定义文件。安装定义文件后, 您可以将 Web 服务数据作为链接表进行链接。

Office Access 2007中引入的新功能使导入和导出数据变得更容易。您可以保存导入或导出操作, 然后在您下次想要执行相同任务时重用保存的操作。"导入电子表格向导" 允许你覆盖 Access 选择的数据类型, 你可以导入、导出和链接到具有至少文件格式的Office Excel 2007的文件。

解决问题的更好方法

此功能在 Access 2007 中引入。

Microsoft Office 诊断是一系列诊断测试, 可帮助您发现计算机崩溃的原因。诊断测试可以直接解决一些问题, 并可以确定可解决其他问题的方法。microsoft office 诊断取代了以下 microsoft office 2003 功能: "检测与修复" 以及 "Microsoft office 应用程序恢复"。

改进的拼写检查器

此功能在 Access 2007 中引入。

以下是拼写检查器的一些新增功能。

  • 拼写检查器在 Office 程序中的行为更一致。此更改的示例包括以下内容:

    • 现在, 几个拼写检查器选项是全局的。如果在一个 Office 程序中更改其中一个选项, 则所有其他 Office 程序也会更改该选项。

    • 除了共享相同的自定义词典, 所有程序都可以使用相同的对话框管理它们。有关详细信息, 请参阅使用自定义词典将单词添加到拼写检查器一文。

  • 拼写检查器包括后期修订法语词典。在 Microsoft Office 2003 中, 这是一个必须单独安装的加载项。

  • 首次使用该语言时, 将自动为该语言创建排除词典。你可以使用排除词典强制拼写检查器标记要避免使用的字词。排除词典有助于避免令你讨厌或不符合你的风格指南的字词。有关详细信息, 请参阅使用排除词典指定字词的首选拼写一文。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×