Excel 中的 "获取 &" 转换入门

Excel 中的 "获取 &" 转换入门

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

使用 Excel 中的Get & 转换, 你可以搜索数据源, 建立连接, 然后按照满足你的需求的方式对数据进行整形(例如, 删除列、更改数据类型或合并表)。在对数据进行整形之后, 您可以共享您的发现或使用查询创建报表。

Power Query 常用步骤

如果按照顺序看这些步骤,将发现其通常按照下面的方式进行:

  • 连接 - 建立与云中、服务内或本地的数据之间的连接

  • 转换 - 调整数据以满足你的需求;原始源保持不变

  • 合并–创建来自多个数据源的数据模型, 并获取数据的独特视图

  • 共享–完成查询后, 您可以保存、共享或将其用于报表

无论何时连接到数据、进行转换或将其与其他数据源合并, 称为 "查询编辑器" 的Get & 转换的一项功能将记录每个步骤, 并允许您根据需要对其进行修改。"查询编辑器" 还允许撤消、恢复、更改顺序或修改任何步骤, 以便您可以按照所需的方式对已连接数据的视图进行整形。

借助Get & 转换, 你可以根据需要创建简单或复杂的查询。当你向查询添加步骤时, "查询编辑器" 在后台工作, 以创建一组用于执行命令的分离指令。这些说明在 M 语言中创建。具有数据脚本功能的强大功能和灵活性的用户可以使用 "高级编辑器" 手动创建或更改 M 语言查询。"查询编辑器" 和高级编辑器将在本文的后面部分详细介绍。

你可以从 "数据" 选项卡开始新的查询 >获取数据> 选择数据源。如果看不到 "获取数据" 按钮, 请从 "数据" 选项卡中选择 "新建查询" 按钮。下面是从数据库源中进行选择的示例。

从数据库选项获取 & 转换

注意: power Query也适用于早期版本的 Excel 作为加载项, 以及power BI。若要在早期版本的 Excel 中查看Power query in 操作, 请查看power query入门。

连接

您可以使用查询连接到单个数据源 (例如Access数据库), 也可以连接到多个文件、数据库、OData 源或网站。然后, 你可以使用自己的独特组合将所有这些源放在一起, 并发现你可能看不到的见解。

当您从 "数据" 选项卡上的 "获取 & 转换" 部分中选择 "获取数据" (如果看不到 "获取数据" 按钮, 则显示 "新建查询"), 您将看到许多数据源可供选择, 包括 Excel工作簿等文件或 CSV 文件、数据库 (如AccessSQL ServerOracleMySQL)、 Azure服务 (如HDInsightBlob 存储) 以及其他类型的其他源 (如Web)SharePoint 列表Hadoop 文件FacebookSalesforce和其他人。

注意: 你可以在此处了解 Excel 版本可使用的数据源:何处获取 & 转换 (Power Query)

当你连接到数据源时, Get & 转换将显示"导航器"窗口, 该窗口允许你编辑来自源的数据。当您从 "导航器" 窗口中选择 "编辑" 时, 请转到 & 转换启动查询编辑器, 这是一个专门的窗口, 可帮助和显示你的数据连接和你应用的转换。下一节 "转换" 提供了有关查询编辑器的详细信息。

转换

获取 & 转换使你能够以有助于分析数据的方式转换数据源中的数据。转换数据意味着以某种方式对其进行修改以满足你的需求-例如, 你可以删除列、更改数据类型或合并表-每个数据都是数据转换。当你转换数据时, 它会共同承担你需要进一步分析的形状。将转换应用于一个或多个数据集的过程通常称为 "整形数据"。

Excel 使用专用查询编辑器来促进和显示数据转换。当你选择 "数据>获取数据", 然后选择数据源 (如工作簿或数据库) 时, 将显示 "导航器" 窗口, 以便你可以选择要在查询中使用的一个或多个表。选择表时, "导航器" 窗口的右窗格中将显示其数据的预览。

获取 & 转换 > Power Query 导航窗格

如果你选择 "加载", 数据源将直接输入到 Excel 中。如果选择 "编辑", 则将启动查询编辑器

Power Query 编辑器窗格

"查询编辑器" 可跟踪对数据执行的所有操作。查询编辑器记录和标记应用于数据的每个转换或步骤。无论转换是与数据源的连接、删除列、合并或数据类型更改,查询编辑器都会在 "查询设置" 窗格的 "已应用步骤" 部分中跟踪每个操作。

对数据连接应用的转换共同构成查询

请务必了解在查询编辑器中定义的操作不会更改原始源数据。相反, 当您连接或转换数据时, Excel 会记录您所执行的每个步骤, 并在您完成对数据的调整后, 将获得经过优化的数据集的快照并将其引入工作簿中。

有许多可应用于数据的转换很多。你也可以使用 M 语言编写自己的转换, 使用查询编辑器的高级编辑器。您可以从查询编辑器的 "开始" 或 "视图" 选项卡打开高级编辑器, 您可以在其中修改与现有查询相关联的 M 语言步骤或创建您自己的编辑器。

Power Query 高级编辑器窗格, 其中包含 M 语言编辑

当您完成创建查询时, 可以从 "开始" 选项卡中选择 "关闭 & 加载", 然后将查询结果加载到 Excel 中, 并在 "新建工作簿" 选项卡中使用。

了解有关转换的详细信息:

共享

当您保存包含查询的 Excel 工作簿时, 也会自动保存该查询。可以通过在 "数据" 选项卡上选择 "查询 & 连接" 来查看 Excel 工作簿中的所有查询。

Power Query 查询和连接窗格

但为什么会停止?借助Power BI 数据目录, 您可以与组织中的任何人共享查询。或者创建将经常使用的查询, 然后在多个工作簿中使用它并保存自己的工作。不要保存 Excel 工作簿并向其发送电子邮件, 找出更改的内容或数据是否已过时, 请将查询保存到数据目录。只需在 "查询 & 连接" 窗格中右键单击查询, 然后有一个菜单提供所有类型的选项, 包括 "发送到数据目录"。

Power Query > 导出到选项

请注意右键单击菜单中的其他选项。您可以复制查询, 这样就可以更改查询的部分或全部元素, 而无需更改原始查询;它类似于创建查询模板, 然后您可以修改它来创建自定义数据集, 例如用于为批发使用一个数据集, 另一个用于根据相同的数据连接进行清点。

还可以“合并”或“追加”查询,从而将查询转化为可重复使用的构建块。

你也可以将工作簿发布到 Power BI, 并创建可与你的组共享的联机报表, 并自动刷新和改进。若要将工作簿发布到 power bi, 请选择 "文件 > 发布 > 发布到 power bi"。

注意: 必须将工作簿保存到OneDrive for business 才能将其发布到 Power BI。

查询完成后, 您可以使用它在ExcelPower BI中创建报表。查看下一节, 了解有关如何报告资源的详细信息, 以便你可以充分利用你在使用 "获取 & 转换" 功能时所做的所有好工作, 以便按照所需方式调整数据的形状。

了解有关共享的详细信息:

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×