Access 2010 中的基本任务

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

下面是一些可帮助你了解如何使用 Microsoft Access 2010 的基本数据库任务。

 

本文内容

什么是 Access​​?

Access 中的关系数据库

打开 Access 时

查找并应用模板

从头开始创建数据库

打开现有 Access 数据库

开始使用新数据库

添加表格

将其他源中的数据粘贴到 Access 表中

导入或链接其他源中的数据

后续步骤

从电子表格或其他程序导入数据

将 Excel 工作表导入 Access

将 Excel 工作表导入为新数据库中的表

使用表分析器向导整理数据

处理其他程序中的数据

在 Access 的多个版本中使用早期版本的数据库

在 access 的多个版本中使用 access 数据库文件

步骤 1: 制作现有数据库的副本, 并将其保存为新格式

步骤 2: 拆分复制数据库并将原始文件用作后端数据库

步骤 3: 将新的前端连接到原始数据库

在多个版本的 Access 中使用前端/后端应用程序

什么是 Access​​?

Access 2010 是一个数据库应用程序设计和部署工具, 可用于跟踪重要信息。 您可以将数据保留在您的计算机上, 也可以发布到 web 上, 以便其他人可以将您的数据库与 web 浏览器配合使用。

当用户使用 Access 跟踪逐渐变得更少的任务时, 很多人都开始使用 Access。 例如, 假设你是活动 planner, 并且希望跟踪你需要管理以使事件成功的所有详细信息。 如果你使用字处理程序或电子表格程序执行此操作, 则可以轻松地使用重复和不一致的数据来遇到问题。 您可以使用日历软件, 但在日历中跟踪财务信息不太合适。

Access 中的关系数据库

有时, 你需要一个关系数据库来跟踪此类信息, 即仓库的数据被分离到较小的数据集合 (称为表) 中, 以消除冗余, 然后基于常见的信息位 (称为字段) 进行关联。. 例如, 事件规划关系数据库可能包含包含客户信息的表、包含供应商信息的表以及包含事件信息的表。 包含事件信息的表可能具有一个字段, 用于将其与 customer 表相关联, 并使用一个字段将其与供应商表相关联。 这样, 例如, 如果供应商的电话号码已更改, 则信息可能会在供应商表中更改一次, 而不是涉及供应商的每个事件。

Access 是一种可用于快速轻松地开发关系数据库应用程序的工具, 可帮助您管理信息。 你可以创建一个数据库来帮助你跟踪有关任何类型的信息, 如库存、专业联系人或业务流程。 实际上, Access 附带了可立即用于跟踪各种信息的模板, 使内容更加容易, 即使是初学者也是如此。

打开 Access 时

启动Access 2010 时, 你将看到 Microsoft Office Backstage 视图, 你可以在其中获取有关当前数据库、创建新数据库、打开现有数据库以及从Office.com 查看特色内容的信息。

Access 2010 的 Backstage 视图

Backstage 视图还包含许多其他可用于调整、维护或共享数据库的命令。 Backstage 视图中的命令通常应用于整个数据库, 而不适用于数据库中的对象。

注意: 通过单击 "文件" 选项卡, 可以随时访问 Backstage 视图。

返回页首

查找并应用模板

Access 提供了各种各样的模板, 可用于加快数据库创建过程。 模板是一个随时可用的数据库, 其中包含执行特定任务所需的所有表、查询、窗体和报表。 例如, 有可用于跟踪问题、管理联系人或保留费用记录的模板。 某些模板包含一些示例记录, 可帮助演示它们的使用。 模板数据库可以按原样使用, 也可以对其进行自定义以更好地满足你的需求。

若要查找模板并将其应用到数据库, 请执行下列操作:

  1. 在“文件”选项卡上,单击“新建”。

  2. 在 "可用模板" 下, 执行下列操作之一:

    • 若要重复使用最近使用过的模板, 请单击 "最近使用的模板", 然后选择所需的模板。

    • 若要使用已安装的模板, 请单击"我的模板", 然后选择所需的模板。

    • 若要在Office.com 上查找模板, 请在 " Office.com 模板" 下, 单击模板类别, 选择所需的模板, 然后单击 "下载" 以将模板从 Office 下载到您的计算机。

      您还可以从 Access 中搜索 Office.com 上的模板。 在 "搜索 Office.com 的模板" 框中, 键入一个或多个搜索词, 然后单击箭头按钮进行搜索。

  3. (可选) 单击 "文件名" 框旁边的文件夹图标, 浏览到要在其中创建数据库的位置。 如果不指定特定位置, Access 将在 "文件名" 框下方显示的默认位置创建数据库。

  4. 单击“创建”。

Access 将创建数据库并将其打开以供使用。

返回页首

从头开始创建数据库

如果想要深入了解使用 Access 创建数据库的概念, 请参阅数据库设计基础一文。

如果这些模板都不满足你的需要, 或者如果你的其他程序中有要在 Access 中使用的数据, 你可能会认为更好地从头开始创建数据库。 在 Access 2010 中, 你有一种选择: 标准桌面数据库或 web 数据库。

有关 web 数据库的详细信息, 请参阅构建要在 web 上共享的数据库一文。

若要创建新数据库, 请执行下列操作:

  1. 启动 Access。

  2. 在 Backstage 视图中的 "新建" 选项卡上, 单击 "空白数据库" 或 "空白 Web 数据库"。

    重要: 您在此处所做的选择将决定数据库中有哪些功能可用。 桌面数据库无法发布到 web, 并且 Web 数据库不支持某些桌面功能, 例如总计查询。

  3. 在右侧的 "文件名" 框中, 键入数据库的名称。

    若要更改创建文件的位置, 请单击 "文件名" 框旁边的 "浏览 按钮图像 ", 浏览并选择新位置, 然后单击"确定"

  4. 单击“创建”。

    Access 将创建数据库, 然后在数据表视图 中打开一个空表 (名为 Table1)。

  5. Access 将光标放在新表的 "单击以添加" 列中的第一个空单元格中。

    若要添加数据, 请开始键入, 或者可以粘贴其他源中的数据, 如本文后面的将其他源中的数据粘贴到 Access 表中所述。

    注意: 

    • 在数据表视图中输入数据的设计与在 Excel 工作表中输入数据非常相似。 主要限制是, 必须在数据表的左上角开始, 输入连续的行和列中的数据。 不要尝试通过包含空白行或列来设置数据的格式, 因为这样做会浪费表格空间。 该表只包含您的数据。 该数据的所有可视化演示文稿将在您以后设计的窗体和报表中完成。

    • 在输入数据时创建表结构。 每当您向数据表添加新列时, 表中都将定义一个新字段。 Access 基于您输入的数据类型设置字段的数据类型 。 例如, 如果您有一个只在其中输入日期值的列, Access 会将该字段的数据类型设置为 "日期/时间"。 如果稍后尝试在该字段中输入非日期值 (如姓名或电话号码), Access 将显示一条消息, 通知您该值与列的数据类型不匹配。 在可能的情况下, 你应该规划表格, 以使每一列都包含相同类型的数据, 无论是文本、日期、数字还是其他类型。 这使得生成仅选择所需数据的查询、窗体和报表变得更加容易。

如果您不想输入数据, 请单击 "关闭 按钮图像 "。

注意: 如果关闭它而不保存, Access 将删除 Table1。

返回页首

打开现有 Access 数据库

提示: 若要快速打开最近打开过的几个数据库之一, 请在 "文件" 选项卡上单击 "最近", 然后单击文件名。

  1. “文件”选项卡上,单击“打开”

  2. 单击 "打开" 对话框中的快捷方式, 或者在 "查找范围" 框中, 单击包含所需数据库的驱动器或文件夹。

  3. 在文件夹列表中, 双击 "文件夹", 直到打开包含该数据库的文件夹。

  4. 当您找到数据库时, 请执行下列操作之一:

    • 若要在默认打开模式下打开数据库, 请双击它。

    • 若要在多用户环境中打开数据库以共享 access, 以便您和其他用户同时读取和写入数据库, 请单击 "打开"。

    • 若要打开数据库以进行只读访问, 以便可以查看它但不能对其进行编辑, 请单击 "打开" 按钮旁边的箭头, 然后单击 "以只读状态打开"。

    • 若要以独占访问方式打开数据库, 以使其他人在您打开它时无法打开该数据库, 请单击 "打开" 按钮旁边的箭头, 然后单击 "以独占方式打开"。

    • 若要打开数据库以进行只读访问, 请单击 "打开" 按钮旁边的箭头, 然后单击 "以独占方式打开只读其他用户仍可打开数据库", 但它们只有只读访问权限。

如果找不到要打开的数据库    

  1. 在 "打开" 对话框中, 单击 "我的电脑" 快捷方式, 或者在 "查找范围" 框中, 单击 "我的电脑"。

  2. 在驱动器列表中, 右键单击您认为可能包含数据库的驱动器, 然后单击 "搜索"。

  3. 输入搜索条件, 然后按 enter 搜索数据库。

  4. 如果找到该数据库, 请在 "搜索结果" 对话框中双击它将其打开。

    由于搜索是从 "打开" 对话框启动的, 因此必须在该对话框中单击 "取消", 然后才会打开数据库。

你可以直接以外部文件格式 (如 dBASE、Paradox、Microsoft Exchange 或 Excel) 打开数据文件。 您也可以直接打开任何ODBC 数据源, 如 microsoft SQL Server 或 microsoft FoxPro。 Access 会自动在与数据文件相同的文件夹中创建新的 Access 数据库, 并将链接添加到外部数据库中的每个表。

返回页首

开始使用新数据库

根据所使用的模板, 可能需要执行以下一项或多项操作才能开始使用新数据库:

  • 如果 Access 显示具有空用户列表的 "登录" 对话框, 请使用以下过程开始操作:

    1. 单击 "新建用户"。

    2. 填写 "用户详细信息" 表单。

    3. 单击“保存并关闭”。

    4. 选择刚刚输入的用户名, 然后单击 "登录"。

  • 如果 Access 显示一个空数据表, 则可以直接向该数据表中输入数据, 或单击其他按钮和选项卡以浏览数据库。

  • 如果 Access 显示 "入门" 页面, 则可以单击该页面上的链接以了解有关数据库的详细信息, 或单击其他按钮和选项卡以浏览数据库。

  • 如果 Access 在消息栏中显示安全警告消息, 并且您信任该模板的来源, 请单击 "启用内容"。 如果数据库需要登录, 您将需要再次登录。

对于桌面数据库和 web 数据库, 您还希望以下列步骤之一开始:

返回页首

添加表格

可以使用 "创建" 选项卡上的 "" 组中的工具将新表添加到现有数据库。

“创建”选项卡上的“表”组

注意: 在 web 数据库中, 只有 "" 命令在 "" 组中可用。

无论在哪种视图中开始, 都可以使用 Access 窗口状态栏上的 "视图" 按钮切换到其他视图。

在数据表视图中创建空白表    在数据表视图中, 您可以立即输入数据, 让 Access 在幕后构建表结构。 字段名称按数字顺序 (Field1、Field2 等) 分配, Access 根据输入的数据类型设置字段数据类型。

  1. 在 "创建" 选项卡上的 "" 组中, 单击 " 按钮图像 "。

  2. Access 将创建表, 然后将光标放在 "单击以添加" 列的第一个空单元格中。

  3. 若要添加数据, 请在第一个空单元格中开始键入, 也可以粘贴其他源中的数据, 如本文后面部分所述。

    • 若要重命名列 (字段), 请双击列标题, 然后键入新名称。

      提示: 为每个字段提供有意义的名称, 以便你可以在不查看数据的情况下知道它所包含的内容。

    • 若要移动列, 请通过单击其列标题将其选中, 然后将其拖动到所需位置。 您也可以选择多个相邻的列, 并将它们全部拖到新位置。

      若要向表中添加更多字段, 可以开始在 "数据表" 视图中的 "单击以添加" 列中键入内容, 也可以使用 "字段" 选项卡上的 "添加 & 删除" 组中的命令添加新字段。

从设计视图开始创建表    在 "设计" 视图中, 首先创建新表的结构。 然后, 切换到数据表视图以输入数据, 或者使用其他方法 (例如使用窗体) 输入数据。

设计视图不可用于 web 数据库中的表。

  1. 在“创建”选项卡上的“”组中,单击“表设计”。 按钮图像

  2. 对于表中的每个字段, 在 "字段名称" 列中键入一个名称, 然后从 "数据类型" 列表中选择一种数据类型。

  3. 你可以为 "说明" 列中的每个字段输入其他信息。 当插入点位于该字段中时, 你输入的说明将显示在状态栏中, 并且将用作你通过将字段从 "字段列表" 窗格拖动到窗体或报表而创建的任何控件的状态栏文本。以及由窗体向导或报表向导为该字段创建的任何控件。

  4. 添加完所有字段后, 保存表:

    • 在“文件”选项卡上,单击“保存”。

  5. 通过切换到数据表视图, 单击第一个空单元格, 然后键入, 可以随时开始向表中输入数据。 您还可以粘贴来自其他源的数据, 如下一节所述。

基于 SharePoint 列表创建表格    使用 SharePoint 列表, 您的数据可以由没有访问权限的人员使用。 此外, 列表数据存储在服务器上, 它通常提供比存储在台式计算机上的文件更好的数据丢失保护。 您既可以从新列表开始, 也可以链接到现有列表。 您必须在要创建列表的 SharePoint 网站上有足够的权限;这可能因网站而异, 因此请与您的 SharePoint 管理员联系以获取有关您的选项的详细信息。

此功能在 Web 数据库中不可用。

  1. 在“创建”选项卡上的“表”组中,单击“SharePoint 列表​​”。

  2. 你可以使用其中一个列表模板来创建标准的 SharePoint 列表, 例如联系人或事件。

    您也可以选择创建自定义列表, 或链接到现有列表或导入现有列表。 单击所需选项。

  3. 如果你选择任何列表模板或创建自定义列表, 则将打开 "新建列表" 对话框, 指导你完成此过程。 如果你选择使用现有列表, 将打开 "获取外部数据" 对话框以帮助你。

有关表的详细信息,请参阅文章表简介

返回页首

将其他源中的数据粘贴到 Access 表中

如果数据当前存储在其他程序 (如 Excel) 中, 则可以将数据复制并粘贴到 Access 表中。 通常情况下, 如果你的数据已分到列中, 因为它们位于 Excel 工作表中, 因此效果最佳。 如果您的数据在字处理程序中, 您应该首先使用制表符分隔数据列, 或将数据转换为字处理程序中的表, 然后复制数据。 如果您的数据需要任何编辑或操作 (例如, 将全名分隔为名字和姓氏), 则可能需要在复制数据之前执行此操作, 尤其是在您不熟悉 Access 的情况下。

将数据粘贴到空表中时, Access 会根据字段在其中找到的数据类型设置每个字段的数据类型。 例如, 如果粘贴的字段包含不包含日期值的内容, Access 会将 "日期/时间" 数据类型应用于该字段。 如果粘贴的字段仅包含单词 "yes" 和 "no", 则 Access 将 "是/否" 数据类型应用于该字段。

Access 将根据在粘贴数据的第一行中找到的内容来命名字段。 如果粘贴数据的第一行与后续行的类型相似, Access 会确定第一行是数据的一部分, 并分配字段通用名称 (Field1、Field2 等)。 如果粘贴的数据的第一行与后面的行不相似, Access 会将第一行用作字段名称, 并将第一行排除在实际数据中。

如果 Access 分配通用字段名称, 则应尽快重命名字段以避免混淆。 使用以下过程:

  1. 在 "文件" 选项卡上, 单击 "保存" 以保存表。

  2. 在 "数据表" 视图中, 双击每个列标题, 然后键入列的名称。

  3. 再次保存该表。

返回页首

导入或链接其他源中的数据

您可能在 Access 中要使用的另一个程序中有所收集的数据。 您可能会将其数据存储在其他程序中, 并且希望在 Access 中使用其数据。 或者, 你有多个不同的数据源, 并且需要一个 "卸货 pad", 你可以在其中将它们放在一起进行深入分析。

Access 使您可以轻松地从其他程序导入或链接数据。 你可以将 Excel 工作表中的数据、来自 SharePoint 列表的表或来自各种其他源的表中的数据导入到其他 Access 数据库中。 该过程略有不同, 具体取决于数据源, 但这些说明将帮助您入门:

  1. 在 "外部数据" 选项卡上的 "导入 & 链接" 组中, 单击要从中导入文件的文件类型的命令。

    例如, 如果要从 Excel 工作表导入数据, 请单击 " Excel"。 如果看不到正确的程序类型, 请单击 "更多"。

    注意: 如果在 "导入 & 链接" 组中找不到正确的格式类型, 可能需要启动最初创建数据的程序, 然后使用该程序以 Access 支持的文件格式保存数据 (如带分隔符的文本文件 )。, 然后导入或链接到数据。

  2. 在 "获取外部数据" 对话框中, 单击 "浏览" 浏览到源数据文件, 或在 "文件名" 框中键入源数据文件的完整路径。

  3. 在 "指定数据在当前数据库中的存储方式和存储位置" 下, 单击所需的选项。 可以使用导入的数据创建新表, 或创建一个链接表来维护指向数据源的链接。

  4. 单击“确定”

    "链接对象" 对话框或 "导入对象" 对话框会打开, 具体取决于您的选择。

  5. 使用对话框完成此过程。 所遵循的确切过程取决于您选择的 "导入" 或 "链接" 选项。

  6. 在该向导的最后一页上,单击“完成”。

    如果你选择导入, Access 会询问你是否要保存刚刚完成的导入操作的详细信息。

  7. 如果你认为你将再次执行此相同的导入操作, 请单击 "保存导入步骤", 然后输入详细信息。

    然后, 可以通过单击 "外部数据" 选项卡上的 "导入" 组中的 "已保存导入", 然后单击 "导入规范", 然后单击 "运行" 来轻松重现导入

  8. 如果不想保存操作的详细信息, 请单击 "关闭"。

Access 将数据导入到一个新表中, 然后在 "导航窗格" 中的 "" 下显示该表。

若要了解有关如何将数据导入 Access 的详细信息, 请参阅本文的 "另请参阅" 部分中的链接。

返回页首

后续步骤

设计过程的其余部分根据你的目标而有所不同, 但你可能需要考虑创建查询、窗体、报表和宏。 本文不提供有关创建其他数据库对象的信息。

有关详细信息, 请参阅以下文章:

返回页首

从电子表格或其他程序导入数据

如果您熟悉其他数据库或电子表格程序, 您可能会知道这些应用程序的工作原理以及哪些数据库用于哪些基础知识。 Access 与许多其他数据库应用程序的不同之处是允许您创建关系数据库, 它与大多数电子表格程序的不同之处在于, 它通过提供用于开发复杂查询、窗体和报表的工具。 Access 还提供了许多用于处理其他数据库程序 (如 SQL Server) 的选项。

将 Excel 工作表导入 Access

在 Excel 中首次构建列表后, 许多人开始探索访问权限。 Excel 是开始列表的绝佳位置, 但随着列表的增加, 组织和保持更新的难度将变得更难。 将列表移动到 Access 通常是下一个逻辑步骤。

数据库表在结构中类似于工作表, 数据存储在行和列中。 因此, 通常很容易将工作表导入到数据库表中。 将数据存储在工作表中并将其存储在数据库中的主要区别在于数据的组织方式。 只要将整个工作表作为新表导入数据库中, 就不会解决与组织和更新数据相关的问题, 尤其是当工作表中包含冗余数据时。 若要解决这些问题, 必须将电子表格数据拆分为多个单独的表, 其中每个表都包含相关数据。 有关如何排列表中的数据的详细信息, 请参阅数据库设计基础一文。

Access 功能 "表分析器向导", 可帮助你完成此过程。 将数据导入到表中后, 该向导将帮助你将表拆分为多个单独的表, 其中每个表都包含未在任何其他表中复制的数据。 该向导还会创建表之间的必要关系。

返回页首

将 Excel 工作表导入为新数据库中的表

  1. 在 "文件" 选项卡上, 单击 "新建", 然后单击 "空白数据库"。

  2. 在 "文件名" 框中键入新数据库的名称, 然后单击 "创建"。

    新数据库随即打开, Access 会创建一个新的空表 Table1。

  3. 关闭 Table1。

    当系统询问您是否要保存对 Table1 设计的更改时, 请单击 ""。

  4. 在 "外部数据" 选项卡上的 "导入 & 链接" 组中, 单击 " Excel"。 按钮图像

  5. 在 "获取外部数据" 对话框中, 单击 "浏览"。

  6. 使用 "文件打开" 对话框找到您的文件。

  7. 选择文件,然后单击“打开”。

  8. 在 "获取外部数据" 对话框中, 确保选中 "将源数据导入当前数据库中的新表" 选项。

  9. 单击“确定”

    "导入电子表格向导" 随即启动, 并询问您有关数据的一些问题。

  10. 按照说明进行操作, 单击 "下一步" 或 "返回" 以浏览页面。 在该向导的最后一页上,单击“完成”。

    注意: Access 询问您是否要保存刚刚完成的导入操作的详细信息。 如果你认为你将再次执行此相同的导入操作, 请单击"是", 然后输入详细信息。 然后, 您可以通过单击 "外部数据" 选项卡上的 "导入" 组中的 "已保存的导入", 轻松重现该操作。 如果不想保存操作的详细信息, 请单击 "关闭"。

Access 将数据导入到新表中, 然后将其显示在导航窗格中的 "所有表" 下。

返回页首

使用表分析器向导整理数据

将数据导入 Access 表后, 您可以使用表分析器向导快速识别冗余数据。 然后, 该向导将提供一种简单的方式将数据组织到单独的表中, 以便以最高效的方式存储数据。 Access 将原始表保留为备份, 然后创建可以用作数据库应用程序基础的新表。

  1. 打开包含要分析的表的 Access 数据库。

  2. 在 "数据库工具" 选项卡上的 "分析" 组中, 单击 "分析表"。

    "表分析器向导" 随即启动。

    向导的前两页包含简短教程, 您可以单击这些按钮以查看示例。 如果看不到 "介绍" 页面, 而是看到标记为"显示引导页"的复选框, 请选中该复选框, 然后单击 "返回两次" 以查看简介。 如果您在阅读简介后不希望再次看到介绍性页面, 则可以清除 "显示引导页? " 复选框。

  3. 哪个表中包含值在多条记录中重复的字段?页面上, 选择要分析的表, 然后单击 "下一步"。

  4. 你可以让向导决定哪些字段转到哪些表中, 或者你可以自己制定决策。 如果按照向导的建议操作, 仍可在向导的下一页上对表布局进行更改。

    注意: 如果你让向导决定将哪些字段放入哪些表中, 其选择可能不会始终适合你的数据, 尤其是在没有大量数据需要处理的情况下。 你应该仔细检查向导的结果。 另一方面, 向导可能会建议比你所考虑的组织效率更高的组织, 因此最好至少尝试一次向导的决定。 如果不喜欢这些建议, 您仍然可以手动重新排列字段, 并且您始终可以单击 "返回" 并自行排列所有字段。

  5. 单击“下一步”。 在此页面上, 您可以指定哪些表包含哪些字段。 如果选择让向导决定, 则应看到多个表通过关系线连接。 否则, Access 仅创建一个包含所有字段的表。 在任何一种情况下, 您都可以在此页面上进行更改。

    • 您可以将表中的字段拖动到页面的空白区域, 以创建包含这些字段的新表。 Access 会提示你输入表名称。

    • 如果您认为在表中存储的字段将更高效, 可以将字段从一个表拖动到另一个表中。

    • 大多数表将获得一个ID或生成的唯一 ID字段。 若要了解有关 ID 字段的详细信息, 请单击向导右上角的 "提示"。

    • 若要撤消更改, 请单击 "撤消" 按钮。

    • 若要重命名表格, 请双击其标题栏, 键入新名称, 然后单击"确定"

  6. 按所需方式排列字段后, 单击 "下一步"。

  7. 如果向导找到的记录具有非常相似的值, 它会将这些值标识为可能的输入错误, 并显示一个屏幕, 可在其中确认要执行的操作。 滚动浏览列表以查找在 "更正" 列中具有值的任何内容, 然后在下拉列表中单击相应的项目。 选择 " (保留原样) " 以防止向导对值进行任何更改。 完成后, 单击 "下一步"。

  8. 向导询问您是否要创建与原始表类似的查询。 如果已经生成基于原始表的窗体和报表, 创建这样的查询是一个好主意。 如果选择"是, 创建查询", 向导将通过向表名称追加 "_OLD" 来重命名原始表, 然后使用原始表的名称命名新查询。 基于该表的窗体和报表现在对其数据使用查询, 并且这些窗体和报表继续正常工作。

  9. 单击“完成”

    向导将创建指定的新表, 然后将其打开。 完成检查结果时, 请关闭它们。

返回页首

处理其他程序中的数据

Access 2010 提供了处理存储在其他程序中的数据的功能。

创建链接到其他文件格式的数据的新 Access 数据库    可以使用 Access 以其他文件格式 (如文本、dBASE 或电子表格) 打开文件。 access 会自动创建 Access 数据库并为您链接文件。

  1. 启动 Access。

  2. “文件”选项卡上,单击“打开”

  3. 在 "打开" 对话框中, 单击要在列表中打开的文件的类型。 如果不确定文件类型, 请单击 "所有文件 (*. *)"。

  4. 如果需要, 请浏览到包含要打开的文件的文件夹。 找到文件后, 双击将其打开。

  5. 按照向导中的说明操作。 在该向导的最后一页上,单击“完成”。

将数据导入或链接到现有 Access 数据库    你可以将其他源和程序中的数据导入 access 表中, 以便数据包含在 access 文件中, 或者你可以链接到 access 中的数据, 以便数据保留在原始文件 (Access 文件之外) 中。

  1. 在 "外部数据" 选项卡上的 "导入 & 链接" 组中, 单击存储数据的格式。

    你可以从以下源导入或链接到数据:

    • Excel    可以在 Excel 工作簿中导入工作表或命名区域中的数据。 每个工作表或命名区域必须单独导入或链接。

    • Access    这非常方便, 可用于将你的流程与数据分离开来, 从而创建一个拆分数据库。 也就是说, 你可以使用一个数据库来包含所有窗体、报表和宏, 并将数据保留在另一个数据库中。 这样, 您就可以在不打断任何人的工作的情况下开展改进。 您还可以将来自许多不同 Access 数据库的数据合并到一个数据库中, 以便更轻松地在各部门或业务合作伙伴之间汇总数据。

    • ODBC 数据库    许多程序支持此格式, 包括许多数据库服务器产品。 这可帮助你创建 "卸货 pad" 数据库, 你可以在其中合并来自不同系统的数据。

    • 文本文件    你可以连接到一个简单的文本文件, 甚至可以使用 Access 更改该文件的内容。 这有助于使 Access 数据易于由各种程序使用。

    • XML 文件    此格式还提供与各种其他程序 (包括某些 web 服务器) 的兼容性。

    • SharePoint 列表    这使你的数据可通过 web 浏览器使用, 这是使用 SharePoint 列表的标准方式。

    • 数据服务    你可以连接到你的企业内部的 web 数据服务。

    • HTML 文档    

    • Outlook 文件夹    您可以连接到 Outlook 文件夹, 以便更轻松地将您的联系人信息与其余的数据集成。

    • dBase 文件    dBase 是 Access 支持的一种最常见的备用数据库系统

      将显示 "获取外部数据" 对话框。

  2. 按照对话框中的说明进行操作。

    Access 会将数据导入或链接到您的数据库。 对于大多数格式, 必须指定数据的位置, 然后选择希望数据存储在数据库中的方式。

返回页首

在 Access 的多个版本中使用早期版本的数据库

如果 access 数据库或 access 项目是在 access 2000 或更高版本中创建的, 则可以在创建它的 access 版本或任何更高版本中使用数据库或项目, 即使该文件已启用安全。 例如, access 2000 文件可以在 access 2000、access 2002、access 2003、access 2007 和 access 2010 中使用。

你可能需要在早期版本的 access 中保留数据, 但你拥有更高版本的 access 的用户希望链接到该数据, 但仍可利用更高版本的某些功能。 解决方案是在更高版本 (包含窗体、报表、查询、宏, 但不包含表) 中创建新的 "前端" 数据库, 并将其链接到早期版本文件中的表。 根据数据库是包含在一个文件中还是已拆分为前端/后端应用程序, 使用下列过程之一。

在 access 的多个版本中使用 access 数据库文件

如果早期版本的 access 数据库的所有表、窗体和其他对象都包含在一个文件中, 而你希望在多个版本的 access 中使用该数据库, 则可以在更高版本中创建新的前端数据库并将其链接到原始文件。 具有早期版本的 Access 的用户仍然能够使用原始数据库。 具有更高版本的用户可以使用新的前端数据库链接到相同的数据。 如果需要满足 Access 的多个版本, 您可以创建多个前端版本。

返回页首

步骤 1: 制作现有数据库的副本, 并将其保存为新格式

使用以下过程将数据库转换为以下三种最新格式中的任意一种: access 2000、access 2002-2003 或 access 2007。 此命令保留原始数据库的原始格式, 并以你指定的格式创建副本。

  1. 关闭 Access 文件。 如果文件是位于服务器或共享文件夹中的多用户 Access 数据库, 请确保没有其他人打开它。

  2. 启动 Access 2010。

  3. “文件”选项卡上,单击“打开”

  4. 通过浏览找到要转换的文件的位置, 然后双击将其打开。

    如果出现 "数据库增强" 对话框, 询问是否要增强数据库, 请单击 ""。

  5. 如果启动数据库时打开一个窗体, 请关闭该窗体。

  6. 在 "文件" 选项卡上, 单击 "数据库另存为"。

  7. 在 "另存为" 对话框中, 键入新数据库的名称。

    注意: 除非要将新数据库保存到其他位置, 否则其名称必须不同于原始数据库的名称。 在任何一种情况下, 通常最好使用不同的名称, 以便你可以轻松地区分前端数据库和后端数据库。 但是, 如果你要转换为 Access 2007 格式, 则文件扩展名将从 .mdb 更改为 .accdb, 这样你就可以使用相同的文件名。

  8. 单击“保存”。

返回页首

步骤 2: 拆分复制数据库并将原始文件用作后端数据库

使用以下过程拆分转换后的数据库:

  • 在 "数据库工具" 选项卡上的 "移动数据" 组中, 单击 " Access 数据库"。 按钮图像

  • 在 "数据库拆分器" 对话框中, 单击 "拆分数据库"。

    如果需要, 您可以创建备份, 但也可以使用原始数据库重新创建副本。

  • 键入后端数据库的名称, 然后单击 "拆分"。

返回页首

步骤 3: 将新的前端连接到原始数据库

  1. 删除数据库拆分器工具创建的后端数据库, 注意不要删除原始数据库。

  2. 将新的前端数据库链接到原始数据库中的表: 在 "外部数据" 选项卡上的 "导入 & 链接" 组中, 单击 "链接表管理器"。 按钮图像

  3. 单击 "全选", 然后选中 "始终提示新位置" 复选框。

  4. 单击"确定", 浏览到早期版本的数据库, 然后双击它。

    如果一切正常, Access 将显示一条消息, 指出所有选定的链接表已成功刷新。

现在, 你可以增强新的前端数据库以支持具有较新版本的 Access 的用户的新功能。 具有早期版本的用户可以继续使用早期版本的数据库。

返回页首

在多个版本的 Access 中使用前端/后端应用程序

如果 Access 数据库已经是前端/后端应用程序, 则可以将前端转换为新的文件格式。 不需要对后端数据库进行任何更改。

以下过程介绍了如何使用 "将数据库另存为" 命令将前端数据库转换为三种最新格式中的任何一种: access 2000、access 2002-2003 或 access 2007。 此命令保留原始数据库的原始格式, 并以你指定的格式创建副本。

  1. 关闭前端数据库。 如果文件是位于服务器或共享文件夹中的多用户 Access 数据库, 请确保没有其他人打开它。

  2. 启动 Access 2010。

  3. “文件”选项卡上,单击“打开”

  4. 通过浏览找到前端数据库的位置, 然后双击将其打开。

    如果出现 "数据库增强" 对话框, 询问是否要增强数据库, 请单击 ""。

  5. 如果打开数据库时出现窗体, 请关闭窗体。

  6. 在 "文件" 选项卡上, 单击 "数据库另存为"。

  7. 在 "另存为" 对话框中, 键入新数据库的名称。

  8. 单击“保存”。

现在, 你可以增强新的前端数据库以支持新功能。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×