Access 2010 中的基本任务

下面是一些基本的数据库任务以帮助您了解如何使用 Microsoft Access 2010可执行的操作。

 

本文内容

什么是 Access?

在 Access 中的关系数据库

当您打开 Access

查找和应用模板

从头开始创建数据库

打开现有的 Access 数据库

开始使用新的数据库

添加表格

从其他源的数据粘贴到 Access 表

导入或链接到数据从另一个源

后续步骤

从电子表格或其他程序导入数据

导入 Access 的 Excel 工作表

作为新数据库中的表导入 Excel 工作表

使用表分析器向导来组织数据

使用其他程序中的数据

在多个版本的 Access 中使用早期版本的数据库

使用 Access 在多个版本的 Access 数据库文件

步骤 1︰ 创建的现有数据库的副本并将其另存为新的格式

步骤 2︰ 拆分复制数据库,并使用原始文件作为后端数据库

步骤 3︰ 将连接的新前端到原始数据库

在多个版本的 Access 中使用前端/后端应用程序

何为 Access?

Access 2010 的数据库应用程序设计和部署工具可用于跟踪的重要信息。您可以将数据保留在您的计算机上或可以发布到网站,以便其他人可以使用 web 浏览器中使用您的数据库。

当用于跟踪信息的程序逐渐变得不再适应要求时,许多人都开始采用 Access。例如,假定您是一名活动计划者,您希望跟踪需要处理的所有细节以使活动取得成功。如果您使用文字处理程序或电子表格程序来执行此任务,那么很容易遇到数据重复和不一致性问题。您可以使用日历软件,但在日历中跟踪财务信息并非一种很好的选择。

Access 中的关系数据库

有时,您需要关系数据库来跟踪此类信息 — 知识宝库的数据已分为 (称为表) 的数据的较小的集合,从而消除了冗余,并然后相关一起基于常见位 (称为字段) 的信息。例如,一种活动计划关系数据库可能包含与客户信息表、 表供应商的信息,以及带有事件信息的表格。带有事件信息表可能有要与客户表中,一个字段和与供应商表中的字段。这种方式,例如,如果更改供应商的电话号码,信息可以进行更改后的供应商表中,而不是涉及供应商的每个事件中。

Access 工具可用于快速、方便地开发有助于您管理信息的关系数据库应用程序。您可以创建一个数据库来帮助您跟踪任何类型的信息,例如,清单、专业联系人或业务流程。实际上,Access 提供了多个可直接用于跟踪各种信息的模板,因此,即便是初学者也很容易上手。

打开 Access 时

当您启动Access 2010时,您将看到 Microsoft Office Backstage 视图中,您可以获得有关当前数据库的信息、 创建新的数据库,打开现有数据库,和视图特色Office.com中的内容。

Access 2010 的 Backstage 视图

Backstage 视图还包含许多其他命令,您可以使用这些命令来调整、维护或共享数据库。Backstage 视图中的命令通常适用于整个数据库,而不是数据库中的对象。

注意: 通过单击“文件”选项卡可以随时访问 Backstage 视图。

返回页首

查找并应用模板

Access 提供了各种各样的模板,您可以使用加快数据库创建过程。模板是包含所有表、 查询、 窗体和报表执行特定任务时所需的现成到数据库。例如,没有可用于跟踪问题、 管理联系人,或保留记录的费用的模板。某些模板包含一些示例记录以帮助说明其使用。是,可以使用模板数据库或您可以自定义它们以更好地满足您的需求。

若要查找模板并将模板应用到数据库,请执行下列操作:

  1. “文件”选项卡上,单击“新建”

  2. “可用模板”下,执行下列操作之一:

    • 若要重新使用您最近使用过的模板,请单击“最近打开的模板”,然后选择所需模板。

    • 若要使用已安装的模板,请单击“我的模板”,然后选择所需模板。

    • 若要查找模板上Office.com,在Office.com 模板下单击模板类别,选择所需的模板,然后单击下载到您的计算机从 Office.com 下载模板。

      您也可以搜索在 Access 中从 Office.com 上的模板。在搜索 Office.com 模板框中,键入一个或多个搜索词,,然后单击箭头按钮以搜索。

  3. 或者,单击“文件名”框旁边的文件夹图标,浏览以找到要创建数据库的位置。如果不指定具体位置,Access 将在“文件名”框下面显示的默认位置创建数据库。

  4. 单击“创建”

Access 会创建数据库并打开它以供使用。

返回页首

从头开始创建数据库

如果您希望使用 Access 创建数据库的概念更深入的简介,请参阅文章数据库设计基础

如果没有模板可满足您的需要,或者要在 Access 中使用另一个程序中的数据,那么您可能认为更好的办法是从头开始创建数据库。在 Access 2010 中,您可以选择标准桌面数据库或 Web 数据库。

有关 web 数据库的详细信息,请参阅生成可在 Web 上共享数据库一文。

若要创建新数据库,请执行下列操作:

  1. 启动 Access。

  2. 在 Backstage 视图的“新建”选项卡上,单击“空白数据库”“空白 Web 数据库”

    重要: 在此所做的选择将决定数据库中的可用功能。不能将桌面数据库发布到 Web,而 Web 数据库不支持某些桌面功能,例如,汇总查询。

  3. 在右侧的“文件名”框中,输入数据库的名称。

    若要更改您在其中创建文件的位置,单击文件名框旁边的浏览 按钮图像 、 通过浏览找到并选择新的位置,然后单击确定

  4. 单击“创建”

    Access 将创建数据库,并在数据表视图将会打开一个空表 (名为 Table1)。

  5. Access 会将光标置于新表的“单击以添加”列中的第一个空单元格内。

    若要添加数据,开始键入,或粘贴到 Access 表的另一个源中的数据,本文后面部分中所述,您可以将粘贴其他来源的数据。

    注释: 

    • 在数据表视图中输入数据与在 Excel 工作表中输入数据非常类似。主要的限制是,必须从数据表的左上角开始,在连续的行和列中输入数据。不应当像在 Excel 工作表中那样,尝试通过包括空行或列来设置数据的格式,因为这样做将浪费表的空间。表只包含数据。数据的所有可视化表现形式都将在随后设计的窗体和报表中完成。

    • 在输入数据时创建的表格结构。任何时候,您将新列添加到数据表中,在表中定义新的字段。Access 会将数据类型根据您输入的数据类型的字段。例如,如果您有您在其中输入仅日期值的列,则 Access 将为日期/时间设置该字段的数据类型。如果您以后尝试在该字段中输入非日期值 (如姓名或电话号码),Access 会显示一条消息,告知您客户的列的数据类型不匹配的值。如果可能,您应该规划表格,以便每个列中包含相同类型的数据,无论是文本、 日期、 数字或某些其他类型。这使得更容易生成查询、 窗体和报表,选择刚所需的数据。

如果您不希望尚未输入数据,请单击关闭 按钮图像

注意: 如果在不保存的情况下关闭,Access 将删除 Table1。

返回页首

打开现有的 Access 数据库

提示: 若要快速打开最近打开过的多个数据库中的一个数据库,请在“文件”选项卡上单击“最近”,然后单击文件名。

  1. “文件”选项卡上,单击“打开”

  2. 单击打开对话框中的快捷方式,或在查找范围框中,单击驱动器或文件夹包含所需的数据库。

  3. 在文件夹列表中,双击文件夹,直到打开包含所需数据库的文件夹。

  4. 找到数据库时,执行下列操作之一:

    • 若要在默认打开模式下打开数据库,请双击它。

    • 若要在多用户环境中,打开共享数据库,以便您和其他用户可以同时读取和写入数据库,同时,请单击打开

    • 若要为了进行只读访问而打开数据库,以便可以查看数据库但不能编辑数据库,请单击“打开”按钮旁边的箭头,然后单击“以只读方式打开”

    • 若要为了进行独占访问而打开数据库,以便在您打开数据库后任何其他人都不能再打开它,请单击“打开”按钮旁边的箭头,然后单击“以独占方式打开”

    • 要以只读访问方式打开数据库,请单击“打开”按钮旁的箭头,然后单击“以独占只读方式打开”。其他用户仍可以打开该数据库,但是只能进行只读访问。

如果找不到您要打开的数据库   

  1. 打开的对话框中,单击我的电脑上快捷方式 —,或在搜索框中,单击我的电脑上

  2. 在驱动器列表中,右键单击您认为可能包含该数据库的驱动器,然后单击“搜索”

  3. 输入搜索条件,然后按 Enter 搜索该数据库。

  4. 如果找到该数据库,请在“搜索结果”对话框中双击它以将其打开。

    由于搜索是从“打开”对话框开始的,因此必须在该对话框中单击“取消”,才能打开数据库。

外部文件格式 (如 dBASE、 困境、 Microsoft Exchange 或 Excel),可以直接打开数据文件。您可以直接打开任何ODBC 数据源,如 Microsoft SQL Server 或 Microsoft FoxPro。Access 自动为该数据文件,同一文件夹中创建新的 Access 数据库,并将链接添加到每个表中的外部数据库。

返回页首

开始使用新数据库

根据所用的模板,您可能需要执行下列一项或多项操作来开始使用新数据库:

  • 如果 Access 显示一个具有空用户列表的“登录”对话框,请使用以下过程来开始:

    1. 单击“新建用户”

    2. 填写“用户详细信息”窗体。

    3. 单击“保存并关闭”

    4. 选择您刚输入的用户名,然后单击“登录”

  • 如果 Access 显示空数据表,则您可以直接在该数据表中开始键入数据,或单击其他按钮和选项卡来浏览数据库。

  • 如果 Access 显示“开始工作”页,则您可以单击该页上的链接来了解有关数据库的详细信息,或单击其他按钮和选项卡来浏览数据库。

  • 如果 Access 在消息栏中显示“安全警告”消息,并且您信任模板源,请单击“启用内容”。如果数据库要求登录,则您将需要再次登录。

对于桌面和 Web 数据库,您还需要从下列步骤之一开始:

返回页首

添加表

使用“创建”选项卡上的“表”组中的工具,可以向现有数据库添加新表。

“创建”选项卡上的“表”组

注意: 在 Web 数据库中,只能在“表”组中使用“表”命令。

不管从哪个视图开始,始终可以使用 Access 窗口中状态栏上的视图按钮切换到其他视图。

创建空白表在数据表视图中   在数据表视图中,可以立即输入数据,并让 Access 生成后台表结构。(Field1、 Field2、 等),按数字顺序指定字段名称,Access 将根据您输入的数据类型的字段数据类型。

  1. 创建选项卡的组中,单击 按钮图像

  2. Access 将创建表,然后将光标放在“单击以添加”列中的第一个空单元格中。

  3. 若要添加数据,开始键入第一个空单元格,或更高版本中本文所述,您可以将粘贴其他来源的数据。

    • 若要重命名列(字段),请双击对应的列标题,然后键入新名称。

      提示: 为每个字段指定有意义的名称,以使您能够在不查看数据的情况下即可知道它包含的内容。

    • 若要移动列,请单击它的列标题将它选中,然后将它拖到所需位置。还可以选择若干连续列,并将它们全部一起拖到新位置。

      若要向表中添加多个字段,可以开始在数据表视图的“单击以添加”列中键入内容,也可以使用“字段”选项卡上的“添加和删除”组中的命令添加新字段。

在设计视图中开始创建表   在设计视图中,您首先创建新的表格结构。然后可以切换到数据表视图以输入数据,或通过其他方法,如使用窗体中输入您的数据。

“设计”视图不可用于 Web 数据库中的表。

  1. 创建选项卡的组中,单击表格设计按钮图像

  2. 对于表中的每个字段,请在“字段名称”列中键入名称,然后从“数据类型”列表中选择数据类型。

  3. 您可以在“说明”列中输入每个字段的附加信息。当插入点位于该字段中时,所输入的说明将显示在状态栏中。对于通过将字段从“字段列表”窗格拖到窗体或报表中所创建的任何控件,以及通过窗体向导或报表向导为该字段创建的任何控件,所输入的说明也将用作这些控件的状态栏文本。

  4. 添加完所有字段之后,保存该表:

    • “文件”选项卡上,单击“保存”

  5. 以通过以下方式随时开始在表中输入数据:切换到数据表视图,单击第一个空单元格,然后开始键入。也可以从另一个源粘贴数据,下一节将对此进行描述。

创建基于 SharePoint 列表的表   与 SharePoint 列表,您的数据可供用户不能访问。此外,列表数据存储在服务器上,它通常提供更好的保护,防止数据丢失比台式计算机上存储的文件。您可以开始使用新的列表中,或者您可以链接到现有列表。您必须在您要在其中创建列表的 SharePoint 网站上具有足够的权限这可以因的网站以便联系人与 SharePoint 管理员联系以有关选项的详细信息。

此功能不可用在 Web 数据库中。

  1. 在“创建”选项卡上的“表”组中,单击“SharePoint 列表”。

  2. 您可以使用某个列表模板来创建标准 SharePoint 列表,例如,“联系人”或“活动”。

    也可以选择创建自定义列表,或者链接到或导入现有列表。单击所需选项。

  3. 如果您选择了任何列表模板或选择了创建自定义列表,系统将打开“新建列表”对话框以引导您完成这一过程。如果选择了使用现有列表,系统将打开“获取外部数据”对话框以向您提供帮助。

有关表的详细信息,请参阅文章表简介

返回页首

将数据从另一个源粘贴到 Access 表中

如果您的数据当前存储在其他程序(如 Excel)中,则可以将数据复制并粘贴到 Access 表中。通常,此方法最适合用于像在 Excel 工作表中一样已按列分隔的数据。如果您的数据位于文字处理程序中,则应首先使用制表符分隔数据列,或者在文字处理程序中将数据转换为表,然后再复制数据。如果数据需要进行任何编辑或处理(如将全名分隔为名字和姓氏),则在复制数据之前可能需要先执行此操作,在不熟悉 Access 的情况下尤其如此。

将数据粘贴到空表中时,Access 会根据每个字段中发现的数据种类来设置该字段的数据类型。例如,如果所粘贴的字段只包含日期值,则 Access 会将“日期/时间”数据类型应用于该字段。如果所粘贴的字段只包含文字“是”和“否”,则 Access 会将“是/否”数据类型应用于该字段。

Access 会根据其在第一行粘贴数据中找到的内容来命名字段。如果第一行粘贴数据与后面行中数据的类型相似,则 Access 会认为第一行属于数据的一部分,并赋予字段通用名称(如 Field1、Field2 等等)。如果第一行粘贴数据与后面行中数据不相似,则 Access 会使用第一行作为字段名,并且不会将第一行算作实际数据。

如果 Access 赋予通用字段名称,则您应当尽快重命名字段,以免发生混淆。请使用以下步骤:

  1. “文件”选项卡上,单击“保存”以保存表。

  2. 在数据表视图中,双击每个列标题,然后为每一列键入一个名称。

  3. 再次保存该表。

返回页首

导入或链接到其他源中的数据

您可能已在另一个程序中收集了数据,并且希望在 Access 中使用这些数据。您可能会与将数据存储在其他程序中的用户协同工作,而且希望在 Access 中使用这些用户的数据。或者,您也可能具有多个不同的数据源,因此需要一个将所有数据源融合在一起以便进行更深入的分析的“平台”。

Access 使您能够很轻松地导入或链接到其他程序中的数据。您可以从 Excel 工作表中、另一个 Access 数据库的表中、SharePoint 列表中或者各种其他源中导入数据。根据数据源的不同,导入过程会稍有不同,但下面这些说明可让您开始执行此操作:

  1. “外部数据”选项卡的“导入和链接”组中,单击要从中导入数据的文件类型对应的命令。

    例如,如果您要从 Excel 工作表导入数据,则请单击“Excel”。如果没有看见正确的程序类型,请单击“更多”

    注意: 如果在导入和链接组中,无法找到正确的格式类型,您可能需要启动最初创建该数据,然后使用该程序以访问 (如带分隔符的文本文件),支持的文件格式保存数据,然后导入或链接到的数据。

  2. “获取外部数据”对话框中,单击“浏览”找到源数据文件,或在“文件名”框中键入源数据文件的完整路径。

  3. “指定数据在当前数据库中的存储方式和存储位置”下,单击所需选项。可以使用导入的数据创建新表,也可以创建链接表以保持与数据源的链接。

  4. 单击“确定”。

    根据您的选择,系统将打开“链接对象”对话框或“导入对象”对话框。

  5. 使用相应的对话框完成此过程。需要执行的确切过程取决于您选择的导入或链接选项。

  6. 在向导的最后一页上,单击“完成”

    如果选择了导入,Access 将询问您是否要保存刚才完成的导入操作的详细信息。

  7. 如果认为您将再次执行此相同的导入操作,请单击“保存导入步骤”,然后输入详细信息。

    可以很容易重复执行该导入操作,方法是:在“外部数据”选项卡上的“导入”组中单击“已保存的导入”,单击导入规范,然后单击“运行”

  8. 如果不想保存该操作的详细信息,请单击“关闭”

Access 会将数据导入新表中,然后在导航窗格中的“表”下面显示该表。

若要了解有关如何将数据导入 Access 的详细信息,请访问本文“请参阅”一节中的链接。

返回页首

后续步骤

设计过程的其余部分因您的目标而异,但您可能需要考虑创建查询、窗体、报表和宏。本文不提供有关创建其他数据库对象的信息。

有关详细信息,请参阅下列文章:

返回页首

从电子表格或其他程序导入数据

如果您熟悉其他数据库或电子表格程序,您可能了解这些应用程序的工作原理以及哪些数据库用于基础知识。Access 允许您创建关系数据库,从而与许多其他数据库应用程序,它进一步的不同大多数电子表格程序通过提供用于开发复杂的查询、 窗体和报表的工具。Access 还提供了许多用于处理其他数据库程序,如 SQL Server 的选项。

将 Excel 工作表导入 Access

很多人都是先使用 Excel 构建报表,然后才开始使用 Access。Excel 是开始构建列表的好地方,但随着列表的增长,它会变得更难以组织和保持更新。将列表移入 Access 通常会成为之后的逻辑步骤。

工作表中,结构类似的数据库表是中的行和列中存储数据。结果,则通常可以轻松地将工作表导入到的数据库表。如何组织数据位于存储在工作表中的数据,并将其存储在数据库中的主要区别。只需为数据库中的新表中导入您的整个工作表不会解决特别是当您的工作表中包含冗余数据与组织和更新您的数据相关的问题。若要解决这些问题,您必须拆分电子表格数据为单独的表,每个包含相关的数据。有关如何排列在表中的数据的详细信息,请参阅文章数据库设计基础

Access 特有的表分析器向导可以帮助您完成此过程。将数据导入表中之后,向导会帮助您将表拆分成若干个单独的表,其中每个表都包含不会在任何其他表中重复的数据。该向导还会在这些表之间创建必要的关系。

返回页首

将 Excel 工作表导入为新数据库中的表

  1. “文件”选项卡上,单击“新建”,然后单击“空白数据库”

  2. “文件名”框中键入新数据库的名称,然后单击“创建”

    此时将打开该新数据库,并且 Access 将新建一个空表,即 Table1。

  3. 关闭 Table1。

    如果系统询问是否要保存对 Table1 的设计所做的更改,请单击“否”

  4. 外部数据选项卡上的导入和链接组中,单击Excel按钮图像

  5. “获取外部数据”对话框中,单击“浏览”

  6. 使用“打开”对话框找到文件。

  7. 选择文件,然后单击“打开”

  8. “获取外部数据”对话框中,确保选中“将源数据导入当前数据库的新表中”选项。

  9. 单击“确定”。

    “导入电子表格向导”将启动,并询问您一些有关数据的问题。

  10. 按照说明,单击“下一步”“上一步”在页面中导航。在向导的最后一页上,单击“完成”

    注意: Access 将询问您是否要保存刚才完成的导入操作的详细信息。如果认为您将再次执行此相同的导入操作,请单击“是”,然后输入详细信息。然后,通过在“外部数据”选项卡上的“导入”组中单击“已保存的导入”,可以很容易重复执行该导入操作。如果不想保存该操作的详细信息,请单击“关闭”

Access 会将数据导入新表中,然后将它显示在导航窗格中“所有表”的下面。

返回页首

使用表分析器向导来组织数据

在将数据导入 Access 表之后,可以使用表分析器向导快速标识出冗余数据。然后,该向导将提供一种简单的方式来将这些数据组织到单独的表中,以便以最有效的方式存储它。Access 会保留原始表作为备份,然后创建新表,您可以用这些新表作为数据库应用程序的基础。

  1. 打开包含要分析的表的 Access 数据库。

  2. “数据库工具”选项卡上的“分析”组中,单击“分析表”

    “表分析器向导”将启动。

    向导的第一次两页包含的简短教程,您可以单击以查看示例的按钮完成。如果您看不到引导页,但看到标签为显示引导页?,选中复选框中,,然后单击返回两次以看到该简介。如果您不希望阅读简介之后再次看到引导页,您可以清除显示引导页?复选框。

  3. “请确定哪张表中含有在许多记录中有重复值的字段?”页上,选择要分析的表,然单击“下一步”

  4. 可以让向导决定哪些字段进入哪些表,也可以您自己做决定。如果遵循向导的建议,仍然可以在向导的下一页对表布局进行更改。

    注意: 如果让向导决定将哪些字段放在哪些表中,那么它的选择可能并不总是适合您的数据,尤其是如果没有很多要处理的数据时,所以,应当仔细检查向导的结果。另一方面,向导可能提供了比您想象的方案更有效的组织建议,因此,最好是至少尝试一次向导的决定。如果不喜欢该建议,仍然可以手动重新排列字段,并且始终可以单击“上一步”,然后由您自己排列所有字段。

  5. 单击“下一步”。在此页上,可以指定哪些表包含哪些字段。如果选择让向导做决定,您应当看到通过关系线连接的多个表。否则,Access 只创建一个包含所有字段的表。在任何一种情况下,都可以在该页上进行更改。

    • 可以将字段从表拖到页的空白区域,以创建包含这些字段的新表。Access 会提示您输入表名称。

    • 如果您认为将字段存储在另一个表中更为有效,则可以将字段从当前表拖到该表中。

    • 大多数表都有一个“ID”“生成的唯一 ID”字段。若要了解有关 ID 字段的详细信息,请单击向导右上角的“提示”

    • 若要撤消更改,请单击“撤消”按钮。

    • 若要重命名表,请双击它的标题栏,键入新名称,然后单击“确定”

  6. 将字段按所需方式排列好后,请单击“下一步”

  7. 如果向导发现记录中有非常相似的值,它会将这些值作为可能的排版错误标识出来,并显示一个屏幕供您确认对它们的操作。滚动该列表以找到在“更正”列中有值的任何项,然后,单击下拉列表中的合适项。选择“(保留原样)”将禁止向导对该值进行任何更改。完成后,请单击“下一步”

  8. 向导询问您是否要创建与原始表类似的查询。如果已经基于原始表生成了窗体和报表,则创建这样的查询是个好想法。如果选择“是,创建查询”,则向导将通过在表名称后面追加“_OLD”来重命名原始表,然后使用原始表的名称来命名新查询。基于该表的窗体和报表现在将使用该查询作为它们的数据,并且继续像以前那样工作。

  9. 单击“完成”

    向导将根据指定的设置创建新表,然后打开它们。在您检查完结果后关闭它们。

返回页首

使用来自其他程序的数据

Access 2010 提供了一些使用存储在其他程序中的数据的功能。

创建新的 Access 数据库链接到其他文件格式中的数据   您可以使用 Access 打开其他文件格式,例如文本、 dBASE 或电子表格中的文件。Access 自动创建 Access 数据库,并为您的文件链接。

  1. 启动 Access。

  2. “文件”选项卡上,单击“打开”

  3. “打开”对话框中,在列表中单击要打开的文件的类型。如果不确定文件类型,请单击“所有文件(*.*)”

  4. 如果需要,请通过浏览找到包含要打开的文件的文件夹。找到文件后,双击将其打开。

  5. 按照向导中的说明操作。在向导的最后一页上,单击“完成”

将数据导入或链接到现有的 Access 数据库   您可以或者将数据从其他源和程序入 Access 表,以便数据包含在 Access 文件中,您可以对数据从 Access 或链接,以便数据保持原始文件 (外部访问文件) 中。

  1. “外部数据”选项卡上的“导入和链接”组中,单击用于存储数据的格式。

    可以导入或链接到来自以下源的数据:

    • Excel   您可以从工作表或命名的区域中的 Excel 工作簿中的数据导入。必须导入或链接单独每个工作表或命名的区域。

    • 访问   这是用于分隔从您的数据,创建拆分的数据库的流程非常方便。也就是说,可以使用一个数据库可以包含窗体、 报表和宏,并保留另一个数据库中的数据。然后,您可以开发改进而不会中断任何人的工作。您也可以合并多个不同的 Access 数据库中一个,以便更容易跨部门或业务合作伙伴之间汇总数据中的数据。

    • ODBC 数据库   许多程序支持此格式,包括许多数据库服务器产品。这可以帮助您创建"登陆板"数据库,您将数据从不同的系统的组合。

    • 文本文件   您可以连接到一个简单的文本文件,并甚至可以使用 Access 更改该文件的内容。这可以帮助便于各种程序通过使用 Access 数据。

    • XML 文件   此格式还提供了大量的其他程序,包括一些 web 服务器的兼容性。

    • SharePoint 列表   这样,您的数据与 web 浏览器中,使用 SharePoint 列表的标准方法可用。

    • 数据服务   在您的企业内,您可以连接到 web 数据服务。

    • HTML 文档   

    • Outlook 文件夹   您可以连接到 Outlook 文件夹,以便更轻松地将您的联系信息集成与您的数据的其余部分。

    • dBase 文件   dBase 是一种常用可选数据库系统支持的访问

      将出现“获取外部数据”对话框。

  2. 按照对话框中的说明操作。

    Access 会将数据导入或链接到数据库。对于大多数格式,必须指定数据的位置,然后选择在数据库中存储数据的方式。

返回页首

在若干 Access 版本中使用早期版本的数据库

如果您的 Access 数据库或 Access 项目创建了在 Access 2000 或更高版本,您可以在或更高版本中创建它的 Access 版本中使用数据库或项目,即使文件已启用安全性。例如,可以在 Access 2000、 Access 2002、 Access 2003、 Access 2007 与 Access 2010 中使用 Access 2000 文件。

您可能必须情况︰ 您想要将数据保留在早期版本的访问权限,但您有想要链接到该数据,但仍然充分利用更高版本的功能的一些使用更高版本的 Access 的用户。解决方案是 (包含窗体、 报表、 查询、 宏,但没有表) 的更高版本中创建新的前端数据库并将其链接到早期版本的文件中的表。使用下面的过程,具体取决于您的数据库包含在一个文件中,还是已拆分为前端/后端应用程序之一。

在若干 Access 版本中使用 Access 数据库文件

如果您早期版本的 Access 数据库的所有表、窗体和其他对象都包含在一个文件中,并且您希望在若干 Access 版本中使用该数据库,则您可以在较新的版本中创建一个新的前端数据库,然后将其链接到原始文件。使用 Access 早期版本的用户仍可以使用原始数据库。使用较新版本的用户可以使用新的前端数据库链接到同一数据。如果需要使用多个 Access 版本,则可以创建多个版本的前端数据库。

返回页首

第 1 步:复制现有数据库,并将其保存为新格式

使用以下过程将数据库转换为三种最新格式中的任何一种:Access 2000、Access 2002-2003 或 Access 2007。此命令会保留原始数据库的原始格式,并以您指定的格式创建副本。

  1. 关闭 Access 文件。如果文件是位于服务器上或共享文件夹中的多用户 Access 数据库,请确保没有其他用户打开它。

  2. 启动 Access 2010。

  3. “文件”选项卡上,单击“打开”

  4. 浏览到要转换的文件所在的位置,然后双击它以将其打开。

    如果显示“数据库增强功能”对话框,询问是否需要增强数据库,请单击“否”

  5. 如果启动数据库时某个窗体打开,请关闭该窗体。

  6. “文件”选项卡上,单击“数据库另存为”

  7. “另存为”对话框中键入新数据库的名称。

    注意: 除非要将新数据库保存到另一个位置,否则它的名称必须不同于原始数据库的名称。无论是哪种情况,最好使用不同的名称,以便可以轻松地区分前端数据库和后端数据库。但是,如果要转换为 Access 2007 格式,文件扩展名将从 .mdb 更改为 .accdb,因此可以使用相同的文件名。

  8. 单击“保存”。

返回页首

第 2 步:拆分复制数据库,并使用原始文件作为后端数据库

使用下面的过程拆分转换后的数据库:

  • 数据库工具选项卡的移动数据组中,单击Access 数据库按钮图像

  • “拆分数据库”对话框中,单击“拆分数据库”

    您可以根据需要进行备份,但是,您也可以使用原始数据库重新创建副本。

  • 键入后端数据库的名称,然后单击“拆分”

返回页首

第 3 步:将新的前端数据库连接到原始数据库

  1. 删除数据库拆分器工具创建后端数据库,注意不要删除原始数据库。

  2. 新的前端数据库链接到原始数据库中的表︰ 在外部数据选项卡的导入和链接组中,单击链接表管理器按钮图像

  3. 单击“全选”,然后选中“始终提示新位置”复选框。

  4. 单击“确定”,浏览到早期版本的数据库,然后双击它。

    如果一切正常,Access 将显示一条消息,告诉您所有选定的链接表都已成功刷新。

现在,便可以增强新的前端数据库,使其支持安装有较新版本的 Access 的用户能够使用新功能。拥有早期版本的用户可以继续使用早期版本的数据库。

返回页首

在若干 Access 版本中使用前端/后端应用程序

如果 Access 数据库已前端/后端应用程序,您可以将前端转换为新型文件格式。无更改所需的后端数据库。

下面的过程说明如何使用“数据库另存为”命令将前端数据库转换为三种最新格式中任何一种:Access 2000、Access 2002-2003 或 Access 2007。此命令将保留原始数据库的原始格式,并以您指定的格式创建副本。

  1. 关闭前端数据库。如果文件是位于服务器上或共享文件夹中的多用户 Access 数据库,请确保没有其他人打开它。

  2. 启动 Access 2010。

  3. “文件”选项卡上,单击“打开”

  4. 浏览到前端数据库的位置,然后双击它将其打开。

    如果显示“数据库增强功能”对话框,询问是否需要增强数据库,请单击“否”

  5. 如果打开数据库时出现某个窗体,请关闭该窗体。

  6. “文件”选项卡上,单击“数据库另存为”

  7. “另存为”对话框中键入新数据库的名称。

  8. 单击“保存”。

现在,便可以增强新的前端数据库以支持新功能。

返回页首

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×