Access 2007 入门

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

有几种方式,您可以开始使用Microsoft Office Access 2007,具体取决于无论您首次使用 Access 移动数据从另一个数据库或电子表格程序到 Access,或从 Access 的早期版本升级。本文介绍了都可能会在每种情况下出现的问题。

你要做什么?

开始使用首次访问

从电子表格或其他程序导入数据

在多个版本的 Access 中使用早期版本的数据库

第一次使用 Access

Office Access 2007许多改进的功能,使创建数据库比以往更容易的过程。以前在 Access 中创建数据库的用户将喜欢这些新功能和改进功能如何加快创建过程。

开始Office Access 2007,第一个屏幕显示时开始使用 Microsoft Office Access页 (除非您开始改为数据库打开通过双击特定的 Access 数据库文件,这种情况下访问权限)。开始使用 Microsoft Office Access页是从其创建新数据库、 打开现有数据库,或查看特色从 Microsoft Office Online 的内容的起始点。

使用模板创建数据库

从 Microsoft Office Online 下载模板

从头开始创建数据库

创建空白的数据库

添加表格

从其他源的数据粘贴到 Access 表

从其他源导入数据

打开现有的 Access 数据库

Access 2010 具有更加轻松地跟踪,报表,并共享您的数据的功能强大的工具。

使用模板创建数据库

Access 提供了各种各样的模板,您可以使用加快数据库创建过程。模板是包含所有表、 查询、 窗体和报表执行特定任务时所需的现成到数据库。例如,没有可用于跟踪问题、 管理联系人,或保留记录的费用的模板。某些模板包含一些示例记录以帮助说明其使用。是,可以使用模板数据库或您可以自定义它们以更好地满足您的需求。

  1. 启动 Access(如果未运行)。

    如果已经打开数据库,请执行以下操作显示“开始使用 Microsoft Office Access”页:

    • 单击Microsoft Office 按钮 Office 按钮图像 中,,然后单击关闭数据库按钮图像

      “开始使用 Microsoft Office Access”页

  2. 多个模板在特色联机模板下显示在开始使用 Microsoft Office Access页和详细信息将变为可用,如果您单击一个类别在模板类别下的左侧Access 窗口。可以从 Microsoft Office 网站下载更多 (请参阅下一节,下载 Microsoft Office Online 上的模板,有关详细信息)。

  3. 单击要使用的模板。

  4. 在 Access 窗口右侧的窗格中,Access 建议您在文件名框中的数据库的文件名称。您可以编辑的文件的名称,并指定另一个文件夹。或者,您可以创建您的数据库并将其链接到Windows SharePoint Services 3.0网站。

  5. 单击创建(或单击 Office Online 模板的下载,)。

    Access 会创建数据库,并在随后打开。然后将显示一个窗体,可以在其中开始数据输入。

    如果模板包含示例数据,则可以按如下所示删除每条记录:

    • 单击要删除的记录的行标头。(行标头是紧靠记录左侧的框或栏。)

    • 开始选项卡,在记录组中,单击删除按钮图像

  6. 若要开始输入数据,请单击窗体上的第一个空单元格,然后开始键入。输入一些记录之后,可以使用导航窗格查看是否还有可能要使用的其他窗体或报表。

从 Microsoft Office Online 下载模板

如果在“开始使用 Microsoft Office Access”页中找不到符合需要的模板,则可以浏览 Office Online 网站,在那里可以有更多选择。

  1. 启动 Access(如果未运行)。

    如果已经打开数据库,请执行以下操作显示“开始使用 Microsoft Office Access”页:

    • 单击Microsoft Office 按钮 Office 按钮图像 中,,然后单击关闭数据库按钮图像

  2. 靠近底部的开始使用 Microsoft Office Access页面的更多 Office Online 上,单击模板

    Office Online 网站将出现在新浏览器窗口中。

  3. 使用 Office Online 网站上的搜索工具查找并下载所需的模板。

  4. 下载模板之后,这个新数据库将存储在以下文件夹中:

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 或 Microsoft Windows XP    c:\Documents 和 Settings\user name\My 文档

      下一次要使用该数据库时,请使用 Access 或 Windows 资源管理器从该位置打开它。

返回节首

从头开始创建数据库

如果没有模板可满足您的需要,或在另一个程序中有您要导入 Access 的数据,那么您可能决定更好的办法是从头开始创建数据库。对于大多数应用程序来说,这通常涉及以下的一个或两个操作:

  • 创建新的表,然后将数据输入、粘贴或导入到这些表中。

  • 从其他源导入数据,这将在该过程中创建新表。

若要了解有关规划和设计数据库的详细信息,或有关创建关系、窗体、报表或查询的详细信息,请访问本文“请参阅”一节中的链接。

创建空数据库

  1. 启动 Access。

  2. “开始使用 Microsoft Office Access”页中,单击“空白数据库”

    “空白数据库”按钮

  3. “空白数据库”窗格的“文件名”框中,键入文件名。如果没有提供文件扩展名,Access 会为您添加扩展名。默认文件位于以下位置:

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 或 Microsoft Windows XP    c:\Documents 和 Settings\user name\My 文档

      若要更改的文件的位置,单击文件名框旁边的浏览 按钮图像 、 通过浏览找到并选择新的位置,然后单击确定

  4. 单击“创建”

    Access 将创建数据库,并在数据表视图将会打开一个空表 (名为 Table1)。

  5. Access 将光标置于“添加新字段”列中的第一个空单元格内。

    新数据库中的新的空白表

    若要添加数据,开始键入,或粘贴到 Access 表的另一个源中的数据,本文后面部分中所述,您可以将粘贴其他来源的数据。

    注释: 

    • 在数据表视图中输入数据与在 Excel 工作表中输入数据非常类似。主要的限制是,必须从数据表的左上角开始,在连续的行和列中输入数据。不应当像在 Excel 工作表中那样,尝试通过包括空行或列来设置数据的格式,因为这样做将浪费表的空间。表只包含数据。数据的所有可视化表现形式都将在随后设计的窗体和报表中完成。

    • 在输入数据时创建的表格结构。随时将新列添加到表中,定义一个新字段。Access 会将数据类型根据您输入的数据类型的字段。例如,如果您有您在其中输入仅日期值的列,则 Access 将为日期/时间设置该字段的数据类型。如果您以后尝试在该字段中输入非日期值 (如姓名或电话号码),Access 会显示一条消息,告知您客户的列的数据类型不匹配的值。如果可能,您应该规划表格,以便每个列中包含相同类型的数据,无论是文本、 日期、 数字或某些其他类型。这使得更容易生成查询、 窗体和报表,选择刚所需的数据。

    • 有关使用数据表的详细信息,请参阅文章打开空白数据表

如果您不感兴趣此时输入数据,请单击关闭 按钮图像

添加表

使用“创建”选项卡上的“表”组中的工具,可以向现有数据库添加新表。

Access 功能区图像

单击在数据表视图中创建空白表。您可以使用数据表视图来立即开始输入数据,让 Access 为您创建的表格结构,请或设计视图可用于创建的表格结构,然后再切换回数据表视图中,输入您的数据。无论您在开始哪个视图,您始终可以切换到其他视图使用 Access 窗口的状态栏上的视图按钮。

插入表格,在数据表视图中启动   在数据表视图中,可以立即输入数据,并让 Access 生成后台表结构。(Field1、 Field2、 等),按数字顺序指定字段名称,Access 将根据您输入的数据类型的字段数据类型。

  1. 创建选项卡的组中,单击表格按钮图像

  2. Access 创建表,然后将光标放置在添加新字段列中的第一个空单元格。

    注意: 如果看不见名为“添加新字段”的列,则可能因为处在设计视图中,而不是在数据表视图中。要切换回数据表视图,请在“导航”窗格中双击该表。Access 将提示您输入新表的名称,然后切换到数据表视图。

  3. 数据表选项卡上的字段和列组中,单击新域按钮图像

    Access 将显示字段模板窗格,其中包含常用的字段类型的列表。如果将这些字段之一拖动数据表,Access 将添加字段,该名称,并将其属性设置为这种类型的字段的相应值。以后,您可以更改属性。您必须将字段拖动到区域中包含数据的数据表。将出现一个垂直插入栏,显示您将在其中放置该字段。

  4. 若要添加数据,开始键入第一个空单元格,或更高版本中本文所述,您可以将粘贴其他来源的数据。

    • 若要重命名列(字段),请双击对应的列标题,然后键入新名称。一种好的做法是为每个字段指定有意义的名称,以便当您在“字段列表”窗格中看见该字段时能够知道它包含的内容。

    • 若要移动列,请单击它的列标题将它选中,然后将它拖到所需位置。还可以选择若干连续列,并将它们全部一起拖到新位置。

插入表格,在设计视图中启动   在设计视图中,您首先创建新的表格结构。然后您可以切换到数据表视图以输入数据,或通过使用其他方法,如粘贴或追加中输入您的数据。

  1. 创建选项卡的组中,单击表格设计按钮图像

  2. 对于表中的每个字段,请在“字段名称”列中键入名称,然后从“数据类型”列表中选择数据类型。

    注意: 如果没有看见“字段名称”“数据类型”列,则可能因为处在数据表视图而不是设计视图中。若要切换到设计视图,请单击 Access 窗口中状态栏的“设计视图”按钮。Access 将提示您输入新表的名称,然后切换到设计视图。

  3. 如果需要,可以在“说明”列中输入每个字段的说明。当插入点位于该字段中时,所输入的说明将显示在状态栏中。对于通过将字段从“字段列表”窗格拖到窗体或报表中所创建的任何控件,以及通过窗体向导或报表向导为该字段所创建的任何控件,所输入的说明也将用作这些控件的状态栏文本。

  4. 添加完所有字段之后,保存该表:

    • 单击Microsoft Office 按钮 Office 按钮图像 然后单击保存或按 CTRL + S。

  5. 可以在任何时候开始将数据输入表中,要这样做,需要切换到数据表视图,并单击第一个空单元格,然后开始键入。也可以从另一个源粘贴数据,下一节将对此进行描述。

如果在输入某些数据之后想要在表中添加一个或多个字段,则可以在数据表视图的“添加新字段”列中开始键入,也可以使用“数据表”选项卡上的“字段和列”组中的命令来添加新字段。

有关创建表,包括使用表格模板的详细信息,请参阅文章数据库中的创建表

返回节首

将数据从另一个源粘贴到 Access 表中

如果数据当前存储在其他程序(如 Office Excel 2007)中,则可以将其复制并粘贴到 Access 表中。一般情况下,如果就像在 Excel 工作表中一样已按列分隔了数据,则可以非常顺利地执行此操作。如果数据位于字处理程序中,最好使用制表符分隔数据列,或者在复制数据之前先在字处理程序中将数据转换为表。如果数据需要进行任何编辑或处理(如将全名分隔为名字和姓氏),则在复制数据之前可能需要先执行此操作,在不熟悉 Access 的情况下尤其如此。

将数据粘贴到空表中时,Access 会根据每个字段中发现的数据种类来设置该字段的数据类型。例如,如果所粘贴的字段只包含日期值,则 Access 会将“日期/时间”数据类型应用于该字段。如果所粘贴的字段只包含文字“是”和“否”,则 Access 会将“是/否”数据类型应用于该字段。

Access 根据第一行粘贴数据中的内容来命名字段。如果第一行粘贴数据与后面的行类型相似,则 Access 判断第一行属于数据,并赋予该字段空泛的名称(如 F1、F2 等等)。如果第一行粘贴数据与后面的行不相似,则 Access 判断第一行包含字段名,Access 将据此命名字段,并且不将第一行算作数据。

如果 Access 赋予通用字段名称,则您应当尽快重命名字段,以免冲突。请使用以下步骤:

  1. 保存该表。

    • 单击Microsoft Office 按钮 Office 按钮图像 然后单击保存或按 CTRL + S。

  2. 在数据表视图中,双击每个列标题,然后为每一列键入一个有效的字段名。可能看上去就好像您正在键入数据,但其实列标题行包含的是字段名,而不是数据。

  3. 再次保存该表。

注意: 也可以通过切换至设计视图并在该视图中编辑字段名来重命名字段。要切换至设计视图,请在“导航”窗格中右键单击该表,然后单击“设计视图”。要切换回数据表视图,请在“导航”窗格中双击该表。

返回节首

从其他源导入数据

您可能已在另一个程序中收集了数据,并想将其导入 Access 中;或与您一同工作的人员可能将其数据存储在其他程序中,而您可能需要在 Access 中使用他们的数据。在这两种情况下,Access 都能很轻松地从其他程序导入数据。您可以从 Excel 工作表中、另一个 Access 数据库的表中、SharePoint 列表中或者各种其他源中导入数据。根据数据源的不同,导入过程也会稍有不同,但下面这些说明会使您很快入门:

  1. “外部数据”选项卡的“导入”组中,单击要从中导入数据的文件类型对应的命令。

    Access 功能区图像

    例如,如果您要从 Excel 工作表导入数据,则请单击“Excel”。如果没有看见正确的程序类型,请单击“更多”

    注意: 如果无法找到正确的格式类型在导入组中,您可能需要手动启动最初创建该数据,该程序,然后使用该程序将数据保存在常见的文件之前,您可以导入中的数据格式 (如带分隔符的文本文件)为访问。

  2. “导入”对话框中,单击“浏览”找到源数据文件,或在“文件名”框中键入源数据文件的完整路径。

  3. “指定数据在当前数据库中的存储方式和存储位置”下,单击所需选项。可以使用导入的数据创建新表,可以将该数据追加到现有表的末尾,也可以创建链接表以维护与该数据源的链接。

  4. 单击“确定”。

    Access 将启动“导入向导”。

  5. 按照“导入向导”中的说明操作。需要执行的确切过程取决于您选择的导入或链接选项。

  6. 在向导的最后一页上,单击“完成”

    Access 将询问您是否要保存刚才完成的导入操作的详细信息。

    • 如果认为您将再次执行此相同的导入操作,请单击“保存导入步骤”,然后输入详细信息。

      可以很容易重复执行该导入操作,方法是:在“外部数据”选项卡上的“导入”组中单击“已保存的导入”,单击导入规范,然后单击“运行”

    • 如果不想保存该操作的详细信息,请单击“关闭”

Access 会将数据导入新表中,然后在导航窗格中的“表”下面显示该表。

若要了解有关如何将数据导入 Access 的详细信息,请访问本文“请参阅”一节中的链接。

返回节首

打开现有的 Access 数据库

  1. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

  2. 单击打开对话框中的快捷方式,或在查找范围框中,单击驱动器或文件夹包含所需的数据库。

  3. 在文件夹列表中,双击文件夹,直到打开包含所需数据库的文件夹。

  4. 找到数据库时,执行下列操作之一:

    • 若要在默认打开模式下打开数据库,请双击它。

    • 若要在多用户环境中,打开共享数据库,以便您和其他用户可以同时读取和写入数据库,同时,请单击打开

    • 若要为了进行只读访问而打开数据库,以便可以查看数据库但不能编辑数据库,请单击“打开”按钮旁边的箭头,然后单击“以只读方式打开”

    • 若要为了进行独占访问而打开数据库,以便在您打开数据库后任何其他人都不能再打开它,请单击“打开”按钮旁边的箭头,然后单击“以独占方式打开”

    • 要以只读访问方式打开数据库,请单击“打开”按钮旁的箭头,然后单击“以独占只读方式打开”。其他用户仍可以打开该数据库,但是只能进行只读访问。

如果找不到您要打开的数据库   

  1. 打开对话框中,单击我的电脑上快捷方式,或在搜索框中,单击我的电脑上

  2. 在驱动器列表中,右键单击您认为可能包含该数据库的驱动器,然后单击“搜索”

  3. 输入搜索条件,然后按 Enter 搜索该数据库。

  4. 如果找到该数据库,请在“搜索结果”对话框中双击它以将其打开。

  5. 由于搜索是从“打开”对话框开始的,因此必须在该对话框中单击“取消”,才能打开数据库。

注意: 外部文件格式 (如 dBASE、 困境、 Microsoft Exchange 或 Excel),可以直接打开数据文件。您可以直接打开任何ODBC 数据源,如 Microsoft SQL Server 或 Microsoft FoxPro。Access 自动为该数据文件,同一文件夹中创建新的 Access 数据库,并将链接添加到每个表中的外部数据库。

提示

  • 若要打开其中一个最后一个多个数据库,您必须打开,请单击开始使用 Microsoft Office Access页上的打开最近的数据库列表中的文件名。Access 打开数据库时,应用相同的选项设置的数据库具有上次打开它。如果未显示最近使用的文件列表中,单击 Office 按钮图像 Microsoft Office 按钮,,然后单击Access 选项Access 选项对话框中显示。单击高级类别,然后在显示部分中,选择最近使用的文件列表复选框。(您还可以指定您想要显示在列表中,最多为 9 个的最近使用的文件数。)

  • 如果您打开数据库,通过单击Microsoft Office 按钮 Office 按钮图像 并使用打开命令,您可以查看您通过单击最近使用的文档以前打开的数据库的快捷方式列表打开对话框。

返回节首

返回页首

从电子表格或其他程序导入数据

如果熟悉其他数据库或电子表格程序,那么您可能了解这些应用程序的工作原理以及数据库的用途等基础知识。Access 与众多其他数据库应用程序的不同之处在于:它允许您创建关系数据库。Access 还为与其他数据库程序(如 SQL Server)一起工作提供了很多选项。

本节内容

导入 Access 的 Excel 工作表

作为新的 Office Access 2007 数据库中的表导入 Excel 工作表

使用表分析器向导来组织数据

使用其他程序中的数据

将 Excel 工作表导入 Access

很多人都是先使用 Excel 构建报表,然后才开始使用 Access。Excel 是开始构建列表的好地方,但随着列表的增长,它会变得更难以组织和保持更新。将列表移入 Access 通常会成为之后的逻辑步骤。

工作表中,结构类似的数据库表是中的行和列中存储数据。结果,则通常可以轻松地将工作表导入到的数据库表。如何组织数据位于存储在工作表中的数据,并将其存储在数据库中的主要区别。只需为数据库中的新表中导入您的整个工作表不会解决特别是当您的工作表中包含冗余数据与组织和更新您的数据相关的问题。若要解决这些问题,您必须拆分电子表格数据为单独的表,每个包含相关的数据。有关如何排列在表中的数据的详细信息,请参阅文章数据库设计基础

Access 特有的表分析器向导可以帮助您完成此过程。将数据导入表中之后,向导会帮助您将表拆分成若干个单独的表,其中每个表都包含不会在任何其他表中重复的数据。该向导还会在这些表之间创建必要的关系。

作为新的Office Access 2007数据库中的表导入 Excel 工作表

  1. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“新建”。

  2. “文件名”框中键入新数据库的名称,然后单击“创建”

  3. 关闭 Table1。

    如果系统询问是否要保存对 Table1 的设计所做的更改,请单击“否”

  4. 外部数据选项卡上的导入组中,单击Excel按钮图像

  5. “获取外部数据”对话框中,单击“浏览”

  6. 使用“打开”对话框找到文件。

  7. 选择文件,然后单击“打开”

  8. “导入”对话框中,确保选中“将源数据导入当前数据库的新表中”选项。

  9. 单击“确定”。

    “导入电子表格向导”将启动,并询问您一些有关数据的问题。

  10. 按照说明,单击“下一步”“上一步”在页面中导航。在向导的最后一页上,单击“完成”

    注意: Access 将询问您是否要保存刚才完成的导入操作的详细信息。如果认为您将再次执行此相同的导入操作,请单击“是”,然后输入详细信息。然后,通过在“外部数据”选项卡上的“导入”组中单击“已保存的导入”,可以很容易重复执行该导入操作。如果不想保存该操作的详细信息,请单击“关闭”

Access 会将数据导入新表中,然后将它显示在导航窗格中“所有表”的下面。

使用表分析器向导来组织数据

您的数据导入到 Access 表后,您可以使用表分析器向导快速识别重复的数据。然后,该向导将提供一种简单方法将重复的数据组织到单独的表,以便它将存储在最有效的方法。Access 保留为备份,原始表,然后创建可用于为基础数据库应用程序的新表。

  1. 打开包含要分析的表的 Access 数据库。

  2. “数据库工具”选项卡上的“分析”组中,单击“分析表”

    “表分析器向导”将启动。

    您是新的规范化概念,在向导中的两个引导页,其中包含的简短教程,您可以单击以查看示例的按钮完成。如果您看不到引导页,但看到标签为显示引导页?,选中复选框中,,然后单击返回两次以看到该简介。如果您不希望阅读简介之后再次看到引导页,您可以清除此复选框。

  3. 在开头句子为“请确定哪张表中含有在许多记录中有重复值的字段?”的页上,选择要分析的表,单击“下一步”

  4. 可以让向导决定哪些字段进入哪些表,也可以您自己做决定。如果遵循向导的建议,仍然可以在向导的下一页对表布局进行更改。

    注意: 如果让向导决定将哪些字段放在哪些表中,那么它的选择可能并不总是适合您的数据,尤其是如果没有很多要处理的数据时,所以,应当仔细检查向导的结果。另一方面,向导可能提供了比您想象的方案更有效的组织建议,因此,最好是至少尝试一次向导的决定。如果不喜欢该建议,仍然可以手动重新排列字段,并且始终可以单击“上一步”,然后由您自己排列所有字段。

  5. 单击“下一步”。在此页上,可以指定哪些表包含哪些字段。如果选择让向导做决定,您应当看到通过关系线连接的多个表。否则,Access 只创建一个包含所有字段的表。在任何一种情况下,都可以在该页上进行更改。

    • 可以将字段从表拖到页的空白区域,以创建包含这些字段的新表。Access 会提示您输入表名称。

    • 如果您认为将字段存储在另一个表中更为有效,则可以将字段从当前表拖到该表中。

    • 大多数表都有一个“ID”“生成的唯一 ID”字段。若要了解有关 ID 字段的详细信息,请单击向导右上角的“提示”

    • 若要撤消更改,请单击“撤消”按钮。

    • 若要重命名表,请双击它的标题栏,键入新名称,然后单击“确定”

  6. 将字段按所需方式排列好后,请单击“下一步”

  7. 如果向导发现记录中有非常相似的值,它会将这些值作为可能的排版错误标识出来,并显示一个屏幕供您确认对它们的操作。滚动该列表以找到在“更正”列中有值的任何项,然后,单击下拉列表中的合适项。选择“(保留原样)”将禁止向导对该值进行任何更改。完成后,请单击“下一步”

  8. 向导询问您是否要创建与原始表类似的查询。如果已经基于原始表生成了窗体和报表,则创建这样的查询是个好想法。如果选择“是,创建查询”,则向导将通过在表名称后面追加“_OLD”来重命名原始表,然后使用原始表的名称来命名新查询。基于该表的窗体和报表现在将使用该查询作为它们的数据,并且继续像以前那样工作。

  9. 单击“完成”

    向导将根据指定的设置创建新表,然后打开它们。在您检查完结果后关闭它们。

返回节首

使用来自其他程序的数据

Office Access 2007提供处理存储在其他程序中的数据的功能。

  • 创建新的 Access 数据库链接到其他文件格式中的数据   您可以使用 Access 打开其他文件格式,例如文本、 dBASE 或电子表格中的文件。Access 自动创建 Access 数据库,并为您的文件链接。

    1. 启动 Access。

    2. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

    3. “打开”对话框中,在列表中单击要打开的文件的类型。如果不确定文件类型,请单击“所有文件(*.*)”

    4. 如果需要,请通过浏览找到包含要打开的文件的文件夹。找到文件后,双击将其打开。

    5. 按照向导中的说明操作。在向导的最后一页上,单击“完成”

  • 将数据导入或链接到现有的 Access 数据库   您可以或者将数据从其他源和程序入 Access 表,以便数据包含在 Access 文件中,您可以对数据从 Access 或链接,以便数据保持原始文件 (外部访问文件) 中。

    导入或链接数据

    1. “外部数据”选项卡上的“导入”组中,单击用于存储数据的格式。

      可以从以下格式导入或链接数据:

      • Microsoft Office Access

      • Microsoft Office Excel

      • Microsoft Windows SharePoint Services

      • 文本文件

      • XML 文件

      • ODBC 数据库

      • HTML 文档

      • Microsoft Office Outlook

      • dBase

      • Paradox

      • Lotus 1-2-3

        将出现“获取外部数据”对话框。

    2. 按照对话框中的说明操作。

      Access 会将数据导入或链接到数据库。对于大多数格式,必须指定数据的位置,然后选择在数据库中存储数据的方式。

返回节首

返回页首

在若干 Access 版本中使用早期版本的数据库

如果您的 Access 数据库或 Access 项目创建了在 Access 2000 或更高版本,您可以在或更高版本中创建它的 Access 版本中使用数据库或项目,即使文件已启用安全性。例如,通过Office Access 2007,可以在 Access 2000 使用 Access 2000 文件,并通过Office Access 2007可以在 Access 2002-2003年中使用 Access 2002-2003年文件。

您可能必须情况: 您想要将数据保留在早期版本的访问权限,但您有想要链接到该数据,但仍然充分利用更高版本的功能的一些使用更高版本的 Access 的用户。解决方案是 (包含窗体、 报表、 查询、 宏,但没有表) 的更高版本中创建新的前端数据库并将其链接到早期版本的文件中的表。使用下面的过程,具体取决于您的数据库包含在一个文件中,还是已拆分为前端/后端应用程序之一。

在多个版本的 Access 中使用一个文件的 Access 数据库

在多个版本的 Access 中使用前端/后端应用程序

在若干 Access 版本中使用单文件的 Access 数据库

如果 Access 数据库的所有表、窗体和其他对象包含在一个 .mdb 文件中,并且您希望使用多个版本的 Access 中的数据库,则您可以在较新的版本中创建一个新的前端数据库,然后将其链接到原始文件。使用早期版本 Access 的用户仍可以使用原始数据库。使用较新版本的用户可以使用前端数据库链接到同一数据。

  1. 使用以下过程将数据库转换为任何三个最新的格式: Access 2000、 Access 2002-2003 中或Access 2007。此命令保留原始数据库以原始格式,并在您指定的格式中创建副本。

    • 关闭 Access 文件。如果文件是位于服务器上或共享文件夹中的多用户 Access 数据库,请确保没有其他用户打开它。

    • 启动 Access 2007。

    • 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

    • 浏览到要转换的文件所在的位置,然后双击它将其打开。

      如果显示“数据库增强功能”对话框,询问是否需要增强数据库,请单击“否”

    • 如果启动数据库时某个窗体打开,请关闭该窗体。

    • 单击Microsoft Office 按钮 Office 按钮图像 ,指向另存为,然后在另存为其他格式的数据库,下单击您要转换的文件格式。

    • “另存为”对话框中键入新数据库的名称。

      注意: 要在不同位置保存新的数据库,除非其名称必须与原始数据库中的不同。在两种情况下,最好通常使用不同的名称,以便您可以轻松地区分前端数据库和后端数据库。但是,如果将转换为Access 2007格式的值时,文件扩展名从变为.mdb.accdb,以便您可以使用相同的文件名。

    • 单击“保存”。

  2. 通过以下步骤将转换后的数据库拆分成前端/后端应用程序:

    • 数据库工具选项卡的移动数据组中,单击Access 数据库按钮图像

    • “数据库拆分器”对话框中,单击“拆分数据库”

    • 键入后端数据库的名称,然后单击“拆分”

  3. 删除数据库拆分器工具创建后端数据库,注意不要删除原始数据库。

  4. 新的前端数据库链接到原始数据库中的表: 在数据库工具选项卡的数据库工具组中,单击链接表管理器按钮图像

  5. 单击“全选”,然后选中“始终提示新位置”复选框。

  6. 单击“确定”,浏览到早期版本的数据库,然后双击它。

    如果一切正常,Access 将显示一条消息,告诉您所有选定的链接表都已成功刷新。

    您现在可以增强将新的前端数据库的用户已升级到 Access 2000、 Access 2002-2003 中或Access 2007支持新功能。具有早期版本的用户可以继续使用早期版本的数据库。

    如果需要,您也可以将新的前端数据库转换为另一个版本。例如,如果原始数据库的 Access 2000 格式,您可以创建 Access 2002-2003年用户前端该版本和Access 2007前端与该版本的用户。两个前端版本都可以链接到 Access 2000 文件中的数据。

返回节首

在若干 Access 版本中使用前端/后端应用程序

如果您的 Access 数据库已前端/后端应用程序,您只需要将前端转换为 Access 2000、 Access 2002-2003 中或Access 2007的文件格式。无更改所需的后端数据库。

以下过程介绍如何使用数据库另存为命令将前端数据库转换为任何三个最新的格式: Access 2000、 Access 2002-2003 中或Access 2007。此命令会保留其原始格式的原始数据库,并在您指定的格式中创建副本。

  1. 关闭前端数据库。如果文件位于服务器上或在共享文件夹中的多用户访问数据库,请确保没有其他人已打开它。

  2. 启动 Access 2007。

  3. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

  4. 浏览到前端数据库的位置,然后双击它将其打开。

    如果显示“数据库增强功能”对话框,询问是否需要增强数据库,请单击“否”

  5. 如果打开数据库时出现某个窗体,请关闭该窗体。

  6. 单击Microsoft Office 按钮 Office 按钮图像 ,指向另存为,然后在另存为其他格式的数据库,下单击您要转换的文件格式。

  7. “另存为”对话框中键入新数据库的名称。

  8. 单击“保存”。

您现在可以增强将新的前端数据库的用户已升级到 Access 2000、 Access 2002-2003 中或Access 2007支持新功能。

返回节首

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×