部署 Access 应用程序

Access 提供了功能丰富的平台,用于开发数据库应用程序。 数据库应用程序是一种计算机程序,它既提供了一种用于存储和管理数据的方式,也提供了一个遵循业务任务逻辑(应用程序逻辑)的用户界面。

若要部署可在用户的计算机上未安装 Access 时运行的 Access 应用程序,你可以随 Access 运行时一起分发这些应用程序,该运行时可从 Microsoft.com 下载中心免费下载。

本文讨论基本部署规划、Access 运行时的功能,以及如何下载该运行时。 本文还概述了使用 Access 部署数据库应用程序的过程。

想进行什么操作?

规划部署

了解 Access 运行时

下载 Access 运行时

部署 Access 应用程序

规划部署

开始之前,你应该询问自己有关应用程序部署方式的以下问题。

是否应将数据和逻辑分开?

你可以创建将数据管理和应用程序逻辑结合在一个文件中的 Access 应用程序。 这是 Access 中的默认应用程序结构。 将数据管理和应用程序逻辑结合在一个文件中可提供最简单的部署方法,但此方法仅在每次只有一个人使用应用程序的情况下才能获得效果,并会涉及一些风险。 例如,用户可能会无意删除或损坏应用程序文件,从而导致数据丢失。

大多数情况下,应将数据管理和应用程序逻辑分开。 这有助于提高:

  • 安全性    使用服务器进行数据存储可以帮助保护数据安全。

  • 性能    使用分开的数据库或数据库服务器可帮助减少网络流量。

  • 可自定义性    导航窗格新的宏操作可以帮助你控制谁可以看到什么内容。 你可以为不同用户分发不同的应用程序逻辑文件。

将数据和逻辑分开的方法

将数据和逻辑分开的一种方法是使用“Access 数据库”命令(在“移动数据”组中的“数据库工具”选项卡上)。 “Access 数据库”命令可将数据库应用程序拆分为两个 Access 文件:一个用于数据,一个用于逻辑。 使用“Access 数据库”命令时,Access 将创建文件名附带有“_be”(表示“后端”)的文件 — 例如,如果原始数据库文件名称为“Database1.accdb”,则 Access 将创建名为“Database1_be.accdb”的新数据库文件。

另一种将数据管理和应用程序逻辑分开的方法是:为数据管理使用数据库服务器程序(例如 Microsoft SQL Server),并为应用程序逻辑使用 Access。

若要确定单个 Access 文件对于数据管理和应用程序逻辑是否足够,请考虑以下事项:

  • 数据完整性和安全性    Access 用户对于包含应用程序逻辑的文件必须具有读/写权限。 如果将数据和逻辑合并在一个文件中,数据会面临与应用程序逻辑同样的风险。

    使用单独的逻辑和数据文件的 Access 应用程序可利用 NTFS 安全功能,从而保护数据完整性和安全性。 由于用户只需对应用程序逻辑文件具有显式读/写访问权限,因此可以让数据文件更安全。

    你的应用程序可能需要进一步的安全选项,例如能够控制哪些用户对特定数据具有访问权限。 在这种情况下,应使用具有 Windows SharePoint Services 功能的服务器产品(例如 SQL Server 或 Windows Server 操作系统)来存储和管理应用程序数据,并使用 Access 来提供应用程序逻辑。

  • 可扩展性    Access 文件的大小最大为 2 千兆字节 (GB)。 尽管 2GB 对于文本数据而言是海量,但对于某些应用程序(尤其是在数据库记录中存储附件的应用程序)而言则可能不足。 如果将数据和逻辑分开,你的应用程序可以容纳更多数据。 如果预期用户将存储大量的数据,你可能会考虑使用多个 Access 数据文件。

    你还应查看 Access 程序规范来了解其他可扩展性信息。 若要详细了解 Access 规范,请参阅文章 Access 规范。

  • 网络容量    如果多个用户需要在网络上同时使用该应用程序,那么在数据和逻辑结合在一个文件中的情况下,更可能发生数据损坏。 此外,如果将数据和逻辑结合在一个 Access 文件中,将无法优化 Access 生成的网络流量。 如果多个用户在网络上同时使用你的应用程序,你应通过以下方式将数据和逻辑分开:使用两个或更多 Access 文件;或者为数据使用数据库服务器产品,并为应用程序逻辑使用 Access。

网络环境将会怎样?

如果你的用户都在同一局域网上,或者你的应用程序不在网络上使用,则大多数情况下单个应用程序文件的表现良好。

如果将数据和逻辑分开,网络性能会更好。 如果你的用户不在同一局域网上,请使用服务器来存储和管理数据,并为应用程序逻辑使用 Access。

用户是否会有 Access?

如果你的所有用户都将在其计算机上安装 Access,他们可以像打开和使用任何 Access 数据库文件一样打开或使用应用程序。

如果部分或全部用户将不会在其计算机上安装 Access,你将需要在部署应用程序时为这些用户部署 Access 运行时。

返回页首

了解 Access 运行时

Access 运行时是一种可再发行组件程序,它允许计算机上未安装 Access 的用户使用 Access 数据库应用程序。 使用 Access 运行时打开 Access 数据库时,数据库将在运行时模式下打开。

什么是运行时模式?

运行时模式是一种 Access 操作模式,其中包含默认情况下未提供的 Access 功能。 而其中部分未提供的功能可在运行时模式下提供。

运行时模式下未提供哪些功能?

运行时模式下未提供以下 Access 功能:

  • 导航窗格    运行时模式下未提供“导航窗格”。 这有助于防止用户访问数据库应用程序中的任意对象。 使用运行时模式时,只能打开你向用户公开的那些对象(例如,通过提供切换面板窗体)。 你无法在运行时模式下提供“导航窗格”。

  • 功能区    默认情况下,运行时模式下未提供“功能区”。 这有助于防止用户创建或修改数据库对象以及执行其他可能有害的操作,例如连接到新数据源,或者以你不希望的方式导出数据。 你可以创建自定义功能区,然后将该功能区与窗体或报表关联。 你不能在运行时模式下公开默认功能区选项卡。

  • 设计视图和布局视图    运行时模式下未提供任何数据库对象的设计视图和布局视图。 这有助于防止用户修改数据库应用程序中对象的设计。 你不能在运行时模式下启用设计视图或布局视图。

  • 帮助    默认情况下,运行时模式下未提供集成的“帮助”。 由于你控制在运行时模式应用程序提供哪些功能,因此某些标准集成 Access 帮助可能与使用你的应用程序的用户无关,并可能会让他们感到困惑或失望。 你可以创建自己的自定义帮助文件作为运行时模式应用程序的补充。

是否可在不使用 Access 运行时软件的情况下在运行时模式下打开 Access 数据库?

在安装了 Access 完整版本的计算机上,你可以在运行时模式下运行任何 Access 数据库。 若要在运行时模式下运行 Access 数据库,请执行下列操作之一:

  • 将数据库文件的文件扩展名从 .accdb 更改为 .accdr。

  • 创建数据库的快捷方式,并在快捷方式中包括 /Runtime 命令行开关。

运行时模式是否让我的数据库更安全?

尽管运行时模式限制了导航和设计功能的可用性,但你不应使用运行时模式作为保护数据库应用程序安全的主要手段。 在安装了 Access 完整版本的计算机上,用户可以将运行时数据库应用程序作为常规数据库应用程序打开(也就是说,所有功能可用),然后更改设计或执行其他不需要的操作。

即使仅在未安装 Access 完整版本的计算机上部署数据库应用程序,用户仍然可以将应用程序转移到安装了 Access 完整版本的计算机,然后以常规数据库应用程序形式打开运行时数据库应用程序。

注意: 如果想要分发 Access 应用程序以使用户无法修改窗体、报表或 Microsoft Visual Basic for Applications (VBA) 模块的设计,请考虑使用已编译二进制文件 (.accde)。 有关使用已编译二进制文件的详细信息,请参阅本文后面的“决定要使用的文件格式”部分。

返回页首

下载 Access 运行时

若要从 Microsoft 下载中心下载 Access 运行时,请单击适用于你的版本的相应链接:

无需购买便可下载、使用或重新分发 Access 运行时,并且可分发运行时的用户数量没有限制。

返回页首

部署 Access 应用程序

若要部署 Access 应用程序,你至少需要执行以下任务:

  1. 创建应用程序    你的应用程序应为用户提供打开和使用数据库对象的方式。 如果你的应用程序未提供此类方式,你的用户将需要在其计算机上安装 Access 才能使用该应用程序。 此外,你将无法预测用户在你的应用程序内的导航方式,并且提供完整的应用程序文档也更加困难。 而且,如果用户通过使用 Access 运行时软件打开你的应用程序,则内置 Access 导航功能将不可用。

    一种方法是,创建一个窗体,其中包含用于打开数据库对象或执行其他操作的按钮,然后将该窗体指定为在应用程序启动时打开的默认窗体。

    注意: 有关创建窗体的帮助,请参阅“使用窗体工具创建窗体”主题。

    如何指定要打开的默认窗体?

    1. 单击“文件”>“选项”。 请注意,如果使用 Access 2007,请单击“Microsoft Office 按钮”,然后单击“Access 选项”。

    2. “Access 选项”对话框的左侧窗格中,单击“当前数据库”

    3. 在右侧窗格中的“应用程序选项”下,通过使用“显示窗体”组合框来选择所需的默认窗体。

    你还可以创建自定义功能区,然后将该功能区与在应用程序启动时打开的窗体关联。 有关创建自定义功能区的详细信息,请参阅在 Access 中创建自定义功能区一文。

  2. 安装应用程序    安装应用程序时可选择多个选项,并要注意若干事项。 你可能需要部署特定文件格式来更好地控制用户使用应用程序的方式。 或者,你可以打包应用程序,以便更轻松地进行安装,或者部署单独的数据和逻辑组件。

    可在以下部分中找到有关这些选项和注意事项的详细信息。

决定要使用的文件格式

部署应用程序时,可以使用四种 Access 文件格式:

  • .accdb    这是 Access 的默认文件格式。 采用这种格式部署应用程序时,用户在选择自定义和导航方式时的选项最多。 如果要确保用户不会更改应用程序设计,你应使用 .accde 文件格式。 此外,在你将 .accdb 文件打包后,用户无法轻松确定该文件是否已更改 — 为了让这一点显而易见,请使用 .accdc 文件格式。

  • .accdc    这种格式也称为 Access 部署文件。 Access 部署文件由应用程序文件和与该文件关联的数字签名组成。 这种文件格式可让用户确信:在你将应用程序文件打包后没有人更改过该文件。 可以将此格式应用于默认格式 Access 文件 (.accdb),或应用于 Access 已编译二进制文件 (.accde)。

    你只能在 Access 部署文件中放置一个应用程序文件。 如果你的应用程序有单独的数据和逻辑文件,你可以将它们单独打包。

  • .accde    此格式也称为已编译二进制文件。 在 Access 中,已编译二进制文件是一个数据库应用程序文件,该文件在保存时编译了所有 VBA 代码。 Access 已编译二进制文件中没有任何 VBA 源代码。

    你可以使用 Access 运行时来打开 Access 已编译二进制文件。 但是,默认情况下,运行时无法识别 .accde 文件扩展名。 若要使用 Access 运行时打开已编译二进制文件,请创建一个指向该运行时的快捷方式,并包括希望该快捷方式打开的已编译二进制文件的路径。

    重要: 如果用户打开已编译二进制文件时使用的 Access 版本比编译时使用的版本低,用户将无法打开已编译二进制文件。 若要解决此问题,你应在用户安装时采用的 Access 版本中编译二进制文件。

    如何将 Access 文件另存为已编译二进制文件?

    1. 在 Access 中,打开要另存为已编译二进制文件 (.accde) 的数据库(.accdb 文件)。

    2. 单击“文件”选项卡,然后单击“另存为”

    3. “数据库文件类型”下,单击“生成 ACCDE”,然后单击“另存为”

    4. “另存为”对话框中,浏览到要在其中保存文件的文件夹,在“文件名”框中为文件键入一个名称,然后单击“保存”

    注意: 如果使用的是 Access 2007,请在“数据库工具”选项卡的“数据库工具”组中单击“生成 ACCDE”

  • .accdr    这种格式使你能够部署在运行时模式下打开的应用程序。 部署运行时应用程序可帮助控制其使用方式,尽管这不是一种保护应用程序安全的手段。 有关运行时模式的详细信息,请参阅“了解 Access 运行时”部分。

打包和签署 Access 数据库

在 Access 中签署和分发数据库比在早期版本中更加轻松快捷。 创建 .accdb 文件或 .accde 文件之后,可以将该文件打包,对该包应用数字签名,然后将签名包分发给其他用户。 “打包并签署”功能会将该数据库放置在 Access 部署 (.accdc) 文件中,对包进行签名,然后将经过代码签名的包放在你确定的用户计算机上的某个位置。 随后,用户可以从该包中提取数据库,并直接在该数据库中工作,而不是在包文件中工作。

注意: 此部分中描述的功能将 Access 文件打包,并将指明文件可信的数字签名应用于该包。

在继续创建和签署包时,请记住下列事实:

  • 将数据库打包并对包进行签名是传达信任的方式。 当你或用户收到包时,签名将确认数据库未被篡改。 如果你信任作者,则可以启用内容。

  • “打包并签署”功能只适用于以 .accdb 文件格式保存的数据库。 Access 提供了早期版本的 Microsoft Office 中的工具,你可以使用这些工具来签署和分发以早期的 .mdb 文件格式创建的数据库。 你不能使用早期版本的 Office 中的工具来签署和部署以较新 .accdb 文件格式创建的文件。

  • 只能向包中添加一个数据库文件。

  • 打包并签署数据库时,将对数据库文件中的所有对象(而不仅仅是宏或代码模块)进行代码签名。 打包和签署过程还将压缩包文件,以便缩短下载时间。

  • 你可以从位于 SharePoint 服务器上的包文件中提取数据库。

下面各部分将介绍如何创建签名包文件和使用签名包文件中的数据库。

注意: 若要完成这些步骤,你至少必须有一个可用的安全证书。 如果你的计算机上未安装证书,可通过使用 SelfCert 工具创建一个。 有关创建私人安全证书的信息,请参阅通过添加数字签名表明信任一文。

创建签名包

  1. 打开要打包并签名的数据库。

  2. 单击“文件”选项卡,然后单击“另存为”

  3. “数据库文件类型”下,单击“打包并签署”,然后单击“另存为”

    注意: 如果使用 Access 2007,请单击“Microsoft Office 按钮”,单击“发布”,然后单击“打包并签署”

  4. “选择证书”对话框中,选择一个数字证书,然后单击“确定”

    将出现“创建 Microsoft Office Access 签名包”对话框。

  5. 在“保存位置”列表中,为经过签名的数据库包选择一个位置。

  6. 在“文件名”框中为签名包输入一个名称,然后单击“创建”。

    Access 将创建 .accdc 文件并将其放置在您选择的位置。

提取并使用签名包

  1. 单击“文件”>“打开”

    注意: 如果使用 Access 2007,请单击“Microsoft Office 按钮”,然后单击“打开”

  2. “打开”对话框中,选择“Microsoft Office Access 签名包 (*.accdc)”为文件类型。

  3. “查找范围”列表中找到包含 .accdc 文件的文件夹,选择该文件,然后单击“打开”

  4. 执行下列操作之一:

    • 如果选择信任应用于部署包的数字证书,则会出现“将数据库提取到”对话框。 转到步骤 5。

    • 如果尚未选择信任数字证书,则会出现一条建议消息。

      1. 建议消息

      2. 如果您信任该数据库,请单击“打开”。 如果你信任来自提供者的任何证书,请单击“信任来自发布者的所有内容”。 将出现“将数据库提取到”对话框。

  5. 另外,还可以在“保存位置”列表中为提取的数据库选择一个位置,然后在“文件名”框中为提取的数据库输入其他名称。

如果您不确定是否信任证书,如何判断数字签名是否可信一文中提供了关于检查证书中的日期和其他项目以帮助确保其有效的一般信息。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×