通过添加数字签名表明信任

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

你可以显示你认为数据库是安全的, 并且可以通过向数据库添加数字签名 来信任其内容。 这有助于使用数据库的用户决定是否信任它及其内容。

用于对数据库进行数字签名的过程取决于数据库使用的是较新的文件格式 (如 .accdb 文件) 还是早期格式 (如 .mdb 文件)。 但是, 这两个进程都需要使用安全证书。

您可以使用商业安全证书, 也可以创建自己的证书。 本主题介绍如何创建您自己的安全证书。

本文内容

准备工作

打包、签名和分发 Access 数据库

对早期版本的数据库进行数字签名

准备工作

若要添加数字签名, 必须首先获取或创建安全证书。 将安全证书视为你用于对某些信息进行数字签名的笔, 或者是只有你可以应用的 wax 密封的笔。

如果您没有安全证书, 则可以使用 SelfCert 工具 (包含在 Microsoft Office 中) 创建一个安全证书。

创建自签名证书

  1. 在 Microsoft Windows 中, 单击 "开始" 按钮, 指向 "所有程序", 指向 " microsoft office", 指向 " microsoft office 工具", 然后单击 " VBA 项目的数字证书"。

    - 或 -

    浏览到包含您的 Microsoft Office 程序文件的文件夹。

    你需要找到可执行文件SelfCert, 该位置可以根据各种条件 (例如使用32位或64位 Windows 操作系统或使用 Office 365 的订阅版本) 而有所不同。

    如果您使用的是 office 2019 或 office 2016, 请尝试以下其中一个位置:

    • C:\Program Files\Microsoft Office\Office16

    • C:\Program Files (x86) \Microsoft Office\Office16

    如果您使用的是 Office 365, 请尝试以下其中一个位置:

    • C:\Program Files\Microsoft Office\root\Office16

    • C:\Program Files (x86)\Microsoft Office\root\Office16

    如果您使用的是 Office 2013, 请从上面的选项查找 Office15 文件夹。 如果您使用的是 Office 2010, 请查找 Office14 文件夹。 如果您使用的是 Office 2007, 请查找 Office12 文件夹。

    找到正确的文件夹, 然后双击 " SelfCert"。

    将出现“创建数字证书”对话框。

  2. 在“您的证书名称”框中,键入新测试证书的名称。

  3. 单击两次“确定”

注意: 如果您未看到“VBA 工程的数字证书”命令或找不到 SelfCert.exe,则可能需要安装 SelfCert

安装 SelfCert.exe

  1. 启动 Microsoft Office 安装程序 CD 或其他安装媒体。

  2. 在安装程序中,单击“添加或删除功能”,然后单击“继续”。

    注意: 如果您工作环境中的 Microsoft Office 是由 IT 管理员(而不是通过 CD)安装在各个计算机上的,请按以下步骤执行操作:

    1. 在 Microsoft Windows 中,单击“开始”按钮,然后单击“控制面板”

    2. 双击 "添加或删除程序"。

    3. 选择您的 Microsoft Office 版本, 然后单击 "更改"。

      安装程序启动。

    4. 单击“添加或删除功能”,然后单击“继续”。

    5. 继续执行下面的步骤。

  3. 单击“Microsoft Office”和“Office 共享功能”节点旁边的加号 (+) 将它们展开。

  4. 单击“VBA 工程的数字证书”。

  5. 单击“从本机运行”。

  6. 单击“继续”安装该组件。

你应仅使用 SelfCert 创建签名, 以便在你自己的组织中使用。 如果要对数据库进行数字签名, 然后将该数据库发布到商业版, 则应从商业证书颁发机构 (CA) 获取商业安全证书。

打包、签名和分发Access 数据库

Access 使签名和分发数据库变得轻松快速。 在创建 .accdb 文件或 .accde 文件后,可以将该文件打包,对该包应用数字签名,然后将签名包分发给其他用户。 “打包并签署”工具会将该数据库放置在 Access 部署 (.accdc) 文件中,对其进行签名,然后将签名包放在您选定的位置。 随后,用户可以从该包中提取数据库,并直接在该数据库中工作,而不是在包文件中工作。

在操作过程中,请记住下列事实:

  • 将数据库打包并对包进行签名是一种传达信任的方式。 在对数据库打包并签名后,数字签名会确认在创建该包之后数据库未进行过更改。

  • 从包中提取数据库后,签名包与提取的数据库之间将不再有关系。

  • 仅可对以较新文件格式 (.accdb、accde,...) 保存的数据库使用打包和签名工具。Access 还提供了用于对具有早期文件格式的数据库进行签名和分发的工具。 所使用的数字签名工具必须适合于所使用的数据库文件格式。

  • 一个包中只能添加一个数据库。

  • 该过程将对包含整个数据库的包(而不仅仅是宏或模块)进行签名。

  • 该过程将压缩包文件,以便缩短下载时间。

  • 你可以从运行Windows SharePoint Services 3.0 或更高版本的服务器上的程序包文件中提取数据库。

下面各部分中的步骤将解释如何创建签名包文件以及如何从签名包文件中提取和使用数据库。

创建签名包

  1. 打开要打包并签名的数据库。

  2. 单击 "文件" > "另存为>程序包和签名"。 

    将出现“选择证书”对话框。

  3. 选择数字证书,然后单击“确定”。

    此时将显示 "创建 Microsoft Access 签名的程序包" 对话框。

  4. 在“保存位置”列表中,为经过签名的数据库包选择一个位置。

  5. 在“文件名”框中为签名包输入一个名称,然后单击“创建”。

    Access 将创建 .accdc 文件并将其放置在您选择的位置。

提取并使用签名包

  1. 单击“文件”>“打开”>“浏览”。 将出现“打开”对话框。 

  2. 选择 " Microsoft Access 签名的程序包 (* .accdc)作为文件类型"。

  3. 找到包含 .accdc 文件的文件夹, 选择该文件, 然后单击 "打开"。

  4. 执行下列操作之一:

    • 如果选择了信任用于对部署包进行签名的安全证书,则会出现“将数据库提取到”对话框。 请转到下一步。

    • 如果尚未选择信任安全证书,则会出现下面一条消息。

      建议消息

      如果您信任该数据库,请单击“打开”。 如果你信任来自提供者的任何证书,请单击“信任来自发布者的所有内容”。 将出现“将数据库提取到”对话框。

      注意: 如果使用自签名证书对数据库包进行签名,然后在打开该包时单击了“信任来自发布者的所有内容”,则将始终信任使用自签名证书进行签名的包。

  5. 另外,还可以在“保存位置”列表中为提取的数据库选择一个位置,然后在“文件名”框中为提取的数据库输入其他名称。

    提示: 如果将数据库提取到一个受信任位置,则每当打开该数据库时其内容都会自动启用。 但如果选择了一个不受信任的位置,则默认情况下该数据库的某些内容将被禁用。

  6. 单击“确定”

如果您不确定是否信任证书,如何判断数字签名是否可信一文中提供了关于检查证书中的日期和其他项目以帮助确保其有效的一般信息。

返回页首

对早期版本的数据库进行数字签名

重要: 本节中的步骤不适用于使用其中一个新文件格式的数据库。

对于使用 .mdb 或 .mde 文件格式的数据库, 您可以将数字签名 应用于数据库中的组件。 通过数字签名,可以确认数据库中的所有宏、代码模块及其他可执行组件都源自该签署者,并且自数据库被签名以来没有人对它进行过更改。

若要将签名应用于数据库,首先需要一个数字证书。 如果您是出于商业分发目的而创建数据库,则必须从商业证书颁发机构 (CA) 获取证书。 这些证书颁发机构会进行背景调查,确保内容(如数据库)的创建者是值得信任的。

如果要将数据库用于个人或有限的工作组方案, Access 提供用于创建自签名证书的工具。 下面各部分中的步骤将解释如何安装并使用名为 SelfCert.exe 的工具创建自签名证书。

对数据库进行代码签名

注意: 请记住, 仅当你使用的数据库使用的是较旧的数据库文件格式 (如 .mdb 文件) 时, 这些步骤才适用。 若要对更新的数据库进行签名, 请参阅打包、签名和分发 Access 数据库部分。

  1. 打开要签名的数据库。

  2. 在“数据库工具”选项卡上的“”组中,单击“Visual Basic”启动 Visual Basic 编辑器。

    键盘快捷方式  按 Alt+F11。

  3. 在“项目资源管理器”窗口中,选择要签名的数据库或 Visual Basic for Applications (VBA) 项目。

  4. 在“工具”菜单上,单击“数字签名”。

    将出现“数字签名”对话框。

  5. 单击“选择”选择测试证书。

    将出现“选择证书”对话框。

  6. 选择要应用的证书。

    如果您是按照前一部分中的步骤操作的,请选择使用 SelfCert 创建的证书。

  7. 单击"确定"关闭 "选择证书" 对话框, 然后再次单击"确定"以关闭 "数字签名" 对话框。

有关对早期版本数据库进行签名的提示

  • 若要避免您的解决方案用户因无意中修改 VBA 项目而使签名无效,请先锁定 VBA 项目,然后再对其进行签名。

    注意: 锁定 VBA 项目并不会防止其他用户将您的数字签名替换为其他签名。 企业管理员可能对模板和加载项重新签名,以便精确地控制哪些用户可以在相应的计算机上运行模板和加载项。

  • 在对 VBA 项目进行数字签名时,请考虑获取一个时间戳,这样即使用于签名的证书已过期,其他人仍可对该签名进行验证。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×