选择和使用 Access 2007 模板

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

本文内容

概述

步骤 1︰ 选择模板

步骤 2︰ 自定义模板

步骤 3︰ 将数据添加到新数据库

步骤 4︰ 定位记录


概述

若要使其更易于入门有效的数据库,Microsoft Office Access 提供了各种专业设计的数据库模板。每个模板创建完整的端到端解决方案,以便您可以使用无需任何修改或自定义以满足您的需求。每个模板包含预定义的表、 窗体、 报表、 查询、 宏和可以提供自定义您自己的数据库的想法的关系。

此外,您可以轻松地下载其他 Access 数据库模板从 Microsoft Office Online 网站通过单击 Access 中的链接。选择一个模板并进行自定义,以满足您的需求后,您可以添加数据,并开始在记录间导航。

步骤 1︰ 选择模板

您可以选择其中一个使用 Access,安装的模板,或者浏览联机模板。

选择已安装的模板

  1. 开始使用 Microsoft Access窗口中,在模板类别下单击本地模板

    可用模板列表   

模板

用途

资产

跟踪的资产,包括资产的详细信息和所有者。可以在类别中放置资产和录制其条件、 购置的日期、 地点和所有者。

联系人

管理客户和合作伙伴等与您的团队合作的人员的相关信息。您可以跟踪名称和地址信息、 电话号码、 电子邮件地址和甚至附加图片。

事件

跟踪即将召开的会议、 期限以及其他重要事件。记录标题、 位置、 开始时间、 结束时间和说明,以及也附加图像。

教职员

管理教职员,如电话号码、 地址、 紧急联系信息,以及雇用数据的重要信息。

问题

管理和跟踪问题或问题的一组。可以分配、 确定其优先顺序,并从开始到结束跟踪进度的问题。

营销项目

管理市场营销项目和计划和监控项目可交付结果的详细信息。

项目

管理任务并跟踪的一个或多个项目的预算。

销售渠道

监视专业销售人员的小型组内的预期销售的进度。

学生

管理您的学生,包括紧急联系人、 医疗信息和及其监护人信息的信息。

任务

跟踪您或团队要完成的一组工作项目。

罗斯文 2007

创建订单跟踪系统。您需要删除为样本中包含的数据。

  1. 单击您要模型数据库的模板。

  2. 文件名框中,键入您的数据库的名称。

  3. 若要选择新的数据库的特定位置,请单击文件名框旁边的文件图标。

    提示: 若要将数据库链接到 Windows SharePoint Services 网站中,选择创建并将您的数据库链接到 Windows SharePoint Services 网站复选框。

  4. 单击“创建”

新数据库现在已准备好使用,并且您可以选择自定义所需。

选择联机模板

  1. 开始使用 Microsoft Access窗口中,执行下列操作之一︰

    • 以浏览所有特色联机模板,在模板类别下的,单击Featuring,然后选择所需的模板。

    • 若要选择联机模板基于主题上,单击从 Microsoft Online,主题,然后选择所需的模板。

  2. 文件名框中,键入模板的新名称,然后单击文本框以选择新的数据库的特定位置旁边的文件图标。

  3. 单击“下载”

提示: 若要将数据库链接到 Microsoft Windows SharePoint Services 网站中,选择创建并将您的数据库链接到 Windows SharePoint Services 网站复选框。

新数据库现在已准备好使用,并且您可以选择自定义所需。

返回页首

步骤 2︰ 自定义模板

选择您的数据库模板后,您可以自定义以满足您的需要。从模板创建的数据库包含大量内置、 预先设计的表、 窗体和报表,您可以立即使用。当您从模板创建数据库时,Access 将创建的表和其他对象需要支持设计模板的用途。在某些情况下,在模板中的数据库结构复杂,并且您可能需要自定义其结构的某些部分。如果您的提供的表进行设计更改,您必须采取措施不以使任何现有关系无效。如果您发现您需要对模板的结构进行重大更改,它可能更轻松地从空白数据库开始。

当您自定义模板时,请尝试避免重命名任何字段或表。可能会在其他数据库对象,例如窗体和报表,使用这些字段和表和重命名它们可能会阻止其他数据库对象的引用,或按预期依赖这些字段和表的名称,无法正常工作。重命名导航窗格中的表或重命名数据表视图或设计视图中的域之前,您应该确保名称自动更正功能已打开。名称自动更正功能会自动传播到字段、 表、 窗体或报表与在整个数据库的其他对象的名称更改。默认情况下为所有新数据库通常打开名称自动更正设置。

自定义窗体或报表

您可以自定义模板窗体或报表,通过多种方式。例如,您可以通过在布局视图中打开它,然后选择 (在格式选项卡) 的自动套用格式组中的为新的格式更改窗体的格式。您还可以通过添加新字段定义窗体或报表。将字段添加到窗体或报表时,您将创建窗体或报表上控件 。如果您想要自定义模板中的现有控件,您可以更改这些控件的属性。

向窗体或报表添加新控件

  1. 在导航窗格中,右键单击窗体或报表,您要在其中添加该控件,,然后单击设计视图

  2. 单击“设计”选项卡。

  3. 控件组中,单击您想添加的控件,然后单击使用控件向导

    “控件”组中的“使用控件向导”命令

  4. 按照向导创建和自定义新的控件中的步骤。

有关创建窗体和报表的详细信息,请参阅另请参阅部分中的链接。

更改控件

您可以自定义现有控件窗体或报表中的显示方式。若要更改显示格式,您可以更改字段的格式属性。该字段的格式属性自动继承通过基于该字段中的任何新窗体和报表,您创建的控件。

在数据表视图中设置显示格式

  1. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

  2. 打开对话框中,打开包含要更改的控件的数据库。

  3. 在导航窗格中,双击包含要设置其格式的字段的表。

    该表将在数据表视图中打开。

  4. 单击要设置其显示格式的字段。

  5. 数据表选项卡上的数据类型和格式组中,单击格式,旁边的下拉列表中的箭头,然后选择格式。 Access 功能区图像的数据类型和“格式”组

    应用新的显示格式将显示该字段。

在设计视图中设置显示格式

  1. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

  2. 打开对话框中,打开包含要更改的控件的数据库。

  3. 在导航窗格中,右键单击包含要更改其显示格式的字段的表,然后单击设计视图

    该表将在设计视图中打开。

  4. 单击要设置其显示格式的字段。

  5. 字段属性常规选项卡上,选择从格式列表显示格式。

  6. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

返回页首

步骤 3︰ 将数据添加到新数据库

选择一个模板并进行必要的任何自定义后,可以通过导入或链接到外部数据将数据添加到您的数据库。

导入数据

您可以导入多种格式,包括 Excel 工作簿、 Windows SharePoint Services 3.0列表、 Outlook 通讯簿或其他 Access 数据库中的数据。

  • 若要导入数据,请在外部数据选项卡中的导入组中,单击您要导入的文件类型的命令。

    “导入”组中的命令按钮

    注意: 

    • 如果看不到您要导入的数据的类型对应的图标,单击更多,,然后按照获取外部数据对话框中的说明操作。

    • 如果仍找不到要导入外部数据的命令,您可能需要启动最初创建 (您将执行此操作在 Access 之外) 的数据,该程序,然后使用该程序将数据保存在常见的文件格式 (如带分隔符的文本文件)。然后,返回到 Access,并使用其中一个外部数据命令导入该数据。

  • 在向导的最后一页上,您可能会提示您保存这些的详细信息导入步骤。保存详细信息可以是您可能会从导入数据相同的数据源将来的情况下非常有用。选择保存导入步骤复选框,输入的详细信息,然后单击保存导入。您现在可以通过单击外部数据选项卡上的导入组中保存的导入随时重复相同导入的时间。如果您不想要保存此导入操作的详细信息,请单击关闭

链接到数据

链接到数据后,数据将继续存储在其原始位置,并显示为新数据库中的链接表。对于大多数文件格式,您可以查看和修改的数据,因为他们正在使用相同的物理数据,请使用访问或创建数据,其原始程序。但是,如果数据存储在 Excel 工作簿中,您只能查看链接的数据在 Access 中;不能修改它。若要修改的链接的工作簿中的数据,您必须使用 Excel。

    1. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“打开”。

    2. 在“打开”对话框中,选择并打开数据库。

    3. 外部数据选项卡上的导入组中,单击您要链接的文件类型的命令。例如,如果您想要链接到 Excel 工作簿中的数据,请单击Excel。如果看不到您想要链接到的数据的类型对应的图标,单击更多

      此时将出现“导入”对话框。

      注意: 如果仍找不到要链接到外部数据的命令,您可能需要启动最初创建该数据,该程序 (这样做外部访问),然后使用该程序将数据保存在常见的文件格式 (如带分隔符的文本文件)。然后,返回到 Access,并使用其中一个命令外部数据链接到该数据。

    4. “获取外部数据”对话框中,单击“浏览”找到源数据文件,或者在“文件名”框中键入源数据文件的完整路径。

    5. “指定数据在当前数据库中的存储方式和存储位置”下单击所需的选项。

      对于大多数文件格式,启动向导。但是,如果您要链接到 Access 数据库中的数据,将显示导入对象对话框。在链接表对话框中进行选择,然后继续步骤 7。否则,请继续步骤 6。

    6. 完成向导中的步骤。您关注的确切过程将取决于您选择的选项。

返回页首

步骤 4︰ 定位记录

在将数据导入您的数据库后,您需要查找特定记录的有效方法。您可以使用底部的数据库工具栏上查找记录。

导航按钮

使用导航按钮以查找表或视图中的记录。:

导航按钮

使用以转到

1.

第一项记录

2.

前一项记录

3.

指定的记录,请单击在文本框中,键入记录编号,然后再按 ENTER 以显示该记录。从窗体或数据表的开头按顺序计数记录编号。

4.

下一项记录

5.

最后一项记录

6.

新(空白)记录

7.

筛选器 — 此指示器可显示是否已应用筛选器。如果没有应用的筛选器或已被清除所有筛选器,将显示无筛选器指示器。

8。

搜索框中,输入文本,在搜索框中,和第一个匹配值被突出显示实时输入每个字符。使用此功能快速搜索记录。

用于查找记录的其他选项

您还可以查找记录使用下列方法之一。

转到特定记录

搜索特定记录

筛选器显示仅一组特定的记录

使用查询执行自定义的搜索

转至特定记录

某些模板包含可以通过使用转到下拉列表中查看特定记录的窗体。例如,联系人模板中的联系人详细信息窗体和营销项目模板中的项目和任务窗体具有此选项。此选项可用于查看从下拉列表的特定记录。如果可用,请在窗体的左上角部分位于转到框。

  1. 单击转到列表旁边的箭头。

    “转到”框

  2. 单击您要查看的记录。

搜索特定记录

使用查找和替换对话框中的查找选项卡以搜索特定记录。您可以搜索特定字段中,或搜索整个表或视图。

注意: 可以使用查找和替换对话框中,只有当表或视图当前显示的数据。

  1. 打开您想要搜索的表,然后单击域包含您要查找的记录。

  2. 开始选项卡的查找组中,单击查找

    “查找”命令按钮

  3. 查找和替换对话框中,键入您在查找内容框中的搜索条件。

  4. “搜索”列表中,选择“全部”,然后单击“查找下一个”

有关使用查找和替换对话框中的详细信息,请参阅另请参阅部分中的链接。

筛选器显示仅一组特定的记录

您可以启用筛选器打开或关闭,以便可以轻松的相同数据的筛选和未筛选视图之间切换。

您可以应用筛选器以限制为仅符合条件的那些显示的记录。应用筛选器将使得更加轻松地查找所需的记录。例如,若要快速缩小所显示的记录,右键单击字段中的值要匹配,然后选择其中一个等于不等于包含不包含选择菜单选项。

  • 打开您想要添加到筛选器的窗体的表。

  • 若要确保表或窗体不经过筛选,在开始选项卡的排序和筛选组中,单击高级,然后单击清除所有筛选器。如果这些命令不可用 (灰显),已应用没有筛选器。

    “排序和筛选”组

  • 若要应用筛选器,单击您想要对其进行筛选,然后在开始选项卡的排序和筛选组中,单击筛选器和选择筛选选项的字段。

  • 要应用的筛选器基于所选内容,请打开表或窗体,然后导航到包含要用作筛选器的一部分的值的记录。然后,单击字段中。在开始选项卡的排序和筛选组中,单击所选内容,,然后单击您想要应用的筛选器。

  • 若要应用的筛选器是基于部分选定内容中,选择所需字符。在开始选项卡的排序和筛选组中,单击所选内容,,然后单击您想要应用的筛选器。

有关应用筛选器的详细信息,请参阅另请参阅部分中的链接。

使用查询执行自定义的搜索

您可以使用查询执行自定义的搜索、 应用自定义筛选器,并对记录进行排序。查询可以保存和重复使用,并且他们可以用于构建窗体和报表。您可以使用查询以查找您感兴趣的表记录。您创建的查询的类型取决于记录所需返回,如果您希望 Access 对结果进行任何操作。

  1. 创建选项卡中的其他组中,单击查询向导

    “其他”组中的“查询向导”命令

  2. 按照查询向导中的步骤。

有关创建查询的详细信息,请参阅另请参阅部分中的链接。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×