选择、移动、调整大小和旋转形状

Visio 为你提供了多个用于对形状和对象进行选择、移动、调整大小和旋转的工具。在绘图上选择某个对象 - 或所有对象 - 后,可以更改其位置、对其进行扩大或缩小和水平翻转以及将其微移动至所需位置。

你的浏览器不支持视频。请安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

注意: 如果在绘图页选择形状时遇到问题,则可能是因为这些形状受保护,或者它们是锁定图层的一部分,亦或是它们被组合在一起。有关更多信息,请参阅本主题中的解决选择问题一节。

选择形状

在很多情况下,需要先选择形状才能在绘图上进行其他操作,例如对形状进行移动、旋转或调整大小。在 Visio 中,可以使用套索工具逐个选择形状,或者选择页面上的所有形状。

快速任务

任务

操作

选中单个形状

  1. 在“开始”选项卡上的“工具”组中,单击“指针工具”。

  2. 指向绘图页面上的形状,直到其变为四向箭头,然后再单击该形状。

使用“区域选择”选中多个形状

  1. 在“开始”选项卡上的“编辑”组中,单击“选择”,然后选择“区域选择”。

  2. 将指针置于想要选择的形状的上方和左侧,然后进行拖动,以围绕形状创建一个选中内容网。

  3. 选择形状后,你将会在选定的形状周围看到蓝色选择控点,并且在各个形状周围看到洋红色线。

使用“套索选择”选中多个形状

  1. 在“开始”选项卡上的“编辑”组中,单击“选择”,然后选择“套索选择”。

  2. 将自由绘制的选中内容网拖至要选择的形状周围。

  3. 选择多个形状时,蓝色选择控点将显示在选定形状周围。

在选择区域内选中部分形状

默认情况下,对于“区域选择”和“套索选择”工具来说,选中内容网必须完全围住它要选中的每个形状。如果您需要更大的灵活性,则可以拓宽选中内容网,使其中的部分形状也被选中。

要启用 Visio 选择选定区域内的部分形状,请执行以下操作之一:

  1. 单击“文件”选项卡。

  2. Visio 下,单击“选项”。

  3. 在“Visio 选项”对话框中的“高级”选项卡的“编辑”选项下,选中“选择区域内的部分形状”复选框。

.

使用键盘快捷方式在页面上选中多个形状

按住 Shift 或 Ctrl,同时单击形状,可以一次选择多个形状。

提示: 您也可以使用这些键向当前选择内容中添加其他形状。例如,若要向使用“区域选择”工具创建的选择内容中添加形状,可以按住 SHIFT 或 CTRL,然后单击相应的形状。

选中绘图页上的所有形状

在“开始”选项卡上的“编辑”组中,单击“选择”,然后选择“全选”。

选中特定类型的所有对象

  1. 在“开始”选项卡上的“编辑”组中,单击“选择”,然后选择“按类型选择”。

  2. 在“按类型选择”对话框中,选中要选择的对象类型,例如形状、连接线或容器,然后单击“确定”。

取消选择一个或多个形状

取消选择所有形状:

  • 单击绘图中的空白区域或按 Esc。

取消选择多个选中的形状中的一个形状:

  • 请按 SHIFT 并单击形状,以取消选择。

移动形状

Visio 提供了多种方法,可以帮助你将形状准确放置在所需的位置。

快速任务

任务

操作

使用鼠标移动形状

  1. 选择想要移动的所有形状。

  2. 将指针停放在其中一个形状上。此时将会显示一个四向箭头。

  3. 将形状拖动至新的位置。

    所有选定形状将从其原始位置按相同的方向移动相同距离。

提示: 要将形状限制为垂直或水平移动,请在按住 SHIFT 的同时拖动形状。要将形状移至绘图中的另一页,请将形状拖至页选项卡。

将形状移动特定距离(需要 Visio 专业版)

  1. 选择想要移动的所有形状。

  2. 在“视图”选项卡上的“”组中,单击“加载项”,指向“Visio 方案”,然后单击“移动形状”。

  3. 在“方向”下,指定想要用于移动形状的坐标系统。

    • 水平/垂直     这将使用 X-Y(笛卡尔)坐标移动选定的形状。

    • 距离/角度     这将使用极坐标移动选定的形状。

  4. 指定选定形状的移动距离。

  5. 要移动选定形状的副本并将原始形状保留在原始位置,请选择“创建副本”。

  6. 完成形状选择之后,单击“确定”。

使用箭头键微移形状

  1. 选择想要移动的所有形状。

  2. 请执行以下操作:

    • 要将形状移至它可以 贴靠 的下一个位置,例如网格线或标尺刻度线,请按箭头键。

      如果没有位置可供形状贴靠,则按箭头键会将形状移动一个标尺刻度。

    • 要将形状移动一个像素,请在按住 SHIFT 的同时按箭头键。

注意: 如果按箭头键是滚动绘图而不是移动形状,请确保未启用 SCROLL LOCK 键。

调整形状大小

在 Visio 中,可以通过拖动形状直到达到所需大小或者指定特定尺寸来调整形状大小。

快速任务

任务

操作

使用鼠标调整二维 (2-D) 形状的大小

  1. 选择想要调整大小的所有形状。

  2. 拖动选择控点 选择控点 直到形状达到所需的大小。要按比例调整形状大小,请拖动角部控点。

使用鼠标调整一维形状的大小,例如线条

  1. 选择想要调整其大小的形状。

  2. 将端点拖至所需长度。

使用“大小和位置”窗口调整形状大小

  1. 选择想要移动的所有形状。

  2. 在“视图”选项卡上的“显示”组中,单击“任务窗格”,然后选择“大小和位置”。

  3. 在“大小和位置”窗口的“宽度”、“高度”或“长度”框中,键入新值。

旋转或翻转形状

你可以将形状旋转一定度数、垂直翻转、水平翻转或使用旋转手柄进行旋转。

注意: 如果想要了解如何旋转文本,请参阅添加、编辑、移动或旋转文本和文本块

快速任务

任务

操作

将形状旋转 90 度

  1. 选择要旋转的形状。

  2. 请执行以下操作之一:

    • 要逆时针旋转形状,请在“开始”选项卡的“排列”组中,单击“位置”,指向“旋转形状”,然后选择“向左旋转 90º”。

    • 要顺时针旋转形状,请在“开始”选项卡的“排列”组中,单击“位置”,指向“旋转形状”,然后选择“向右旋转 90º

使用旋转手柄旋转形状

  1. 选择要旋转的形状

  2. 拖动旋转手柄 Visio 2010 中的旋转句柄。

    形状将围绕固定点 旋转句柄 旋转。要移动固定点,请将指针停放在旋转手柄上,然后再将指针移至固定点上并将其拖至新的位置。

    在拖动旋转手柄时,光标移离选定形状越多,则旋转增量越小。

使用“大小和位置”窗口旋转形状

  1. 选择要旋转的形状

  2. 在“视图”选项卡上的“显示”组中,单击“任务窗格”,然后选择“大小和位置”。

  3. 在“视图”选项卡上的“显示”组中,单击“任务窗格”,然后选择“大小和位置”。

  4. 在“大小和位置”窗口的“角度”框中,键入新值。

垂直翻转形状

  1. 选择要翻转的形状。

  2. 在“开始”选项卡上的“排列”组中,单击“位置”,指向“旋转形状”,然后选择“垂直翻转”。

水平翻转形状

  1. 选择要翻转的形状。

  2. 在“开始”选项卡上的“排列”组中,单击“位置”,指向“旋转形状”,然后选择“水平翻转”。

解决形状选择问题

如果在绘图页选择形状时遇到问题,则可能是因为这些形状受保护,或者它们是锁定图层的一部分,亦或是它们被组合在一起。

形状是否受保护?

如果无法选择某个形状,则形状可能是因受保护而无法选择,这可以防止删除形状或对其进行任何更改,例如,定位、调整大小、设置格式、编辑文本或旋转。

要取消锁定形状:

  1. 在“开发开具”选项卡上,选择“绘图资源管理器”。

  2. 在“绘图资源管理器”树菜单中,右键单击绘图文件的名称,然后单击“保护文档”。

  3. 在“保护文档”对话框中,清除“形状”复选框,然后单击“确定”。

如果可以选择形状,但无法对其进行任何更改,则形状可能仍受保护。如果在选定的形状上出现灰色句柄,则形状已锁定,无法对其进行任何更改。在这种情况下,需要取消锁定所有形状,使其可被选定。若要执行此操作,请参阅禁止或允许对形状进行更改中的锁定形状使其无法选定,或取消锁定形状使其可被选定一节。

这些形状是否是锁定图层的一部分?

如果无法选择某个形状,则该形状可能是锁定图层的一部分。

要取消锁定图层:

  1. 在“开始”选项卡上的“编辑”组中,单击“图层”,然后单击“图层属性”。

  2. 在“图层属性”的“锁定”列中,清除与想要选择的形状类型相关联的复选框。

这些形状是否被组合在一起?

如果可以选择形状,但无法正常使用它,则可能是一组形状。组合在一起的形状相当于一个单元。例如,如果将形状组合在一起,则可以同时更改其颜色。

要确定某个形状是否属于组:

  • 只需单击该形状。如果该形状属于组,则选中的将是组,而不是该形状。再次单击形状时,将会选择组中的形状。

要选择组中的某个形状:

可通过多种方法选择此类形状。有关详细信息,请参阅形状选择工具

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×